Error: "The specified Tenant does not exist or has been deleted" in the Administrator Console

Overview

The Administrator Console or a Client shows the following error message:

The specified Tenant does not exist or has been deleted.

In some cases, this error message is generated when opening the Administrator Console because Surveyor points to a database that is different than the database initially set during installation. 

The steps below can be followed to replicate the issue:

  1. Install Surveyor 6.
  2. Edit the C:\Program Files (x86)\Verdiem\Surveyor\Configuration\Verdiem.Enterprise.Common.config to point Surveyor at a different database.
  3. Open the Administrator Console. The error message is generated.

 

Root Cause

The Global Unique Identifier (GUID) for the database has changed.

 

Resolution

This issue is fixed by stopping and restarting the World Wide Web Publishing Service in Services.

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