Overview
This article addresses an issue where the Verdiem Surveyor Task Processor service fails to start due to lack of internet connectivity on the server.
Root Cause
This problem occurs because the application must download the Certificate Revocation List (CRL) for authentication. However, since there is no network connectivity, the download times out and fail.
Resolution
Providing Internet access to the Surveyor server resolves the issue. If Internet access is not available, the following steps can be performed:
- Open the Registry Editor (regedit):
- Windows XP: Click Run, type 'regedit', and then click OK.
-
Windows 7: Search 'regedit' in the search box, and then open regedit.exe from the search results.
- Locate the following Registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
- In the Edit menu, click New, and then click DWORD Value.
- Type 'ServicesPipeTimeout' and press the Enter key.
- Right-click ServicesPipeTimeout, and click Modify.
- In the Value field, type the desired time-out value in milliseconds (ms), and click OK. For example, if the new service time-out should be 60 seconds, type 60000 in the Value field.
- On the File menu, click Exit.
- Restart the computer.
NOTE: You must restart the computer for the Service Control Manager to apply this change.
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