Analytics graphs showing no data

Overview

This article outlines the resolution steps to be followed when the Analytics graphs are not showing any data.

 

Diagnosis

The ANALYTICS tab on the ScaleArc dashboard will be showing empty graphs and reporting there is No data to display as shown below:

Analytics_-_No_data_to_display.png

 

Solution

Follow these steps to confirm that the Analytics service is running for ScaleArc to correctly display the various analytics graphs described in Using ScaleArc Analytics.

  1. Navigate to SETTINGS > System Settings > System Status tab and check the ScaleArc Commands section to confirm that global Analytics service has not been stopped. Presence of a button labelled Stop Analytics is an indication that global Analytics is running, otherwise start the service by clicking on the Start Analytics button as shown below: Start_Analytics.png

    Select Yes on the confirmation dialog when prompted:

    Start_Analytics_confirm_dialog.png

  2. Click on the Services tab and confirm from the status column that the analytics service is running:
    Analytics_service.png

  3. Confirm that Cluster Analytics is set as ON in the Cluster Settings for each cluster by navigating to CLUSTERS > Cluster Settings > CLUSTER tab. Use the toggle switch to enable Analytics for the cluster if necessary.
    Cluster_Analytics.png

Testing

Confirm that the Analytics graphs are now displaying correctly by navigating to the ANALYTICS tab in the ScaleArc dashboard:

Anaytics_-_with_data.png

Note: Use the Select Date filter to ensure that you are selecting a date for which you had traffic flowing through the ScaleArc appliance.

Back to top

 

Comments

0 comments

Please sign in to leave a comment.