Error: "Unable to get login settings"

Overview

When accessing Everest, you are getting an error displaying "Unable to get login settings" related to an error message code: 316: UNABLE TO GET LOGIN SETTINGS as seen on the screenshot below:

The correlating message in the C:\ProgramData\Everest\Temp\clnterror.log file display as follows:

ErrorLevel:3;MethodName:40;DateTime:22;UID:38;UserID:20;SessionID:12;ErrorNo:12;ErrorMessage:150;Server:25;ObjectID:75;
0 TboUserInfo.GetLoginParameters 07/25/2018 09:15:42 PM {28109086-C048-49EC-BD1A-781F3A4A0560} CDM 72886531 -2147418113 -2147418113 : Invalid pointer operation db eData.doNotifications
1 TboUserInfo.GetLoginParameters 07/25/2018 09:15:42 PM {28109086-C048-49EC-BD1A-781F3A4A0560} CDM 72886531 -2147418113 316 : Unable to get login settings. db eData.doNotifications

Solution

Environment

Any Everest Standard version below 6.0.

Root Cause

The error was caused by a defect that was fixed in Everest Standard versions 6.0 and above that had the unintended effect of knocking users out of their session and locking them out.

Workaround

The permanent fix is to upgrade to a higher Everest Standard version where the issue is resolved. However, for customers that are unable to upgrade for different reasons, the following workaround procedures can be attempted, depending on the situation addressed:

Error occurs sporadically

The solution provided aims at restarting the Everest application manually.

  1. Click on Start > Run or press the Windows Key (⊞ Win)+ R.
  2. Type dcomcnfg and hit Enter to open Components Services.
  3. Navigate to Component Services > Computers > My Computer > COM+ Applications.
  4. Right-click on Everest.
  5. Select Shut Down to shut down the application.
  6. Select Start to start the application.

Error occurs frequently

The solution provided aims at restarting the Everest application automatically every certain amount of minutes (for practical purposes, this example will apply 120 minutes). The default number of minutes is 0, which indicates that the process will not recycle from reaching a lifetime limit.

  1. Click on Start > Run or press the Windows Key (⊞ Win)+ R.
  2. Type dcomcnfg and hit Enter to open Components Services.
  3. Navigate to Component Services > Computers > My Computer > COM+ Applications.
  4. Right-click on Everest.
  5. Select Properties.
  6. Click on the Pooling & Recycling tab.
  7. Set the Lifetime Limit (minutes) to 120
  8. Click on Apply.
  9. Click on OK.

Testing

After applying the workarounds above, users will now be able to log into the Everest application without any issues.

 

 

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