Overview
This article provides the steps to fix an issue a user may encounter when attempting to create or run reports. The reports are not generated/printed due to the following error:
Error Number: 588
Error Message: Error:999 Error in File C:\Users\...\AppData\Local\Temp\Top86.tmp:
Operation not yet implemented.
Executed <PEStartPrintJob>
Error source: Main
Solution
Root cause
The cause of the error is due to an upgrade or custom report modification and the report was not able to find the resource used (e.g., Windows Font/Image).
<supportagent>
For more information, please refer to the support ticket 1072516.
</supportagent>
Process
To fix this issue, check the following items:
- Check if there are other workstations that are able to run the report. If there are, copy the fonts (
C:\Windows\Fonts
) from that workstation to the suspended workstation. - Check if there is any Crystal Report development in the suspended workstation, as it may have conflicted. Reports tend to have a conflict with the Crystal Report engine due to an incorrect path. This usually happens when the Crystal Report Designer is installed after the Everest client. The solution is to re-install the Everest client to correct the registered libraries.
- If you are able to edit the report, try to remove any external resources, such as images, and to use default Windows fonts, such as Arial, in order to minimize the chance of the issue manifesting.
- Attempt to re-install Everest client in the suspended workstation.
Testing
Run the report again. If the issue persists, contact support and share an export of the report for troubleshooting
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