Overview
You receive a message related to the Bank Reconciliation Error Source which prevents you from saving a bank reconciliation. The most common error messages for this situation are:
- Cannot perform this operation on a closed dataset
- Batch_Number exists in Transact.
This article covers the steps to successfully remove the erroneous/duplicate value in order to process the Bank Reconciliation.
Solution
Root Cause
When a bank reconciliation is started but not finished, it can create incomplete or duplicate records in the database.
Resolution
Take a backup before completing any database change. Please follow this external article for help on how the take a backup of your database.
Review the reconciliation in the account in question. Find whether there is a reconciliation entry that is duplicating a journal entry and causing the next entry to fail to be saved. If so, delete the entry, and then you will be able to create a new reconciliation entry and save it normally.
- Find the record in the bank reconciliation entry. In this example, "a10505" is the account name.
SELECT * FROM bank_reconciliation WHERE coa_code LIKE 'a10505 Pre';
- Check whether there is an entry in the bank reconciliation entry table, based on the previous query's bank_reconciliation_id result for the latest statement date, that has a duplicated journal_number:
SELECT * FROM bank_recon_entry WHERE bank_recon_id = <bank_reconciliation_id>;
NoteOther than a duplicated value, there can also be an incomplete entry containing a NULL value. For incomplete entries, they need to be backed up and then removed from the bank_reconciliation table.
- If the query returns no results, something other than a duplicate entry is at fault. If the query returns records, delete the bank_reconciliation record corresponding to the last bank_reconciliation_id that has a duplicated entry:
DELETE FROM bank_reconciliation
WHERE bank_reconciliation_id = <bank_reconciliation_id>.
Testing
The Bank Reconciliation can be saved with no errors.
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