e-SCOR
User’s Guide
Version 5.1 Rev. 0

e-SCOR User’s Guide, Version 5.1 Rev. 0
November 2015
The information in this publication is subject to change without notice and does not represent a
commitment by Gensym Corporation.
Although this software has been extensively tested, Gensym cannot guarantee error-free
performance in all applications. Accordingly, use of the software is at the customer’s sole risk.
Copyright (c) 1985-2015 Gensym Corporation
All rights reserved. No part of this document may be reproduced, stored in a retrieval system,
translated, or transmitted, in any form or by any means, electronic, mechanical, photocopying,
recording, or otherwise, without the prior written permission of Gensym Corporation.
Gensym®, G2®, Optegrity®, and ReThink® are registered trademarks of Gensym Corporation.
NeurOn-Line™, Dynamic Scheduling™ G2 Real-Time Expert System™, G2 ActiveXLink™, G2
BeanBuilder™, G2 CORBALink™, G2 Diagnostic Assistant™, G2 Gateway™, G2 GUIDE™,
G2GL™, G2 JavaLink™, G2 ProTools™, GDA™, GFI™, GSI™, ICP™, Integrity™, and SymCure™
are trademarks of Gensym Corporation.
Telewindows is a trademark or registered trademark of Microsoft Corporation in the United States
and/or other countries. Telewindows is used by Gensym Corporation under license from owner.
This software is based in part on the work of the Independent JPEG Group.
Copyright (c) 1998-2002 Daniel Veillard. All Rights Reserved.
SCOR® is a registered trademark of PRTM.
License for Scintilla and SciTE, Copyright 1998-2003 by Neil Hodgson, All Rights Reserved.
This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit
(http://www.openssl.org/).
All other products or services mentioned in this document are identified by the trademarks or
service marks of their respective companies or organizations, and Gensym Corporation disclaims
any responsibility for specifying which marks are owned by which companies or organizations.

Gensym Corporation
52 Second Ave.
Burlington, Massachusetts 01803
(781) 265-7100
FAX: (781) 265-7101

Part Number: DOC096-510

Contents Summary
Preface xix

Part I

Introduction 1

Chapter 1

e-SCOR Concepts and Terminology 3

Chapter 2

Running e-SCOR 25

Chapter 3

Organizing Models and Controlling Simulations 31

Chapter 4

Working with Models 53

Part II

Basic e-SCOR Modeling 105

Chapter 5

Creating a Supply-Chain Model 107

Chapter 6

Configuring Level 2 SCOR 143

Chapter 7

Running the Simulation 239

Chapter 8

Viewing Metrics 259

Chapter 9

What Happens When the Simulation Runs 311

Chapter 10

Using Reports 323

Chapter 11

Accessing External Databases 369

Chapter 12

Using Batch Simulation 383

Part III

Building e-SCOR Models 405

Chapter 13

Modeling a Distribution Process 407

iii

Chapter 14

Modeling a Manufacturing Process 431

Chapter 15

Using Stock Planning Strategies 447

Chapter 16

Using Alternative Planning Strategies 461

Chapter 17

Modeling a Process with Multiple Suppliers 477

Chapter 18

Configuring Role Details for Multiple Products 493

Chapter 19

Using Pull and Push Planning Modes 501

Part IV

Appendix, Glossary, and Index 535

Appendix A Asset Metrics Formulas 537
Appendix B SCOR Metrics 545

Glossary 555
Index 561

iv

Contents
Preface xix
About this Guide xix
Audience xx
Conventions xxi
Related Documentation xxi
Customer Support Services xxiv

Part I

Introduction 1

Chapter 1

e-SCOR Concepts and Terminology 3
Introduction 3
e-SCOR and SCOR 4
Level 1 Roles 5
Level 2 SCOR 5
SCOR Metrics 6
Benefits of Using e-SCOR 6
SCOR Modeling Concepts 7
Supply Chain Management 7
SCOR Management Processes 8
Source, Make, and Deliver Processes 8
e-SCOR Implementation of Level 2 SCOR 9
Source Process Categories 10
Make Process Categories 10
Deliver Process Categories 11
Return Process Categories 11
Plan Categories 12
Enable Process Categories 12
Boundary Conditions 13
e-SCOR Implementation of Level 1 Roles 13
Base Manufacturer Role 14
Distributor Role 15
Manufacturer Role 17
Consumer Role 19

v

Products 20
Product Hierarchy 20
Product Composites 21
Orders 22
Manufacturing Resources 23
Reporting 24
Chapter 2

Running e-SCOR 25
Introduction 25
Starting the Server and Connecting the Client 26
Connecting to a Specific Server at Startup 27
Connecting the Client to the Default Server 28
Starting the Server on a Specific Port 28
Connecting the Client to a Specific Server 28
Starting the Server with Your Application Loaded 29
Exiting e-SCOR 29

Chapter 3

Organizing Models and Controlling Simulations 31
Introduction 31
Working with Projects 32
Creating a New Project 33
Saving a Project 33
Opening a Project 34
Configuring the Model Environment 34
Creating a Model 35
Creating an Organizer 37
Controlling the Simulation 38
Activating and Deactivating the Scenario 38
Starting and Stopping the Simulation 39
Configuring the Scenario 40
Configuring the Simulation Mode 41
Running the Simulation in Jump Mode 41
Running the Simulation in Step Mode 42
Running the Simulation in Synch Mode 42
Configuring the Duration of the Simulation 43
Configuring the Simulation Version 43
Configuring the Start Time of the Simulation 43
Configuring Simulation Speed 44
Configuring Animation 44

vi

Configuring Object Tracking 45
Configuring the Behavior of Indicator Arrows 46
Configuring the Computation Behavior 47
Configuring the Scenario to Generate Identical Random Numbers 48
Summary of Creating Models and Running Simulations 48
Viewing Demo Models 50
Chapter 4

Working with Models 53
Introduction 54
Summary of Common Tasks 54
Using the Project Menu 55
Using the Project Menu 55
Using the Manage Dialog 56
Using the Project Submenus 57
Navigating Applications 57
Using the Navigator 58
Searching for Objects 59
Interacting with Workspaces 60
Displaying a Detail Workspace 60
Hiding a Workspace 60
Deleting a Workspace 61
Creating a Detail Workspace 61
Editing Workspace Properties 61
Scaling a Workspace 62
Shrink Wrapping a Workspace 62
Showing the Superior Object of a Detail Workspace 64
Printing a Workspace 64
Saving a Workspace to a JPEG File 64
Loading Background Images 65
Creating and Accessing Top-Level Workspaces 65
Using the Menus 66
Using the File Menu 67
Using the Edit Menu 67
Using the View Menu 68
Using the Layout Menu 70
Using the Go Menu 71
Using the Project Menu 72
Using the Workspace Menu 74
Using the Simulation Menu 74
Using the Tools Menu 75
Using the Help Menu 76
Using the e-SCOR Toolbox 77

vii

Source, Make, and Deliver 79
Return 79
Products 80
Reports 80
Resources 81
Roles 81
Tools 81
Using the G2 and ReThink Toolbox 82
Interacting with Objects 82
Selecting Objects 82
Cutting, Copying, Pasting, and Deleting Objects 83
Controlling the Layout of Objects 83
Displaying the Properties Dialog for an Object 84
Resizing an Object 84
Editing Icon Color Regions 84
Using the Toolbars 85
Standard Toolbar 86
Simulation Toolbar 87
Web Toolbar 88
Layout Toolbar 89
Status Bar 89
Metrics Toolbars 90
Setting and Clearing Breakpoints and Indicators 90
Switching User Modes 91
Viewing Messages 92
Configuring User Preferences 93
Specifying User Preferences for Different Types of Users 93
Configuring User Preferences 95
Delivering Messages by Email 98
Starting the G2 JMail Bridge Process 99
Creating, Configuring, and Connecting the JMail Interface Object
99

Configuring e-SCOR to Send Email Messages 102
Configuring Startup Parameter for Sending Email Messages 103
Configuring Network Interfaces 103
Configuring Message Browsers 104
104

viii

Part II

Basic e-SCOR Modeling 105

Chapter 5

Creating a Supply-Chain Model 107
Introduction 107
Determining the Level of Detail to Model 108
Creating the Product Hierarchy 109
Examples of Product Hierarchies 109
Determining the Level of Detail in the Product Hierarchy 111
Creating a Product Hierarchy with a Single Product Specification 112
Creating a Product Hierarchy with Components 113
Creating a Product Hierarchy with By-Products 114
Creating a Product Hierarchy with Alternate Products 115
Creating the Supply-Chain Model 118
Examples of Supply-Chain Models 119
Determining the Number of Roles to Use 123
Creating and Connecting Roles 125
Configuring the Products a Role Sources and Delivers 126
Assigning Product Specifications to Roles 127
Examples of Assigning Product Specifications to Roles 129
Navigating to Product Composites 131
Configuring Role Parameters 132
Configuring General Parameters for Roles 132
Configuring Financial Parameters for Roles 134
Configuring the Time Period for Computing Time-Weighted
Statistics 135
Configuring the SCOR Definition and Best Practices 136
Configuring Resources 137
Configuring Manufacturing Resources 138
Sharing Resources Between Roles 140
Upgrading Models 141

Chapter 6

Configuring Level 2 SCOR 143
Introduction 143
Viewing Role Details 145
Standard Objects on Role Details 145
Process Category Summary 147
Configuring Process Category Parameters 152
Configuring Category Parameters 153
Configuring the Mathematical Distribution 154
Configuring the Plan Category 156

ix

Configuring the Source Category 160
Configuring the Make Category 167
Configuring the Deliver Category 178
Configuring the Source Returns Category 189
Configuring the Deliver Returns Category 193
Configuring Product Composites 196
Default Source and Delivery Products for Each Role 197
Configuring Product Composite Parameters 197
Configuring Multipliers for Timing Parameters 199
Configuring Parameters for Source Products 201
General Tab 202
Demand Tab 204
MRO Tab 206
Inventory Tab 207
Supplier Tab 209
Supplier Selection Tab 213
Multipliers Tab 217
Configuring Parameters for Delivery Products 218
General Tab 219
Inventory Tab 221
Sourcing Tab 223
Manufacturing Tab 224
Return Tab 226
Delivery Tab 227
Multipliers Tab 229
Configuring Demand and Change Orders through a Demand Report 233
Chapter 7

Running the Simulation 239
Introduction 239
Controlling the Simulation 240
Activating and Deactivating the Scenario 240
Starting and Stopping the Simulation 241
Verifying that the Simulation is Running Correctly 242
Problems that Can Occur When Running a Simulation 244
Configuring the Scenario 244
Configuring the Simulation Mode 245
Running the Simulation in Jump Mode 246
Running the Simulation in Step Mode 246
Running the Simulation in Synch Mode 246
Configuring the Duration of the Simulation 247
Configuring the Simulation Version 247
Configuring the Start Time of the Simulation 248
Configuring Simulation Speed 248

x

Configuring Animation 249
Configuring Object Tracking 249
Configuring the Behavior of Indicator Arrows 250
Configuring the Computation Behavior 251
Configuring the Scenario to Generate Identical Random Numbers 252
Showing Transient Objects 252
Transient Objects in Pools 256
Transient Objects that Flow through the Model 257
Showing Resource Representations for a Role 258
Chapter 8

Viewing Metrics 259
Introduction 259
Updating Metrics 260
Viewing Statistics and Histories for Metrics 261
Viewing Metrics for Roles 265
Viewing Metrics for Categories 272
Viewing Metrics for the Plan Categories 273
Viewing Metrics for the ES: Enable Source Category 275
Viewing Metrics for the Source Categories 277
Viewing Metrics for the Make Categories 281
Viewing Metrics for the ED: Enable Deliver Category 286
Viewing Metrics for the Deliver Categories 288
Viewing Metrics for the Source Returns Categories 293
Viewing Metrics for the Deliver Returns Categories 296
Viewing Metrics for Source and Delivery Products 297
Viewing Metrics for Delivery Products 298
General Tab 298
Manufacturing Tab 299
Metrics Tab 300
Viewing Metrics for Source Products 303
General Tab 304
Sourcing Tab 305
Supplier Tab 306
Metrics Tab 307
Viewing Metrics for Resources 309

Chapter 9

What Happens When the Simulation Runs 311
Introduction 311
Contracts Process 313
Order/Product Process 315

xi

Build Process: Base Manufacturer Role 317
Financial Process 318
Make Planning Process: Base Manufacturer Role 320
Source Planning Process: Manufacturer and Distributor Roles 321
Chapter 10

Using Reports 323
Introduction 324
Viewing Simulation Metrics in a Toolbar 324
Creating Reports 327
Summary of Input and Output Reports 328
Creating a Report 330
Generating Output Report Data from the Model 333
Applying Input Report Data to the Model 334
Configuring the Time Unit 335
Updating Output Reports at Regular Time Intervals 339
Configuring Output Reports to Update Regularly 340
Triggering Updates Manually 341
Configuring When Clients Refresh Their Data 341
Keeping a History of Data Values 341
Charting Report Data 344
Configuring Standard Report Templates 345
Filtering Report Data 347
Configuring the Attributes to Appear in a Report 347
Creating Reports in Excel 351
Creating a Report in Excel 351
Generating Output Report Data from the Model to Excel 356
Applying Input Report Data to the Model from Excel 357
Filtering Report Data in Excel 358
Controlling the Simulation from Excel 361
Connecting to and Disconnecting from the Server from Excel 361
Writing to and Reading from CSV Files 362
Writing Output Report Data to CSV Files 362
Importing Input Report Data from CSV Files 363
Writing to and Importing from Databases 364
Creating Specialized Reports 364
Creating Demand Reports 364
Logging Transactions that Occur Between Roles 365

xii

Chapter 11

Accessing External Databases 369
Introduction 369
Configuring e-SCOR for Database Access 370
Creating the Database 370
Configuring the ODBC Data Source 371
Starting the ODBC Bridge Process 372
Creating and Configuring the Database Interface Object
Connecting to the Database 374

373

Using Reports to Access External Databases 375
Configuring Report Objects for Database Access 375
Writing Output Report Data to a Database 379
Importing Input Report Data from a Database 381
Chapter 12

Using Batch Simulation 383
Introduction 383
Using the Batch Simulation Object to Run Simulations 385
Example Scripts 388
Determining the Impact of Seasonal Demand 388
Modeling Changes in Order Demand Over Product Life Cycles 389
Determining Optimal Replenishment Levels 390
Simulation Keywords 391
Report Keywords 392
Scenario and Model Parameter Keywords 393
Role Parameter Keywords 393
Cost Category Parameter Keywords 394
Source Category Keywords 395
Make Category Keywords 395
Deliver Category Keywords 395
Plan Category Keywords 396
Timing Category Parameter Keywords 396
Source Category Keywords 397
Make Category Keywords 397
Deliver Category Keywords 398
Sort-Order Category Parameter Keywords 398
Product Composite Parameter Keywords 399
General Tab Keywords 399
Demand Tab Keywords 400
Sourcing Tab Keywords 400

xiii

Supplier Tab Keywords 400
Supplier Selection Tab Keywords 401
Multipliers Tab Keywords 401
Delivery Tab Keywords 402
Inventory Tab Keywords 402
Manufacturing Tab Keywords 402
Resource Parameter Keywords 403

Part III

Building e-SCOR Models 405

Chapter 13

Modeling a Distribution Process 407
Introduction 408
Configuring a Distributor to Deliver its Source Products 408
Configuring a Distributor to Assemble Components into Kits 411
Configuring a Distributor Role to Outsource Finished Products 414
Configuring Level 2 Parameters for a Distributor Role 416
Configuring Order Selection Parameters 418
Sorting Orders with No Cutoff 423
Restricting the Orders to Sort Based on a Numeric Cutoff 424
Restricting the Orders to Sort Based on a Time Cutoff 425
What Happens When the Simulation Runs 426
Analyzing the Performance of a Distributor Role 427
Level 1 Metrics to Analyze 427
Level 2 Metrics to Analyze 427

Chapter 14

Modeling a Manufacturing Process 431
Introduction 431
Configuring a Manufacturer Role 432
Configuring Level 2 Parameters for a Manufacturer Role 434
Configuring Build Selection Parameters 437
Sorting Build Orders with No Cutoff 440
Restricting the Orders to Sort Based on a Cutoff 440
Coordinating Source and Make Planning 441
What Happens When the Simulation Runs 442
Analyzing the Performance of a Manufacturer Role 442
Level 1 Metrics to Analyze 442

xiv

Level 2 Metrics to Analyze 443
Chapter 15

Using Stock Planning Strategies 447
Introduction 447
Configuring the Stock Planning Strategy 448
Using a Stock/Replenishment Planning Strategy 451
Configuring Product Composites for Replenishment Planning 452
Understanding How the Role Computes Order Size for Replenishment
Planning 452
Formula for Computing Order Size for Replenishment
Planning 453
Metrics and Parameters Used in the Formula 453
Example: Order Size is Zero 454
Example: Order Size is the Amount Needed to Maintain Current
Inventory 454
Example: Order Size is the Minimum Reorder Quantity 455
Using a Stock/Forecast Planning Strategy 455
Configuring Buyer Roles to Use Forecast Planning 456
Understanding How the Role Computes Order Size for Forecast
Planning 457
Using a Stock/R-Q and Q Planning Strategy 458
Analyzing the Performance of a Model that Uses Stock Planning 458

Chapter 16

Using Alternative Planning Strategies 461
Introduction 461
Using an Engineer-to-Order Planning Strategy 462
Using a Make-to-Order Planning Strategy 463
Configuring the Role to Use Alternative Planning Strategies 464
Rules for Configuring the Planning Strategy of a Role 469
Examples of Valid Planning Strategy Combinations 470
Analyzing the Performance of a Model that Uses Alternative Planning
Strategies 473

Chapter 17

Modeling a Process with Multiple Suppliers 477
Introduction 477
Sourcing Identical Products from Multiple Suppliers 479
Configuring Contract Parameters in the Buyer 480

xv

Configuring the Supplier Selection Criteria 482
Configuring Supplier Selection Criteria in the Source Product 482
Configuring the Supplier Preference for the Delivery Product 485
Examples of Configuring the Source Product for Choosing Suppliers 486
Analyzing the Performance of a Model with Multiple Suppliers 489
Chapter 18

Configuring Role Details for Multiple Products 493
Introduction 493
Adding Multiple Categories to Role Details 494
Example of Adding Multiple Categories to a Manufacturer Role 496

Chapter 19

Using Pull and Push Planning Modes 501
Introduction 501
Using Pull Mode Planning 502
Configuring Initial Order Demand 503
Configuring Order Parameters for Product Composites 503
Configuring Planning Parameters for Product Composites 504
Configuring Planning Parameters for the Plan Category 505
Configuring Cost Parameters Related to Orders 506
What Happens When the Simulation Runs in Pull Mode 506
Distributor Role in Pull Mode 507
Manufacturer Role in Pull Mode 509
Base Manufacturer Role in Pull Mode 511
Using Push Mode Planning 513
Configuring the Amount to Push 513
Configuring Which Delivery Products to Push First 514
Configuring the Amount to Push When Components are Shared 515
Determining How Much is Pushed 518
What Happens When the Simulation Runs in Push Mode 518
Distributor Role in Push Mode 519
Manufacturer Role in Push Mode 521
Base Manufacturer Role in Push Mode 523
Combining Pull and Push Mode within a Role 525
Distributor Role that Uses Pull-Push 525
Distributor Role that Uses Push-Pull 527
Manufacturer Role that Uses Pull-Push 528
Manufacturer Role that Uses Push-Pull 529
Examples of Combining Pull and Push Mode 530
Analyzing the Performance of a Model that Uses Pull and Push Planning
Modes 532

xvi

Part IV

Appendix, Glossary, and Index 535

Appendix A Asset Metrics Formulas 537
Introduction 537
Days of Supply 538
Raw Materials 539
Work in Progress 539
Finished Goods 540
Inventory 541
Asset Turns 541
Cash-to-Cash Cycle Time 542
Days Sales Outstanding 543
Appendix B SCOR Metrics 545
Introduction 545
SCOR Definitions 546

Glossary 555
Index 561

xvii

xviii

Preface
Describes the purpose of this guide, the intended audience, and the typographic
conventions.
About this Guide xix
Audience xx
Conventions xxi
Related Documentation xxi
Customer Support Services xxiv

About this Guide
This guide provides all the information you need to model, run, and analyze your
supply chain, using e-SCOR. The chapters include:
Part I: Introduction

• Concepts and terminology of e-SCOR and SCOR (Supply Chain Operations
Reference), upon which e-SCOR is based.

• Running e-SCOR, which describes how to start e-SCOR running and exit.
• Organizing models and controlling simulations, which provides an
introduction to creating models and running simulations.

• Working with models through the e-SCOR user interface.
Part II: Basics of Using e-SCOR

• Creating a supply-chain model by configuring Level 1 roles, which are
e-SCOR abstractions of Level 2 SCOR elements.

• Configuring Level 2 SCOR parameters for the simplest e-SCOR model, which
supplies a single product to a single buyer, based on orders.

xix

• Running a simulation and configuring how it runs.
• Viewing metrics that the model computes while it runs.
• What happens when a simulation runs.
• Creating reports for viewing static and time-series e-SCOR metrics and for
entering e-SCOR parameters.

• Accessing databases by writing report data to a database and applying report
data from a database.

• Using the Scenario Manager to run batch simulations and set parameter
values during the simulation.

Part III: Building e-SCOR Models

• Modeling a distribution process, which delivers products to downstream
buyers, either directly or by assembling components into kits.

• Modeling a manufacturing process, which makes finished products from
components.

• Using stock planning strategies, which include replenishment, forecast, Q,
and R-Q planning for sourcing and making stock products.

• Using alternative planning strategies, which include stock, make-to-order,
and engineer-to-order for sourcing, making, and delivering products.

• Modeling a process with multiple suppliers to source identical products,
using contracts.

• Configuring role details for sourcing, making, and delivering multiple
products.

• Using pull and push planning modes for sourcing and delivering products.
In addition, this guide has two appendices that provide:

• Asset metrics formulas that e-SCOR uses to compute asset metrics for Level 1
roles.

• SCOR metrics for each e-SCOR metric and parameter that derives its
definition from SCOR.

Audience
This guide is for e-SCOR users who want to understand the concepts and
techniques required to create, run, and analyze supply-chain models, using
e-SCOR. e-SCOR users are typically consultants or business people, who are
familiar with supply-chain modeling and SCOR. Although users are expected to
be familiar with SCOR, this guide gives a basic overview of the SCOR modeling

xx

Conventions

concepts that relate to e-SCOR. If you are not familiar with SCOR, visit
www.supply-chain.org.
e-SCOR is built on ReThink, Gensym’s graphical tool for modeling business
processes. Therefore, knowledge of ReThink is also useful.

Conventions
This tutorial uses the following typographic conventions:
Example

Description

true

Parameter and metric values

role

Glossary terms

Order Fulfillment Lead Time

SCOR metrics

c:\Program Files\Gensym\
g2-8.3r0\escor\
kbs\e-scor.kb

Pathnames and filenames

Related Documentation
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• ReThink User? Guide
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G2 Core Technology

• G2 Bundle Release Notes
• Getting Started with G2 Tutorials
• G2 Reference Manual
• G2 Language Reference Card
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Customer Support Services
You can obtain help with this or any Gensym product from Gensym Customer
Support. Help is available online, by telephone, by fax, and by email.
To obtain customer support online:
 Access G2 HelpLink at www.gensym-support.com.

You will be asked to log in to an existing account or create a new account if
necessary. G2 HelpLink allows you to:

• Register your question with Customer Support by creating an Issue.
• Query, link to, and review existing issues.
• Share issues with other users in your group.
• Query for Bugs, Suggestions, and Resolutions.
To obtain customer support by telephone, fax, or email:
 Use the following numbers and addresses:
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Americas

Europe, Middle-East, Africa (EMEA)

Phone

(781) 265-7301
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Fax
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+31-71-5682621

Email

service@gensym.com

service-ema@gensym.com

Part I

Introduction
Chapter 1: e-SCOR Concepts and Terminology
Describes the e-SCOR implementation of Level 1 and Level 2 SCOR modeling.
Chapter 2: Running e-SCOR
Describes how to start the server and connect the client.
Chapter 3: Organizing Models and Controlling Simulations
Describes how to use models, scenarios, and organizers to organize and control models.
Chapter 4: Working with Models
Describes how to work with models through the menus and toolbars.
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Introduction 3
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Products 20
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Introduction
e-SCOR is a dynamic decision support and management tool for supply chains.
You use it to design and analyze your current supply chain; to model alternative
supply chains; and to perform “what-if” analysis to monitor, compare, and report
on the performance of various alternative supply chains.
e-SCOR is part of an overall methodology for modeling supply chains and
refining their performance over time, which consists of all aspects of supply-chain
design, analysis, optimization, and implementation. e-SCOR enables progressive
refinement of your supply chain by allowing you to model the impact of
implementing supply-chain planning and execution tools.
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Traditional supply-chain planning tools help you optimize your supply chain.
Supply-chain execution tools help you implement the logistical and operational
functions of your supply chain. e-SCOR helps you determine which areas of your
supply chain will benefit most from implementing these tools. Therefore, e-SCOR
complements traditional supply chain management tools from companies such as
SAP and i2.
e-SCOR provides graphical tools that let you:

• Configure, design, and map existing and alternative supply chains.
• Simulate performance of these supply chains over time.
• Report on supply-chain metrics.
• Model complex business rules used to manage supply chains.
• Detail and blueprint IT designs and specifications.

e-SCOR and SCOR
The Supply-Chain Council (SCC) (www.supply-chain.org) was established in
1997 as a non-profit organization whose charter was to develop a framework that
allows companies to build a more competitive supply chain. To do this, SCC
created the Supply Chain Operations Reference model (SCOR)1, which provides
common terminology and measurements that manufacturers and their vendors
and distributors can use to evaluate the performance of their supply chains and to
identify areas of improvement. The SCOR model is rapidly becoming the de facto,
cross-industry standard for supply-chain management.
e-SCOR provides an implementation of the SCOR model by providing an
interactive modeling environment that allows organizations to:
“proactively identify the needs of their supply chain processes and map the capabilities
of supply-chain software products to them.”
- http://www.supply-chain.org
SCOR identifies three levels of abstraction:

• Level 1 SCOR — The scope and content of the overall supply chain. You

model this by configuring sets of Source-Make-Deliver processes, the
products that each step in the supply chain processes, and the manufacturing
resources that each step requires.

1. SCOR is freely available to all who wish to use the standard reference model.
Council membership is open to all companies and organizations interested in applying
and advancing state-of-the-art supply-chain management systems and practices. All
who use the SCOR model are asked to acknowledge the SCC in all documents
describing or depicting the SCOR model and its use. All who use SCOR are
encouraged to join the SCC, both to further model development and to obtain the full
benefits of membership.
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e-SCOR and SCOR

• Level 2 SCOR — The configuration of the supply chain in terms of a number
of SCOR process categories, which are specific configurations of each
management process for each planning strategy. You model this by
configuring the Level 2 SCOR categories that your supply-chain model uses
and by configuring parameters for each category in the model.

• Level 3 SCOR — The operations strategy of each process category in terms of
its inputs and outputs, performance metrics, and best practices.

You use Level 1 roles and SCOR metrics in e-SCOR to model and analyze your
overall supply chain. You use the Level 2 SCOR features of e-SCOR to implement
and analyze the particular configuration of your supply chain.
e-SCOR provides default implementations for numerous Level 3 SCOR features,
which you can enhance or customize as needed. In general, when modeling in
e-SCOR, you do not need to interact with the lower levels of SCOR directly.

Level 1 Roles
e-SCOR provides abstractions of the Level 2 SCOR model by implementing Level
1 “roles.” e-SCOR provides these high-level capabilities, using Level 1 roles:

• Business-level analysis, from suppliers’ suppliers to customers’ customers.
• Product/product family identification.
• High-level resource identification.
• Export of metrics to spreadsheet for further analysis.
• Dynamic modeling to simulate behavior over time.
• Multiple planning and supply chain management modes.

Level 2 SCOR
e-SCOR provides a subset of Level 2 and Level 3 SCOR. e-SCOR provides these
Level 2 SCOR features:

• Plan, Source, Make, Deliver, and Return process categories.
• Stock, make-to-order, and engineer-to-order planning strategies.
• Pull, push, replenishment, forecast, Q, and R-Q planning strategies.
• Material acquisition, vendor contracts, and payments.
• Production execution, which includes material acquisition, build order
selection, manufacturing, packaging, and shipping.

• Order management, warehouse management, packing and shipping time,
order selection, and inventory management.
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• Performance metrics, based on orders, shipments, build orders, financials,
costs, inventory, and contracts.

• Configurable parameters for categories relating to suppliers, orders,
manufacturing, order selection, packing and shipping, and costs.

• Configurable parameters for products relating to order type, cost, inventory,
and planning.

• “What-if” parameter changes.
e-SCOR does not implement these features of Level 2 SCOR:

• Demand/supply planning, including plan inventory, make/buy decisions,

long-term capacity and planning, product phase-in/phase-out, product-line
management.

• Logistics and scheduling of the delivery tasks of a supply chain.

SCOR Metrics
e-SCOR supports numerous SCOR metrics. The model computes these metrics
and makes them available through dialogs and reports in the appropriate location
in the model.
Some SCOR metrics are what e-SCOR considers parameters, which are values
that the user enters into the model as variables.
Other SCOR metrics are what e-SCOR considers metrics, which are values that
e-SCOR computes during the simulation.
e-SCOR refers to all inputs to the model as parameters and all outputs from the
model as metrics, regardless of whether they are SCOR metrics.

Benefits of Using e-SCOR
e-SCOR offers these benefits to supply chain managers:

• Compare process performance to targets by:
– Benchmarking metrics across multiple industries.
– Comparing existing practices to industry best practices.
• Evaluate supply-chain management improvement alternatives by:
– Identifying gaps in current processes.
– Quantifying the potential benefits of specific process improvements.
– Providing data for project financial justifications.
– Analyzing impact of e-business on supply chains.
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SCOR Modeling Concepts

• Implement supply-chain process improvements by:
– Integrating e-SCOR to augment ERP capabilities.
– “Fine tuning” designs, based on pilot results and changing market needs.
• Increase the value of the model by:
– Enhancing models to Level 4 and beyond.
– Integrating with MRP and ERP systems.
– Using Gensym database bridges for real-time access.
– Deploying models across a network.

SCOR Modeling Concepts
To use e-SCOR, you need to understand these SCOR modeling concepts:

• Supply chain management.
• SCOR management processes.
• Source, make, and deliver process categories.

Supply Chain Management
A supply chain is a business process that describes the complete set of steps
involved in obtaining raw materials, producing and assembling products, and
delivering those products to consumers.
A supply chain consists of two general types of functions or “roles:”

• Buyer — A Level 1 role that obtains goods from upstream suppliers.
• Supplier — A Level 1 role that deliver goods to downstream buyers.
Numerous configurations of buyers and suppliers exist, depending on an
organization’s location in the supply chain. A buyer might purchase raw
materials and supply manufactured products, purchase components and supply
assemblies, or purchase and supply finished products.
Supply chain management is the process of controlling the supply chain in the
most efficient and effective manner possible. You measure efficiency in terms of
various metrics, such as costs, asset turns, inventory days of supply, order
fulfillment times, and fill rates.
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SCOR Management Processes
A SCOR model consists of four distinct management processes:

• Plan — Plan supply and demand cycles.
• Source — Obtain materials from suppliers for manufacture, distribution, or
consumption.

• Make — Produce manufactured products.
• Deliver — Distribute ordered products, manage orders, and ship products.
From a high level, a supply chain model consists groups of Plan, Source, Make,
and Deliver processes for each distinct step in the supply chain, as this figure
illustrates:
Plan
Make

Plan
Make
Plan
Source

Make

Deliver Source

Supplier’s
Supplier

Make

Plan
Make

Plan
Make
Plan
Source

Deliver

Supplier

(Internal or
External)

Source

Plan
Source

Make

Your
Company

Deliver

Source

Make

Deliver

Customer

(Internal or
External)

Source

Customer’
Customer

Source, Make, and Deliver Processes
The Level 2 SCOR process categories for the Source, Make, and Deliver processes
use one of three planning strategies, which determine how the role computes
order size and to whom it delivers products:

• Stock — Fills orders for stock products from inventory and replenishes

inventory, based on inventory levels or forecasts; computes replenishment,
based on inventory planning.

• Make-to-order — Fills orders for make-to-order products from inventory and
replenishes inventory only when a buyer places an order; computes
replenishment, based directly on orders, but ships products to any buyer that
places an order.
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e-SCOR Implementation of Level 2 SCOR

• Engineer-to-order — Fills orders for engineer-to-order products by

engineering and manufacturing custom products for a particular customer;
maintains no inventory and ties shipped products to particular orders.

SCOR identifies each process category by letter—Source (S), Make (M), and
Deliver (D)—and number, where the numbers represent planning strategies:
This number...

Represents...

1

Stock

2

Make-to-order (MTO)

3

Engineer-to-order (ETO)

You can combine planning strategies within the same role, depending on the role.
For example, a Distributor role might source stock products and deliver make-toorder products. You can also combine planning strategies across roles. For
example, a Manufacturer role might source make-to-order products, but its
upstream distributor might deliver stock products.

e-SCOR Implementation of Level 2 SCOR
e-SCOR provides implementations of a subset of all the Level 2 SCOR process
categories. In addition, e-SCOR provides additional categories that SCOR does
not identify explicitly, which define boundary conditions in the supply chain.
e-SCOR implements these types of Level 2 SCOR categories:

• Source process categories
• Make process categories
• Deliver process categories
• Return process categories
• Plan process categories
• Enable process categories
• Boundary conditions
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Source Process Categories
e-SCOR provides the following Level 2 SCOR process categories to source stock,
make-to-order, and engineer-to-order products:
Category

Description

S1: Source Stocked Product

Sources stocked products, based on inventory
planning, and places them in inventory. The
P2: Plan Source category determines how much
to order.

S2: Source Make-to-Order
(MTO) Product

Sources make-to-order products, based on
orders, and places them in inventory. Inventory
can go to any downstream Make or Deliver
category.

S3: Source Engineer-to-Order
(ETO) Product

Sources engineer-to-order products, based on
orders, and sends them directly to the
downstream Make or Deliver category; the
Source category does not maintain an
inventory. Products go to the buyer that placed
the order.

Make Process Categories
e-SCOR provides the following Level 2 SCOR process categories to make stock,
make-to-order, and engineer-to-order products:
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Category

Description

M1: Make-to-Stock

Makes stock products, based on inventory
planning, and places them in inventory. The
P3: Plan Make category determines how much
to make.

M2: Make-to-Order

Makes make-to-order products, based on
orders, and places them in inventory. Inventory
can go to any downstream Deliver category.

M3: Engineer-to-Order

Makes engineer-to-order products, based on
orders, and sends them directly to the
downstream Deliver category; the Make
category does not maintain an inventory.
Products go to the buyer that placed the order.

e-SCOR Implementation of Level 2 SCOR

Deliver Process Categories
e-SCOR provides the following Level 2 SCOR process categories to deliver stock,
make-to-order, and engineer-to-order products:
Category

Description

D1: Deliver Stocked Product

Delivers stock products from inventory, based
on orders.

D2: Deliver Make-to-Order
(MTO) Product

Delivers make-to-order products from
inventory, based on orders. Inventory can go to
any downstream buyer role.

D3: Deliver Engineer-toOrder (ETO) Product

Delivers engineer-to-order products, based on
orders, and sends them directly to the
downstream buyer; the Deliver category does
not maintain an inventory. Products go to the
buyer that placed the order.

Return Process Categories
e-SCOR provides the following Level 2 SCOR process categories to source and
deliver defective products, MRO products, and excess products:
Category

Description

SR1: Source Defective
Product

Sources defective products from inventory.

SR2: Source MRO Product

Sources products that need to be maintained,
repaired, and/or overhauled.

SR3: Source Excess Product

Sources excess products from inventory.

DR1: Deliver Defective
Product

Delivers defective products from inventory.

DR2: Deliver MRO Product

Delivers maintenance, repair, and overhaul
(MRO) products from inventory.

DR3: Deliver Excess Product

Delivers excess products from inventory.
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Plan Categories
e-SCOR provides three of the five Level 2 SCOR process categories to model
planning:
Category

Description

P2: Plan Source

Plans and prioritizes material resource supply and
availability. Specifies the frequency with which roles
send orders to upstream suppliers.

P3: Plan Make

Plans and prioritizes demand requirements and
inventory. Specifies the frequency with which roles
make products for delivery to downstream buyers.

P5: Plan Return

Plans and prioritizes sourcing defective, excess, and
maintenance, repair, and overhaul (MRO) products.

Enable Process Categories
Level 2 SCOR identifies an additional process category for each management
process, called enable process, which manages the prerequisites for each process.
For example, the enable process categories determine which suppliers can deliver
which products. They also manage contracts when a buyer sources multiple
identical products from multiple upstream suppliers.
e-SCOR provides two of the four Level 2 SCOR enable process categories:
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Category

Description

ES: Enable Source

Awards contracts to upstream suppliers for
orders that downstream buyers place. Orders can
go to any number of suppliers. The order can be
divided among multiple suppliers, based on
proportion.

ED: Enable Deliver

Sends purchase responses to downstream
suppliers, based on purchase requests, obtains net
selling price and published lead time, and
manages contracts with buyers.

e-SCOR Implementation of Level 1 Roles

Boundary Conditions
e-SCOR implements two additional process categories, which SCOR does not
identify, to represent boundary conditions. These categories exist at the
beginning and at the end of the supply chain, as follows:
Category

Description

Mb: Make Product

Initiates the process of manufacturing and
delivering raw materials for the overall supply
chain. This category is located in the Base
Manufacturer role, which must be the first role
upstream in the supply chain.

Input

Initiates the process of creating orders for finished
products, which upstream suppliers deliver. This
category determines how often to generate
orders, the order size, and the timing of each
order. This category is located in the Consumer
role, which must be the last role downstream in
the supply chain.

End

Signals the end of the supply chain, when a
Consumer role receives and has paid for the
products it has ordered.

e-SCOR Implementation of Level 1 Roles
e-SCOR provides four Level 1 roles, which are abstractions of the management
processes implicit in Level 2 SCOR. e-SCOR refers to these roles as Level 1 roles,
because they define a level of abstraction that is one level higher than the Level 2
categories that SCOR identifies.
Roles simplify the process of creating SCOR models. To build a model, you
connect and configure a relatively small number of Level 1 roles, which
automatically include the required Level 2 SCOR categories, which you then
configure.
The Level 1 roles that e-SCOR implements correspond to the four basic functions
in a supply chain:

• Base Manufacturer role — Represents the beginning of the supply chain by

providing raw materials to downstream buyers for the overall supply chain.

• Distributor role — Sources components or finished products from upstream
suppliers, and delivers those products to downstream buyers, either as
complete products or by assembling components into “kits,” which are
simply finished products that do not require a manufacturing step.
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• Manufacturer role — Sources raw materials from upstream suppliers,
manufactures finished products, and delivers finished products to
downstream buyers.

• Consumer role — Initiates the acquisition of the finished products in the

overall supply chain and terminates the overall supply chain when those
products have been received and paid for.

Each Level 1 role includes the appropriate Level 2 SCOR process categories, as the
following figures show.

Base Manufacturer Role

Level 2

The Base Manufacturer role represents the beginning of the supply chain and
must be the furthest upstream role in the model.
The Base Manufacturer role includes these Level 2 SCOR categories:

• Make
– Mb: Make Product — Manufactures raw materials for the overall supply
chain.

• Plan
– P3: Plan Make — Determines the frequency with which the role
manufactures raw materials and computes how much to make.

• Deliver
– D1: Deliver Stocked Product — Delivers stock raw materials to
downstream buyers.

– D2: Deliver Make-to-Order Product — Delivers make-to-order raw
materials to downstream buyers.
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– D3: Deliver Engineer-to-Order Product — Delivers engineer-to-order raw
materials to downstream buyers.

– ED: Enable Deliver — Manages contracts with buyers.
• Return
– DR1: Deliver Defective Product — Delivers defective products to
downstream buyers, based on returns.

– DR2: Deliver MRO Product — Delivers MRO products to downstream
buyers, based on returns.

– DR3: Deliver Excess Product — Delivers excess products to downstream
buyers, based on returns.

Distributor Role

Level 2

The Distributor role includes these Level 2 SCOR categories:

• Source
– ES: Enable Source — Determines how the role chooses its suppliers.
– S1: Source Stocked Product — Sources stock components or finished
products from upstream suppliers.

– S2: Source Make-to-Order Product — Sources make-to-order components
or finished products from upstream suppliers.

– S3: Source Engineer-to-Order Product — Sources engineer-to-order
components or finished products from upstream suppliers.
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• Plan
– P2: Plan Source — Determines the frequency with which the role sources

components or finished products from upstream suppliers, and computes
how much to order.

– P5: Plan Return — Determines the frequency with which the role sources
defective products, MRO products, and excess inventory from upstream
suppliers, based on returns, and computes how much to order.

• Deliver
– D1: Deliver Stocked Product — Delivers stock components, kits from
components, finished products, and/or components to downstream
buyers.

– D2: Deliver Make-to-Order Product — Delivers make-to-order

components, kits from components, finished products, and/or
components to downstream buyers.

– D3: Deliver Engineer-to-Order Product — Delivers engineer-to-order
components, kits from components, finished products, and/or
components to downstream buyers.

– ED: Enable Deliver — Manages contracts with buyers.
• Return
– SR1: Source Defective Product — Sources defective products from
upstream suppliers, based on returns.

– SR2: Source MRO Product — Sources MRO products from upstream
suppliers, based on returns.

– SR3: Source Excess Product — Sources excess products from upstream
suppliers, based on returns.

– DR1: Deliver Defective Product — Sources defective products to
downstream buyers, based on returns.

– DR2: Deliver MRO Product — Sources MRO products to downstream
buyers, based on returns.

– DR3: Deliver Excess Product — Sources excess products to downstream
buyers, based on returns.
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Manufacturer Role

Level 2

The Manufacturer role includes these Level 2 SCOR categories:

• Source
– ES: Enable Source — Determines how the role chooses its suppliers and
manages contracts with suppliers.

– S1: Source Stocked Product — Sources stock components from upstream
suppliers.

– S2: Source Make-to-Order Product — Sources make-to-order components
from upstream suppliers.

– S3: Source Engineer-to-Order Product — Sources engineer-to-order
components from upstream suppliers.

• Plan
– P2: Plan Source — Determines the frequency with which the role sources
components from upstream suppliers and computes how much to order.

– P3: Plan Make — Determines the frequency with which the role

manufactures finished products and computes how much to make.

– P5: Plan Return — Determines the frequency with which the role sources
defective products, MRO products, and excess inventory from upstream
suppliers, based on returns, and computes how much to order.

• Make
– M1: Make-to-Stock — Manufactures stock finished products.
– M2: Make-to-Order — Manufactures make-to-order finished products.
– M3: Engineer-to-Order — Manufactures engineer-to-order finished
products.
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• Deliver
– D1: Deliver Stocked Product — Delivers stock finished products from
components to downstream buyers.

– D2: Deliver Make-to-Order Product — Delivers make-to-order finished
products from components to downstream buyers.

– D3: Deliver Engineer-to-Order Product — Delivers engineer-to-order
finished products from components to downstream buyers.

– ED: Enable Deliver — Manages contracts with buyers.
• Return
– SR1: Source Defective Product — Sources defective products from
upstream suppliers, based on returns.

– SR2: Source MRO Product — Sources MRO products from upstream
suppliers, based on returns.

– SR3: Source Excess Product — Sources excess products from upstream
suppliers, based on returns.

– DR1: Deliver Defective Product — Sources defective products to
downstream buyers, based on returns.

– DR2: Deliver MRO Product — Sources MRO products to downstream
buyers, based on returns.

– DR3: Deliver Excess Product — Sources excess products to downstream
buyers, based on returns.
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Consumer Role
The Consumer role represents the end of the supply
chain and must be the furthest downstream buyer
role in the model.
The Consumer role includes these Level 2 SCOR
categories:
Level 2

• Source
– ES: Enable Source — Determines how the role
chooses its suppliers and manages contracts
with suppliers.

– S1: Source Stocked Product — Sources stock
components from upstream suppliers.

– S2: Source Make-to-Order Product — Sources
make-to-order components from upstream
suppliers.

– S3: Source Engineer-to-Order Product —

Sources engineer-to-order components from
upstream suppliers.

• Return
– SR1: Source Defective Product — Sources

defective products from upstream suppliers,
based on returns.

– SR2: Source MRO Product — Delivers MRO

products from upstream suppliers, based on
returns.

– SR3: Source Excess Product — Delivers excess
products from upstream suppliers, based on
returns.

• P5: Plan Return — Determines the frequency with
which the role sources defective products, MRO
products, and excess inventory from upstream
suppliers, based on returns, and computes how
much to order.

• Input — Initiates the process of creating orders

for finished products for the overall supply chain.

• End — Terminates the overall supply chain
process when finished products have been
received and paid for.
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Products
Each Level 1 role sources, makes, and/or delivers products, based on a product
specification.
To model products in a supply chain, you create:

• A product hierarchy, or bill of materials (BOM), which is a hierarchical

representation of the relationship between each product specification in the
supply chain.

• Product composites, which determine the products each role sources and/or
delivers.

You create the product hierarchy on the detail of a product structure organizer.

Product Hierarchy
A product hierarchy consists of a high-level product specification, called a
finished product, which might contain one or more lower-level product
specifications, called components. The product hierarchy can describe as many
levels of detail as needed.
You specify the number of components that each product represents by
configuring the usage quantity of the connection between the products in the
hierarchy. For example, a laptop finished product might consist of a computer
case and 3 electronics components.
Here are two different product hierarchies. First is the product hierarchy for a
computer finished product, which consists of a computer case component and 3
electronics components:
Finished product
Usage Quantity = 1

Components
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Usage Quantity = 3

Products

Next is the product hierarchy for a computer, which consist of a monitor, a
keyboard, and a CPU component, where the CPU consists of a computer case
component and 3 electronics components:
Finished product

Components
Usage Quantity = 3

Components

You can also configure the product hierarchy to model alternate products,
whereby the model chooses between generic products and specific products,
based on availability and priority.
You can create one or more product hierarchies, as needed, to describe the
structure of each finished product that your supply chain sources and delivers.
Each role sources, makes, and/or delivers one or more products in the product
hierarchy, as follows:

• A Base Manufacturer role makes and delivers components or finished
products, which are raw materials for the overall supply chain.

• A Distributor role sources components and delivers finished products as kits,
sources and delivers components, and/or sources and delivers finished
products.

• A Manufacturer role sources components, and makes and delivers finished
products.

• A Consumer role sources components or finished products.

Product Composites
When you assign a product specification to a role, e-SCOR creates a product
composite for each product that the role sources, makes, and/or delivers. e-SCOR
creates two types of product composites:

• Source product — A product composite that a role sources from an upstream
supplier.

• Delivery product — A product composite that a role delivers to a
downstream buyer.
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You configure various parameters for source and delivery products. Each source
and delivery product also computes various metrics.
By creating product composites for each role, e-SCOR allows you to configure
parameters and track metrics separately for each role’s source and delivery
products. For example, you might configure the inventory safety stock to be 100
for the source product of a downstream buyer role and 50 for the delivery product
of the upstream supplier role. Similarly, you can track inventory levels separately
for the source product of a buyer role and the delivery product of the upstream
supplier role.
Here are the product composites for a Manufacturer role that sources computer
cases and electronics components, and makes and delivers computer finished
products:

Source
products

Delivery
product

Orders
By default, e-SCOR uses a pull planning mode, which means downstream buyers
place orders with upstream suppliers for source products. Conceptually, e-SCOR
creates two basic types of orders when the model runs in pull mode:

• Customer orders — Orders for the source products of a Consumer,

Distributor, or Manufacturer role, which initiate the order fulfillment process.
The three types of customer orders are:

– Replenishment orders — Customer orders that originate in a Distributor
or Manufacturer role.

– Demand orders — Customer orders for finished products in the overall
supply chain, which originate in a Consumer role.

– Change orders — Change orders for existing demand orders for finished

products in the overall supply chain, which originate in a Consumer role.

• Build orders — Orders for the delivery products of a Base Manufacturer or
Manufacturer role, which initiate the manufacturing process.
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Manufacturing Resources

This diagram illustrates the various types of orders for a Manufacturer role:
Customer
(replenishment)
order

Customer
order

Buyer

Supplier

Build order

e-SCOR creates and deletes orders as the model runs and stores these orders in
pools on the role detail.
You can also configure individual roles to use a push planning mode, which
means the upstream supplier pushes its delivery products to downstream buyers,
based on forecasts.

Manufacturing Resources
Each Level 1 role sources, makes, and/or delivers products, based on the capacity
of its required resources. The model uses resources to represent the number of
finished products a manufacturer role can make at one time. The model also uses
resources to compute production cost.
e-SCOR models require manufacturing resources for Base Manufacturer and
Manufacturer roles, only; Distributor and Consumer roles do not require
resources.
e-SCOR automatically creates a single resource for each manufacturing role in
your supply chain. The role then allocates available resources when it makes
products. You can configure the capacity of an individual resource to enable the
role to make more finished products.
You can model shared resources by associating the same resource with multiple
roles in your supply chain, which further constrains the model’s ability to make
finished products.

23

Reporting
The SCOR model describes numerous metrics that measure the performance of
the supply chain, including:

• Delivery performance and quality metrics, such as order fulfillment fill rates
and lead times, and supplier on-time performance.

• Flexibility and responsiveness metrics, such as supply chain response time.
• Cost metrics, such as value-added productivity cost.
• Asset metrics, such as cash-to-cash cycle time and inventory days of supply.
• Financial metrics that compute regular collections and payments.
e-SCOR computes these and other performance metrics for roles, categories, and
product composites. You can compute static values, time-series data, and timeweighted statistics, such as averages and moving averages.
The model computes metrics, based on input parameters that you configure for
each role, category, and product composite in the model. You configure
parameters to perform “what-if” analysis to test the performance of the model
under different scenarios.
You view metrics and configure parameters, using several techniques:

• Dialogs for roles, categories, and product composites.
• Reports within e-SCOR.
• CSV (Comma Separate Values) files.
• Excel reports.
• Databases.
In addition, you can view key metrics in the Metrics toolbars, which
automatically update as the simulation runs.
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Running e-SCOR
Describes how to start the server and connect the client.
Introduction 17
Starting the Server and Connecting the Client 18
Connecting to a Specific Server at Startup 19
Starting the Server with Your Application Loaded 21
Exiting Integrity 21

Introduction
e-SCOR is a client/server application. e-SCOR provides a batch file that, by
default, starts the G2 server as a hidden process on the local machine at a default
port (1111).
To run e-SCOR, you must connect the Telewindows client to the server. By
default, Telewindows automatically connects to the server running on the local
machine on the default port.
You can run e-SCOR in a secure G2 environment, which means users must
provide a password before e-SCOR grants access to a KB. User names and
passwords are stored in the g2.ok file. For details on how to configure e-SCOR to
run in a secure G2 environment, see Chapter 54 “Licensing and Authorization” in
the G2 Reference Manual.
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Starting the Server and Connecting the Client
You can start the server and connect the client by using the Start menu.
To start the server and connect the client:
1

Choose Start > Programs > Gensym G2 2011 > G2 e-SCOR >
Start G2 e-SCOR Server.
This menu choice starts the G2 server, using the StartServer.bat batch file,
located in the g2 directory of your e-SCOR installation directory. It starts the
server on the local machine on TCP/IP port number 1111, and it automatically
loads the KB named e-scor.kb.
When the server has been started, the G2 icon appears in the system tray.
When the server is running, the icon looks like this:

2

Once the server is running, connect the client in one of two ways:
 To connect Telewindows to the server running on the default host and
port, choose Start > Programs > Gensym G2 2011 > Telewindows Next
Generation.

or
 To connect Telewindows to the server running on the local host on the
current port, right-click the G2 icon in the system tray and choose Connect
Telewindows.

The Telewindows client is now connected to the G2 server.
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Connecting to a Specific Server at Startup

When the client is connected and all files have finished loading, you will see this
window:

Connecting to a Specific Server at Startup
You can run the e-SCOR client and server on different computers, or multiple
e-SCOR servers on the same computer.
You can:

• Connect the client directly to the server.
• Start the server on a specific port.
• Connect the client to a specific server.
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Connecting the Client to the Default Server
To connect the client to the default server:
1

Start the e-SCOR server from the Start menu.
By default, the server starts on the local host at port 1111. Each time you start a
new server on the same machine, the port number increments by one. For
example, if you start another server, the port number would be 1112.

2

To determine the host and port, hover the mouse over the G2 server icon in
the system tray.
For example, MY-HOST:1111 means the server is running on the machine
named MY-HOST at port 1111.

3

Right-click the G2 server icon in the system tray and choose Connect
Telewindows.

The Telewindows client connects to the specific host and port of that server.

Starting the Server on a Specific Port
To start the server on a specific port:
1

Right-click the Start G2 e-SCOR Server menu choice in the Start menu and
choose Create Shortcut.

2

Rename the shortcut and/or drag it to your desktop, as needed.

3

Display the properties dialog for the shortcut and click the Shortcut tab.

4

Configure the Target property in the dialog to be the specific port on which to
start the server, using the -tcpport command-line option.
For example, to start the server on port 1115, the shortcut would look like this:
"C:\Program Files\Gensym\g2-2011\g2\StartServer.bat"
-kb ..\escor\kbs\e-scor.kb -nowindow -tcpport 1115

Connecting the Client to a Specific Server
To connect the client to a specific server:
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1

Create a shortcut to the twng.exe file located in the g2 directory of your
e-SCOR product installation, either directly or by creating a shortcut from the
Telewindows Next Generation menu choice in the Start menu.

2

Display the properties dialog for the shortcut and click the Shortcut tab.

Starting the Server with Your Application Loaded

3

Configure the Target by appending the host and port of the e-SCOR server to
which to connect, using this syntax: host:port.
For example, to connect to my-host at port 1115, the shortcut would look like
this:
"C:\Program Files\Gensym\g2-2011\g2\twng.exe"
my-host:1115

Starting the Server with Your Application
Loaded
By default, the server starts up with the default e-SCOR application running, escor.kb. Once you create an application, you might want to create a shortcut to
the e-SCOR server that automatically loads your application at startup.
To start the server with your application loaded:
1

Copy the Start G2 e-SCOR Server shortcut from the Start menu.
You can rename the shortcut and drag it to your desktop, as needed.

2

Display the properties dialog for the shortcut and click the Shortcut tab.

3

Configure the application to load by editing the Target.

For example, to load the application named escor-demo.kb located in the
\escor\examples directory, the Target should look like this:
"C:\Program Files\Gensym\g2-2011\g2\StartServer.bat"
-kb "c:\Program Files\Gensym\g2-2011\escor\examples\escor-demo.kb"
-nowindow

Exiting e-SCOR
To exit e-SCOR, you disconnect the client from the server, then shut down the
server. By default, you can only exit the server directly from the client in
Developer mode.
To disconnect the client from the server:
 Choose File > Close.
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To exit the server:
 Right-click the G2 server icon in the system tray and choose Shut Down G2.

or
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1

Choose Tools > User Mode > Developer.

2

Choose File > Exit.

3

Click Yes in the confirmation dialog.

3
Organizing Models and
Controlling Simulations
Describes how to use models, scenarios, and organizers to organize and control
models.
Introduction 9
Working with Projects 11
Configuring the Model Environment 13
Controlling the Simulation 17
Configuring the Scenario 20
Performing “What-if” Analysis on a Model 28
Working with Large Models 32
Viewing Demo Models 37
Customizing Scenarios 38

Introduction
The first step in building a e-SCOR model is to create a new project. e-SCOR takes
care of loading and saving all the required modules for you; therefore, we
recommend that you always create a new project.
The next step is to create a model, which contains the blocks, resources, and
instruments that describe your business process. You place these objects on the
subworkspace of the model, which is called the detail.
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A model typically has one or more organizers, which contain various types of
objects that the model requires but that are not directly connected to the model,
such as work object definition classes or resources. You place these objects on the
organizer’s detail.
Each model must define a scenario, e-SCOR’s discrete event simulation engine,
which tracks events by using a simulation clock. A scenario controls various
aspects of the model, including the mode, status, and simulation time, which
represents the current time at which the simulation is running.
Once you have created a model of your process, you typically experiment with
alternative scenarios and processes to test the performance of the model under
different conditions. For example, you might test the model under a heavy load
and a light load to see how it performs, or you might test the same set of input
parameters against a model with fewer resource constraints. Thus, scenarios serve
as control centers for a model, allowing you to perform “what-if” analysis.
This topic describes how to:

• Work with projects.
• Configure the model environment.
• Control the simulation.
• Configure the scenario.
• View a summary of creating models and running simulations.
• View demonstration models.

Working with Projects
An e-SCOR project consists of a set of related files that form a knowledge base.
Each file contains a stand-alone module, which together make up a module
hierarchy. Each module is associated with its own .kb file, whose name typically
corresponds to the module name. The module hierarchy consists of a top-level
module and a number of lower-level modules. The top-level module requires the
lower-level modules to run.
You can:

• Create a new project.
• Save a project.
• Open a project.
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Creating a New Project
When creating a new project, e-SCOR creates a new, blank project with the name
you enter. The new project is saved it in the projects directory of your e-SCOR
installation directory.
Note Creating a new project replaces the existing model in memory. Therefore, before
you create a new project, be sure to save the existing project, as necessary.
To create a new project:
1

Choose File > New.

2

Enter the name of the project.
The project name cannot contain spaces.

3

Ensure that e-SCOR is chosen as the selected library.

4

Check or uncheck any additional libraries, depending on how your
application needs to access external data.

5

Click OK.

e-SCOR displays the Operator Logbook as it creates a new project with the name
you specify, then loads the new project and all required modules onto the server.
When all modules have been successfully loaded, the menu bar updates. You
must wait until the KB has finished loading in the server before you can access
your project.

Saving a Project
Projects are stored in the projects directory of your e-SCOR installation
directory.
e-SCOR saves the top-level module only; it does not save the required modules.
Unless you are customizing e-SCOR, you do not generally need to save the
required modules.
To save a project:
 To save a project to the project file that was loaded when you started the
client, choose File > Save or click the equivalent toolbar button: (
)

or
 To save the project to a different project file, choose File > Save As, enter a
new project name, or choose an existing project name from the list of available
projects on the server.
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Opening a Project
To open a project, specify the project name associated with the top-level module
in the module hierarchy.
Note Opening a new project replaces the existing application in memory. Therefore,
before you open a new project, be sure to save the existing project, as necessary.
To open a project:
1

Choose File > Open or click the equivalent toolbar button (
Open Project dialog.

2

Enter or choose the project to open and click Open.

3

Click Yes in the confirmation dialog.

) to display the

e-SCOR displays the Operator Logbook as it loads the project file and all required
modules onto the server. When all modules have been successfully loaded, the
menu bar updates. You must wait until the KB has finished loading in the server
before you can access the application.

Configuring the Model Environment
You create your e-SCOR model by creating and configuring these objects within
the model environment:

• Model — A container in which you build your e-SCOR model.
• Scenario — The discrete event simulation engine for controlling the
simulation.

• Organizer — A container in which you place various objects in your model.
Note Every model must have a Scenario; otherwise, you cannot configure certain
aspects of the model.
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Creating a Model
You create and organize models through the Projects menu, in which case
e-SCOR keeps track of where the model is located.
You can also create models directly from the e-SCOR toolbox and place them on a
top-level workspace.
To create a model:
1

Do one of the following:
 Choose Project > System Models > Supply-Chain Processes > Manage,
then click the New button (
) to display the properties dialog for
creating a new model.

or
 In the Navigator, expand System Models in the tree, mouse right on the
Supply-Chain Processes node, and choose New Instance.
2

Configure the Label to name your model.

3

Configure the Best Practice URL, as needed.
The Best Practice URL can reference any HTML file, either on the World Wide
Web or on the file system, or any RTF file on the file system, which describes
the model. When this attribute is configured, choosing Show URL or clicking
the model displays the file in a browser window.

4

Configure the Model Version to be any number to uniquely identify the
model.

5

Click OK to add the model to the Manage dialog and Navigator.

6

In the Manage dialog, select your model and click the Model button (
) to
show the model detail, or in the Navigator, mouse right on the model and
choose Show Detail.
You create your model on this detail.

7

Choose View > Toolbox - e-SCOR and click the Tools button:

Scenario
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8

Select a Scenario and click to place it on the model detail.

9

Choose Layout > Shrink Wrap or click the equivalent toolbar button:

The workspace and window size adjust to fit the model. Drag the Scenario to
adjust the borders of the workspace.
The model detail should look similar to this:

Scenario
Model detail

Alternatively, to create a model and place it on a top-level workspace:
1

Choose Workspace > New.
For more information, see Creating and Accessing Top-Level Workspaces.

2

Display the e-SCOR toolbox and click the Tools button.

3

Create a Model object and place it on the workspace.

4

Choose Show Detail on the model to show its detail.

For example, here is a top-level workspace with two models:
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Creating an Organizer
When you create a model, you might want to use an Organizer to store
miscellaneous objects such as the Scenario Manager or report objects. You use an
organizer for any object that the model requires to run but that is not directly
connected to the model.
To create an organizer:
1

Choose View > Toolbox - e-SCOR and click the Tools button:

Organizer

2

Select an Organizer and click to place it on the model detail.

3

Choose Properties on the organizer.

4

Edit the Label parameter to be any text, then drag the label to the desired
location next to the organizer.

5

Choose Create Detail on the organizer.
The organizer detail appears in its own window. You place objects on this
detail, as needed.

6

Choose Show Detail on the organizer to show the detail.

This figure shows a model with a scenario and an organizer on the model detail:
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Controlling the Simulation
You control the simulation from the Simulation menu or toolbar. These menu
choices and toolbar buttons affect the scenario, which is the control center for
running the simulation. Every model must contain a scenario.
To control the simulation, you:

• Activate and deactivate the scenario.
• Start and stop the simulation.
The scenario shows the simulation mode, status, and current simulation time,
for example:

Activating and Deactivating the Scenario
Before you can run a simulation, you must activate the Scenario. Certain menu
choices, such as Show Scenario, are only available when the scenario is active.
The following figure shows an active and inactive scenario:
active

inactive

Note Starting the simulation automatically activates the scenario; therefore, typically,
you do not need to activate the scenario explicitly.
To activate and deactivate a scenario:
 Display a model that contains a scenario, then choose Simulation > Activate or
click the equivalent toolbar button ( ) to toggle activation.
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Starting and Stopping the Simulation
You control the status of the simulation by using menu choices in the Simulation
menu, by using keyboard shortcuts, or by clicking the equivalent toolbar button,
as follows:
Menu Choice/
Shortcut

Toolbar Button

Status

Description

Start All

running

Start the simulation
running.

Reset

resetting

Reset the simulation.

Pause

paused

Pause the simulation.

Continue

running

Continue running the
paused simulation.

By default, the simulation runs in Jump mode, which advances the simulation
clock continuously with each discrete event. For alternative ways to run the
simulation, see Configuring the Simulation Mode.
To start and stop the simulation:
1

Start the simulation by choosing Simulation > Start All or by clicking the
equivalent toolbar button.
Choosing Start All activates the scenario and resets the simulation before
starting.
Resetting the simulation can take a period of time, depending on the size of
the model and the speed of your computer. The status of the scenario is
resetting.
After resetting, e-SCOR verifies that you have configured all roles correctly.
Once role verification is complete, objects begin flowing through the model.
These objects represent orders, product shipments, invoices, payments, and
other objects that the model creates and deletes when the simulation runs.
You can only see these objects as they flow through the model if animation is
enabled. The model also begins computing metrics. The status of the scenario
is running.
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2

To pause the simulation, choose Simulation > Pause or click the equivalent
toolbar button.
Pausing the simulation stops the simulation clock, causes all objects to stop
flowing through the model, and stops computing metrics. The status of the
scenario is paused.

3

To resume running the simulation after pausing, choose Simulation >
Continue or click the equivalent toolbar button.
The simulation clock begins advancing again, objects begin flowing through
the model, and the status of the scenario is running.

4

To reset the simulation, choose Simulation > Reset or click the equivalent
toolbar button.

Resetting the simulation resets the simulation clock, deletes all objects that the
model created, and resets all metrics to their initial values.

Configuring the Scenario
You can configure these features of the scenario:

• Simulation mode, which determines whether the simulation runs
continuously, step-by-step, or in real time.

• Duration of the simulation.
• Version of the simulation.
• Start time of the simulation.
• Simulation speed.
• Animation.
• Speed at which objects flow along paths.
• Indicator arrow behavior.
• Computational behavior of the scenario.
• Random number generation.
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Configuring the Simulation Mode
You can run the simulation in one of three modes by using the menu choices in
the Simulation menu or the equivalent toolbar button, as this table describes:
Menu
Choice

Toolbar
Button

Mode

Description

Jump Mode

jump

The normal discrete event simulation mode. Events
occur in their normal time sequence while a
simulation is running, but the real-time clock
advances non-linearly relative to the simulation
clock. After each discrete event, e-SCOR
immediately advances the simulation clock to the
start time of the next event. Objects flow through
the model without stopping.

Step Mode

step

The mode you use for careful examination of the
model. e-SCOR pauses after each event so you can
walk through the simulation one step at a time.
When you continue running the simulation, the
clock immediately advances to the start time of the
next event, then stops.

Synch Mode

synch

The mode you use to help visualize the relative
times between events. e-SCOR scales the simulation
time to real time. For example, you can use this
mode to run the simulation at one hour per second
of real time. Most of the time when you are running
a simulations, however, you let the simulation clock
keep track of the time by using either jump or step
mode.

You configure the simulation mode from the Simulation menu or toolbar, or on
the properties dialog for the scenario.

Running the Simulation in Jump Mode
To run the simulation in jump mode:
1

Choose Simulation > Jump Mode, click the equivalent toolbar button, or
display the properties dialog for the Scenario and configure the Mode to
be Jump.

2

Choose Simulation > Start All or click the equivalent toolbar button to start
the simulation
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Running the Simulation in Step Mode
To run the simulation in step mode:
1

Choose Simulation > Step Mode, click the equivalent toolbar button, or
display the properties dialog for the Scenario and configure the Mode to
be Step.

2

Choose Simulation > Start All or click the equivalent toolbar button to take a
single step in the simulation, then pause the simulation.

3

Choose Simulation > Continue or click the equivalent toolbar button to take a
single step for each discrete event, then pause the simulation.

Running the Simulation in Synch Mode
When you run the model in synch mode, you must configure the proportion of
simulation time to real time. The larger the number, the faster the overall
execution time of the simulation. By default, the value is 1, which means the
timing parameters contribute exactly the specified amount of simulation time to
the simulation clock. A value of 2 means they contribute half the amount of time.
For example, if a timing parameter specifies 10 minutes to perform a task, and the
Seconds per Tick is 2, the parameter contributes 5 minutes of simulation time.
Note If your model is complex, e-SCOR may not be able to keep up with the specified
synch rate. For example, if you specify a synch rate such that one minute of
simulation time is equivalent to one year of real time, e-SCOR might require more
than one minute to process a year-long simulation. If this is the case, e-SCOR
gives no indication that the synch rate is too slow; however, the metrics that the
simulation computes are correct.
To run the simulation in synch mode:
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1

Display the properties for the scenario, click the Scenario tab, and configure
Seconds per Tick to be a number greater than one.

2

Choose Simulation > Synch Mode, click the equivalent toolbar button, or
display the properties dialog for the Scenario and configure the Mode to
be Synch.

3

Choose Simulation > Start All to run the simulation.

4

Choose Simulation > Pause to pause the simulation.

5

Choose Simulation > Continue to continue running the simulation in synch
mode.

Configuring the Scenario

Configuring the Duration of the Simulation
Depending on your model, you typically configure the scenario to run for a
specific duration, such as a month, a year, or ten years. You do this by specifying
the ending time of the simulation. A duration of 0 means the simulation will run
for the maximum allowable simulation time, which is 17 years.
Tip To ensure accurate financial reporting, configure the duration of the simulation to
be slightly longer than the end of the last financial period.
To configure the duration of the simulation:
 Display the properties dialog for the scenario, click the Scenario tab, and
configure the Duration to be the amount of time the simulation should run,
for example, 3 months or 2 years.

Configuring the Simulation Version
When performing “what-if” analysis, you often use different scenarios with the
same or with different versions of the model. When using the Scenario Manager
to run multiple simulations from a script, you typically output the data to a
report. To identify which scenario was used to generate the data, you configure
the version of the simulation, using a unique number.
To configure the simulation version:
 Display the properties dialog for the scenario, click the Scenario tab, and
configure the Simulation Version to be a unique number.

For example, you might use 1.0, 1.1, and 1.2 for the scenario associated with three
different versions of a model.

Configuring the Start Time of the Simulation
By default, e-SCOR uses January 1, 2006 as the start time of the simulation. You
might want to start the simulation at a different time.
To configure the start time of the simulation:
 Display the properties dialog for the scenario, click the Start Time tab, and
configure the Year, Month, Day, Hour, Minute, and/or Second to be the start
time of the simulation.

When you reset the simulation, the new start time appears.
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Configuring Simulation Speed
By default, the scenario is configured to run as fast as possible, which means that
when you are running in jump or synch mode, the clock advances with each new
event as fast as it can. This default configuration is desirable when:

• Running simulations from a script, using the Scenario Manager.
• You do not need to interact with the model while the simulation is running.
• You do not need to visualize the animation of objects as they flow through
the model.

Depending on the speed of your computer, running the simulation as fast as
possible often means that you will experience delays when interacting with the
user interface while the simulation is running. For example, when you click the
Pause button to pause the simulation, the simulation clock continues to advance
until the processing has caught up with the user interaction. Similarly, you will
experience delays when configuring values through the dialogs or reports while
the simulation is running.
If you want to interact with the user interface while the simulation is running, for
example, to configure parameter values, you should slow the simulation down to
allow more time for the user interface to respond.
To slow the simulation down, you configure the simulation speed to be a larger
number. Depending on the speed of your computer, you might try a simulation
speed of 10 or 15.
Note Once you have configured your model, we recommend that you set the
Simulation Speed to 0 for optimal performance, the default.
To configure the simulation speed:
 Display the properties dialog for the scenario, click the Options tab, and
adjust the Simulation Speed, where the larger the number, the slower the
speed.

Configuring Animation
e-SCOR can animate running simulations by physically moving objects along
paths and highlighting blocks as they become active. If you are using your model
as a communication tool to visualize work objects as they flow along paths, you
might want to enable animation.
Depending on the speed of your computer, you might need to adjust the
animation speed. In particular, if you have a relatively fast computer, you might
need to slow down the animation speed to better visualize the flow of work
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objects. However, keep in mind that performance degrades the slower the
animation speed.
You configure animation speed, based on the number of milliseconds it takes to
move an object from the beginning of a path to the end of a path. By default, it
takes an object 5 milliseconds to move along a path. To slow down the animation,
you might want to move an object along the path in 8 or 10 milliseconds.
Note Once you have configured your model, we recommend that you disable
animation for optimal performance.
To enable animation for a simulation:
 Display the properties dialog for the scenario, click the Options tab, and click
the Enable Animation option on.

When you run the simulation, objects move along paths and blocks animate as the
simulation clock advances.
To adjust animation speed:
 Display the properties dialog for the scenario, click the Options tab, and
adjust the Animation Speed, where the larger the number, the slower the
speed.

Configuring Object Tracking
You can configure the scenario so that objects that flow through the model keep
track of the blocks through which they have passed since they were created.
When object tracking is enabled, you can pause the simulation and show tracking
for any object. Object tracking is a useful way of verifying the model to ensure
objects flow along the correct paths.
When showing object tracking, e-SCOR animates all the blocks upstream of the
current block, in order, starting at the current block and ending at the block that
created the object. e-SCOR repeats this process four times, by default. You can
configure the color used for animating blocks when showing object tracking.
To configure object tracking:
1

Display the properties dialog for the scenario, click the Options tab, and click
the Enable Tracking option on.

2

Configure the Animation Repeat Counter to be the number of times to
animate the blocks when showing object tracking.

3

Configure the Animation Color to be the highlight color to use.
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To show object tracking for an object:
 Pause the simulation, then choose Show Flow History on a object in the
model.

Configuring the Behavior of Indicator Arrows
e-SCOR places indicator arrows next to objects when you show various objects
associated with other objects, such as when you show the scenario associated with
a role.
By default, the indicator arrow remains on the workspace until you explicitly hide
it. You can clear all indicators automatically, or you can configure the scenario to
clear indicators automatically after a certain number of seconds.
Note To clear all indicators, the scenario must be active, as described in Activating and
Deactivating the Scenario.
To clear an individual indicator arrow:
 Left click the indicator arrow.
To clear all indicator arrows:
 Activate the scenario, then choose Simulation > Clear Indicators or click the
equivalent toolbar button:
To clear indicators associated with a scenario after a timeout period:
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1

Display the properties dialog for the scenario, click the Options tab, and
configure the Indicate Mode by choosing Timeout.

2

Configure the Timeout period after which indicators should automatically
disappear, in seconds.

Configuring the Scenario

Configuring the Computation Behavior
To maximize performance, the scenario is configured to perform the minimum
amount of computation necessary at Level 3, Level 4, and Level 5. If you are
customizing the implementation of Level 2 categories, you can configure these
parameters for a scenario related to computation behavior:
You can configure these parameters related to computation behavior:
Parameter

Description

Compute All Blocks

Enables the computation of Task blocks with detail.
The default value is off, which means e-SCOR
computes values for Task block details only; it does
not compute values for the block itself.

Update Charts

Enables the updating of charts. The default value is
off, which means that you must update charts
manually or by using a button or a rule. For details,
see “Updating Charts” in the ReThink User’s Guide.

Enable Metrics
Toolbar Update

Disables the updating of the Metrics toolbars. The
default value is on, which means that the Metrics
toolbars update once every half second.

Note The scenario computes metrics for all e-SCOR Level 1 roles and Level 2 categories
and product composites in the model, regardless of how the Scenario is
configured.

Note Once you have configured your model, we recommend that you disable updating
of the Metrics toolbar for optimal performance.
To compute metrics for Task blocks with detail:
 Display the properties dialog for the scenario, click the Options tab, and
enable the Compute All Blocks option.
To update charts automatically:
 Display the properties dialog for the scenario, click the Options tab, and
enable the Update Charts option.
To disable metrics toolbar updating:
 Display the properties dialog for the scenario, click the Options tab, and
disable the Enable Metrics Toolbar Update option.
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Configuring the Scenario to Generate Identical
Random Numbers
By default, the scenario generates random numbers that vary with each
simulation by generating a new seed number for each simulation. You might
want to run a simulation with identical random numbers to test different model
configurations, using the same set of random numbers.
e-SCOR generates random numbers to compute mathematical distributions such
as Random Normal, Random Exponential, or Random Triangular. You use these
random distributions to generate values for attributes such as Demand Order
Size, Demand Order Duration, Receiving Duration, Manufacturing Duration, and
Order Entry Duration.
To configure the scenario to generate identical random numbers:
1

Display the properties dialog for the Scenario and, on the Scenario tab,
configure the Seed Value to be an integer that holds the seed value, which eSCOR uses as the basis for randomly generated numbers.
By default, it generates a random number as the Seed Value.

2

Disable the Generate New Seed option to use the specified Seed Value for
each simulation.

3

Reset the Scenario to use these new values.

Each time you run the simulation, using this scenario, e-SCOR uses the same set
of randomly generated numbers.

Summary of Creating Models and Running
Simulations
A typical model consists of these roles:

• Base Manufacturer role, which delivers components to the overall supply
chain.

• Distributor role, which delivers its source products or which assembles
components into kits.

• Manufacturer role, which sources components, and manufactures and
delivers finished products.

• Consumer role, which sources finished products and/or kits from upstream
suppliers.

To configure a model with Distributor and Manufacturer roles, you typically
configure the product structure as a hierarchy, where finished products consist of
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components, which might consist of other components. For example, a computer
might consist of electronics and case components.
You configure Level 1 role and Level 2 SCOR parameters to determine the
behavior of the model, such as:

• Timing and cost parameters for Source, Make, and Deliver categories.
• Planning parameters related to stock/replenishment, stock/forecast, make-toorder, and engineer-to-order planning strategies.

• Contract parameters for choosing suppliers when sourcing identical products
from multiple suppliers.

• Pull and push planning mode parameters.
You can configure categories on the role detail to support alternative planning
strategies—make-to-order and engineer-to-order—as well as different Level 2
SCOR parameters for multiple products assigned to the role.
You can create various types of reports for viewing metrics and configuring
parameters.
When you run the simulation, you are primarily concerned with the metrics the
model computes for roles, categories, and product composites. In addition, you
can configure how the simulation runs by configuring the Scenario.
e-SCOR runs a number of processes when the simulation runs, which determine
parameters, compute metrics, and create objects and place them in repositories.
To create a model and run a simulation:
1

Create a supply-chain model and configure Level 2 SCOR parameters for each
category and product composite in the model.
For details, see:

• Working with Models.
• Creating a Supply-Chain Model.
• Configuring Level 2 SCOR.
2

Run the simulation.
For details, see:

• Running the Simulation.
• Viewing Metrics.
• What Happens When the Simulation Runs.
3

Create input and output reports for configuring parameters and
viewing metrics.
For details, see:
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• Using Reports.
• Accessing External Databases.
4

Configure Distributor roles:
For details, see Modeling a Distribution Process.

5

Configure Manufacturer roles.
For details, see Modeling a Manufacturing Process.

6

Configure Level 2 SCOR parameters to use different stock planning strategies:
For details, see Using Stock Planning Strategies.

7

Configure Level 2 SCOR parameters to use alternative planning
strategies—make-to-order or engineer-to-order.
For details, see Using Alternative Planning Strategies.

8

Configure the model to use contracts for sourcing identical products from
multiple upstream suppliers.
For details, see Modeling a Process with Multiple Suppliers.

9

Add categories to the role details to source, make, and deliver multiple
products.
For details, see Configuring Role Details for Multiple Products.

10 Configure the model to use a pull or push planning mode, as needed.

For details, see Using Pull and Push Planning Modes.
For information on how asset metrics are computed, see Appendix A, Asset
Metrics Formulas.
For information on the SCOR parameters and metrics that e-SCOR supports, see
Appendix B, SCOR Metrics.
11 Create scripts for running multiple simulations, using different parameters.

For details, see Using Batch Simulation.

Viewing Demo Models
e-SCOR provides a number of a tutorial models. For details, see the e-SCOR
Getting Started Tutorials.
e-SCOR also provides demonstration models that you can view named
escor-demo.kb, which includes examples of pull and push planning strategies,
kitting, MTO, ETO, and product hierarchies.
These models are all located in the escor\examples directory of your e-SCOR
product directory.
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Viewing Demo Models

To view e-SCOR demo models:
 Choose File > Open and choose the file to open.
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Introduction
To work with e-SCOR models, you perform these tasks:

• Use the Project menu.
• Navigate models.
• Interact with workspaces.
• Use the menus.
• Use the e-SCOR toolbox.
• Use the G2 Toolbox.
• Interact with objects in the model.
• Use toolbars.
• Set and clear breakpoints and indicators.
• Switch user modes.
• View messages.
• Configure user preferences.
• Configure network interfaces.
• Configure message browsers.
You can also view a summary of command tasks.

Summary of Common Tasks
This section summarizes how to perform common tasks in e-SCOR:
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To...

Do this...

Display the popup menu for an
object on a workspace

Click the right mouse button on the object.

Display the properties dialog for
an object on a workspace

Double-click the object, select the object
and press the F4 key, or choose Properties
from the object’s popup menu. You can
also select the item, then choose Edit >
Properties or click the equivalent toolbar
button:

Using the Project Menu

To...

Do this...

Display the detail for an object,
such as a model or a role

Choose Show Detail from the popup menu
for the object, choose View > Show Details,
enter Ctrl + right click on the object, or
click the equivalent toolbar button:

Display the e-SCOR toolbox

Choose View > Toolbox - e-SCOR.

Adjust the size of a workspace and
its associated window to fit the
contents of the workspace

Choose Shrink Wrap on the workspace,
choose Layout > Shrink Wrap, or click the
equivalent toolbar button:

Hide a workspace

Click the Minimize button on the window,
choose Hide on the workspace, choose
View > Hide, or enter Ctrl + right click on
the workspace.

Go to the Products pool detail

Choose Show Products on a role.

Configure product composite
parameters

Choose Products on a role, then choose the
product to configure.

Using the Project Menu
You create, configure, and interact with e-SCOR objects to create a model by using
the Project menu.
You can also create and interact with objects through the Navigator, and you can
search for objects once they exist. For more information, see:

• Using the Navigator.
• Searching for Objects.

Using the Project Menu
The Project menu allows you to create and manage the various objects you need
to build an e-SCOR application.
For details, see Using the Project Menu.
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Using the Manage Dialog
The Manage dialog allows you to create and configure new e-SCOR objects, show
model details, copy and delete objects, and perform specific operations.
The Manage dialog provides these toolbar buttons:
New

Model

Copy

Properties Go To

Delete

The buttons in the Manage dialog are enabled or disabled, as appropriate, for the
particular type of object.
The Go To button is disabled in Modeler mode because, typically, you interact
with objects through properties dialogs and model details. You can go to objects
directly through the Navigator or search, if desired.
For information about interacting with objects directly, see Interacting with
Objects in Developer Mode.
To use the Manage dialog:
1

Choose a submenu from the Project menu and choose Manage.
If the submenu has additional submenus, choose one of the submenus. The
Manage dialog appears, which includes all objects in the submenu.

2

To create a new object, click the New button in the Manage dialog.
A properties dialog appears for configuring the object. The default name is a
unique, system-generated name.

3

Configure the properties, depending on the type of object, and click OK.
For information on configuring the properties, see the various chapters in this
guide.
The object now appears in the Manage dialog.

4
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Select an object in the list to enable the toolbar buttons, as appropriate for the
type of object.

Navigating Applications

5

To display the properties dialog for an object, click the Properties button.
Note that the only way to configure the properties of a container object once it
has been created is through the Manage dialog.

6

To display the detail associated with a container object, click the Model
button.
This button is only available if the object has detail.

7

To copy an existing object, select the object you want to copy, then click the
Copy button.
A properties dialog appears for configuring the copy. The default name is the
existing object name with -copy appended.

8

To delete an object, select the object you want to delete and click the Delete
button.

Using the Project Submenus
e-SCOR provides access to the various objects in a model through submenus of
the Project menu. Selecting the menu choice for a configuration object displays the
properties dialog for the object. Selecting the menu choice for a container object
displays its detail.
To use the project submenus:
1

Choose a submenu from the Project menu.
If the submenu has additional submenus, choose a submenu until you see a
submenu that includes the names of all objects of that type.

2

Choose an object from the submenu.

Navigating Applications
To navigate applications, you can:

• Use the Navigator.
• Search for objects.
For information on creating and managing objects through the Project menu, see
Using the Project Menu.
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Using the Navigator
The Navigator displays all the elements of a project.
You can interact with objects in the Navigator, for example, showing its
properties or going to the detail, depending on the type of object. You can also
create new objects from the Navigator.
To display the Navigator:
 Choose View > Navigator or click the equivalent toolbar button (
expand the tree view to the desired level.

) and

Here is the Navigator for the Tutorial Simplest Model with the tree expanded to
show Level 2 categories of the Consumer role:

To interact with objects in the Navigator:
 Right-click a node in the Navigator and choose the desired menu choice.

In addition to the menu choices that you normally get when you right-click the
object, you can choose Go To to show the selected object. Depending on the type
of object, you might go to the object on a detail or you might go to the object in a
repository.
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You can also choose New Instance on the Supply Chain Processes folder to create
a new model directly from the Navigator.

Searching for Objects
You can search for specific types of objects, by matching text in the label field
and/or the target class, depending on the type of object. You can also go directly
to named objects.
To search for objects:
1

Choose Tools > Search and choose a category of object to be found.

2

Enter the Keyword text to match and, depending on the type of object,
optionally, the Target Class.

3

Configure Search By to search for the keyword only, class only, keyword or
class, or keyword and class.

4

Click the Search button.
The search results include all objects whose label matches the specified text.

5

Select an object and click the Go To button.

An arrow appears next to the found object, if it exists; otherwise, the Search dialog
display No Matches Found.
Depending on the type of object, you might go to the object on a detail or you
might go to the object in a repository. You can interact with the object through its
menu choices, for example, to go its detail or show its properties.
To go to a named object in the model:
 Enter the exact name of an object in the Go To type-in box on the toolbar:

A red arrow points to the named object on a workspace.
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Interacting with Workspaces
You place all model objects on detail workspaces, which appear their own
window. You display and interact with workspaces in these ways:

• Display a detail workspace.
• Hide a workspace.
• Delete a workspace.
• Create a detail workspace.
• Edit workspace properties.
• Scale a workspace.
• Shrink wrap a workspace to fit the enclosed elements.
• Show the superior object for a workspace.
• Print a workspace.
• Save a workspace as a JPEG file.
• Assign a background image to a workspace.
• Create and access top-level workspaces.

Displaying a Detail Workspace
A number of objects define detail, which is a workspace associated with the object
on which you place other objects. For example, models, organizers, and roles all
define detail.
To display detail for an object:
 Right-click the background of a workspace and choose Show Detail, choose
View > Show Details, or click the equivalent toolbar button: (
)

or
 Press Ctrl + right-click on the object.

Hiding a Workspace
To hide a workspace:
 Right-click the background of a workspace and choose Hide or press
Ctrl + right-click on the workspace.
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Deleting a Workspace
Deleting a workspace permanently deletes it from the server, including all objects
on the workspace.
To delete a workspace:
 Select a workspace and choose Edit > Delete, right-click the background of a
workspace and choose Delete, or click the equivalent toolbar button: (
)

Creating a Detail Workspace
If you delete a detail workspace associated with a model, you can create a new
detail for an existing model.
To create a detail workspace:
1

Show the detail of a model.
For details, see Displaying a Detail Workspace.

2

Delete the detail workspace associated with the model.
For details, see Deleting a Workspace.

3

Show the Navigator.
For details, see Using the Navigator.

4

Right-click the model whose detail you deleted and choose Create Detail.

The model has a new detail workspace.

Editing Workspace Properties
You can edit the name of the workspace, as well as the background and
foreground colors, and the margins around the objects at the edges of the
workspace. By default, the background color is white and the foreground color is
black.
For information about configuring the background image, see Loading
Background Images.
To edit workspace properties:
1

Select a workspace and choose Edit > Properties, right-click the background of
a workspace and choose Properties, or click the equivalent toolbar button:
(
)

2

Configure the Names to be any text.
The text is converted to a symbol, with hyphens in place of spaces when you
accept the dialog.
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3

Configure the Workspace Margin by entering the number of pixels.

4

Configure the Foreground Color and Background Color by choosing a color.

The name appears at the top of the workspace when you accept the dialog.

Scaling a Workspace
You can scale a workspace to fit the current window, or zoom a workspace in,
out, or to a specific scale.
To scale a workspace:
 Choose View > Zoom In or Zoom Out, enter Ctrl + = to zoom in or Ctrl + (minus) to zoom out, or click the equivalent toolbar buttons: (
)

or
 Choose View > Zoom, then choose or enter a zoom scale, or enter a specific
zoom scale in the zoom scale on the toolbar: (
)

or
 Choose View > Zoom to Fit or click the equivalent toolbar button: (

)

Shrink Wrapping a Workspace
When you move objects on a workspace beyond the visible borders, the borders
adjust to fit the objects. When you move objects on a workspace such that the
workspace contains extra space at its borders, you can adjust the borders by
shrink wrapping the workspace. Shrink wrapping a workspace also adjusts the
window size. You can resize the window to make it smaller to add scroll bars to
the window.
To shrink wrap a workspace:
 Select a workspace and choose Layout > Shrink Wrap or click the equivalent
toolbar button: ( )
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This figure shows a workspace that has extra space around its borders:

This figure shows the result of shrink wrapping the workspace:
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This figure shows the result of dragging the object on the workspace so it has
extra space around its borders, then adjusting the window size to make it smaller,
which adds scroll bars:

Showing the Superior Object of a Detail Workspace
You can show the superior object of a detail workspace, for example, the detail of
a Model .
To show the superior object of a detail workspace:
 Right-click the background of a workspace and choose Go to Superior, or
select a detail workspace and choose View > Go to Superior or click the
equivalent toolbar button: (
)

The workspace with the superior object is now on top with an indicator arrow
next to the object.
Depending on the type of object, you might go to the object in a repository. You
can interact with the object through its menu choices, for example, to show its
properties.

Printing a Workspace
To print a workspace:
 Choose File > Print, or enter Ctrl + P or click the equivalent toolbar button
(
), and configure the Print dialog.

Saving a Workspace to a JPEG File
To save a workspace to a JPEG file:
 Choose File > Save as JPEG and specify a file name.
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Loading Background Images
You can load one or more JPEG, XMB, or GIF files as the background for a
workspace.
To load a single background image:
 Choose Workspace > Load Background Image, navigate to the image to use as
the background, and click Open.
To load multiple background images:
1

Create one or more Image Definition objects from the Displays palette of the
ReThink toolbox.

2

Configure the Image Name and File Name of Image, and optionally click Save
Image Data with KB to save the image data as part of the KB.

3

Show the properties dialog for a workspace, click the Background tab, click
the Add Background Image button to add one or more rows, choose an image
definition from the list of existing definitions, and configure the X-Y position
of each image.

To remove background images:
 Choose Workspace > Delete Background Image.

or
 Show the properties dialog for a workspace, click the Background tab, select a
row, and click the Remove Background Image button.

Creating and Accessing Top-Level Workspaces
Typically, you create new workspaces when you create models through the
Project menu. However, you can also create new workspaces directly through the
Workspace menu, which are top-level workspaces that you can access by name.
For example, you might want to create models or organizers directly on the toplevel workspace. The models you create on top-level workspaces appear in the
Navigator and in the Project menu as if you had created them through the Project
menu.
To create a new top-level workspace:
1

Choose Workspace > New.
The workspace is assigned a unique number, which starts with unnamedworkspace.

2

Configure the workspace properties as described in Editing Workspace
Properties.
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To access the top-level workspace:
1

Choose Workspace > Get or click the equivalent toolbar button: (

)

A list of all top-level workspaces available in the current user mode appears.
2

Select a workspace and click OK.

Using the Menus
The top-level menu bar consists of these menus:
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Menu

Description

File

Standard file operations, and print and export
operations for workspaces.

Edit

Standard editing operations for objects on
workspaces.

View

Display the various toolboxes and toolbars, display
the Navigator, zoom workspaces, show details, and
show superior objects.

Layout

Standard layout operations for objects on
workspaces, including align, distribute, rotate,
reflect, order, nudge, as well as shrink wrapping
workspaces.

Go

Standard browser navigation operations and
interaction with the server.

Project

Manage system models, object models, reports,
charts, system settings, and user preferences.

Simulation

Activate and deactivate scenarios, control the
simulation mode, start, reset, pause, and continue the
simulation, and clear indicators and breaks.

Workspace

Create new and get existing workspaces, and edit
background images for workspaces.

Tools

Find model objects, show users, and switch user
modes.

Window

Control window positioning and choose the active
window.

Help

Display online help.

Using the Menus

The following sections summarize each of these menus.
For information about how to use specific menu choices, see the referenced
sections.
For information about additional menu choices available in Developer mode, see
the Customizing ReThink User’s Guide.

Using the File Menu
The File menu allows you to perform basic file and module operations.
Menu Choice

Description

New

Creates a new project.
See Working with Projects.

Open

Opens an existing project, replacing the one
currently loaded.

Save

Saves the top-level module of the current
project.

Save As

Saves the top-level module of the current
project to a user filename. You save models to
filenames with a .kb extension.

Save as JPEG

Exports the currently selected workspace as a
.jpg file.

Print

Prints the currently selected workspace to a
postscript printer.

Close

Exits the client.

Using the Edit Menu
The Edit menu allows you to perform basic edit operations for objects.
Menu Choice

Description

Delete

Deletes the selected object.

Transfer

Transfers the selected object to the mouse.
Click on a workspace to transfer the object.

Clone

Transfers the selected object to the mouse.
Click on a workspace to clone the object.
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Menu Choice

Description

Select All

Selects all objects on a workspace.

Properties

Displays the properties dialog for the selected
object.

Colors

Changes the colors of the icon regions of the
selected objects.

Using the View Menu
The View menu allows you to show and hide toolboxes and toolbars, and to
control the zoom scale.
For details about each of the toolboxes, see Using the e-SCOR Toolbox.
The View menu contains the menu choices in the following table:
Menu Choice

Description

Toolbars > Standard

Toggles the Standard toolbar, which contains
standard buttons for file and edit operations.

Toolbars > Layout

Toggles the Layout toolbar, which contains
buttons for performing standard layout
operations for objects on workspaces.

Toolbars > Web

Toggles the Web toolbar, which contains
standard buttons for browsing HTML and
text pages.

Toolbars > Simulation

Toggles the Simulation toolbar, which contains
buttons for controlling the simulation run state
and mode.

Status Bar

Toggles the status bar, which displays the
connection status to the server.

Message Board

Displays the G2 Message Board, which displays
text messages.

Message Browser

Displays a message browser of operator
messages.

Navigator

Toggles the display of a tree view of all objects in
the current project.
See Navigating Applications.

68

Using the Menus

Menu Choice

Description

Toolbox - ReThink

Toggles the display of the ReThink toolbox,
which contains all the objects you need to create a
model and run a simulation, including Tools,
Basic Activities, Instruments, Resources, and
Reports.

Toolbox - e-SCOR

Toggles the display of the e-SCOR toolbox, which
contains all the objects you need to create a model
and run a simulation, including Tools, Roles,
Products, Resources, Source, Make, Deliver, and
Reports.

Asset Metrics
Contract Metrics
Financial Metrics
Inventory Metrics
Order Metrics
Resource Metrics

Toggles the display of various reports containing
metrics that the model computes when the
simulation runs.

Zoom

Scales the selected workspace.

Zoom In
Zoom Out
Zoom to Fit
Hide

Hides the currently selected workspace.

Go to Superior

Displays the superior object of the currently
selected workspace.

Show Details

Shows the detail workspace of the currently
selected object.
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Using the Layout Menu
The Layout menu allows you to interact with objects on workspaces. For details,
see Interacting with Objects.
Menu Choice

Description

Order >

Controls the stacking order of
selected objects on workspaces.

Bring to Front
Send to Back
Nudge >
Nudge Up

Micro-adjusts the position of
selected objects in each
direction.

Nudge Down
Nudge Right
Nudge Left
Align or Distribute >
Align Left
Align Center
Align Right
Align Top
Align Middle
Align Bottom
Distribute Horizontally
Distribute Vertically
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Aligns two or more selected
objects along various axes.
Distributes three or more
selected objects vertically or
horizontally.

Using the Menus

Menu Choice

Description

Rotate or Flip >

Rotates and reflects the
selected objects.

Normal
90 Clockwise
90 Counterclockwise
180
Flip Horizontally
Flip Vertically
Shrink Wrap

Adjusts the borders of the
selected workspace to just fit
the contained objects.

Using the Go Menu
The Go menu allows you to perform standard browser navigation and interact
with the server.
Menu Choice

Description

Back

Provides standard browser operations for
HTML and text pages.

Forward
Stop
Refresh
Home
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Using the Project Menu
The Project menu allows you to interact with all the objects in the current project,
as follows:
Menu Choice

Description

Initialize Application

Clears the Message Browser.

Uninitialize Application
My User Preferences

Configures user preferences for the
current user.
See Configuring User Preferences.

System Models >
Supply Chain Processes

Creates and manages e-SCOR
supply chain process models.

Logic >

Creates and manages business
rules.

Business Rules

See the Business Rules Management
System User’s Guide.

Reports

Creates and manages a variety of
reports.

Charts

Creates and manages various
types of charts.

Object Models >

Creates and manages business
objects and processes for use with
business rules, and supply chain
processes.

Business Objects
Business Processes
Supply Chain Processes
System Settings
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Creates and manages the various
system settings described below.

Using the Menus

Menu Choice

Description

System Settings >

Creates and manages network and
database interface objects for
communicating with various types
of external systems.

Interfaces >
SQL
SMTP
JMS
HTTP
System Settings >
Interface Pools >
SQL

Creates and manages network and
database interface pools for
communicating with various types
of external systems.

SMTP
JMS
System Settings >
Message Browsers >

Creates and manages custom
message browsers and queues.

Queues
Events
Messages
Access Tables
Templates
System Settings >
Users
System Settings >
System Performance
System Settings >
Event and Alarm Metrics

Creates and manages user
preferences.
See Configuring User Preferences.
Enables, disables, and configures
system performance metrics.

Enables and disables event and
alarm metrics.
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Using the Workspace Menu
The Workspace menu allows you to interact with workspaces. For details, see
Interacting with Workspaces.
Menu Choice

Description

New

Creates a new workspace.

Get

Displays a list of named workspaces, which
you can display.

Load Background Image

Loads and deletes background images for
the selected workspace.

Delete Background Image

Using the Simulation Menu
The Simulation menu allows you to control the simulation.

74

Menu Choice

Description

Activate

Activates or deactivates the current
scenario.

Start All

Starts all Source blocks associated with the
current scenario.

Reset

Resets the simulation for the current
scenario.

Pause

Pauses the simulation for the current
scenario.

Continue

Continues running a paused simulation for
the current scenario.

Jump Mode

Sets the scenario to jump mode, where the
simulation clock advances continuously
with each discrete event.

Step Mode

Sets the scenario to step mode, where the
simulation clock pauses after each discrete
event.

Synch Mode

Sets the scenario to synch mode, where the
simulation clock is synchronized with real
time, based on a scale factor.

Using the Menus

Menu Choice

Description

Online Mode

Sets the scenario to online mode, where eSCOR performs real-time transaction
processing.

Clear Breaks

Clears all break points that have been set in
the model.

Clear Indicators

Hides all indicator arrows in the model.

Using the Tools Menu
The Tools menu allows you to browse objects in the model.
Menu Choice

Description

Search

Allows you to search for objects in a
model by name or label.
See Searching for Objects.

Show Users

Shows the users currently logged into
the server.

User Mode >

Changes the user mode. The default
user mode is Modeler, which allows
you to create models by copying,
connecting, and configuring objects,
and to run simulations. Operator
mode allows end users to view models
only. Developer mode allows
developers to customize the
application.

Administrator
System-Administrator
Developer
Modeler
Operator

Note: In general, you work in Modeler
mode. Very occasionally, modelers
need to switch to Developer,
Administrator, or System
Administrator mode to perform
particular tasks.
See Switching User Modes.
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Using the Help Menu
The Help menu allows you to access online help that displays as a window within
the client:
Menu Choice

Description

G2 Help Topics

Display the G2 online help.

e-SCOR Help Topics

Display the e-SCOR online help.

Server Information

Displays version information about the
server.

About G2

Displays the G2 title block, which shows
the current version.

About e-SCOR

Displays the e-SCOR title block, which
shows the current version.

About SCOR

Displays the SCOR disclaimer.

You can view PDF versions of the following guides:

• e-SCOR Getting Started Tutorials
• e-SCOR User’s Guide
• e-SCOR Quick Reference
• ReThink User’s Guide
• Customizing ReThink User’s Guide
• Getting Started with ReThink
To view the online manuals:
 Choose Start > Programs > Gensym G2 2011 > Documentation > G2 e-SCOR
or G2 ReThink and choose the manual you want to view.
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Using the e-SCOR Toolbox

Using the e-SCOR Toolbox
The e-SCOR toolbox contains all of the objects that you use to create a model.
To display and interact with the e-SCOR toolbox:
1

Choose a toolbox from the View menu.
The toolbox appears with the first palette in the toolbox visible. The palettes
are organized alphabetically. You access the various palettes in the toolbox by
clicking the buttons at the bottom of the toolbox.
Here is the Deliver palette of the e-SCOR toolbox:

Click the buttons to display
the various categories of
objects in the toolbox.
Deliver

2

To access the various palettes in the toolbox, hover the mouse over a button to
display its tool tip, then click the button to display the palette.
Depending on the size of toolbox, the toolbar at the bottom shows only a
subset of the available buttons in the toolbox.

3

To display the additional buttons in the toolbox, click the configure button at
the far right of the toolbar (
), then choose a palette.

4

To configure the buttons that are visible in the toolbar and associated
configuration menu, choose Add or Remove Buttons to display a list of all
palettes, then choose a button to add or remove.
Once you have configured the buttons you want, you can expand the buttons
to show their labels for some or all of the buttons.

5

To show button labels in the toolbox, drag the divider at the bottom of the
toolbox up to expose the buttons with their labels.
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For example, here is the e-SCOR toolbox with button labels showing:

Drag the divider up and
down to expose buttons.

Once you have configured the buttons you want to appear in the toolbox, you
can auto hide the toolbox by clicking the pin in the upper right corner of the
toolbox.
Note Do not close the toolbox or the toolbox reverts to the default set of buttons.
6

Click the pin to autohide the toolbox, and move the mouse over the tab to
display the toolbox after it has been hidden.
You can display, configure, and autohide multiple toolboxes, as needed, each
of which will have its own toolbox tab.
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Source, Make, and Deliver

For information on configuring categories, see Configuring Process Category
Parameters.
For information on adding categories to the role detail, see Configuring Role
Details for Multiple Products.

Return

For information on configuring categories, see Configuring Process Category
Parameters.
For information on adding categories to the role detail, see Configuring Role
Details for Multiple Products.
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Products

See Configuring the Products a Role Sources and Delivers.

Reports

See Using Reports.
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Resources

See Configuring Resources.

Roles

See Creating a Supply-Chain Model.

Tools

See Organizing Models and Controlling Simulations.
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Using the G2 and ReThink Toolbox
In general, you use the G2 and ReThink toolboxes when customizing models.
For details, see the Customizing ReThink User’s Guide.

Interacting with Objects
You can interact with objects in a model by using the Edit menu, the object’s
popup menu, and the Layout menu. Many of the menu choices have shortcuts
and/or equivalent toolbar buttons.
When you create a model, we recommend that first, you place the roles on the
workspace, then you align and distribute them, using buttons on the Layout
toolbar, then you connect them, as needed.
You configure attributes of objects through properties dialogs.

Selecting Objects
To select one or more objects:
 Click an object to select it.

or
 Click and drag a rectangular area to select all the objects in the rectangle.

or
 Use Shift key and click on an object to add or remove it to or from an existing
selection.

or
 Use the Alt key and click on a connected network of objects to select all the
connected objects.
To select all objects on a workspace:
 Choose the Edit > Select All or enter Ctrl + A.
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Cutting, Copying, Pasting, and Deleting Objects
When you copy an object, the new object has the same property values as the
existing object. If the object has details, the new object has the same details. You
can transfer objects from one workspace to another.
To copy and paste objects:
 Select one or more objects to copy, choose Edit > Clone, then click on any
workspace to paste the selected objects to the workspace.
To cut and paste objects:
 Select one or more objects to cut, choose Edit > Transfer, then click on any
workspace to paste the selected objects to the new workspace.
To delete objects:
 Select an object, then choose Delete from the Edit menu or from the popup
menu, press the Delete key, or click the equivalent toolbar button (
), then
click Yes to confirm the deletion.

Controlling the Layout of Objects
To adjust the order of objects:
 Select an object, then choose Layout > Order > Bring to Front or Send to Back
or click the equivalent toolbar button: (
)
To rotate or flip objects:
 Select an object, choose Layout > Rotate or Flip, then choose the desired action
from the submenu or click the equivalent toolbar button:
To align objects:
 Select two or more objects, choose Layout > Align or Distribute, then choose
the desired align action from the submenu or click the equivalent toolbar
button: (
)
To distribute objects:
 Select three or more objects, choose Layout > Align or Distribute, then choose
the desired distribute action from the submenu or click the equivalent toolbar
button: (
)
To nudge an object up, down, right, or left:
 Select an object, choose Layout > Nudge, then choose the desired nudge
action from the submenu; or hold down the Ctrl key while pressing the up,
down, right, and left arrow keys to nudge the item in the desired direction; or
click the equivalent toolbar button:
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For information on the Shrink Wrap toolbar button on the Layout toolbar, see
Shrink Wrapping a Workspace.

Displaying the Properties Dialog for an Object
To display the properties dialog for an object:
 Double-click the object.

or
 Select the object and press the F4 key.

or
 Choose Properties from the object’s popup menu.

or
 Select the object, then choose Edit > Properties or click equivalent toolbar
button: (
)

Resizing an Object
You might need to resize an object, for example, the category routers on the detail
of a role when adding categories to the role detail.
To resize an object:
 Click an object to select it, and drag the selection handles to resize the object.

Editing Icon Color Regions
You can edit the color of any named region of any icon.
To edit icon colors:
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1

Click an object to select it, and choose Edit > Colors.

2

Configure the color of the named icon region for the object, as desired.

Using the Toolbars

For example:

Using the Toolbars
e-SCOR provides a number of toolbars that you can use to interact with models.
The toolbars are all docked, by default. You can drag the toolbar to a new location
or off the toolbar to make it a floating toolbar.
The available toolbars are:

• Standard toolbar
• Simulation toolbar
• Web toolbar
• Layout toolbar
• Status bar
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Standard Toolbar
The Standard toolbar contains many of the toolbar buttons that you need to work
with the model:
Zoom Out
Zoom
Percent

Print
Save
Open

Properties

Zoom In

Message
Browser

Delete

Zoom to Fit

Show Details

Navigator

User Mode

Go to Superior

Go To

Get Workspace

To hide and show the Standard toolbar:
 Choose View > Toolbars > Standard.
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For information
on this button...

See...

Open

Opening a Project.

Save

Saving a Project.

Print

Printing a Workspace.

Delete

Cutting, Copying, Pasting, and Deleting Objects.

Properties

Displaying the Properties Dialog for an Object.

Navigator

Using the Navigator.

Message Browser

Viewing Messages.

Get Workspace

Creating and Accessing Top-Level Workspaces.

Go to Superior

Showing the Superior Object of a Detail Workspace.

Show Detail

Displaying a Detail Workspace.

Zoom In, Zoom Out,
Zoom Percent, and
Zoom to Fit

Scaling a Workspace.

Using the Toolbars

For information
on this button...

See...

User Mode

Switching User Modes.

Go To

Searching for Objects.

Simulation Toolbar
The Simulation toolbar contains toolbar buttons that you need to configure and
run a simulation:
Activate
Start All
Reset
Pause
Continue
Jump
Mode
Clear
Breaks

Step
Mode
Clear
Indicators

To hide and show the Simulation toolbar:
 Choose View > Toolbars > Simulation.
For information
on this button...

See...

Activate

Activating and Deactivating the Scenario.

Start All, Reset, Pause,
Continue

Starting and Stopping the Simulation.

Jump Mode and
Step Mode

Configuring the Simulation Mode.

Clear Breaks

Setting and Clearing Breakpoints and Indicators.

Clear Indicators

Setting and Clearing Breakpoints and Indicators.
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Web Toolbar
The Web toolbar provides the standard browser navigation buttons and
commands for browsing HTML pages:
Stop
Home

Back

Address

Forward
Refresh

To hide and show the Web toolbar:
 Choose View > Toolbar > Web.

You can go to any URL, including any HTML file on the World Wide Web or on
the file system, or any RTF file.
To go to an HTML file on the World Wide Web, you use the standard HTTP
protocol, for example, http://www.gensym.com.
To go to an HTML or RTF file on the file system, you use this protocol:
file:\<drive>:\<directory>\<filename>
For example, to go to the readme file, you would use:
file:\C:\Program Files\Gensym\g2-2011\doc\escor\escor-readme.html

You navigate by using standard buttons in the Web toolbar or in the Go menu.
You configure the Home button URL in your user preferences. For more
information, see Configuring User Preferences.
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Layout Toolbar
The Layout toolbar contains toolbar buttons that you need to control the visual
layout of objects on a workspace:
Shrink
Wrap

Nudge

Align

Distribute

Flip

Rotate

Bring to Front
Send to Back

To hide and show the Layout toolbar:
 Choose View > Toolbars > Layout.
For information
on this button...

See...

Shrink Wrap

Shrink Wrapping a Workspace.

Send to Front, Send to
Back, Nudge, Align,
Distribute, Rotate, Flip

Controlling the Layout of Objects.

Status Bar
The status bar shows various status information, such as the host and port of the
client, the current file being loaded, and the progress bar.
By default, the status bar also shows the current message in the operator Message
Browser. For information on how to disable this feature, see Configuring User
Preferences.
To hide and show the status bar:
 Choose View > Status Bar.
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Metrics Toolbars
The Metrics toolbars contain a variety of metrics for roles, product composites,
and resources in the model.
To hide and show the Metrics toolbar:
 Choose View > Asset Metrics, Contract Metrics, Financial Metrics, Inventory
Metrics, Order Metrics, or Resource Metrics.

For examples of each of these toolbars, see Viewing Simulation Metrics in a
Toolbar.
For information about these metrics, see Viewing Metrics.

Setting and Clearing Breakpoints and
Indicators
You can set breakpoints to pause the simulation at various points in the model.
When you run the simulation with a breakpoint set, the simulation pauses at that
point and an indicator arrow appears at the breakpoint.
To set a breakpoint:
 Show the detail of a role and choose Set Break on a router on the role detail, or
show the detail of a category, then continue to show the detail of blocks until
the Set Break menu choice appears on a block.

When you run the simulation, an indicator arrow appears at the breakpoint you
set, and the simulation pauses. Click the indicator to continue running the
simulation until it reaches the breakpoint again.
For information on controlling the behavior of indicators, see Configuring the
Behavior of Indicator Arrows.
To clear breakpoints:
 Choose Simulation > Clear Breaks or click the equivalent toolbar button:
To clear all indicators:
 Choose Simulation > Clear Indicators or click the equivalent toolbar button:
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Switching User Modes
You build and run applications in one of four built-in user modes, or you can
define you own user mode. The user mode determines what you can and cannot
do when you create your application and run it. For example, the user mode
determines whether you can move, edit, and delete objects, and whether you can
use the full set of G2 features in your model. For example, the user mode
determines the parameters that you can configure.
e-SCOR supports the following user modes for these classes of users:

This type of user...

Works in this user
mode...

Which allows you to...

Managers and
end users

Operator

View pre-built applications without
damaging them in any way. Operators
cannot open, save, run, or configure
applications.

Business analysts
who create
applications

Modeler

Create, connect, and configure Level 1
roles and Level 2 categories to create
models and run simulations. This is the
default user mode.

e-SCOR customizers
experts and
G2 programmers

Developer

Customize the behavior of the model at
Level 3 and Level 4 SCOR. Developers
have the full capabilities of ReThink, the
underlying modeling toolkit upon which
e-SCOR is based.

SystemAdministrator
Administrator

End users of fully developed applications generally work in Operator mode.
Operator mode is restricted so that users may run a model but may not create,
configure, or delete objects.
As a model developer, you will almost always be working in Modeler mode. This
manual assumes you are working in Modeler mode, unless otherwise stated.
Occasionally, as a model developer, you will also need to go into Developer mode
to perform certain tasks.
If you are an expert who is customizing e-SCOR, you will be working mostly in
Developer mode. The Customizing ReThink User’s Guide assumes you are working
in Developer mode.
The user mode that is available to you depends on your login privileges.
To switch to a different user mode:
 Choose Tools > User Mode or configure the User Mode on the toolbar.
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Viewing Messages
Various messages might occur when running a simulation, which you can view in
the Message Browser or Message Board, depending on the type of message. By
default, operator messages appear in the Message Browser, whereas error
messages appear in the Message Board.
To view the Message Browser:
 Choose View > Message Browser or click the equivalent toolbar button: (

).

Here is the Message Browser with a message that occurs when you choose Show
Scenario on an object:

To interact with messages in the Message Browser:
 Select the message and click a button in the toolbar.

You can delete and acknowledge the message, show properties, show the target
and initiator of the message, configure filters, and lock the view.
To delete all messages in the Message Browser:
 Choose Project > Initialize Application.
To view the Message Board:
 Choose View > Message Board.

The Message Board remains open until you close it. You can also auto hide it by
clicking the pin in the upper-right corner.
Here is the Message Board with an error message that results if you delete the
product specification for a model and run the simulation:
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Configuring User Preferences
e-SCOR allows you to configure different levels of access and default behavior for
different categories of users. When a particular user starts e-SCOR, the user
preference associated with that user restricts the access and provides default
behavior, as appropriate for the given user.
You can configure the following preferences:

• The default user mode, which determines the level of access to e-SCOR
features.

• Subscription to queues.
• Message filter to subscribed queues, for filtering messages based on priority,
process map, type, category, target, assigned to, age, and acknowledgement
status.

• Acknowledgement and deletion permission and behavior in the Message
Browser.

• Client disconnection, server shutdown, and modeling configuration
permissions, and whether the user is an administrator.

• The default behavior for interacting with objects through menus and showing
the logbook.

• Email and mobile email addresses for use with the JMail interface.

Specifying User Preferences for Different Types
of Users
e-SCOR creates a default user preference for the e-SCOR server to determine the
level of access and default behavior for all users that log into the server. Similarly,
e-SCOR creates one user preference for each user associated with a G2 login
account. The name of the user preference corresponds with the user name
specified in the g2.ok file. For more information, see Chapter 62 “Licensing and
Authorization” in the G2 Reference Manual.
If you are logged in as the user named administrator, you are automatically
configured to be the Administrative User and can create and configure user
preferences for all users. If you are logged in as any other user, you can only
configure your own user preferences. You can be logged in either to your
windowing system or to the e-SCOR server through a secure G2 as administrator.
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We recommend that the user preference for the server provide access to all
available features, and that it use either Modeler or Developer mode. The user
preferences for the clients should provide appropriate levels of access and should
use the appropriate user mode, depending on the type of user. For example, you
might configure user preferences as follows for these types of users:

For this type of user...

Operators, who interact
with messages only

Use this default
user mode...

And provide these
permissions and defaults...

operator

• Disconnect permission
• Acknowledge message
permission

• Show message in operator
mode by default

• Subscribe to appropriate

queues, depending on the
model

Modelers, who create
models

modeler

• Disconnect permission
• Configuration permission
• Acknowledge message
permission

• Delete message permission
• Subscribe to Messages
queue

Developers, who use G2 to
customize models

developer

• Indicate items upon menu
selection

• Disconnect permission
• Shutdown permission
• G2 Logbook
• Acknowledge message
permission

• Delete message permission
• Subscribe to all queues
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Use this default
user mode...

And provide these
permissions and defaults...

Administrators, who
configure user preferences
for all users, using the eSCOR user interface

systemadministrator

The same as developers, plus
Administrative User.

Administrators, who
configure user preferences
for all users, using G2’s
user interface

administrator

Note: You must log in as
administrator to enable the
Administrative User option.

For this type of user...

Configuring User Preferences
In Modeler mode, you can configure these attributes for each user preference. For
information about additional attributes that you can configure in administrator
mode, see the Customizing ReThink User’s Guide.
Attribute

Description

General
User Name

The user name of the user that starts either the
server or the client, which is read-only.
If you are an administrative user, you can create
new user preferences for specific users. For details,
see Configuring User Preferences.

Default User Mode

The default user mode for the specified user, which
is modeler, by default. The options are: operator,
modeler, developer, system-administrator, and
administrator.

User Interface Theme

The Windows user interface theme. The default
value is window-theme-2003.

Email Address
Mobile Email

E-mail and mobile e-mail address of the specified
user for sending email when a message occurs. For
more information, see Delivering Messages by
Email.
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Attribute

Description

Home Process Map

A process map to use as the background in the
operator interface. The default process map is
default view, which is associated with the process
map named guif-default-main-view. Click Select to
display a list of all process maps in the KB and
choose a map to use as the default background.

Telnet Command

The command for launching a Telnet session.

Default Web Location The default URL when clicking the Home button in
the Web toolbar.
Set Default User
Mode

Whether the default user mode should be set upon
startup.

Indicate Items

Configures the behavior when choosing items from
the Project menu. By default, e-SCOR displays the
properties dialog or the model detail, depending on
the type of item.
Developers who are familiar with G2 and prefer to
work with the iconic representations of items might
want to enable the Indicate Items option, in which
case, choosing items from the Project menu goes
directly to the item.
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Extended Menus

Whether to display the complete list of objects in
the Project submenus, the default. If your project
has many domain models, for example, you might
want to disable this option, in which case, selecting
Project > System Models > Supply Chain Models
displays the Manage dialog for interacting with
object.

Show Logbook

Whether to show the G2 Logbook when errors
occur. By default, the G2 Logbook does not appear.
Modelers or developers who are familiar with G2
might want to enable the Show Logbook option. We
recommend that you disable this option for
operators and modelers who are not familiar with
G2.

Tabbed Mdi Mode

Whether to display workspaces in tabs in the
window.

Configuring User Preferences

Attribute

Description

Restore Last Pane
Settings

Whether to restore the settings for panes upon
connection.

Message Browser
Email Notification
Mobile Email
Notification

The format when sending e-mail and mobile e-mail
messages. By default, the value is never, which
means email messages are not sent. For details, see
Delivering Messages by Email.

Modeler Browser

The browser to use in Modeler mode. The default is
gevm-modeler-message-view-template, which is
the browser that appears when you choose View >
Message Browser.

Operator Browser

The browser to use in Operator mode. The default
is gevm-operator-message-view-template, which is
the browser that appears when you are in Operator
mode.

Acknowledge
Messages Upon
Selection

Whether to acknowledge messages automatically
when the operator selects a message in the Message
Browser view of the operator interface. By default,
messages are not automatically acknowledged.
When Ack Msg Upon Selection is enabled, Ack Msg
Permission must also be enabled.

Show Browser in
Operator Mode

Whether to show the Message Browser by default
view in the operator interface, or whether to show
the process map view. By default, the Message
Browser appears as the default view in the operator
interface.

Enable Status Bar
Message Browser

Whether to show the most recent message in the
status bar.

Beep Enabled

Whether to enable beeping when new messages
arrive in the Message Browser, as well as when they
are acknowledged and deleted. By default, beeping
is enabled.
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To configure user preferences for yourself:
 Choose Project > My User Preferences and configure the user preferences,
as needed.

For example, here is the default user preferences dialog appears for the user
named nrs:

To configure user preferences for other users:
 Choose Project > System Settings > Users and choose the user whose
preferences you want to configure.

For information on creating new user preferences, see Customizing ReThink User’s
Guide.

Delivering Messages by Email
You can configure the user preference for individual users to provide an email
address and a mobile email address, then configure rules for when to send email
messages when an event occurs.
You can configure e-SCOR to format the message as short plain text, suitable for
cell phones, for example, plain text with full message contents, or as an HTML
document. You can also configure when to send a message, based on when it was
created or updated, whether the user is currently connected to the server, and the
priority of the message.
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To deliver messages by email, you:

• Start the G2 JMail Bridge process.
• Create, configure, and connect a JMail Interface object.
• Configure e-SCOR to send email messages.
• Configure startup parameter for sending email.
Starting the G2 JMail Bridge Process
To deliver messages by email, you must start the G2 JMail Bridge process. You
identify the host and port to which the bridge is connected for configuring in the
JMail Interface object.
To start the G2 JMail Bridge process:
 Choose Start > Programs > Gensym G2 2011 > Bridges > G2 JMail Bridge.

The G2 JMail Bridge process appears in the command window.
To determine the bridge port:
 Open the command window for the bridge process.

The last line indicates the TPC/IP host and port number, for example:
TCP_IP:NSALVO-1165:22080

Creating, Configuring, and Connecting the JMail Interface Object
To deliver messages by email, you must create and configure a JMail Interface
object, which specifies:

• A name.
• The host and port of the machine running the G2 JMail Bridge.
• Information about the SMTP mail server, including the user name, password,
incoming and outgoing SMTP mail host, and SMTP protocol.

If the bridge process is running on the local machine, the host is localhost. The
default port number is 22080, 22081, 22082, etc., depending on the number of
clients that are currently connected on that port.
Note To configure a JMail Interface object, you must be in Developer mode.

Once you have configured the JMail interface object, you can connect it to the
G2 JMail bridge process.
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To create, configure, and connect a JMail Interface object:
1

Choose Tools > User Mode > Developer.

2

Choose Project > System Settings > Interfaces > SMTP > Manage and click the
New button to create a new JMail Interface object.
Alternatively, you can choose View > Toolbox - G2, click the Network
Interfaces tab, and create a JMail Interface object.
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3

In the properties dialog for the JMail Interface object, configure the Interface
Name attribute to be any symbol, for example, my-jmail-interface.

4

Configure the Bridge Host and Bridge Port to be the host and port of the
machine on which you started the G2 JMail Bridge process.

5

Configure the following additional information:
Attribute

Description

User Name

The user name of the account to which
email should be sent.

Password

The password of the user account to
which email should be sent.

Incoming Host

The name of the host computer used
for incoming email.

Incoming Port

The port number of the host computer
used for incoming mail.

Incoming Protocol

The SMTP protocol that the incoming
mail host uses. The default is pop3.

Incoming Folder

The folder name of the user account to
which to send email. The default is
inbox.

Delete Messages on Server

Whether to delete the email message
on the mail server after it is sent. By
default, messages are not deleted.

Outgoing Host

The name of the host computer used
for outgoing email.

Outgoing Port

The port number of the host computer
used for outgoing mail.

Configuring User Preferences

Attribute

Description

Outgoing From

The name to use as the From address
when the email message is sent, which
cannot contain spaces.

Auto Reconnect to Bridge

Whether to automatically reconnect if
the connection goes down.

Shutdown Bridge Upon
Disconnect

Whether to shutdown the bridge when
the connection is closed.

Launch Bridge Upon Connect

Whether to launch the bridge when a
connection is made.

Bridge Launch Shell Script

Pathname to script for launching the
bridge.

6

Click Apply to apply these values.

7

Click the Connect button in the dialog to connect the interface to the bridge.

8

Choose Tools > User Mode > Modeler to return to Modeler mode.

For example:
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Configuring e-SCOR to Send Email Messages
You configure e-SCOR to send email messages through the user preferences
dialog.
To configure e-SCOR to send email messages:
1

Choose Project > My User Preferences.

2

Configure Email Address and/or Mobile Email.

3

Choose the rule to use for each of the configured email addresses, as follows:

• never — Do not send e-mail messages. This is the default rule.
• send-as-text — Send the message text and details as plain text.
• send-as-short-text — Send the message text only as plain text.
• send-as-html — Send the message text and details as HTML.
• only-high-priority-as-text — Send the message text and details as plain text
only if the priority is 1.

• only-high-priority-as-short-text — Send the message text as plain text only
if the priority is 1.

• only-high-priority-as-html — Send the message text and details as HTML
only if the priority is 1.

• if-not-connected-send-short-text — Send the message text as plain text
only if the user is not connected to the server.

• if-not-connected-send-as-text — Send the message text and details as
plain text only if the user is not connected to the server.

• if-not-connected-send-as-html — Send the message text and details as
HTML only if the user is not connected to the server.
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When a message occurs, e-SCOR also sends an email to the specified addresses.
Here is the User Preferences dialog with both email addresses and rules
configured:

Configuring Startup Parameter for Sending Email Messages
You can configure the following startup parameter in the configuration file:
JMAIL-INTERFACE-NAME=none
Specifies the default JMail interface to use for sending email messages.
For details about using the configuration file, see the G2 Run-Time Library User’s
Guide.

Configuring Network Interfaces
e-SCOR allows you to configure various types of network interfaces for
communicating with external systems, using the Project > System Settings >
Interfaces menu.
Note To configure network interfaces, you must be in Developer mode.
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SQL interfaces provide communication with databases. For details, see Accessing
External Databases.
You configure SMTP interfaces to send email when a message occurs. For details,
see Delivering Messages by Email.
e-SCOR also allows you to send email messages, using a JMail Connection pool
and to send messages to JMS message servers, using a JMS Connection pool. For
details, see Sending Email and Using JMS Messaging.

Configuring Message Browsers
By default, all messages go to the Messages Browser, which you access by
choosing View > Message Browser.
e-SCOR allows you to create and configure different message browsers and
message queues. You do this by using the Project > System Settings > Message
Browsers menu.
For details, see the G2 Event Manager User’s Guide.

104

Part II
Basic
e-SCOR Modeling
Chapter 5: Creating a Supply-Chain Model
Describes how to configure a model of your supply chain by creating and configuring Level 1
roles.
Chapter 6: Configuring Level 2 SCOR
Describes the default details for each role and how to configure category and product
composite parameters.
Chapter 7: Running the Simulation
Describes how to run a simulation and configure the Scenario.
Chapter 8: Viewing Metrics
Describes the metrics the model computes for roles, categories, product composites, resources,
and routers.
Chapter 9: What Happens When the Simulation Runs
Describes the basic processes that occur while the simulation runs.
Chapter 10: Using Reports
Describes how to view metrics and enter parameter values through various types of reports.
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Chapter 11: Accessing External Databases
Describes how to access databases.
Chapter 12: Using Batch Simulation
Describes how to use run multiple simulations from a script.
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configuring Level 1 roles.
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Configuring Role Parameters 136
Configuring Resources 141
Upgrading Models 145

Introduction
This chapter describes the basic steps in creating your e-SCOR supply-chain
model:
1

Determine the level of detail to model. The level of detail you model
depends on the performance data you wish to analyze.

2

Configure the product hierarchy. The product hierarchy or bill of materials
(BOM) describes the products that your supply chain sources, makes, and
delivers.
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3

4

Configure the Level 1 roles. Roles are the high-level entities that describe
your supply chain. To configure Level 1 roles, you perform these tasks:
a

Create the supply chain model. Select roles from the e-SCOR toolbox to
represent the sites in your supply chain and place them on your model
workspace.

b

Configure the products each role sources and delivers. Assign product
specifications to roles to create source and delivery products.

c

Configure role parameters. Configure role parameters to determine such
things as when the role computes its financial metrics.

Configure resources. Resources determine the capacity of each role to
manufacture finished products and are automatically assigned to each
manufacturing role in your supply chain. You can modify parameters,
as needed.

This chapter also describes how to upgrading models. When you install a new
version of e-SCOR, you typically upgrade the model details to use the new
default templates.

Determining the Level of Detail to Model
Before you begin creating your supply-chain model, you must think carefully
about the level of detail you wish to model. The level of detail affects the amount
of performance data you can obtain from the model; however, it also affects the
level of complexity required to configure Level 2 SCOR.
Keep in mind that once you have created your supply-chain model by creating
and configuring Level 1 roles, you must then configure these Level 2 SCOR
aspects of the model:

• Parameters for the Level 2 categories on the detail of each role.
• Parameters for each source and delivery product that e-SCOR creates for each
role when you assign product specifications to roles.

The task of configuring your model can rapidly become rather complex, given a
detailed product specification and corresponding roles. On the other hand, the
more detail your model includes, the more information it can provide for
analyzing and improving its performance. Therefore, the first question you must
ask when creating your supply-chain model is:

Q What performance data am I most interested in measuring?
The answer to this question determines the level of detail you need to model,
including the number of products in your product hierarchy and the number of
roles in the supply-chain model.
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For example, suppose you are a distributor interested in understanding factors
that affect your inventory. You would focus on modeling only those aspects of the
supply chain that affect your inventory, such as safety stocks, turnaround times,
and supplier lead times. You would avoid modeling the details of your upstream
suppliers and downstream buyers except those parameters that affect your
inventory.

Creating the Product Hierarchy
e-SCOR allows you to model and simulate a supply chain for a particular product
hierarchy. To model the product hierarchy, you create one or more top-level
finished products. Each finished product consists of one or more components
and/or finished products, and each finished product consists of one or more
components or finished products, and so on, until there are only components.
To create the product hierarchy, you:

• Determine the level of detail in the product hierarchy.
• Depending on your bill of materials, you can create a product hierarchy with:
– Components.
– By-products.
– Alternate products.
This section provides examples of product hierarchies and describes how to
create the simplest product hierarchy, which consists of a single product
specification. It then describes how to create a product hierarchy with
components, by-products, and alternate products.

Examples of Product Hierarchies
Suppose you are a computer manufacturer that sources components from two
suppliers, one for the electronics and one for the case. You model this by creating
a finished product to represent the computer, which consists of two components,
one representing the electronics and the other representing the case.
When you run the simulation, the manufacturer produces finished products by
obtaining one of each component, by default. You can configure the number of
components that each finished product requires, in which case, the role obtains
the specified number of components. For example, a computer might require two
electronics components.
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Computer

Usage Quantity = 2

Computer Case

This figure shows the
product hierarchy for a
supply chain that
manufactures computers
from two electronics
components and a
computer case.

Electronics

Computer

A finished product can be a
component of some other
product. In this figure, the CPU
and the computer might be
finished products of two
different Manufacturer roles.

CPU

Computer Case

Electronics

A Distributor role can assemble its components into a kit. The difference between
a finished product and a kit is whether or not the role that delivers it adds value,
as follows:

• A Manufacturer role changes components into finished products, thereby
adding value in the supply chain by creating a completely new product.

• A Distributor role assembles components into kits, which does not change the
original products.
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In the following figure, a Manufacturer role might make and deliver the CPU
finished product, and a Distributor role would assemble and deliver the
computer kit from its four components:
Computer
(kit)

CPU
(finished
product)
Mouse

Keyboard

Computer
Case

Monitor

Electronics

Determining the Level of Detail in the Product
Hierarchy
Suppose your supply chain sources five components, each of which has
essentially the same characteristics, such as the type of order (stock or make-toorder), turnaround time, manufacturing yield, timing parameters, and inventory
levels. In this case, you can create a single product specification to represent all
five products. By creating a single product specification to represent multiple
products, the model computes metrics for all products as a unit.
On the other hand, suppose your supply chain manufactures an entire product
line, and you want to measure the relative performance of each product
separately. In this case, the characteristics of each product are typically
significantly different; therefore, you would create individual product
specifications in the product hierarchy and assign each to the same or a different
role. By creating individual product specifications, you can track separately
metrics, such as inventory levels, orders received and shipped, lead time, and
planning metrics.
Similarly, if your supply chain sources five components from five different
vendors, you might be interested in comparing inventory levels and other metrics
of each component separately.
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See Also Creating the Product Hierarchy.

Viewing Metrics for Source and Delivery Products.

Creating a Product Hierarchy with a Single Product
Specification
The product hierarchy for the simplest model consists of a single product
specification. You use this technique to represent a single product or when each
product in a product family behaves similarly in terms of its Level 2 SCOR
parameters and when you do not need to track metrics for each product
separately.
This section describes how to create a product hierarchy that consists of a single
product specification. The next section shows how to create a product hierarchy
with components.
Caution We recommend that you configure the product hierarchy before you create your
supply chain and assign products to roles.
To create a product hierarchy with a single product specification:
1

Display the Products palette of the e-SCOR toolbox:

You typically place a product specification on the detail of a Product Structure
Organizer, however, that is not a requirement.
2

Select a Product Structure Organizer from the palette and click to place it on
your model detail.

3

Choose Show Detail on the product structure organizer to show its detail.
You create the product hierarchy on this detail.

4
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Place a Product Specification on the detail and display its properties dialog.

Creating the Product Hierarchy

For shortcuts on displaying the properties dialog for items on a workspace,
see Configuring the Model Environment.
5

Configure the Product Name for the product specification.
You can think of the product name as the SKU number for the product, which
should be unique. For example, the product name for the simplest model
might be Product Family. The text of the product specification updates.

6

Configure the Weight and Volume for the product specification, as needed.

Here is a Product Structure Organizer and its detail, which contains a single
Product Specification for a product family:

Product Structure Organizer

Product Specification

Creating a Product Hierarchy with Components
You create a product hierarchy with components when modeling a
Manufacturing process and when modeling a Distribution process that assembles
components into kits.
To create a product hierarchy with components, you connect product
specifications to form a product hierarchy. You can also configure the quantity
that each component represents in the hierarchy. For example, a CPU component
might require 2 electronics components.
To create a product hierarchy with components:
1

Create and configure a Product Specification on the detail of a Product
Structure Organizer.
This product specification should represent the finished product in your
supply chain and should be located at the top of the product hierarchy.
For details, see Creating a Product Hierarchy with a Single Product
Specification.

2

Create and configure additional product specifications, as needed, to describe
the components, finished products, and/or kits that make up the finished
product.
Place finished products and kits below the finished product, and place
components below finished products and kits.
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3

Starting at the bottom of the product hierarchy, choose Create Product
Connection on each product specification to create a connection stub, then
connect the stub to the next higher-level product specification in the hierarchy
until all are connected.

4

If more than one product specification is required to manufacture a finished
product or assemble a kit, configure the Usage Quantity on the connection
between product specifications.

For example, the following figure shows a product hierarchy for a computer,
which is a finished product. The computer consists of a CPU component, which is
itself a finished product that consists of computer case and electronics
components. The CPU requires 2 electronics components.

Finished product

Finished product
Usage Quantity = 2
Components

See Also Modeling a Distribution Process.

Modeling a Manufacturing Process.

Creating a Product Hierarchy with By-Products
Your product hierarchy can include by-products, which are extra products that
the supply chain manufactures that are by-products of the primary process but
that some other buyer sources.
You configure by-products by creating a by-product connection between product
specifications in the product hierarchy, then configuring the output proportion of
the by-product connection.
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To create a product hierarchy with by-products:
1

Create and configure a Product Specification to represent the by-product of
some other finished product in the supply chain, typically a finished product.
For details, see Creating a Product Hierarchy with a Single Product
Specification.

2

Create and configure the product from which the by-product is produced and
place it below the by-product.

3

Choose Create By-Product Connection on the finished product, then connect
the finished product to the by-product.
A by-product connection is dashed green, as opposed to solid black.

4

Configure the Output Proportion on the connection between the finished
product and its by-product to be the percentage of the finished product that
results in a by-product.

5

Configure the rest of the product hierarchy normally, as described in Creating
a Product Hierarchy with Components.

This example shows a product hierarchy with by-products, where the by-product
represents 20% of the finished product:
By-product

Output Proportion = 0.2

Finished product

Components

Creating a Product Hierarchy with Alternate
Products
Your supply chain model might source and deliver generic products, which the
model can substitute with alternate products if the generic product is not
available. For example, a computer supplier might deliver computer systems
from a set of generic components such as a CPU, monitor, keyboard, and mouse.
If the generic component is not available, the supplier can choose from one of
several alternate products, which can, in turn, consist of one or more units. For
example, the CPU might require a generic memory chip, if available; otherwise, it
can use one 512K memory chip or two 256K memory chips.
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You configure the priority of each alternate product on the connection between
the alternate product and its corresponding generic product.
To use alternate products, assign the generic product as a source product of a role,
then configure the Fulfillment Using Alternate Products parameter as true on the
Supplier tab of the source product. For details, see Supplier Tab.
To create a product hierarchy with alternate products:
1

Display the Products palette of the e-SCOR toolbox, select a Generic Product
Specification, place it on the detail of a product structure organizer, and
configure its parameters.
This product specification represents a generic product in the hierarchy.
For details, see Creating a Product Hierarchy with a Single Product
Specification.

2

Create and configure product specifications for each alternate product that
can be used in place of the generic product, placing them below the generic
product specification in the hierarchy.

3

Connect each alternate product to the generic product with a product
connection.

4

Configure the Usage Quantity of the connection between each alternate
product and its corresponding generic product, as needed.
For details, see Creating a Product Hierarchy with a Single Product
Specification.
By default, the model always chooses the generic product first, if it is
available, and it chooses one of the alternate products at random. You can also
configure a priority for each alternate product.

5

Configure the Alternate Product Priority of the connection between each
alternate product and its corresponding generic product, as needed.

The default priority is 1, which means that if there are two alternate products, it
chooses each product at random. If there are two alternate products, where one
has a priority of 1 and the other has a priority of 2, it chooses the alternate product
with a priority of 1 first, and if that one is not available, it chooses the alternate
product with a priority of 2, and so on.
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This figure shows a simple product hierarchy with alternate products. The
Delivery Product consists of Source Product 1 and Generic Product 2. If Generic
Product 2 is not available, the model choose Alt 1 for Product 2 first, based on its
priority, and Alt 2 for Product 2 if Alt 1 is not available.
Finished product

Generic product specification

Alternate products

Alternate Product Priority = 1
means Alt 1 is chosen first when
Generic Product 2 is not available.

Alternate Product Priority = 2
means Alt 2 is chosen next if
Alt 1 is not available.

This figure shows a more complicated product hierarchy with alternate products,
where the Computer System consists of generic CPU, Monitor, Keyboard, and
Mouse-or-trackball components. Each generic product, in turn, has two alternate
products. Each alternate CPU component consists of two components, which are
shared between the alternate products.
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Creating the Supply-Chain Model
Once you have created a product hierarchy, you can create the supply-chain
model by creating roles to form a supply chain. A role can source, make, and/or
deliver one or many products in the hierarchy.
In general, upstream supplier roles in the supply chain deliver lower-level
products in the hierarchy, namely, components, and downstream buyer roles
deliver higher-level products, namely, finished products.
When creating your supply chain, follow these guidelines:

• A Base Manufacturer role can deliver components or finished products;

however, if it delivers finished products, it ignores any components that the
finished product requires.

• A Distributor role can deliver components and/or finished products; if it
delivers finished products, it can obtain either components or finished
products from upstream suppliers.

• A Manufacturer role must source components and deliver finished products.
• A Consumer role can source components or finished products; however, it

must source those products from a supplier that is immediately upstream in
the supply chain.

In general, each product specification in the hierarchy must be associated with at
least one role. The exception is a Base Manufacturer role that delivers finished
products, in which case you do not need to assign the components to any roles.
However, typically, you would only assign a finished product to a Base
Manufacturer role if another role in the model also delivers the components;
otherwise, you would not need to define components.
To create the supply-chain model, you:

• Determine the number of roles to use.
• Create and, optionally, connect roles.
See Also Configuring Role Details for Multiple Products.
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Examples of Supply-Chain Models
Suppose you are a toy manufacturer that sells games to a retail chain. As the
manufacturer, you obtain all your parts from a single supplier, and the game
requires 6 parts in all. The high-level model of the supply chain consists of a Base
Manufacturer role, a Manufacturer role, and a Consumer role, where the Base
Manufacturer role delivers components, the Manufacturer role delivers finished
products, and the Consumer roles sources finished products.
A Toy Manufacturer’s Supply Chain

Base Mfg.

Toy parts
manufacturer

Manufacturer

Your company

Consumer

Toy retailer

Product Hierarchy
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Suppose you are a computer manufacturer. You might have two Base
Manufacturer roles, one for each major component of the computer: the
electronics and the case. The electronics components might go through a
distributor, while the case components might come directly from the
manufacturer. The manufacturer makes computers, which the consumer then
buys.
A Computer Manufacturer’s Supply Chain
Computer case
manufacturer

Base Mfg.

Base Mfg.

Electronics
manufacturer

Manufacturer

Consumer

Your company

Computer
retailer

Distributor

Electronics
distributor

Product Hierarchy

Usage Quantity = 2
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Suppose you are a distributor of two major lines of products, sports equipment
and office supplies. Your supply chain might look like this, where the product
hierarchy consist of two finished products that are unrelated hierarchically.
A Distributor’s Supply Chain
Sports equipment
manufacturer

Consumer

Base Mfg.

Distributor
Base Mfg.

Office supplies
manufacturer

Consumer

Your company

Retail outlets

Product Hierarchy
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Finally, suppose you are a distributor of computers and CPUs. You might have a
primary supplier of the three basic components of the computer: the monitor,
keyboard, and CPU. You might also have a secondary supplier of complete
systems, which you use when the components are not available. In this case, the
secondary supplier delivers complete systems, ignoring any components. The
Distributor role assembles components into kits and distributes those kits, and it
distributes CPUs. The Consumer role sources computers and CPUs.
A Computer and CPU Distributor

Base Mfg.

Monitor manufacturer

Base Mfg.

Distributor

Consumer

Keyboard manufacturer

Your company

Computer retailer

Base Mfg.

Product Hierarchy
CPU manufacturer
computer
(kit)

Supplier

Secondary supplier
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Monitor

Keyboard

CPU

Creating the Supply-Chain Model

Determining the Number of Roles to Use
Once you have determined the level of detail in the product hierarchy and
configured the product hierarchy, you must determine the number of roles to use.
The most straightforward way to model your supply chain is to create separate
roles for each product specification in the product hierarchy. This approach
allows you to use a different financial model and to track cost, asset, and financial
metrics for each product composite separately. However, this approach also
means your model contains more roles, which means you must configure more
Level 2 category parameters.
Often, your supply chain contains products that behave similarly at the role level.
For example, a role that delivers multiple products might use the same financial
model for all its products, and keep track of cost, asset, and financial metrics for
all its products together. In this case, your supply chain can have fewer roles,
where the same role sources, makes, and/or delivers multiple products.
To determine whether to create separate roles for each product specification in the
product hierarchy, you must ask these questions:

Q Does the role use a different financial model to source and deliver its products?
Q Do you need to measure asset metrics individually for each product that a role
sources and delivers?

If you answer yes to either of these questions, then you must create separate roles
for each product whose asset metrics are distinct. If you answer no to both of
these questions, then you can use a single role to source, make, and/or deliver
multiple products.
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Specifically, consider whether you want to configure the following parameters
and track the following metrics together or separately for a role:
Parameters

Group/Metrics

Financial Period
Financial Payment Terms

Resources
Maximum Capacity Used

Statistical Metrics Period

Metrics
Number of End Products
General
Number of Financial Periods
Incoming
Financial Bookings
Financial Outstanding
Financial Collections within Financial Period
Financial Collections Total
Outgoing
Financial Obligations
Financial Payments within Financial Period
Financial Payments Total
Days of Supply
Raw Materials
Work in Progress
Finished Goods
Inventory
Metrics
Asset Turns
Cash-to-Cash Cycle Time
Days Sales Outstanding
Cash Flow Period
General
Order Management Costs

See Also Configuring Financial Parameters for Roles.

Viewing Metrics for Roles.
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Creating and Connecting Roles
To create your supply-chain model, you place roles on the model detail in a
configuration that describes your supply chain, given the product hierarchy.
Typically, you align roles horizontally so that supplier roles are upstream of
buyer roles. Each role name must be unique.
To provide a graphical indication of the direction of flow in the supply chain, you
can optionally connect the roles, using paths. Connecting roles is not required.
When the simulation runs, the model create a variety of objects such as purchase
requests, purchase responses, purchase awards, orders, invoices, product
shipments, and payments.
To create and connect roles:
1

Display the Roles palette of the e-SCOR toolbox:

2

Place on the model detail as many roles as are required to describe your
supply chain, given your product hierarchy.
Place Base Manufacturer roles on the left side of the workspace, Distributor
and Manufacturer roles downstream of Base Manufacturer roles, and
Consumer roles on the right side of the workspace.

3

Configure the Role Label parameter to be unique within the model.

Note The Role Label parameter is automatically configured with a unique label. It
cannot be empty; otherwise, you cannot configure the potential suppliers of
source products.
4

Optionally, choose Create Connection on an upstream supplier role to create
an output connection stub on the downstream side of the role.
By default, the connection is diagonal with a filled arrow and solid line. You
can also create orthogonal connections with a variety of arrow and line styles.
For details, see the chapter on connections in the G2 Reference Manual.
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5

Click the connection stub to attach it to the mouse, then click anywhere on the
upstream side of a downstream buyer role to create the connection.

Tip Click the mouse to create a junction in the connection, as needed.
6

To delete the connection between two roles, choose Delete on the connection,
then drag the stubs into the roles to delete the stubs.

This figure shows the simplest supply-chain model, which consists of a Base
Manufacturer role and a Consumer role, with and without connections:
Without connections

With connections

Configuring the Products a Role Sources and
Delivers
Once you have created the product hierarchy and the supply-chain model, you
can configure the products a role sources and delivers by assigning product
specifications to roles. You assign the delivery products of Base Manufacturer,
Distributor, and Manufacturer roles, and you assign the source products of
Distributor, Manufacturer, and Consumer roles.
e-SCOR creates the appropriate product composites—source or delivery
products—and places them in the Products pool on the role’s detail.
You configure parameters and view metrics for source and delivery products to
determine how the role sources, makes, and delivers its products.
To configure the products a role sources and delivers, you:

• Assign product specifications to roles.
• Navigate to product composites.
See Also Configuring Product Composites.

Viewing Metrics for Source and Delivery Products.
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Assigning Product Specifications to Roles
When assigning product specifications to roles, follow these guidelines:

• Assign each product specification in the product hierarchy to at least one role.
• A supplier role can deliver multiple products, and a Consumer role can
source multiple products.

• Multiple roles can source, make, and deliver the same product.
• In general, you assign components to upstream supplier roles and finished
products to downstream buyer roles.

Note We recommend that you finalize the product hierarchy before you assign products
to roles. Changing the product hierarchy requires that you reconfigure the supply
chain and reassign products to roles, which can be time-consuming if you have
many roles.

You assign a product specification to a role by choosing the product specification
in the role dialog.
To assign a product specification to a role through the role dialog:
1

Display the properties dialog for a role and click the Product tab.
You will see a list of all available product specifications in the model.

2

Depending on the type of role, click a product specification in the All Products
list and move it to the Source Products or Delivery Products list, as
appropriate, to assign it to the role.

For example, suppose your product hierarchy consists of a computer finished
product, and a computer case and electronics components:

Product
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If you assign to Manufacturer role the computer as a delivery product, and the
computer case and electronics as the source products, e-SCOR creates these
product composites in the Products pool on the role detail:

• Computer case and electronics source products.
• Computer delivery product.
Here is the Product tab of the Manufacturer role, which sources electronics and
cases, and delivers computers:
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Here is the resulting Products pool for the Manufacturer role:

Products pool

Source
products

Delivery
product

Examples of Assigning Product Specifications to
Roles
The following examples show four supply-chain models and product hierarchies,
which correspond to the four examples described in Examples of Supply-Chain
Models.
A Toy Manufacturer
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A Computer Manufacturer

A Distributor of Multiple Product Lines
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A Computer and CPU Distributor

Navigating to Product Composites
You have several options for showing the Products pool for a role and showing
the properties dialog for a product composite.
To show the Products pool for a role:
 Choose Show Products on a role to display the detail of the Products pool.

or
 Show the detail of a role, then show the detail of the Products pool.

The Products pool looks like this:
The detail of the Products pool contains all the source and delivery products
assigned to a role.
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To show the properties dialog for a product composite:
 Show the Products pool for a role, then choose Properties on a product
composite in the pool.

or
 Choose Products on a role, then choose a product composite to display its
properties dialog directly.

Configuring Role Parameters
You configure these parameters for each role:

• General parameters that identify the role.
• Financial parameters that the role uses to compute financial metrics.
• The time period for computing time-weighted statistics, such as averages and
moving averages.

• SCOR description and best practices.
You can also configure a role to use logging, which records every transaction that
occurs between roles when the model runs. For details, see Logging Transactions
that Occur Between Roles.

Configuring General Parameters for Roles
You can configure the following general parameters for a role:
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Parameter

Description

Role Label

The label to display with the role, which must be
unique within the model. e-SCOR specifies a unique
label when you initially create the role, which you can
modify.

Highlight Color

A region of color on the role icon, which you can use to
organize roles in the model. The default value is
Transparent.

Configuring Role Parameters

Parameter

Description

Site Longitude
Site Latitude

The longitude and latitude of the site for locating on a
map.

Upgrade

When installing a new version of e-SCOR, whether to
upgrade the role, using the default role template (“on”)
or whether to leave the role as it is (“off”). The default
value is “on”.
For details, see Upgrading Models.

To configure general role parameters:
 Display the properties dialog for a role and configure the parameters on the
Role tab as described in the table above.

This figure shows the Role tab of the dialog for a Base Manufacturer role:
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Note The properties dialog for each role varies, depending on the type of role.

This figure shows a role whose Highlight Color has been configured:
Highlight Color

Configuring Financial Parameters for Roles
For each role, you configure the following financial parameters, which the role
uses to compute financial and asset metrics:
Parameter

Description

Financial Period

The time period for computing financial and asset
metrics. The default value is 4 weeks and 2 days (30 days)

Financial Payment
Terms

The time period for making payments from invoices. The
Financial Payment Terms of the supplier role determines
when the buyer role makes payments from invoices. The
default value is 4 weeks and 2 days (30 days).
Note: Financial Payment Terms is not relevant for a
Consumer role because it is not a supplier.

To configure the role to make immediate payments, configure the Financial
Payment Terms parameter to be zero. Immediate payments are common in
e-commerce and mail order businesses.
To configure financial parameters for roles:
 Display the properties dialog for a role, click the Financial tab, and configure
the parameters, as described in the table above.
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This figure shows the Financial tab of the role dialog for a Base Manufacturer role:

Configuring the Time Period for Computing TimeWeighted Statistics
e-SCOR computes a variety of time-weighted statistics for various Level 2
category and product composite metrics, such as averages and moving averages.
You can view these statistics in the Inventory Metrics and Order Metrics toolbars.
You can also add these and other statistics the appropriate category output
reports.
By default, e-SCOR computes time-weighted statistics, based on a yearly time
period (52 weeks). This means, for example, that the average represents the
average value over a year-long period. If you are running your simulation for a
specific time period, such as three months, you might want to compute timeweighted statistics, based on the duration of the simulation. To do this, you
configure the Statistical Metrics Period parameter for the role.
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To configure the time period for computing time-weighted statistics:
 Display the properties dialog for a role, click the General tab, and configure
the Statistical Metrics Period for the role to be the time period over which to
compute time-weighted statistics for Level 2 metrics.
See Also Configuring the Attributes to Appear in a Report.

Viewing Simulation Metrics in a Toolbar.

Configuring the SCOR Definition and Best Practices
For each role, you can configure the following SCOR parameters:
Parameter

Description

Definition

A textual description of the role.

Best Practices

A list of URLs to best practices for the role.

The Best Practices URLs can be RTF or HTML files.
Note Currently, e-SCOR supports the display of HTML 3.2 and basic RTF formats only.

For example:
Protocol

Example

file:<absolutepathname>

file:C:\\MyModel\\BestPractices\\Block52.rtf
file:C:/MyModel/BestPractices/Block52.html

http://<url>

http://www.gensym.com/myModel/
BestPractices/Block52.html

<relative-pathnamefrom-installation-dir>

BestPractices\Block52.rtf

To configure SCOR definition and best practices for roles:
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1

Display the properties dialog for a role, click the Definition tab, and enter a
textual description for the role.

2

Click the Best Practices tab, use the button to insert rows, and enter a URL for
each best practice associated with the role.

Configuring Resources

Configuring Resources
Once you have configured the product hierarchy, configured the supply-chain
model, assigned product specifications to roles, and configured role parameters,
the last step in configuring Level 1 roles is to:

• Configure resources for manufacturing roles in your model.
• Share resources between roles, as needed.
You use resources to constrain the model by specifying the capacity of each
manufacturing role to make its delivery products.
Note Only the Base Manufacturer and Manufacturer roles require resources.

A single manufacturing resource represents one unit of capacity, by default. To
increase capacity, you configure the Resource Capacity of individual resources to
be a number greater than one, in which case the role can make as many products
as there are resources.
For example, as a computer manufacturer, you might have multiple suppliers of
electronics, in which case, you would configure the Resource Capacity of the
manufacturing resource to be 2. The result is that now the role can produce twice
as many products in the same amount of time, on average.
When you configure the Resource Capacity
to be 2, the role can make and deliver twice
as many finished products, on average.

If you need to track resource utilization separately for individual resources, rather
than configuring the resource capacity, you can assign multiple resources to a
role. The role chooses resources at random, and you track resource utilization
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separately for each resource. This figure shows multiple resources assigned to the
same role:

Create multiple resources for a role when
you need to track resource capacity
separately for each resource.

You can also assign the same resource to multiple roles, in which case the roles
must share the resources, which constrains the model even further.

Configuring Manufacturing Resources
e-SCOR automatically creates a single manufacturing resource for each
manufacturing role in the model and places it on the detail of the Resources pool.
You can configure these parameters on these tabs for each resource:
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Tab/Attribute

Description

General
Resource Label

he label to display with the resource, which must be
unique.

General
Resource Priority

The priority of the resource, where 1 is the highest.

Configuring Resources

Tab/Attribute

Description

Utilization
Maximum
Utilization

The maximum capacity of the individual resource,
which must be a positive integer. You use this
parameter to determine the number of batches of
delivery products that a Base Manufacturer or
Manufacturer role can make at one time. The default
value is 1.

Utilization
Efficiency Factor

A number that the model multiplies by the duration of
an activity to determine the amount of time the
resource is active manufacturing finished products. The
default value is 1.
You use this parameter to determine the relative
amount of time it takes to make a batch of delivery
products, which the model uses to compute resource
utilization metrics.

To configure manufacturing resources:
1

For each Base Manufacturer and Manufacturer role in the model, choose
Resources to display a submenu of resources assigned to the role, then choose
the default resource to show its properties dialog.

Tip You can choose Show Resources to show the detail of the Resources pool, then
display the properties of the resource. You can also go to the Resources pool
on the role detail and choose Show Detail. The Resources pool looks like this:

2

Configure the properties described above, as needed.

3

Optionally, to assign multiple resources to the role, display the Resources
palette of the e-SCOR toolbox, select a Mfg Resource, place it on the detail of a
Resources pool, and configure its properties.
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Here is the Utilization tab for a manufacturing resource that represents two
physical resources and has an 80% efficiency factor:

Resource represents
2 physical resources
and has an 80%
efficiency factor.

Sharing Resources Between Roles
To share a single manufacturing resource between two or more roles, you create a
surrogate from an existing manufacturing resource and place the surrogate in the
Resources pool of another role.
To share resources between roles:
1

Show the detail of the Resources pool of the role whose manufacturing
resource you want to share.

2

Choose Create Surrogate on the resource in the pool.
A surrogate appears in the pool.

3

Show the Resources pool of the role that should share the existing resource.

4

Choose Transfer on the surrogate in the first pool, and click in the second pool
to transfer the surrogate.

For example, as a computer manufacturer, you might have two different
manufacturing processes, one for laptop computers and one for desktop
computers, each of which might compete for the same manufacturing resource.
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To do this, you create a manufacturing resource surrogate and assign it to another
manufacturing role, as this figure shows:

Surrogate

Create a surrogate from an existing
manufacturing resource to cause the
roles to compete for the resource
when making finished products.

Upgrading Models
When you run a new version of e-SCOR, typically, you upgrade the details of all
roles and categories in your project to use the new default templates. You can
update roles and/or categories individually, or upgrade all models in your
project at once.
If you have customized any aspect of the model details—an advanced
feature—then you can choose not to upgrade individual roles and/or categories.
To upgrade all roles and categories in a model:
 Choose Simulation > Upgrade Models.

By default, all roles and categories in your project are upgraded to use the new
default templates.
To avoid upgrading individual roles and/or categories in the model:
1

Disable the Upgrade parameter for individual roles and/or categories in the
model whose details you have customized and do not want to upgrade.

2

Choose Simulation > Upgrade Models.

Only those roles and categories whose Upgrade parameter is enabled are
upgraded.
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To upgrade individual models, roles, and/or categories:
1

Configure the Upgrade parameter for individual roles and/or categories in
the model, as needed, to determine whether or not to upgrade the details.

2

Do one of the following, depending on how much of the model you want to
upgrade:
 To upgrade all roles and categories for a particular model, choose
Upgrade Model on a Model object.

or
 To upgrade individual roles and all categories on the role detail, choose
Upgrade Block on individual roles in the model.

or
 To upgrade individual categories on the role detail, choose Upgrade Block
on individual categories on the role detail.
Tip To display the model object associated with a model, choose Go to Superior from
the model detail.
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Introduction
Once you have configured the supply-chain model by configuring Level 1 roles,
you configure Level 2 SCOR by configuring parameters for each category and
product composites associated with each role in the model.
The only Level 2 SCOR parameter you must configure before you can run the
model is the Potential Supplier of each source product for each buyer role;
otherwise, you can use the default values for all parameters. By default, the model
uses these general defaults:

• Timing parameters are all configured to take exactly 1 hour.
• The Net Selling Price for all delivery products is $1, which means all financial
and asset metrics are calculated based on this price.

• Cost parameters are all configured to be zero.
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• All source and delivery products use a stock/replenishment planning
strategy and a pull planning mode.

• The source products of a Consumer role are configured to order exactly 100
products once an hour.

You only need to configure parameters that are relevant for the particular
planning strategy that each product uses. For example, when using an engineerto-order planning strategy, you do not need to configure parameters related to
stock inventory planning.
This chapter describes how to configure Level 2 SCOR for the simplest e-SCOR
model, which consists of a Base Manufacturer role and a Consumer role. It shows
sample dialogs for the categories and product composites in the simplest model.
If the dialogs for other categories are significantly different, it shows sample
dialogs for these categories, as well. The descriptions of each category parameter
apply to all categories, unless otherwise indicated in the description.
To configure Level 2 SCOR, you:

• View the role details for each role.
• Configure process category parameters on the detail of each role, which
includes the Plan, Source, Make, and Deliver categories.

• Configure product composite parameters for each source and delivery
product on the detail of the Products pool for each role.

You can also configure demand and change orders through a Demand Report.
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Viewing Role Details
This section describes:

• Standard objects on the role detail.
• Summary of all process categories.

Standard Objects on Role Details
Each role detail includes Source, Make, and/or Deliver process categories
appropriate to the role. These categories are connected by input and output paths,
through routers, which send objects along the appropriate paths, both upstream
and downstream in the model.
In addition, each role detail has one or more category routers, which appear on
the detail and send objects to appropriate categories. When adding multiple
categories to the role detail, you must connect the paths to these category routers.
Each role detail also includes a number of repositories or pools in which e-SCOR
stores a variety of objects. The role detail contains two types of pools:

• Pools that store permanent objects. The Products pool contains source and
delivery products associated with each role, and the Mfg Resources pool
contains manufacturing resources required to make finished products.

• Pools that store transient objects, which e-SCOR creates and deletes when the

simulation runs. For example, the Orders pool stores orders that buyers create
when sourcing products from suppliers.
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This figure labels each of these general types of objects on the detail of a Base
Manufacturer role:
Categories

Connection

Routers

Pools

See Also Showing Transient Objects.
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Process Category Summary
The following table indicates the roles on whose details each category can appear
and provides a general description of what you need to configure for each
category:
Category

Roles

Description

P2: Plan Source

Distributor
Manufacturer
Consumer

You configure the planning period for
ordering source products and the time at
which the first plan goes into effect. You
can also configure the category to create
replenishment orders on demand.

P3: Plan Make

Base Manufacturer
Manufacturer

You configure the planning period for
making finished products and the time at
which the first plan goes into effect. You
can also configure the role to create build
orders on demand and to compensate for
the build yield.

P5: Plan Return

Distributor
Manufacturer
Consumer

You configure the planning period for
sourcing and delivering defective
products, MRO products, and excess
inventory, based on returns, and the time
at which the first plan goes into effect.

S1: Source
Stocked Product

Distributor
Manufacturer
Consumer

You configure the time it takes to receive,
verify, and transfer stock source products,
and the costs associated with sourcing
stock products.

S2: Source
Make-to-Order
Product

Distributor
Manufacturer
Consumer

You configure the time it takes to receive
make-to-order source products and the
costs associated with sourcing make-toorder products.

Plan

Source
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Category

Roles

Description

S3: Source
Engineer-to-Order
Product

Distributor
Manufacturer
Consumer

You configure the time it takes to receive
engineer-to-order source products and the
costs associated with sourcing engineerto-order products.

M1: Make-to-Stock

Manufacturer

You configure timing parameters related
to creating build orders for stock delivery
products, choosing which build order to
manufacture first, taking raw materials
from inventory, manufacturing batches,
and transferring finished products to
inventory. You also configure the cost of
taking raw materials from inventory.

M2: Make-to-Order

Manufacturer

You configure timing parameters related
to creating build orders for make-to-order
delivery products, choosing which build
order to manufacture first, taking raw
materials from inventory, manufacturing
batches, and transferring finished
products to inventory. You also configure
the cost of taking raw materials from
inventory.

M3: Engineer-to-Order Manufacturer

You configure timing parameters related
to engineering delivery products, creating
build orders for engineer-to-order
products, choosing which build order to
manufacture first, taking raw materials
from inventory, manufacturing batches,
and transferring finished products to
inventory. You also configure the
engineering cost and the cost of taking raw
materials from inventory.

Make
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Viewing Role Details

Category

Roles

Description

D1: Deliver
Stocked Product

Base Manufacturer
Distributor
Manufacturer

You configure timing parameters related
to creating an order for stock delivery
products, choosing which order to deliver
first, picking delivery products from
inventory, packing containers, and
shipping containers. You also configure
the costs associated with delivering
products.

D2: Deliver
Make-to-Order
Product

Base Manufacturer
Distributor
Manufacturer

You configure timing parameters related
to creating an order for make-to-order
delivery products, choosing which order
to deliver first, picking delivery products
from inventory, packing containers, and
shipping containers. You also configure
the costs associated with delivering
products.

D3: Deliver
Engineer-to-Order
Product

Base Manufacturer
Distributor
Manufacturer

You configure timing parameters related
to creating an order for engineer-to-order
delivery products, choosing which order
to deliver first, picking delivery products
from inventory, packing containers, and
shipping containers. You also configure
the costs associated with delivering
products.

ES: Enable Source

Distributor
Manufacturer
Consumer

The only parameters you configure for the
ES category are the Label and Upgrade.

ED: Enable Deliver

Base Manufacturer
Distributor
Manufacturer

The only parameters you configure for the
ED category are the Label and Upgrade.

Deliver

Enable Categories
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Category

Roles

Description

Source Returns Categories
SR1: Source Defective
Product

Distributor
Manufacturer
Consumer

You configure the duration for
transporting defective products, and the
cost of transporting and holding defective
products.

SR2: Source MRO
Product

Distributor
Manufacturer
Consumer

You configure the duration for
transporting maintenance, repair, and
overhaul (MRO) products, and the cost of
transporting and holding MRO products.

SR3: Source Excess
Product

Distributor
Manufacturer
Consumer

You configure the duration for
transporting excess inventory, and the cost
of transporting and holding excess
inventory.

Deliver Returns Categories
DR1: Deliver Defective
Product

Base Manufacturer
Distributor
Manufacturer

You configure the duration for
authorizing defective products, and the
cost of authorizing and disposing of
defective products.

DR2: Deliver MRO
Product

Base Manufacturer
Distributor
Manufacturer

You configure the duration for
authorizing maintenance, repair, and
overhaul (MRO) products, and the cost of
authorizing and disposing of MRO
products.

DR3: Deliver Excess
Product

Base Manufacturer
Distributor
Manufacturer

You configure the duration for
authorizing the delivery of excess
inventory, and the cost of authorizing and
disposing of excess inventory.
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Category

Roles

Description

Base Manufacturer

For stock and make-to-order delivery
products, you configure timing
parameters related to creating build
orders, choosing which build order to
manufacture first, taking raw materials
from inventory, manufacturing batches,
and transferring finished products to
inventory. You also configure the cost of
taking raw materials from inventory.

End Conditions
Mb: Make Product

For engineer-to-order products, you also
configure timing and cost parameters
associated with engineering finished
products.
This category represents a boundary
condition in the supply chain.
Input

Consumer

This category initiates the process of
creating customer orders and change
orders for the finished products in the
overall supply chain. This category
represents a boundary condition in the
supply chain and has no parameters to
configure.

End

Consumer

This category signals the end of the supply
chain, when finished products have been
received and paid for.

See Also Configuring Process Category Parameters.
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Configuring Process Category Parameters
Category parameters apply to every product that the category sources, makes, or
delivers and include:

• Timing parameters related to sourcing, making, and delivering products, such
as the time it takes to enter an order for a source product, manufacture a
finished product, and pick, pack, and deliver a product shipment.

• Cost parameters, such as the cost of acquiring materials, handling

components during manufacturing, and entering and fulfilling an order.

• Parameters for choosing which order to manufacture or deliver first.
To configure process category parameters, you need to understand how to:

• Configure category parameters, in general.
• Configure the mathematical distribution the category uses to compute
variation.

You configure Level 2 SCOR parameters for these categories:

• Plan categories
• Source categories
• Make categories
• Deliver categories
• Source Returns categories
• Deliver Returns categories
Note The ES: Enable Source category and the ED: Enable Deliver category have no
configurable parameters except Label and Upgrade. For information on using the
Upgrade option, see Upgrading Models.

See Also Viewing Metrics for Categories.

Configuring Role Details for Multiple Products.
Configuring Multipliers for Timing Parameters.
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Configuring Category Parameters
You configure process category parameters on the detail of the specified role.
To configure category parameters:
1

Show the detail of a role.

2

Display the properties dialog for a process category on the role detail.

3

Configure the parameters on the tabbed dialog that appears.

This dialog shows the Source tab of the S1: Source Stocked Product category:
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Configuring the Mathematical Distribution
By default, the timing parameters that you can configure for Source, Make, and
Deliver categories, use a triangular distribution for computing variation. This
means you configure the Min, Max, and Mode parameters of a triangular
distribution, and the model computes a random value, based on these
parameters.
You can configure the mathematical distribution the model uses to compute these
parameters. To do this, you configure the Distribution Mode to be one of a
number of mathematical distributions, and you configure the specific parameters
required for that distribution.
You can configure the mathematical distribution for a variety of Level 2 category
and product composite parameters, such as the Demand Order Duration and
Demand Order Size of Consumer source products, the Receiving Duration of a
Source category, Manufacturing Duration of a Make category, and Transportation
Duration of a Deliver category.
When you configure the Distribution Mode, the dialog displays the appropriate
parameters required to configure the mathematical distribution.
For information on the available distributions, see “Working with the Duration of
Blocks” in Chapter 4 “Using Blocks” in the ReThink User? Guide.
To configure the mathematical distribution:
1

Configure the Distribution Mode parameter for one of the timing or initial
order demand parameter listed above by choosing a mathematical
distribution from the dropdown list.
For information about configuring category parameters, in general, see
Configuring Category Parameters.
Once you choose the Distribution Mode, e-SCOR displays the parameters that
you must configure for that mathematical distribution.

2
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Configure the parameters associated with the distribution you choose.

Configuring Process Category Parameters

For example, you might configure the Distribution Mode of the Receiving
Duration parameter of the S1: Source Stocked Product category to be
Random Normal, as follows:

Takes an average
of 1 day to receive
shipments, +/- 12
hours.
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Configuring the Plan Category
The properties dialogs for the P2: Plan Source, P3: Plan Make, and P5: Plan Return
categories are identical except that the P3 category has the Compensate for Yield
parameter.
The following figure shows the default properties dialog for the P3: Plan Make
category of a Base Manufacturer role:

Sends build
orders to the
Make category
once a week,
the default.
Waits 2 days
before sending the
first build order,
the default.
Uses cyclic
planning, the
default.
Compensates
for expected
loss due to the
Build Yield
during planning,
the default.
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Group/
Parameter

Tab

Description

General

Planning

The label to display with the category. The default
value is the SCOR category name.

Planning

When using a new version of e-SCOR, whether to
upgrade the category, using the default role
template (“on”) or whether to leave the category
as it is (“off”). The default value is “on”.

Label
General
Upgrade

For details, see Upgrading Models.
Planning
Planning Period

Planning

The time interval between executing plans.
For the P3: Plan Make category, each time a plan
executes, the Plan category sends build orders to
the Make category, which manufactures delivery
products to satisfy current build orders.
For the P2: Plan Source category, each time a plan
executes, the Plan category sends replenishment
orders to the Source category, which places
orders for source products with upstream
suppliers.
The default value is 1 week.
Note: You only need to configure the Planning
Period for the P3 category when the upstream
Make category uses a stock or make-to-order
planning strategy. If the upstream Make category
uses an engineer-to-order planning strategy, the
Make category initiates its make planning process
as soon as it can, based on available components.
For details, see Using an Engineer-to-Order
Planning Strategy.
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Group/
Parameter

Tab

Description

Planning

Planning

The initial delay from the start time of the
simulation to the time at which the first plan goes
into effect. By default, planning occurs every
Planning Period, thereafter. The default value is
2 days.

Initial Plan Delay

You configure this parameter to coordinate
source and make planning when the model
contains Manufacturer roles.
For details, see Coordinating Source and Make
Planning.
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Group/
Parameter

Tab

Description

Planning

Planning

Whether the role uses cyclical planning, in
addition to demand-based planning. By default,
Continuous Planning is disabled, which means
the role uses cyclical planning only, based on the
Planning Period.

Continuous Planning

When Continuous Planning is enabled, in
addition to its normal cyclical planning, the role
initiates a plan whenever the downstream
category creates an order. The type of planning
depends on the role and the Plan category, as
follows:

• For the P2 category of a Distributor role,

source planning initiates whenever a
downstream buyer role creates a
replenishment order for the role’s delivery
products.

• For the P2 category of a Manufacturer role,

source planning initiates whenever the
downstream Make category creates a build
order for the role’s delivery products.

• For the P3 category of a Manufacturer role,
make planning initiates whenever a
downstream buyer role creates a
replenishment order for the role’s delivery
products.

To use demand-based planning only, configure
the Planning Period to be a very large number so
it never gets invoked.
For more information, see Configuring the Stock
Planning Strategy.
Planning
Compensate for Yield

Planning

(P3) Whether the role takes into account the Build
Yield parameter of the delivery product during
the make planning process. When Compensate
for Yield is enabled, the default, the P3 category
increases the number of products it plans to
make, due to expected loss. Disable Compensate
for Yield to disregard the build yield during make
planning.
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Configuring the Source Category
The properties dialogs for all the Source categories are the same.
The following figure shows the Source tab of the default properties dialog for the
S1: Source Stocked Product category of a Consumer role:

Parameters
apply to all
source
products
assigned to
the role, the
default.
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The following figure shows the Receiving tab of the default properties dialog for
the S1: Source Stocked Product category:

Takes 1 hour to
receive shipments
of source products,
the default.
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The following figure shows the Verification tab of the default properties dialog
for the S1: Source Stocked Product category:

Takes 1 hour to
verify shipments of
source products,
the default.
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The following figure shows the Transfer tab of the default properties dialog for
the S1: Source Stocked Product category:

Takes 1 hour to
transfer shipments
of source products
to inventory, the
default.

163

The following figure shows the Cost tab of a sample properties dialog for the
S1: Source Stocked Product category:

Costs $10 to receive, verify,
and transfer source products to
inventory, create each order,
and pay each invoice. By
default, these costs are all 0.

Group/
Parameter

Tab

Description

General

Source

The label to display with the category. The
default value is the SCOR category name.

Source

When using a new version of e-SCOR, whether
to upgrade the category, using the default role
template (“on”) or whether to leave the category
as it is (“off”). The default value is “on”.

Label
General
Upgrade

For details, see Upgrading Models.
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Group/
Parameter

Tab

Description

Product Selection

Source

Whether the Source category parameters apply
to all source products associated with the role or
to a specific source product. By default, All
Products is enabled.

All Products
Specific Product Name

You configure these parameters when the
Source category sources multiple products.
When All Products is disabled, configure the
Specific Product Name parameter to determine
the specific source product to which the Source
category parameters apply.
For details, see Adding Multiple Categories to
Role Details.
Receiving Duration
Distribution Mode

Receiving

The time it takes from when the Source category
receives source products to when it places them
in inventory.
For information on how to use other
distributions, see Configuring the Mathematical
Distribution.
Tip: Assets transfer from supplier to buyer at
the end of the Transportation Duration of the
buyer role’s Deliver category and before the
Receiving Duration. To cause assets to transfer
at shipment time, configure the Receiving
Duration to be zero and configure the
Transportation Duration to include the
receiving time. The asset metrics for the
supplier and buyer roles reflect this difference,
as do the Supplier On-Time Performance and
Delivery Performance metrics of the ES: Enable
Source and ED: Enable Deliver categories,
respectively.

Verification Duration
Distribution Mode

Verification The time it takes to verify shipments of source
products before placing them in inventory.
For information on how to use other
distributions, see Configuring the Mathematical
Distribution.
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Group/
Parameter

Tab

Description

Transfer Duration

Transfer

The time it takes to transfer shipments of source
products to inventory.

Distribution Mode

Costs per Transaction

For information on how to use other
distributions, see Configuring the Mathematical
Distribution.
Cost

The costs associated with receiving source
products. The default value is 0.

Cost

The costs associated with verifying a shipment
of source products. The default value is 0.

Cost

The costs associated with transferring a
shipment of source products to inventory. The
default value is 0.

Cost

The costs associated with creating an order for
source products. The default value is 0.

Cost

The costs associated with paying invoices for
source products. The default value is 0.

Receiving
Costs per Transaction
Verification
Costs per Transaction
Transfer
Costs per Transaction
Create Customer
Order
Costs per Transaction
Invoice
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Configuring the Make Category
The properties dialogs for the Make categories have these parameter differences,
by tab:

• Engineering tab: The Mb and M3 categories include the Engineering tab.
• Cost tab: The Mb and M3 categories include the ECO parameter.
The following figure shows the Manufacturer tab of the default properties dialog
for the Mb: Make Product category of a Base Manufacturer role:

Parameters
apply to all
delivery
products
associated
with the role,
the default.
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The following figure shows the Engineering tab of the default properties dialog
for the Mb: Make Product category:

When the Order Type
of the delivery product
is ETO, takes 1 hour to
engineer orders, the
default.
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The following figure shows the Build Orders tab of the default properties dialog
for the Mb: Make Product category:

Takes 1 hour from when
the Make category
receives a build order to
when it receives
components, the default.
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The following figure shows the Build Selection 1-2 tab of a sample properties
dialog for the Mb: Make Product category. The Build Selection 3-4 tab is similar.

Sorts build orders on a
FIFO basis, based on
Internal Order Number.
By default, it chooses
build orders at random.
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The following figure shows the Production Material tab of the default properties
dialog for the Mb: Make Product category:

Takes 1 hour from when the
Make category receives
components to when it
begins manufacturing
batches of finished products,
the default.
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The following figure shows the Manufacturing tab of the default properties
dialog for the Mb: Make Product category:

Takes 1 hour to
manufacture one batch
of finished products,
the default.
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The following figure shows the Transfer tab of the default properties dialog for
the Mb: Make Product category:

Takes 1 hour to transfer
finished products from
where they are built into
inventory, the default.
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The following figure shows the Cost tab of a sample properties dialog for the
Mb: Make Product category:

Costs $10 to handle
the components used
to make finished
products. When
making engineer-toorder finished
products, costs $10 to
engineering products.
By default, these
costs are both 0.
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The following figure shows the Cost tab of a sample properties dialog for the
M1: Make-to-Stock category:

Costs $10 to handle
components used to make
finished products. By
default, this cost is 0.

Group/
Parameter

Tab

Description

General

Manufacturer

The label to display with the category. The
default value is the SCOR category name.

Manufacturer

When using a new version of e-SCOR,
whether to upgrade the category, using the
default role template (“on”) or whether to
leave the category as it is (“off”). The default
value is “off”.

Label
General
Upgrade

For details, see Upgrading Models.
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Group/
Parameter

Tab

Description

Product Selection

Manufacturer

Whether the Make category parameters apply
to all delivery products associated with the
role or to a specific delivery product. By
default, All Products is enabled.

All Products
Specific Product
Name

When All Products is disabled, configure the
Specific Product Name parameter to
determine the specific delivery product to
which the Make category parameters apply.
You configure these parameters when the
Make category manufactures multiple
products.
For details, see Adding Multiple Categories to
Role Details.

Engineering Duration

Engineering

Distribution Mode

(Mb and M3) The time it takes to engineer a
single batch of engineer-to-order delivery
products, regardless of the number of
products in the batch.
You configure this parameter only when the
Order Type of the delivery product is ETO.
For information on how to use other
distributions, see Configuring the
Mathematical Distribution.

Order Release to
Manufacturing
Duration
Distribution Mode
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Build Orders

The time it takes from when the Make
category receives a build order to when it
receives components.
For information on how to use other
distributions, see Configuring the
Mathematical Distribution.

Configuring Process Category Parameters

Group/
Parameter

First
Second
Third
Fourth
Sort Direction
Sort Criteria
Cutoff
Cutoff Value
Cutoff Duration

Tab

Description

Build Selection
1-2

The criteria that determines how to choose
build orders for manufacturing. By default,
the Make category chooses build orders at
random, based on the Sort Criteria.

Build Selection
3-4

The Make category sorts build orders waiting
to be manufactured, based on up to four
criteria of an order, which are numeric values.
The Make category sorts build orders, based
on the criteria in the First group. If two build
orders have the same value for the specified
criteria, it sorts build orders, based on the
criteria in the Second group, and so on.
For a description of the sort and cutoff
parameters and examples of how to use them,
see Configuring Build Selection Parameters.

Production Material
Duration

Production
Material

Distribution Mode

The time it takes from when the Make
category receives components to when it
starts manufacturing batches of finished
products.
For information on how to use other
distributions, see Configuring the
Mathematical Distribution.

Manufacturing
Duration

Manufacturing

Distribution Mode

The time it takes from when the Make
category starts to manufacture a single batch
of delivery products to when it finishes
manufacturing the batch. The Manufacturing
Duration is the same, regardless of the
number of products in the batch.
For information on how to use other
distributions, see Configuring the
Mathematical Distribution.

Move to Delivery
Duration
Distribution Mode

Transfer

The time it takes from when the Make
category finishes manufacturing a batch of
delivery products to when the finished
products are transferred to inventory.
For information on how to use other
distributions, see Configuring the
Mathematical Distribution.
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Group/
Parameter

Tab

Description

Costs per Transaction

Cost

(Mb, M3) The costs associated with
engineering change orders for engineer-toorder products. The default value is 0.

ECO

Note: This parameter applies to ETO delivery
products only.
Costs per Transaction
Production
Material
Handling

Cost

The costs associated with handling the
components the Make category uses to
manufacture finished products. The default
value is 0.

Configuring the Deliver Category
The properties dialogs for the Deliver categories have these parameter
differences, by tab:

• Order tab: The D3 category does not have the Order Entry Duration

parameter; therefore, the D3 category does not have the Order tab at all.

• Order Selection tab: The D3 category does not have the Order Selection tab.
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The following figure shows the Delivery tab of the default properties dialog for
the D1: Deliver Stocked Product category of a Base Manufacturer role:

Parameters apply
to all delivery
products
associated with
the role.
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The following figure shows the Order tab of the default properties dialog for the
D1: Deliver Stocked Product category:

Takes 1 hour to
enter an order,
the default.
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The following figure shows the Order Selection 1-2 tab of a sample properties
dialog for the D1: Deliver Stocked Product category. The Order Selection 3-4 tab
is similar.

Delivers the orders
with the highest
cost first. By
default, it chooses
orders at random.
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The following figure shows the Fulfillment tab of the default properties dialog for
the D1: Deliver Stocked Product category:

Takes 1 hour to pick
delivery products from
inventory, the default.

Takes 1 hour to pack a
container with a
shipment, the default.
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The following figure shows the Transportation tab of the default properties dialog
for the D1: Deliver Stocked Product category:

Takes 1 hour to ship
an order, the default.
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The following figure shows the Cost tab of a sample properties dialog for the
D1: Deliver Stocked Product category:

Costs $10 per
transaction to enter
and fulfill an order,
pick the shipment
from inventory, pack
the container for
shipment, transport
the shipment, and
invoice and collect
payments from the
buyer.
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Group/
Parameter

Tab

Description

General

Delivery

The label to display with the category. The
default value is the SCOR category name.

Delivery

When using a new version of e-SCOR,
whether to upgrade the category, using
the default role template (“on”) or
whether to leave the category as it is
(“off”). The default value is “on”.

Label
General
Upgrade

For details, see Upgrading Models.
Product Selection

Delivery

All Products
Specific Product
Name

Whether the Deliver category parameters
apply to all delivery products associated
with the role or to a specific delivery
product. By default, All Products is
enabled.
When All Products is disabled, configure
the Specific Product Name parameter to
determine the specific delivery product to
which the Deliver category parameters
apply.
You configure these parameters when the
Deliver category delivers multiple
products.
For details, see Adding Multiple
Categories to Role Details.

Order Entry Duration
Distribution Mode

Order

(D1, D2) The time it takes from when the
Deliver category receives an order to
when it enters the order.
For information on how to use other
distributions, see Configuring the
Mathematical Distribution.
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Group/
Parameter

First
Second
Third
Fourth

Tab

Description

Order Selection 1-2
Order Selection 3-4

(D1, D2) The criteria that determines how
to choose orders for delivery. By default,
the Deliver category chooses orders at
random, based on the Sort Criteria.
The Deliver category sorts orders waiting
to be delivered, based on up to four
criteria. You can sort orders, based on any
numeric or time-based value of an order.

Sort Direction
Sort Criteria
Cutoff
Cutoff Value
Cutoff Duration

The Deliver category sorts orders, based
on the criteria in the First group. If two
orders have the same value for the
specified sort attribute, the Deliver
category sorts orders, based on the criteria
in the Second group, and so on.
The D3: Deliver Engineer-to-Order
Product category does not include order
selection criteria. Instead, the build
selection criteria for the M3: Engineer-toOrder category determines the criteria the
role uses to deliver engineer-to-order
products.
For a description of the sort and cutoff
parameters and how to use them, see
Configuring Order Selection Parameters.

Pick Duration

Fulfillment

Distribution Mode

The time it takes from when the Deliver
category enters an order to when it picks
delivery products from inventory for
packing.
For information on how to use other
distributions, see Configuring the
Mathematical Distribution.

Packing Duration
Distribution Mode

Fulfillment

The time it takes from when the Deliver
category picks delivery products from
inventory to when it packs them into
containers for shipment.
For information on how to use other
distributions, see Configuring the
Mathematical Distribution.
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Group/
Parameter

Transportation
Duration

Tab

Description

Transportation

The time it takes from when the Deliver
category packs containers for shipment to
when the buyer receives the shipment. By
default, you specify the Min, Max, and
Mode of a triangular function. The default
values are 1 hour.

Distribution Mode

For information on how to use other
distributions, see Configuring the
Mathematical Distribution.
Tip: Assets transfer from supplier to
buyer at the end of the Transportation
Duration and before the Receiving
Duration of the buyer role’s Source
category. To cause assets to transfer at
shipment time, configure the Receiving
Duration to be zero and configure the
Transportation Duration to include the
receiving time. The asset metrics for the
supplier and buyer roles reflect this
difference, as do the Supplier On-Time
Performance and Delivery Performance
metrics of the ES: Enable Source and
ED: Enable Deliver categories,
respectively.
Costs per Transaction

Cost

The costs associated with entering an
order. The default value is 0.

Cost

The costs associated with fulfilling an
order. The default value is 0.

Cost

The costs associated with picking delivery
products from inventory. The default
value is 0.

Cost

The costs associated with packing
shipments for delivery. The default value
is 0.

Cost

The average shipping cost per shipment.
The default value is 0.

Order Entry
Costs per Transaction
Order Fulfillment
Costs per Transaction
Pick
Costs per Transaction
Packing
Costs per Transaction
Transportation
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Group/
Parameter

Tab

Description

Costs per Transaction

Cost

The costs associated with invoicing the
buyer. The default value is 0.

Cost

The costs associated with collecting
payments from the buyer. The default
value is 0.

Customer Invoicing
Costs per Transaction
Customer
Collections
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Configuring the Source Returns Category
The properties dialogs for the Source Returns categories have these parameter
differences, by tab:

• Transportation tab: The label depends on the category — Defective Product

Transportation Duration, MRO Product Transportation Duration, and Excess
Product Transportation Duration.

• Cost tab: The label depends on the category, for example, Defective Product
Transportation Cost, MRO Product Transportation Cost, and Excess
Inventory Transportation Cost.

The following figure shows the Source tab of the default properties dialog for the
SR1: Source Defective Product category of a Consumer role:
Parameters apply to all
source products
associated with the role.
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The following figure shows the Transportation tab of the default properties dialog
for the SR1: Source Defective Product category:

Takes 1 hour to ship
returned defective
products, the default.
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The following figure shows the Cost tab of a sample properties dialog for the
SR1: Source Defective Product category:

Costs $10 per transaction
to ship and hold defective
products.

Group/
Parameter

Tab

Description

General

Delivery

The label to display with the category. The
default value is the SCOR category name.

Delivery

When using a new version of e-SCOR,
whether to upgrade the category, using
the default role template (“on”) or
whether to leave the category as it is
(“off”). The default value is “on”.

Label
General
Upgrade

For details, see Upgrading Models.
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Group/
Parameter

SR1:
Defective Product
Transportation
Duration

Tab

Description

Transportation

The time it transport products that are
defective, excess or require MRO back to
the relevant supplier.
For information on how to use other
distributions, see Configuring the
Mathematical Distribution.

SR2:
MRO Product
Transportation
Duration
SR3:
Excess Product
Transportation
Duration
Distribution Mode
Min
Max
Mode
Costs per Transaction

Cost

The costs associated with transporting
defective products, MRO products, or
excess inventory. The default value is 0.

Cost

The costs associated with holding
defective products, MRO products, or
excess inventory. The default value is 0.

SR1:
Defective Product
Transportation
SR2:
MRO Product
Transportation
SR3:
Excess Inventory
Transportation
Costs per Transaction
SR1:
Defective Product
Holding
SR2:
MRO Product
Holding
SR3:
Excess Inventory
Holding
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Configuring the Deliver Returns Category
The properties dialogs for the Deliver Returns categories have these parameter
differences, by tab:

• Authorization tab: The label depends on the category — Defective Product

Authorization Duration, MRO Product Authorization Duration, and Excess
Inventory Authorization Duration.

• Cost tab: The label depends on the category, for example, Defective Product

Authorization Cost, MRO Product Authorization Cost, and Excess Inventory
Authorization Cost.

The following figure shows the Delivery tab of the default properties dialog for
the DR1: Deliver Defective Product category of a Base Manufacturer role:

Parameters apply to all
delivery products
associated with the role.

The following figure shows the Authorization tab of the default properties dialog
for the DR1: Deliver Defective Product category:

Takes 1 hour to authorize
defective products, the
default.

193

The following figure shows the Cost tab of a sample properties dialog for the
DR1: Deliver Defective Product category:

Costs $10 per transaction
to authorize and dispose
of defective products.

Group/
Parameter

Tab

Description

General

Delivery

The label to display with the category. The
default value is the SCOR category name.

Delivery

When using a new version of e-SCOR,
whether to upgrade the category, using
the default role template (“on”) or
whether to leave the category as it is
(“off”). The default value is “on”.

Label
General
Upgrade

For details, see Upgrading Models.
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Group/
Parameter

Tab

Description

DR1:
Authorization
Defective Product
Authorization Duration

The time it takes to authorize the delivery
of defective products, MRO products, and
excess inventory.

DR2:
MRO Product
Authorization Duration

For information on how to use other
distributions, see Configuring the
Mathematical Distribution.

DR3:
Excess Inventory
Authorization Duration
Distribution Mode
Min
Max
Mode
Costs per Transaction

Cost

The costs associated with authorizing
defective products, MRO products, or
excess inventory. The default value is 0.

Cost

The costs associated with disposing of
defective products, MRO products, or
excess inventory. The default value is 0.

DR1:
Defective Product
Authorization
DR2:
MRO Product
Authorization
DR3:
Excess Inventory
Authorization
Costs per Transaction
DR1:
Defective Product
Disposition
DR2:
MRO Product
Disposition
DR3:
Excess Inventory
Disposition
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The parameters for source and delivery products apply to individual products
that a role sources, makes, or delivers. Compare these parameters with the
parameters for categories, which, by default, apply to every product that the
category sources, makes, or delivers. Source and delivery product parameters
include the order type, starting inventory, inventory control strategy, safety stock,
reorder quantities, desired turnaround, batch sizes, and net selling price.
To configure product composite parameters, you need to understand:

• The default source and delivery products for each role.
• How to configure product composite parameters, in general.
• How to configure multipliers for timing parameters.
You can configure parameters for:

• Source products.
• Delivery products.
The sections that describe the source and delivery product parameters include a
sample properties dialog for the source product of a Consumer role and the
delivery product of a Base Manufacturer role.
The parameters you configure for the source and delivery products of a
Distributor and Manufacturer role are similar. Differences are noted in the
descriptions of parameters.
A Base Manufacturer role has delivery products only, and a Consumer role has
source products only.
See Also Configuring the Products a Role Sources and Delivers.
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Default Source and Delivery Products for Each Role
This table describes the source and delivery products that you assign to each type
of role:
For this type of role...

You assign...

Base Manufacturer

Delivery products that are the raw materials for the
overall supply chain.
If the product specification you assign has
components, the Base Manufacturer ignores the
components.

Distributor

Source and delivery products.
When assembling components into kits, you assign
components as source products and finished
products as delivery products.

Manufacturer

Source products that are either components or
finished products, and delivery products that are
finished products, which use the source products as
components.

Consumer

Source products that are the finished products for the
overall supply chain.

Configuring Product Composite Parameters
You configure parameters for each source and delivery product that e-SCOR
creates. Source and delivery products exist on the detail of the Products pool,
which is located on the role detail.
To configure product composite parameters:
 Choose Products from a role, then choose a source or delivery product whose
parameters you want to configure.

or
1

Do either of the following to go to the Products pool detail:
 Choose Show Products from a role.

or
 Show the detail of a role, then show the detail of the Products pool:
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Each source and delivery product associated with the role appears in the pool.
2

Display the properties dialog for each source and delivery product to
configure its parameters.

Note If no product composites appear in the Products pool, you have not yet assigned
products specifications to the role. For details, see Configuring the Products a
Role Sources and Delivers.

The Products pool shows the source and delivery products for a role. The product
composite shows the Product Name, Order Type, and various order metrics.
Source products specify Is Source Product as true, and delivery products specify
Is Delivery Product as true. A product that is both a source and delivery product
specifies both Is Source Product and Is Delivery Product as true.
This figure shows the product hierarchy, Products menu, and Products pool of a
Manufacturer role that defines a source product named Component and a
delivery product named Product Family:

source
product
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delivery
product
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Configuring Multipliers for Timing Parameters
By default, the timing parameters you configure for each Source, Make, and
Deliver category on the role detail apply equally to each product composite
associated with the role. For example, the Manufacturing Duration parameter of
the Make category of a Manufacturer role applies equally to each delivery
product the role makes. If you assign multiple product specifications to the role,
each delivery product takes the same amount of time to build.
You might want to model variation in the timing parameters for Source, Make,
and Deliver categories for different source and delivery products associated with
a role. For example, a Manufacturer role might make two different finished
products, where one product takes 25% longer than the other to make due to an
extra assembly or finishing step.
One way to model this variation in build time is to configure a multiplier for the
Manufacturing Duration parameter for each delivery product associated with the
role. For example, the multiplier for one delivery product would be 1.0, the
default, and the multiplier for the other delivery product would be 1.25.
To model variation in timing parameters for individual product composites, you
configure the multipliers associated with the following Source, Make, and Deliver
category parameters located on these tab pages:
Category

Tab

Parameter

Source category

Receiving

Receiving Duration

Verification

Verification Duration

Transfer

Transfer Duration

Engineering

Engineering Duration
(raw materials)

Build Orders

Order Release to Manufacturing
Duration (raw materials)

Production Material

Production Material Duration
(raw materials)

Manufacturing

Manufacturing Duration
(finished goods)

Transfer

Move to Delivery Duration
(finished goods)

Make category
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Category

Tab

Parameter

Deliver
category

Order

Order Entry Duration

Fulfillment

Pick Duration

Fulfillment

Packing Duration

Transportation

Transportation Duration

For information about an alternative technique for modeling variation among
product composites, see Adding Multiple Categories to Role Details.
To configure multipliers for timing parameters:
 Display the properties dialogs for individual source or deliver products
associated with a role, click the Multipliers tab, and configure the multiplier
associated with the timing parameter whose value you want to vary.

Typically, you configure the multiplier associated with one product composite to
be 1.0, the default, and the other to be a multiple or a fraction of 1.0, such as 1.25
or .85.
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The following figures show how to configure the Manufacturing Duration
Multiplier for a High-end Computer, which requires an extra assembly step:

The High-End Computer takes twice as long
to manufacture than the Low-End Computer.
To model this, configure the Manufacturing
Duration Multiplier to be 2.

Configuring Parameters for Source Products
You configure parameters for source products on the following tabs of the
product composite dialog:

• General tab
• Demand tab (Consumer role only)
• MRO tab
• Inventory tab (Distributor and Manufacturer roles only)
• Supplier tab
• Supplier Selection tab
• Multipliers tab
Each section below provides an example of the properties dialog tab page for the
source product of a Consumer role and a description of each parameter.
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General Tab
The following figure shows the General tab of the default properties dialog for the
Product Family source product of a Consumer role:

Uses a stock
planning strategy,
the default.

Uses the default
preferences for the
source product and
the buyer role.
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Group/
Parameter

General
Order Type

Description

Determines whether to use a stock, mto (make-to-order), or
eto (engineer-to-order) planning strategy when creating
customer orders for source products. The default is stock.
For details on each of these planning strategies, see Using
Alternative Planning Strategies.

Preference
Customer Preference

A number representing the priority of a downstream buyer’s
source product, where the lower number means a higher
priority. The default value is 1.
You can use this number to choose which delivery product to
deliver first when configuring the Order Selection
parameters of the Deliver category of the upstream supplier.
For details, see Configuring Order Selection Parameters.
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Demand Tab
The following figure shows the Demand tab of the default properties dialog for
the source product of a Consumer role. You only configure parameters on the
Demand tab for the source product of a Consumer role.

Creates the first demand order
one day after the start of the
simulation, the default, and
uses the default stop time,
which is 10 years.

Creates a demand
order once an hour,
the default.

Creates a demand
order for 100 source
products, the default.

Group/
Parameter

Demand Details
Demand Start Time

Demand Details
Demand Stop Time
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Description

The time at which a Consumer role creates its first
demand order for source products, from the start
time of the simulation. The default value is one day
after the start of the simulation.
The time after which the Consumer role stops placing
demand orders for source products, from the start
time of the simulation. The default value is 521
weeks and 3 days, which is 10 years.

Configuring Product Composites

Group/
Parameter

Demand Details
Use Demand Input Report
Demand Input Report Name

Description

Whether to import order demand parameters from
the specified report or use the Demand Order Start
Time, Demand Order Stop Time, Demand Order
Duration, and Demand Order Size from the dialog.
By default, the Use Demand Input Report option is
disabled.
When the Use Demand Input Report option is
enabled, you also configure the Demand Input
Report Name.
For details on configuring these parameters, see
Configuring Demand and Change Orders through a
Demand Report.

Demand Order Duration
Distribution Mode
Mean

The frequency with which the Consumer role creates
demand orders for source products. By default, you
specify the Mean of a fixed distribution. The default
value is 1 hour.
For information on how to use other distributions, see
Configuring the Mathematical Distribution.
For information on configuring these parameters
through a report, see Configuring Demand and
Change Orders through a Demand Report.

Demand Order Size
Distribution Mode
Mean

The number of units of source products that a
Consumer role orders, which determines initial order
demand for the overall supply chain. By default, you
specify the Mean of a fixed distribution. The default
value is 100.
For information on how to use other distributions, see
Configuring the Mathematical Distribution.
For information on configuring these parameters
through a report, see Configuring Demand and
Change Orders through a Demand Report.

205

MRO Tab
The following figure shows the MRO tab of the default properties dialog for the
source product of a Consumer role:

Enables maintenance, repair,
and overhaul of source
products, where 5% of the
source products are returned.

Sources replacement products
from Manufacturer role.

Group/
Parameter

MRO Details
Enable MRO
MRO Details
MRO Verification Yield
MRO Details
MRO Start Time
MRO Stop Time
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Description

Whether to enable the maintenance, repair, and overhaul of
source products.
The percentage of source products that are returned for
maintenance, repair, and overhaul.
The time at which to start and stop the maintenance, repair,
and overhaul of source products.

Configuring Product Composites

Group/
Parameter

Description

MRO Duration
Distribution Mode
Mean
Potential Service Providers
Potential Service
Provider Names

The time it takes to return source products for maintenance,
repair, and overhaul.

The list of potential suppliers that potentially accept MRO
contracts.

Inventory Tab
The following figure shows the Inventory tab of the default properties dialog for
the source product of a Manufacturer role. You do not configure inventory
parameters for the source product of a Consumer role.

Uses a stock/replenishment
planning strategy, the default,
and the default starting and
maximum inventory levels,
safety stock, and minimum
reorder quantity.
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Group/
Parameter

Policy
Starting Product
Inventory Level
Policy
Maximum Inventory
Level

Description

The number of source products in inventory at the start of the
simulation. Configure this parameter to avoid skewed order
fulfillment lead times at startup while the model accumulates
inventory. The default value is 0.
The maximum number of source products the role can
accommodate in its inventory. If the Inventory Level exceeds
this maximum, the role discards the excess. The default value
is 100,000,000.
The only time the inventory could potentially exceed this
maximum is if a supplier pushes products onto a buyer,
causing the buyer to exceeds its Maximum Inventory Level.
For details, see Using Push Mode Planning.

Policy
Inventory Control
Strategy

When using a stock planning strategy in pull mode, the
planning strategy to use for computing replenishment order
size for stock source products. The options are: replenishment,
forecast-customer, r-q, and q. The default is replenishment.
For more information on using each of these planning
strategies, see Using Stock Planning Strategies.

Policy
Safety Stock

When using a stock/replenishment planning strategy in pull
mode, the minimum number of source products the role
needs to maintain in inventory before creating a new
replenishment order for source products. The default value is
500.
You configure this parameter when the Inventory Control
Strategy is replenishment.
For details, see Using Stock Planning Strategies.

Policy
Minimum Reorder
Quantity

When using a stock/replenishment planning strategy in pull
mode, the minimum number of source products for which the
role creates replenishment orders. The default value is 100.
You configure this parameter when the Inventory Control
Strategy is replenishment.
For details, see Using Stock Planning Strategies.
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Supplier Tab
The following figure shows the Supplier tab of the default properties dialog for
the source product of a Consumer role:

Uses the default
desired turnaround,
fulfillment, and push
planning parameters.

Uses the default
contract parameters.
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Group/
Parameter

Policy
Desired Turnaround

Description

The desired amount of time from when a buyer role places
customer orders for its source products to when the buyer
receives the shipment. The role uses this parameter to
compute the Product Shipment Lead Time of the Source
category. The default value is 1 week.
For details, see Viewing Metrics for Categories.
For information on configuring this parameter through a
report, see Configuring Demand and Change Orders through
a Demand Report.

Policy
Fulfillment
Preference

Whether the role must receive complete shipments of the
source products it orders (whole) or whether it can receive
partial shipments (partial). The default value is whole.
If the buyer requires whole shipments, the supplier waits to
deliver shipments until it has enough delivery products for a
complete order.
If the buyer accepts partial shipments, the supplier delivers
what it can when it can and creates back orders for the
unfulfilled portion of the order.
For information on configuring this parameter through a
report, see Configuring Demand and Change Orders through
a Demand Report.

Policy
Fulfillment Using
Alternate Products

Whether to fulfill orders for source products with alternate
products when generic products are not available. The
default value is false, which always uses the generic product.
To use alternate products, set this option to true.
For more information, see Creating a Product Hierarchy with
Alternate Products.
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Group/
Parameter

Policy
Push Stock Product

Description

Whether to use a push planning mode when placing orders
for source products. The default is false, which means the
role uses a pull planning mode, whereby the buyer sources
products from suppliers by placing orders, and a supplier
delivers products to buyers, based on orders.
Set this parameter to true to cause the supplier to push
products onto buyers, based on contracts. The buyer simply
receives those products from suppliers when the supplier
pushes them.
For more information, see Using Pull and Push Planning
Modes.

Contract
Contract Start Time

The time from the start of the simulation until the role sends
its first purchase request to upstream suppliers for source
products. The default value is the start time of the simulation.
Note: This parameter is also used when using a
stock/forecast planning strategy and when using a push
planning mode.
For details, see Modeling a Process with Multiple Suppliers
and Using a Stock/Forecast Planning Strategy.

Contract
Contract Length

The length of time during which the contract is valid. The
default value is 521 weeks and 3 days (10 years).
Note: This parameter is also used when using a
stock/forecast planning strategy and when using a push
planning mode.
For details, see Modeling a Process with Multiple Suppliers
and Using a Stock/Forecast Planning Strategy.

Contract
Contract Response
Cycle Time

The number of days the supplier has to respond to a
purchase request with a purchase response. The default
value is 1 day.
Note: Orders that are sent when there is no valid contract are
deleted.
Note: This parameter is also used when using a
stock/forecast planning strategy and when using a push
planning mode.
For details, see Modeling a Process with Multiple Suppliers
and Using a Stock/Forecast Planning Strategy.
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Group/
Parameter

Contract
Forecast Estimated
Amount

Description

An estimate of the number of source products the buyer
expects to order over the life of the contract. The default
value is 1000.
Note: This parameter is only used when using a
stock/forecast planning strategy and when using a push
planning mode. However, when using contracts to choose
suppliers, the Forecast Estimated Amount must be greater
than zero.
For details, see Using a Stock/Forecast Planning Strategy and
see Modeling a Process with Multiple Suppliers.

Contract
Contract Repetition
Count
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The number of times to repeat the contract during the
lifetime of the simulation. The default is 100,000.
Note: This parameter is also used when using a
stock/forecast planning strategy and when using a push
planning mode.
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Supplier Selection Tab
The following figure shows the Supplier Selection tab of the default properties
dialog for the source product of a Consumer role, which sources products from
the Base Manufacturer role:

Obtains source products
from a single upstream
supplier, based on price,
the default.

Obtains source products
from the Base Manufacturer
supplier role.
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Group/
Parameter

Supplier Selection
Maximum Number of
Suppliers

Description

Specifies the number of qualified suppliers to which
the buyer issues awards for its source products. The
default value is 1.
Note: You only need to configure this parameter
when sourcing identical products from multiple
suppliers.
For details, see Configuring the Supplier Selection
Criteria.

Supplier Information
Split Orders Between
Suppliers

Determines whether to send the order to a single
supplier (false) or whether to split the order among
the specified number of suppliers (true). The default
value is false.
Note: You only need to configure this parameter
when sourcing identical products from multiple
suppliers.
For details, see Configuring the Supplier Selection
Criteria.
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Group/
Parameter

Supplier Selection
Supplier Selection Criteria 1
Supplier Selection Criteria 2
Supplier Selection Criteria 3
Supplier Selection Criteria 4

Description

Determines how the buyer chooses qualified
suppliers. The buyer chooses suppliers, based on the
smallest value of the Supplier Selection Criteria 1. If
two suppliers have the same value for the sort
attribute, the buyer looks at Supplier Selection
Criteria 2 to determine which supplier should receive
an award, and so on.
The options are:

• product-price — The Net Selling Price of the

supplier’s delivery product. This is the default
value.

• supplier-preference — The Supplier Preference of
the supplier’s delivery product.

• supplier-product-preference — The Product

Preference of the supplier’s delivery product.

• negotiated-turnaround-cycle-time — The Desired
Turnaround of the buyer’s source product that
has been negotiated with the supplier in the
current contract.

• supplier-published-delivery-lead-time — The
Published Delivery Lead Time of supplier’s
delivery product.

• supplier-available-inventory — The Inventory
Level of the supplier’s delivery product.

• negotiated-customer-preference — The Customer
Preference of the buyer’s source product that has
been negotiated with the supplier in the current
contract.

• negotiated-payment-terms — The buyer’s
Financial Payment Terms that has been
negotiated with the supplier.

Note: You only need to configure this parameter
when sourcing identical products from multiple
suppliers.
For details, see Configuring the Supplier Selection
Criteria.
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Group/
Parameter

Supplier Information
Selected Suppliers Proportions

Description

When Split Orders Between Suppliers is false and the
Maximum Number of Suppliers is greater than 1,
determines the percentage of the time, on average,
that the order will go to each qualified supplier.
When Split Orders Between Suppliers is true and the
Maximum Number of Suppliers is greater than 1,
determines the proportion of the order that goes to
each qualified supplier.
The percentage or proportions correspond to each
chosen supplier, based on the Supplier Selection
Criteria. The value is a comma-separated list of
values, for example:
.75, .25
Note: You only need to configure this parameter
when sourcing identical products from multiple
suppliers.
For details, see Configuring the Supplier Selection
Criteria.

Potential Suppliers
Potential Supplier Names

The list of potential suppliers for the source product.
Note: You must configure at least one potential
supplier for all source products in the model;
otherwise, the role will not generate orders for
source products.
When sourcing identical products from multiple
suppliers, you can choose multiple potential
suppliers, and the buyer chooses the supplier based
on the various supplier information configured for
the source product.
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Multipliers Tab
The following figure shows the Multipliers tab of the default properties dialog for
the source product of a Consumer role:

Uses the same Source
category durations for all
source products,
the default.
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Group/
Parameter

Description

Source Multipliers
Receiving Duration

A number that the role multiplies by the Receiving Duration
parameter of the Source category to determine the actual
time it takes to receive source products. The default value is
1.0, which means it takes exactly the Receiving Duration.
For details, see Configuring Multipliers for Timing
Parameters.

Source Multipliers
Verification Duration

A number that the role multiplies by the Verification
Duration parameter of the Source category to determine the
actual time it takes to verify source products. The default
value is 1.0, which means it takes exactly the Verification
Duration.
For details, see Configuring Multipliers for Timing
Parameters.

Source Multipliers
Transfer Duration

A number that the role multiplies by the Transfer Duration
parameter of the Source category to determine the actual
time it takes to transfer source products to inventory. The
default value is 1.0, which means it takes exactly the Transfer
Duration.
For details, see Configuring Multipliers for Timing
Parameters.

Configuring Parameters for Delivery Products
You configure parameters for delivery products on the following tabs of the
product composite dialog:

• General tab
• Inventory tab
• Sourcing tab (Base Manufacturer role only)
• Manufacturing tab
• Return tab
• Delivery tab
• Multipliers tab
Each of the following sections provides an example of the properties dialog tab
page for the delivery product of a Base Manufacturer role and a description of
each parameter.
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General Tab
The following figure shows the General tab of the default properties dialog for a
delivery product of a Base Manufacturer role:

Uses a stock planning
strategy, the default.

Uses the default preferences
for the delivery product and
the supplier role.

Group/
Parameter

General
Order Type

Description

Determines whether the role uses a stock, mto (make-toorder), or eto (engineer-to-order) planning strategy when
making and delivering its delivery products. The default is
stock.
For details on each of these planning strategies, see Using
Alternative Planning Strategies.

General
Is Kitted

For the delivery product of a Distributor role that assembles
components into finished products, or kits, whether the
finished product is a kit. You must explicitly enable this
option to assemble components into kits.
For details, see Configuring a Distributor to Assemble
Components into Kits.
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Group/
Parameter

Preference
Product Preference

Description

A number representing the priority of the delivery product,
where the lower number means a higher priority. The default
value is 1.
You can use this number to choose which delivery product to
deliver first when configuring the Order Selection
parameters of the Deliver category and which finished
product to make first when configuring the Build Selection
parameters of the Make category.
For details, see Configuring Order Selection Parameters and
Configuring Build Selection Parameters.
You also use this number to determine which delivery
products to deliver first when using a push planning strategy
when a role makes and/or delivers multiple products and
when components are shared.
For details, see Configuring Which Delivery Products to
Push First and Configuring the Amount to Push When
Components are Shared.

Preference
Supplier Preference

A number that represents the priority as a supplier of the role
associated with this delivery product. The smaller the
number, the more likely a downstream buyer will choose this
supplier when issuing purchase awards, using contracts. The
default value is 1.
You only need to configure this parameter when choosing
among multiple suppliers, using contracts. For details, see
Configuring the Supplier Selection Criteria.
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Inventory Tab
The following figure shows the Inventory tab of the default properties dialog for a
delivery product of a Base Manufacturer role:

Uses a stock/replenishment
planning strategy, the default, and
the default starting and maximum
inventory levels, safety stock, and
minimum reorder quantity.

Group/
Parameter

Policy
Starting Product
Inventory Level
Policy
Maximum Inventory
Level

Description

The number of delivery products in inventory at the start of
the simulation. Configure this parameter to avoid skewed
order fulfillment lead times at startup while the model
accumulates inventory. The default value is 0.
The maximum number of delivery products the role can
accommodate in its inventory. If the Inventory Level exceeds
this maximum, the role discards the excess. The default value
is 100,000,000.
The only time the inventory could potentially exceed this
maximum is if a supplier pushes products onto a buyer,
causing the buyer to exceeds its Maximum Inventory Level.
For details, see Using Push Mode Planning.
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Group/
Parameter

Policy
Inventory Control
Strategy

Description

When using a stock planning strategy in pull mode, the
inventory control strategy to use for computing build order
size for stock delivery products. The options are:
replenishment, forecast-customer, r-q, and q. The default is
replenishment.
For more information on using each of these planning
strategies, see Using Stock Planning Strategies.

Policy
Safety Stock

When using a stock/replenishment planning strategy in pull
mode, the minimum number of delivery products the role
needs to maintain in inventory before creating a new build
order for delivery products. The default value is 500.
You configure this parameter when the Inventory Control
Strategy is replenishment.
For details, see Using a Stock/Replenishment Planning
Strategy.

Policy
Minimum Reorder
Quantity

When using a stock/replenishment planning strategy in pull
mode, the minimum number of delivery products for which
the role can create build orders. The default value is 100.
You configure this parameter when the Inventory Control
Strategy is replenishment.
For details, see Using a Stock/Replenishment Planning
Strategy.
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Sourcing Tab
In general, the Sourcing tab contains the Purchase Cost metric, which is computed
for source products, based on the Net Selling Price of the upstream supplier’s
delivery product.
However, because a Base Manufacturer does not order source products directly,
you must configure the cost of raw materials for a Base Manufacturer role in the
dialog for the role’s delivery product. You do this by configuring the Purchase
Cost parameter, located on the Sourcing tab.
The following figure shows the Sourcing tab of the properties dialog for a
delivery product of a Base Manufacturer role:

Costs $100 for the raw
materials required to make
the delivery product. The
default value is 0.
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Group/
Parameter

Description

Policy
Purchase Cost

For a Base Manufacturer role only, the cost of raw materials
to make one delivery product. The default value is 0.
The model uses this cost to compute outgoing financial
metrics for the Base Manufacturer role.
Note: For all other roles, Purchase Cost is a metric, which the
model computes by averaging the Net Selling Price of the
delivery product from all its upstream suppliers.

Policy
Verification Yield

The yield when verifying delivery products that are
returned.

Manufacturing Tab
The following figure shows the Manufacturing tab of the default properties
dialog for the delivery product of a Base Manufacturer role:

Uses the default parameters for
build time, batch size, and build
yield when creating build orders
for delivery products.
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Group/
Parameter

Policy
Build Time Dependent
on Order Size

Policy
Minimum Batch Size
Maximum Batch Size

Policy
Build Yield

Description

Whether the Manufacturing Duration parameter of the Make
category depends on the actual size of a batch. If Build Time
Dependent on Order Size is false, the default, the time it
takes to manufacture a batch of products is the entire
Manufacturing Duration, regardless of whether the batch is
the maximum size. If Build Time Dependent on Order Size is
true and the size of the build order is for less than the
Maximum Batch Size, the actual time it takes to manufacture
the batch is adjusted proportionally.
The minimum and maximum number of delivery products to
manufacture in each batch. The role can only manufacture
finished products if the build order size is greater than or
equal to the Minimum Batch Size, and less than or equal to
the Maximum Batch Size. The value of the Manufacturing
Duration parameter of the Make category can be
proportional to the batch size, based on the Build Time
Dependent on Order Size option. The default values are 0
and 1000, respectively.
A percentage of the batch size, which determines the number
of delivery products the role can actually use to fulfill build
orders. The rest is discarded. The default value is 1.0.
By default, if you configure this number to be less than 1.0,
the Make category creates additional build orders for
delivery products to make up for the loss, based on the
Compensate for Yield parameter of the M3: Make Category.
For details, see Configuring the Plan Category.
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Return Tab
The following figure shows the Return tab of the default properties dialog for a
delivery product of a Base Manufacturer role:

Delivers returned products
based on a 90% yield for
defective products, MRO
products, and excess inventory.

Group/
Parameter

Description

Policy

The yield for defective product returns.

Defective Return
Authorization Yield
Policy

The yield for excess inventory returns.

Excess Inventory
Return Authorization
Yield
Policy
MRO Return
Authorization Yield
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The yield for MRO product returns.
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Delivery Tab
The following figure shows the Delivery tab of the default properties dialog for
the delivery product of a Base Manufacturer role:

Uses the default published
lead time and selling price
for customer quotes.
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Group/
Parameter

Delivery
Published Delivery
Lead Time

Delivery
Net Selling Price

Description

The typical standard lead time that the role quotes to its
customers for a delivery product. The default value is 3 days.
You can use this parameter to choose suppliers when using
contracts. For details, see Modeling a Process with Multiple
Suppliers.
The net price suppliers charge customers for each delivery
product. The default value is 1.
The model uses this price to compute the Purchase Cost
metric of the downstream buyer’s source product. It also uses
it to compute financial metrics, including Financial Payments
Total and Financial Collections Total for the role.
You can use this parameter as the supplier selection criteria
for choosing suppliers when using contracts. For details, see
Modeling a Process with Multiple Suppliers.
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Multipliers Tab
The following figure shows the Multipliers tab of the default properties dialog for
the delivery product of a Base Manufacturer role:

Uses the same Make and
Deliver category durations
for all delivery products,
the default.
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The following figure shows the Multipliers tab of the default properties dialog for
the delivery product of a Manufacturer role:

Uses the same Make and Deliver
category durations for all delivery
products, the default.
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Group/
Parameter

Make Multipliers
Engineering Duration

Description

A number that the role multiplies by the Engineering
Duration of the Mb: Make Product and M3: Engineer-toOrder category to determine the actual time it takes to
engineer a single batch of engineer-to-order delivery
products. The default value is 1, which means it takes exactly
the Engineering Duration.
Note: This parameter is only relevant for the source products
of a Manufacturer role and the delivery products of a Base
Manufacturer role whose Order Type is ETO.
For details, see Configuring Multipliers for Timing
Parameters.

Make Multipliers
Order Release to
Manufacturing Duration

A number that the role multiplies by the Order Release to
Manufacturing Duration parameter of the Make category to
determine the actual time it takes from when the Make
category receives a build order for delivery products to
when it receives components. The default value is 1, which
means it takes exactly the Order Release to Manufacturing
Duration.
Note: This parameter is relevant for the source products of a
Manufacturer role and the delivery products of a Base
Manufacturer role.
For details, see Configuring Multipliers for Timing
Parameters.

Make Multipliers
Production Material
Duration

A number that the role multiplies by the Production Material
Duration parameter of the Make category to determine the
actual time it takes from when the role receives components
to when it starts to manufacture delivery products. The
default value is 1, which means it takes exactly the
Production Material Duration.
Note: This parameter is relevant for the source products of a
Manufacturer role and the delivery products of a Base
Manufacturer role.
For details, see Configuring Multipliers for Timing
Parameters.
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Group/
Parameter

Make Multiplier
Manufacturing Duration

Description

A number that the role multiplies by the Manufacturing
Duration parameter of the Make category to determine the
actual time it takes to make one batch of delivery products.
The default value is 1, which means it takes exactly the
Manufacturing Duration.
Note: This parameter is relevant for the delivery products of
a Base Manufacturer role and Manufacturer role.
For details, see Configuring Multipliers for Timing
Parameters.

Make Multiplier
Move to Delivery
Duration

A number that the role multiplies by the Move to Delivery
Duration parameter of the Make category to determine the
actual time it takes from when the Make category finishes
manufacturing a batch of delivery products to when the
finished build order is transferred to the delivery location.
The default value is 1, which means it takes exactly the Move
to Delivery Duration.
Note: This parameter is relevant for the delivery products of
a Base Manufacturer role and Manufacturer role.
For details, see Configuring Multipliers for Timing
Parameters.

Deliver Multiplier
Order Entry Duration

A number that the role multiplies by the Order Entry
Duration parameter of the Deliver category to determine the
actual time it takes to enter an order for a delivery product.
The default value is 1, which means it takes exactly the
Order Entry Duration.
For details, see Configuring Multipliers for Timing
Parameters.

Deliver Multiplier
Pick Duration

A number that the role multiplies by the Pick Duration
parameter of the Deliver category to determine the actual
time it takes to pick components from inventory for making
a delivery product. The default value is 1, which means it
takes exactly the Pick Duration.
For details, see Configuring Multipliers for Timing
Parameters.
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Group/
Parameter

Description

Deliver Multiplier
Packing Duration

A number that the role multiplies by the Packing Duration
parameter of the Deliver category to determine the actual
time it takes to pack containers for shipment with delivery
products. The default value is 1, which means it takes exactly
the Packing Duration.
For details, see Configuring Multipliers for Timing
Parameters.

Deliver Multiplier
Transportation Duration

A number that the role multiplies by the Transportation
Duration parameter of the Deliver category to determine the
actual time it takes to ship a container of delivery products.
The default value is 1, which means it takes exactly the
Transportation Duration.
For details, see Configuring Multipliers for Timing
Parameters.

Configuring Demand and Change Orders
through a Demand Report
By default, initial order demand for the overall supply chain is based on
parameters that you configure for the source products associated with each
Consumer category in the model.
You might have actual order-demand data for your supply chain, which you
would like to use in your model. To do this, you can configure orders through a
Demand Report.
When using a Demand Report, you can also configure change orders for existing
orders that have not yet been fulfilled. To configure change orders, you enable
change orders for a particular row in the report, then identify the demand order
to change, using a unique order tag.
When you run the simulation, the model creates demand orders and change
orders for the products you configured in the report, then stops. You configure
the simulation time at which to generate each demand order or change order,
which is offset from the start of the simulation. The duration can be a number,
which the model interprets using the time unit of the report, or it can be a
duration, which uses a format such as 4 weeks, 2 days, 1 hour, and 30 minutes.
The role uses the simulation time configured in the report instead of the Demand
Order Duration to determine when to generate orders. It uses the Demand Start
Time and Demand Stop Time from the dialog.
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You can configure values for the following parameters in a Demand Report:

• Simulation Time
• Consumer Label
• Product Name
• Demand Order Size
• Desired Turnaround
• Fulfillment Preference
• Order Tag
To configure demand and change orders through a report:
1

Create product specifications for each product whose orders you want to
configure through a report, then assign each product specifications as the
source product of a Consumer role in the model.
For example, if you are configuring demand orders through a report for
computers and monitors, create one product composite named Computer and
another named Monitor, then assign each as the source product of a
Consumer role. You must also assign them as the delivery product of the
appropriate upstream supplier roles.

2

Display the Reports palette of the e-SCOR toolbox and create a Demand
Report on the model detail.

3

Choose Show Report on the Demand Report.
For details, see one of the following, depending on whether you want to
create the report locally or in Excel:

• Creating Reports.
• Creating Reports in Excel.
4

To configure demand orders, configure the Simulation Time, Role Label,
Product Name, Order Size, Desired Turnaround, and Fulfillment Preference
for each demand order through the report.
Configure the Simulation Time according to the Time Unit of the report or as a
duration such as 1 week, 2 weeks, 3 weeks and 2 days, and so on. The value
you enter is converted to the Time Unit of the report.

Note The rows can be in any order in the report; they do not need to be sorted by
the Simulation Time.

Configure the Desired Turnaround according to the Time Unit of the report.
To use the default value for a parameter, leave the cell empty.
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5

To configure change orders, in addition to the parameters above, configure
these parameters:

• Enable Change Order = true.
• Order Size = The change in order size, either positive or negative.
• Order Tag = A matching unique ID for both the order and the
change order.

For example, to create a change order that adds 10 units to the original order,
configure Enable Change Order as true, configure the Order Size to be 10, and
configure the Order Tag for the change order and the original order to be a
unique ID, such as order-id-1. To create a change order that removes 10 units
from the order, configure the Order Size to be -10.
Note It is only necessary to configure the Order Tag for change orders and their
associated order.
6

Apply the data to the model.
For details, see one of the following, depending on whether you created the
report locally or in Excel:

• Applying Input Report Data to the Model.
• Applying Input Report Data to the Model from Excel.
7

On the Demand tab of the source product of the Consumer role, enable the
Use Demand Input Report option on the Demand tab.

8

Configure the Demand Input Report Name to be the Demand Report that
contains the order demand data to use.

Note You must reset the model to use the new report data before running the
simulation.
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This figure shows a simple model in which a Consumer role sources computers
and monitors, using a Demand Report:

The Demand
Report specifies
initial order
demand data.
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Here is the properties dialog for the Computer source product of the Consumer
role, which uses a Demand Report:

Specifies order demand,
using a report.

Here is a sample Demand Report, which creates orders for computers and
monitors. The report generates orders at each time unit in sequence; it generates
orders for 2 monitors 2 days into the simulation, for 1 computer 3 days into the
simulation, for 2 computers 4 days into the simulation, and 5 monitors 5 days into
the simulation. Finally, it generates a change order for the order whose Order Tag
is order-id-1, changing the order size by -1, the Desired Turnaround to 3 days, and
the Fulfillment Preference to whole. Computer orders have a Desired Turnaround
of 3 days, and monitors have a Desired Turnaround of 4 days. Computers have an
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Order Fulfillment Preference of complete, and monitors have an Order
Fulfillment Preference of partial.

When the simulation runs, it generates orders for 3 computers (1 + 2) and
6 monitors (2 + 5 - 1) at the specified simulation times. Note that the change order
takes effect only if the original order has not yet been fulfilled.
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Introduction
Once you have configured Level 1 roles and Level 2 SCOR, you can run the
simulation. To do this, you:

• Control the simulation by starting, pausing, continuing, and resetting the
Scenario.

• Configure the scenario, which includes configuring the simulation mode,

simulation start time and duration, animation, and behavior of indicators.

• Verify that the simulation is running correctly by viewing key metrics for
roles, categories, and product composites.

• View a list of problems that can occur when running a simulation.
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• View these objects while the simulation runs:
– Transient objects in pools, which the model creates and deletes while
it runs.

– Resource representations, which show resource utilization.

Controlling the Simulation
You control the simulation from the Simulation menu or toolbar. These menu
choices and toolbar buttons affect the scenario, which is the control center for
running the simulation. Every model must contain a scenario.
To control the simulation, you:

• Activate and deactivate the scenario.
• Start and stop the simulation.
The scenario shows the simulation mode, status, and current simulation time,
for example:

Activating and Deactivating the Scenario
Before you can run a simulation, you must activate the Scenario. Certain menu
choices, such as Show Scenario, are only available when the scenario is active.
The following figure shows an active and inactive scenario:
active

inactive
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Note Starting the simulation automatically activates the scenario; therefore, typically,
you do not need to activate the scenario explicitly.
To activate and deactivate a scenario:
 Display a model that contains a scenario, then choose Simulation > Activate or
click the equivalent toolbar button ( ) to toggle activation.

Starting and Stopping the Simulation
You control the status of the simulation by using menu choices in the Simulation
menu, by using keyboard shortcuts, or by clicking the equivalent toolbar button,
as follows:
Menu Choice/
Shortcut

Toolbar Button

Status

Description

Start All

running

Start the simulation
running.

Reset

resetting

Reset the simulation.

Pause

paused

Pause the simulation.

Continue

running

Continue running the
paused simulation.

By default, the simulation runs in Jump mode, which advances the simulation
clock continuously with each discrete event. For alternative ways to run the
simulation, see Configuring the Simulation Mode.
To start and stop the simulation:
1

Start the simulation by choosing Simulation > Start All or by clicking the
equivalent toolbar button.
Choosing Start All activates the scenario and resets the simulation before
starting.
Resetting the simulation can take a period of time, depending on the size of
the model and the speed of your computer. The status of the scenario is
resetting.
After resetting, e-SCOR verifies that you have configured all roles correctly.
Once role verification is complete, objects begin flowing through the model.
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These objects represent orders, product shipments, invoices, payments, and
other objects that the model creates and deletes when the simulation runs.
You can only see these objects as they flow through the model if animation is
enabled. The model also begins computing metrics. The status of the scenario
is running.
2

To pause the simulation, choose Simulation > Pause or click the equivalent
toolbar button.
Pausing the simulation stops the simulation clock, causes all objects to stop
flowing through the model, and stops computing metrics. The status of the
scenario is paused.

3

To resume running the simulation after pausing, choose Simulation >
Continue or click the equivalent toolbar button.
The simulation clock begins advancing again, objects begin flowing through
the model, and the status of the scenario is running.

4

To reset the simulation, choose Simulation > Reset or click the equivalent
toolbar button.

Resetting the simulation resets the simulation clock, deletes all objects that the
model created, and resets all metrics to their initial values.

Verifying that the Simulation is Running
Correctly
e-SCOR provides a number of metrics that you can use to verify that the
simulation is running correctly. These metrics indicate that the model is creating
orders, delivering product shipments, generating invoices, and making
payments.
If these metrics do not have values, you have not configured the Level 1 roles,
Level 2 categories, or product composites correctly.
Note The model computes total financial collections and payments with each new
event; therefore, these metrics are always current. The model computes financial
collections and payments for the financial period at the end of each financial
period; therefore, these metrics refer to collections and payments for the previous
financial period.
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This table summarizes the objects that define the metrics, the metrics to view, and
the values:
Object

Metric

Values

Role

Number of End Products
Number of Financial Periods
Financial Payments within Financial Period
Financial Payments Total
Financial Collections within Financial Period
Financial Collections Total

Positive.

Plan
category

Number of Planning Periods

Positive.

ES category

Orders Sent
Product Shipments Received
Contracts Established

Positive and should
match the sum of the
Source category metrics
of the same name.

Source
category

Orders Sent
Product Shipments Received

Positive.

Make
category

Build Orders Started
Build Orders Completed

Positive.

ED category

Orders Received
Product Shipments Sent
Contracts Established

Positive and should
match the sum of the
Deliver category
metrics of the same
name.

Deliver
category

Orders Received
Product Shipments Sent

Positive.

Source
product

Quantity Ordered
Quantity Received

Positive.

Delivery
product

Quantity to Deliver
Quantity Shipped
Total Products Accepted

Positive.

See Also Viewing Metrics for Roles.

Viewing Metrics for Categories.
Viewing Metrics for Source and Delivery Products.
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Problems that Can Occur When Running a
Simulation
The most common mistakes you can make when configuring a model are:

• You forget to assign product specifications to roles.
• You forget to configure the potential suppliers of source products.
• You do not label each role with a unique name, when multiple roles of the
same type exist.

Other things to note when a simulation is running are:

• The simulation does not compute all metrics immediately. For example, it

does not compute financial metrics for roles until one or two financial cycles
have completed, due to the time lag in payments.

• The simulation should compute financial or asset metrics for a role after

several financial periods have completed, based on the Net Selling Price
parameter of the delivery products for the role, which is 1, by default. For a
Base Manufacturer role, outgoing financial metrics are based on the Purchase
Cost parameter for delivery products, located on the Sourcing tab.

• Occasionally, when you pause the simulation, certain metrics that should add
up do not add up. This situation only occurs between clock ticks; it does not
occur while the model is running.

See Also Creating and Connecting Roles.

Assigning Product Specifications to Roles.
Configuring the Products a Role Sources and Delivers.

Configuring the Scenario
You can configure these features of the scenario:

• Simulation mode, which determines whether the simulation runs
continuously, step-by-step, or in real time.

• Duration of the simulation.
• Version of the simulation.
• Start time of the simulation.
• Simulation speed.
• Animation.
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• Speed at which objects flow along paths.
• Indicator arrow behavior.
• Computational behavior of the scenario.
• Random number generation.

Configuring the Simulation Mode
You can run the simulation in one of three modes by using the menu choices in
the Simulation menu or the equivalent toolbar button, as this table describes:
Menu
Choice

Toolbar
Button

Mode

Description

Jump Mode

jump

The normal discrete event simulation mode. Events
occur in their normal time sequence while a
simulation is running, but the real-time clock
advances non-linearly relative to the simulation
clock. After each discrete event, e-SCOR
immediately advances the simulation clock to the
start time of the next event. Objects flow through
the model without stopping.

Step Mode

step

The mode you use for careful examination of the
model. e-SCOR pauses after each event so you can
walk through the simulation one step at a time.
When you continue running the simulation, the
clock immediately advances to the start time of the
next event, then stops.

Synch Mode

synch

The mode you use to help visualize the relative
times between events. e-SCOR scales the simulation
time to real time. For example, you can use this
mode to run the simulation at one hour per second
of real time. Most of the time when you are running
a simulations, however, you let the simulation clock
keep track of the time by using either jump or step
mode.

You configure the simulation mode from the Simulation menu or toolbar, or on
the properties dialog for the scenario.
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Running the Simulation in Jump Mode
To run the simulation in jump mode:
1

Choose Simulation > Jump Mode, click the equivalent toolbar button, or
display the properties dialog for the Scenario and configure the Mode to
be Jump.

2

Choose Simulation > Start All or click the equivalent toolbar button to start
the simulation

Running the Simulation in Step Mode
To run the simulation in step mode:
1

Choose Simulation > Step Mode, click the equivalent toolbar button, or
display the properties dialog for the Scenario and configure the Mode to
be Step.

2

Choose Simulation > Start All or click the equivalent toolbar button to take a
single step in the simulation, then pause the simulation.

3

Choose Simulation > Continue or click the equivalent toolbar button to take a
single step for each discrete event, then pause the simulation.

Running the Simulation in Synch Mode
When you run the model in synch mode, you must configure the proportion of
simulation time to real time. The larger the number, the faster the overall
execution time of the simulation. By default, the value is 1, which means the
timing parameters contribute exactly the specified amount of simulation time to
the simulation clock. A value of 2 means they contribute half the amount of time.
For example, if a timing parameter specifies 10 minutes to perform a task, and the
Seconds per Tick is 2, the parameter contributes 5 minutes of simulation time.
Note If your model is complex, e-SCOR may not be able to keep up with the specified
synch rate. For example, if you specify a synch rate such that one minute of
simulation time is equivalent to one year of real time, e-SCOR might require more
than one minute to process a year-long simulation. If this is the case, e-SCOR
gives no indication that the synch rate is too slow; however, the metrics that the
simulation computes are correct.
To run the simulation in synch mode:
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1

Display the properties for the scenario, click the Scenario tab, and configure
Seconds per Tick to be a number greater than one.

2

Choose Simulation > Synch Mode, click the equivalent toolbar button, or
display the properties dialog for the Scenario and configure the Mode to
be Synch.

Configuring the Scenario

3

Choose Simulation > Start All to run the simulation.

4

Choose Simulation > Pause to pause the simulation.

5

Choose Simulation > Continue to continue running the simulation in synch
mode.

Configuring the Duration of the Simulation
Depending on your model, you typically configure the scenario to run for a
specific duration, such as a month, a year, or ten years. You do this by specifying
the ending time of the simulation. A duration of 0 means the simulation will run
for the maximum allowable simulation time, which is 17 years.
Tip To ensure accurate financial reporting, configure the duration of the simulation to
be slightly longer than the end of the last financial period.
To configure the duration of the simulation:
 Display the properties dialog for the scenario, click the Scenario tab, and
configure the Duration to be the amount of time the simulation should run,
for example, 3 months or 2 years.

Configuring the Simulation Version
When performing “what-if” analysis, you often use different scenarios with the
same or with different versions of the model. When using the Scenario Manager
to run multiple simulations from a script, you typically output the data to a
report. To identify which scenario was used to generate the data, you configure
the version of the simulation, using a unique number.
To configure the simulation version:
 Display the properties dialog for the scenario, click the Scenario tab, and
configure the Simulation Version to be a unique number.

For example, you might use 1.0, 1.1, and 1.2 for the scenario associated with three
different versions of a model.
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Configuring the Start Time of the Simulation
By default, e-SCOR uses January 1, 2006 as the start time of the simulation. You
might want to start the simulation at a different time.
To configure the start time of the simulation:
 Display the properties dialog for the scenario, click the Start Time tab, and
configure the Year, Month, Day, Hour, Minute, and/or Second to be the start
time of the simulation.

When you reset the simulation, the new start time appears.

Configuring Simulation Speed
By default, the scenario is configured to run as fast as possible, which means that
when you are running in jump or synch mode, the clock advances with each new
event as fast as it can. This default configuration is desirable when:

• Running simulations from a script, using the Scenario Manager.
• You do not need to interact with the model while the simulation is running.
• You do not need to visualize the animation of objects as they flow through
the model.

Depending on the speed of your computer, running the simulation as fast as
possible often means that you will experience delays when interacting with the
user interface while the simulation is running. For example, when you click the
Pause button to pause the simulation, the simulation clock continues to advance
until the processing has caught up with the user interaction. Similarly, you will
experience delays when configuring values through the dialogs or reports while
the simulation is running.
If you want to interact with the user interface while the simulation is running, for
example, to configure parameter values, you should slow the simulation down to
allow more time for the user interface to respond.
To slow the simulation down, you configure the simulation speed to be a larger
number. Depending on the speed of your computer, you might try a simulation
speed of 10 or 15.
Note Once you have configured your model, we recommend that you set the
Simulation Speed to 0 for optimal performance, the default.
To configure the simulation speed:
 Display the properties dialog for the scenario, click the Options tab, and
adjust the Simulation Speed, where the larger the number, the slower the
speed.
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Configuring Animation
e-SCOR can animate running simulations by physically moving objects along
paths and highlighting blocks as they become active. If you are using your model
as a communication tool to visualize work objects as they flow along paths, you
might want to enable animation.
Depending on the speed of your computer, you might need to adjust the
animation speed. In particular, if you have a relatively fast computer, you might
need to slow down the animation speed to better visualize the flow of work
objects. However, keep in mind that performance degrades the slower the
animation speed.
You configure animation speed, based on the number of milliseconds it takes to
move an object from the beginning of a path to the end of a path. By default, it
takes an object 5 milliseconds to move along a path. To slow down the animation,
you might want to move an object along the path in 8 or 10 milliseconds.
Note Once you have configured your model, we recommend that you disable
animation for optimal performance.
To enable animation for a simulation:
 Display the properties dialog for the scenario, click the Options tab, and click
the Enable Animation option on.

When you run the simulation, objects move along paths and blocks animate as the
simulation clock advances.
To adjust animation speed:
 Display the properties dialog for the scenario, click the Options tab, and
adjust the Animation Speed, where the larger the number, the slower the
speed.

Configuring Object Tracking
You can configure the scenario so that objects that flow through the model keep
track of the blocks through which they have passed since they were created.
When object tracking is enabled, you can pause the simulation and show tracking
for any object. Object tracking is a useful way of verifying the model to ensure
objects flow along the correct paths.
When showing object tracking, e-SCOR animates all the blocks upstream of the
current block, in order, starting at the current block and ending at the block that
created the object. e-SCOR repeats this process four times, by default. You can
configure the color used for animating blocks when showing object tracking.
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To configure object tracking:
1

Display the properties dialog for the scenario, click the Options tab, and click
the Enable Tracking option on.

2

Configure the Animation Repeat Counter to be the number of times to
animate the blocks when showing object tracking.

3

Configure the Animation Color to be the highlight color to use.

To show object tracking for an object:
 Pause the simulation, then choose Show Flow History on a object in the
model.

Configuring the Behavior of Indicator Arrows
e-SCOR places indicator arrows next to objects when you show various objects
associated with other objects, such as when you show the scenario associated with
a role.
By default, the indicator arrow remains on the workspace until you explicitly hide
it. You can clear all indicators automatically, or you can configure the scenario to
clear indicators automatically after a certain number of seconds.
Note To clear all indicators, the scenario must be active, as described in Activating and
Deactivating the Scenario.
To clear an individual indicator arrow:
 Left click the indicator arrow.
To clear all indicator arrows:
 Activate the scenario, then choose Simulation > Clear Indicators or click the
equivalent toolbar button:
To clear indicators associated with a scenario after a timeout period:
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1

Display the properties dialog for the scenario, click the Options tab, and
configure the Indicate Mode by choosing Timeout.

2

Configure the Timeout period after which indicators should automatically
disappear, in seconds.

Configuring the Scenario

Configuring the Computation Behavior
To maximize performance, the scenario is configured to perform the minimum
amount of computation necessary at Level 3, Level 4, and Level 5. If you are
customizing the implementation of Level 2 categories, you can configure these
parameters for a scenario related to computation behavior:
You can configure these parameters related to computation behavior:
Parameter

Description

Compute All Blocks

Enables the computation of Task blocks with detail.
The default value is off, which means e-SCOR
computes values for Task block details only; it does
not compute values for the block itself.

Update Charts

Enables the updating of charts. The default value is
off, which means that you must update charts
manually or by using a button or a rule. For details,
see “Updating Charts” in the ReThink User? Guide.

Enable Metrics
Toolbar Update

Disables the updating of the Metrics toolbars. The
default value is on, which means that the Metrics
toolbars update once every half second.

Note The scenario computes metrics for all e-SCOR Level 1 roles and Level 2 categories
and product composites in the model, regardless of how the Scenario is
configured.

Note Once you have configured your model, we recommend that you disable updating
of the Metrics toolbar for optimal performance.
To compute metrics for Task blocks with detail:
 Display the properties dialog for the scenario, click the Options tab, and
enable the Compute All Blocks option.
To update charts automatically:
 Display the properties dialog for the scenario, click the Options tab, and
enable the Update Charts option.
To disable metrics toolbar updating:
 Display the properties dialog for the scenario, click the Options tab, and
disable the Enable Metrics Toolbar Update option.
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Configuring the Scenario to Generate Identical
Random Numbers
By default, the scenario generates random numbers that vary with each
simulation by generating a new seed number for each simulation. You might
want to run a simulation with identical random numbers to test different model
configurations, using the same set of random numbers.
e-SCOR generates random numbers to compute mathematical distributions such
as Random Normal, Random Exponential, or Random Triangular. You use these
random distributions to generate values for attributes such as Demand Order
Size, Demand Order Duration, Receiving Duration, Manufacturing Duration, and
Order Entry Duration.
To configure the scenario to generate identical random numbers:
1

Display the properties dialog for the Scenario and, on the Scenario tab,
configure the Seed Value to be an integer that holds the seed value, which eSCOR uses as the basis for randomly generated numbers.
By default, it generates a random number as the Seed Value.

2

Disable the Generate New Seed option to use the specified Seed Value for
each simulation.

3

Reset the Scenario to use these new values.

Each time you run the simulation, using this scenario, e-SCOR uses the same set
of randomly generated numbers.

Showing Transient Objects
The model creates and deletes a number of objects as the simulation runs. It sends
these transient objects along the paths between categories and between roles. It
also stores some of these objects in pools on the detail of the role. You can view
these objects and their properties while the simulation is running by enabling
animation.
Note Enabling animation causes the simulation to run much more slowly; therefore, we
recommend that, in general, you run the simulation with animation off.
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To facilitate viewing transient objects, you can run the simulation in step mode or
you can set breakpoints in the model at appropriate locations.
Note Objects flow on paths on the detail of each category, as well as on the paths
between categories and between roles. Therefore, depending on what you are
viewing, you might or might not see any objects flowing through the model when
you step through the simulation.
To show transient objects:
1

Show the details of the Consumer and Base Manufacturer roles so that both
details are visible.

2

Enable animation for the Scenario.
For details, see Configuring Animation.

3

Start the simulation running in step mode.
For details, see Configuring the Simulation Mode.
The Input block of the downstream buyer role highlights, which indicates the
beginning of the simulation.

4

Click the Continue button (
) once until you see the ES category of the
downstream buyer role highlight.

5

Continue stepping through the simulation until you see the P3, D1, and D2
categories of the upstream buyer role highlight, then return to their default
state.

6

Continue stepping through the simulation until you see the ES category of the
buyer role highlight again.

7

Drill down in the ES category to show the detail of each lower-level block that
is highlighted.

8

Click Continue once until you see a purchase request on the subdetail of the
Enable Source category:
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The ES category generates a purchase request for its source products.
9

Continue stepping through the simulation and drilling down in the details to
see the purchase request move from the ES category of the buyer to the ED
category of the supplier.

10 Continue stepping through the simulation and drilling down until you see a
purchase response on a subdetail of the ED category of the supplier role:

If the upstream supplier role can deliver the requested product, the ED
category of the supplier role generates a purchase response for its delivery
products.
11 Show the detail of the Responses pool on the buyer role detail.
12 Continue stepping through the simulation to see the purchase response move
from the ED category of the supplier to the ES category of the buyer, then into
the Responses pool:

13 Show the properties dialog of the response and inspect the metrics that it
computes, which is based on the parameters configured for the source
product of the buyer role.
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14 Show the detail of the Purchase Awards pool of the buyer role and continue
stepping through the simulation until you see a purchase award in the pool:

The ES category of the buyer role generates a purchase award and sends it to
the supplier that sent the purchase response.
15 Continue stepping through the simulation until you see a customer order on
the detail of the Consumer role:

16 Show the detail of the Supplier Awards pool of the supplier role and continue
stepping through the simulation until you see a purchase award in the pool.
17 Display the properties dialog of the ES category of the buyer role and the ED
category of the supplier role.

Notice that the Contracts Established metric is now 1, indicating that a
contract has been established between the buyer and supplier.
18 Choose Simulation > Jump Mode or click the equivalent toolbar button (

).
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19 Click the Continue button and observe the other types of objects that flow
through the model for each of the other processes.

These include orders, invoices, payments, and product shipments.
20 Pause the simulation and continue in step mode to observe these objects more
closely, if desired.
21 Reset the simulation and set it to run in jump mode.
22 Disable animation in the Scenario object.

Transient Objects in Pools
Each role has a number of pools in which various types of objects are stored as the
simulation runs. This table describes the contents of each pool and the relevant
roles:
This pool...

Exists for these roles...

And holds instances of...

Buyer Awards

Distributor
Manufacturer
Consumer

Purchase awards that each ES: Enable Source
category creates when it establishes contracts
with available suppliers.

Build Orders

Manufacturer

Build orders that each Make category uses to
determine the number of batches to
manufacture.

Responses

Distributor
Manufacturer
Consumer

Purchase responses that each ED: Enable
Deliver category creates when responding to
purchase requests from buyers at startup and
when contracts are in effect.

Staging Area

Base Manufacturer
Distributor
Manufacturer

Delivery products that each Deliver category
pulls from inventory before delivering
product shipments.

256

Showing Transient Objects

This pool...

Exists for these roles...

And holds instances of...

Orders

Base Manufacturer
Distributor
Manufacturer

Customer orders for delivery products that
each Deliver category receives from buyers.

Source Orders

Consumer

Customer orders for the finished products in
the supply chain.

Supplier
Awards

Base Manufacturer
Distributor
Manufacturer

Purchase awards that each ED: Enable Deliver
category creates when it establishes contracts
with buyers. These are identical to the
purchase awards stored in the Buyer Awards
pool of the downstream buyer.

Transient Objects that Flow through the Model
In addition to the objects described in Transient Objects in Pools, a number of
other objects also flow through the model when the simulation runs; however, the
model does not save these objects in pools. This table describes the additional
objects that flow through the model:
Object

Description

Order

Buyers send customer and replenishment orders to
suppliers for products ordered.

Invoice
Payment

Suppliers send invoices to buyers for products
ordered. Buyers send payments to suppliers for
product shipments received.

Product Ordered
Product Container

Buyers send products ordered to suppliers. Suppliers
send product containers to buyers, when they are
available.
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Object

Description

Product Chit
Order Chit

Manufacturer roles generate product chits as part of
the Build process when finished products have been
manufactured and are available for delivery. Buyer
roles generate order chits as part of the source
planning process when source products arrive from
suppliers and are available for manufacture or
delivery, depending on the role.

Showing Resource Representations for a Role
Each Base Manufacturer and Manufacturer role has a pool that contains
representations of the manufacturing resources assigned to the role.
To show resource representations for a role:
 Choose Show Resources on a Base Manufacturer and Manufacturer role.

or
 Show the detail of the Mfg Resources pool:

The detail contains a representation for each manufacturing resource associated
with the role. For example, here is the detail of the Mfg Resources pool for the
Base Manufacturer role, which contains a single resource representation:
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Describes the metrics the model computes for roles, categories, product composites,
resources, and routers.
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Viewing Metrics for Source and Delivery Products 307
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Introduction
While running the simulation, you can analyze the performance of your supply
chain by viewing metrics for these objects:

• Roles
• Categories
• Source and delivery products
• Resources
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You can view metrics through:

• Properties dialogs
• Metrics toolbars
• Reports
The properties dialogs update automatically at regular intervals. By default, the
Metrics toolbars also update automatically. When viewing metrics through
dialogs, you can also update metrics manually. You configure reports to update at
regular time intervals.
Metrics that are calculated based on histories allow you to view the statistics and
histories and to configure SCOR performance metrics for comparative analysis.
This chapter describes how to view metrics through properties dialogs.
You can also view various types of metrics in toolbars.
See Also Viewing Simulation Metrics in a Toolbar.

Generating Output Report Data from the Model.

Updating Metrics
When you open a dialog, e-SCOR updates the metrics so they are current. e-SCOR
continues to update metrics as the simulation runs once every few seconds. Once
the dialog is open, you can also manually update the metrics.
Note The model computes total financial collections and payments with each new
event; therefore, these metrics are always current. The model computes financial
collections and payments for the financial period at the end of each financial
period; therefore, these metrics refer to collections and payments for the previous
financial period.
To manually update metrics in dialogs:
 Click the Update button in the dialog or choose Update on the block.
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Viewing Statistics and Histories for Metrics
Metrics that are based on historical values calculate various statistics, including
minimum and maximum values, average value, moving average, and timeweighted value. These metrics also allow you to view the histories. You can also
configure various SCOR metrics, such as descriptions, performance attributes,
metrics class, and target values, which you can use for comparative analysis.
The metrics that calculate statistics include financial, asset, and cost metrics for
roles, performance metrics for categories such as Supplier On-Time Performance,
and inventory and fulfillment time metrics for product composites.
To view statistics and histories for metrics:
1

In the properties dialog for a role, category, or product composite, click the
button next to the metric:
For example, here is the Assets tab of the role properties dialog for a Base
Manufacturer role:

Click this
button to
show
statistics for
the metric.
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Here is the result of clicking the button next to the Asset Turns metric:
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2

To configure metrics related to the calculated statistics, click the
Configuration tab:

For information about these SCOR parameters, see the SCOR specification.
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3

To keep a history, click the History tab and click the Keep History option.
Here is the result of keeping a history for the Asset Turns metric, which
creates an entry once per financial period:
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Viewing Metrics for Roles
Each role in the model computes financial, asset, and cost metrics while the
simulation runs. These metrics update once per financial period.
This figure shows the Role tab of a sample properties dialog for a Base
Manufacturer role:

Maximum capacity
of manufacturing
resource used by
the role.

The number of
delivery products
associated with
the role.
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This figure shows the Financial tab of a sample properties dialog for a Base
Manufacturer role.
Note The Incoming financial metrics are not relevant for a Consumer role.

The money the
supplier receives from
buyers for shipments
it has delivered, which
is based on the
Net Selling Price of
the role’s delivery
products.

The money the
supplier pays to its
suppliers for source
products, which is
based on the
Purchase Cost metric
of the role’s source
products. For a Base
Manufacturer, it is
based on the
Purchase Cost
parameter of the role’s
delivery products.
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This figure shows the Assets tab of a sample properties dialog for a Base
Manufacturer role.
Note The Asset metrics are not relevant for a Consumer role.

Inventory days of
supply for source
products, work in
progress, delivery
products, and total
inventory.

Standard asset
calculations.
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This figure shows the Cost tab of a sample properties dialog for a Base
Manufacturer role:

The total cost of doing
business for this role.

Group/Parameter

Tab

Description

General

Role

The label that appears on the role icon.

Role

The maximum number of resources that the role
allocates during the simulation, based on the
Resource Capacity of the resource.

Process Number
Resources
Maximum Capacity
Used
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Note: This metric is only relevant for Base
Manufacturer and Manufacturer roles.
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Group/Parameter

Tab

Description

Metrics

Role

The number of delivery products assigned to
the role.

Number of End
Products

General

Note: This metric is not relevant for Consumer
roles, because a Consumer role does not have
any delivery products.
Financial

The number of financial periods that have
passed since the start of the simulation.

Financial

Supplier bookings for orders that buyers have
placed with this supplier role but that the
supplier has not yet invoiced. This metric
includes bookings since the start of the
simulation.

Number of Financial
Periods
Incoming
Financial Bookings

Note: This metric is not relevant for a Consumer
role.
Incoming

Financial

Financial Outstanding

The amount of money outstanding for orders
that buyers have placed with this supplier role
but for which the supplier has not yet been paid.
This metric includes outstanding money for
orders since the start of the simulation.
Note: This metric is not relevant for a Consumer
role.

Incoming

Financial

Financial Collections
within Financial
Period
Incoming

Note: This metric is not relevant for a Consumer
role.
Financial

Financial Collections
Total

Outgoing
Financial Obligations

The total amount of money that this supplier
role has received from buyers during the
previous collection period.

The total amount of money that this supplier
role has received from buyers since the start of
the simulation.
Note: This metric is not relevant for a Consumer
role.

Financial

Buyer obligations for orders that this buyer role
has placed with suppliers but has not yet paid.
This metric includes obligations since the start
of the simulation.
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Group/Parameter

Tab

Description

Outgoing

Financial

The total amount of money that this buyer role
has sent to its suppliers for product shipments
received during the previous collection period.

Financial

The total amount of money that this buyer role
has sent to its suppliers for product shipments
received since the start of the simulation.

Assets

The cost-weighted value of source product
inventory at the end of the previous financial
period, given current inventory and the
consumption of source products during the
financial period.

Financial Payments
within Financial
Period
Outgoing
Financial Payments
Total
Days of Supply
Raw Materials

Note: This metric is not relevant for a Consumer
role.
Days of Supply

Assets

Work in Progress

The cost-weighted value of work in progress at
the end of the previous financial period, given
current work in progress and the consumption
of source products during the financial period.
Note: This metric is not relevant for a Consumer
role.

Days of Supply

Assets

Finished Goods

The cost-weighted value of delivery product
inventory at the end of the previous financial
period, given current inventory and the amount
of delivery product picked for delivery during
the financial period.
Note: This metric is not relevant for a Consumer
role.

Days of Supply

Assets

Inventory

Metrics
Asset Turns

The sum of Raw Materials, Work in Progress,
and Finished Goods days of supply.
Note: This metric is not relevant for a Consumer
role.

Assets

The number of days the role takes to turn over
its inventory for delivery products, measured as
a cost-weighted value in days.
Note: This metric is not relevant for a Consumer
role.
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Group/Parameter

Tab

Description

Metrics

Assets

The time it takes for money to flow from buyers
to suppliers. A positive value indicates the role
spends more money than it takes in. A negative
value indicates the role takes in more money
than it spends. This metric is weighted, based on
the Financial Payment Terms of each buyer role
and is measured in days.

Cash-to-Cash
Cycle Time

Note: This metric is not relevant for a Consumer
role.
Metrics

Assets

Days Sales
Outstanding

The value of delivery product sales, which
includes Financial Collections within Financial
Period, Financial Bookings, and Financial
Outstanding metrics for the previous financial
period, measured in days.
Note: This metric is not relevant for a Consumer
role.

Metrics

Assets

Cash Flow Period

The amount of money available during the
previous financial period, which is equal to the
Financial Collections within Financial Period
minus the Financial Payments within Financial
Period, which could be positive or negative.
Note: This metric is not relevant for a Consumer
role.

General
Order Management
Costs

Cost

The total cost of doing business since the start of
the simulation, which includes these Cost
Incurred metrics for these categories:

• Source category:
Create Customer Order Metric

• Deliver category:
Order Entry Metric
Order Fulfillment Metric
Pick Metric
Packing Metric
Transportation Metric
Customer Invoicing Metric
Customer Collections Metric
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See Also Appendix A, Asset Metrics Formulas.

Viewing Metrics for Categories
Each category computes a number of metrics, which you can view as the
simulation runs. This section describes the metrics for each category for the
simplest e-SCOR model, which consists of a Base Manufacturer role and a
Consumer role. Each section provides sample dialogs for the categories that
appear in the simplest model. If the dialogs for other categories are significantly
different, sample dialogs for these categories appear, as well.
The descriptions of each category metric apply to all categories, unless otherwise
indicated in the description. For example, the ECO cost metric is only relevant for
the Mb and M3 categories when the Order Type is eto.
The following sections show sample dialogs and describe metrics that appear for
the following categories:

• Plan categories
• ES: Enable Source category
• Source categories
• Make categories
• ED: Enable Deliver category
• Deliver categories
• Source Returns categories
• Deliver Returns categories
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Viewing Metrics for the Plan Categories
The properties dialogs for the P2: Plan Source and P3: Plan Make categories are
identical except that the P3 category has the Compensate for Yield parameter.
The following figure shows a sample properties dialog for the P3: Plan Make
category of a Base Manufacturer role:

The number of
planning periods
that have
completed since
the start of the
simulation.
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Group/Parameter

Tab

Description

General

Planning

The label of the associated role.

Role Label
General

See Configuring General Parameters for Roles.
Planning

The SCOR process number.

Planning

The number of planning periods that have passed
since the start of the simulation, which the model
computes, based on the Planning Period
parameter.

Process Number
Planning
Number of
Planning Periods

See Configuring the Plan Category.
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Viewing Metrics for the ES: Enable Source Category
The following figure shows the Source tab of a sample properties dialog for the
ES: Enable Source category of a Consumer role:

The number of orders and
change order for source
products the ES category has
sent, the number of product
shipments it has received,
and the number of contracts it
has established since the
start of the simulation.
The percentage of orders that
the ES category has received
on or before the customer
request date.

Note The metrics on the Enable Source tab include orders for all source products
associated with the role.

Group/Parameter

Tab

Description

General

Enable
Source

The label of the associated role.

Enable
Source

The SCOR process number.

Role Label
General
Process Number

See Configuring General Parameters for Roles.
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Group/Parameter

Tab

Description

Metrics

Enable
Source

The total number of customer orders that the ES
category has sent to suppliers since the start of the
simulation.

Enable
Source

The total number of change orders that the ES
category has sent to suppliers since the start of the
simulation.

Enable
Source

The total number of product shipments that the
ES category has received from suppliers since the
start of the simulation.

Enable
Source

The total number of contracts for source products
that the ES category has established with
suppliers since the start of the simulation. When
contracts have been established, one contract is
established for every potential supplier role.

Enable
Source

The percentage of product shipments that the ES
category has received on or before the customer
request date. The ES category computes this date
from the Desired Turnaround parameter of all
source products associated with the role.

Orders Sent
Metrics
Change Orders Sent
Metrics
Product Shipments
Received
Metrics
Contracts Established

Metrics
Supplier On-Time
Performance
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Viewing Metrics for the Source Categories
The properties dialogs for the Source categories are the same.
The Receive, Verification, and Transfer tabs have no metrics.
The following figure shows the Source tab of a sample properties dialog for the
S1: Source Stocked Product category of a Consumer role:

The number of
orders and change
orders the Source
category has sent,
and the number of
product shipments
it has received
since the start of
the simulation.
The average
number of days
by which product
shipments are
early or late.
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The following figure shows the Financial tab of a sample properties dialog for the
S1: Source Stocked Products category of a Consumer role:

The money the Source
category has paid or
will pay to suppliers
for products received
since the start of the
simulation.
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The following figure shows the Cost tab of a sample properties dialog for the
S1: Source Stocked Product category of a Consumer role:

The costs the
Source category
has incurred since
the start of the
simulation.

Group/Parameter

Tab

Description

General

Source

The label of the associated role.

Role Label
General

See Configuring General Parameters for Roles.
Source

The SCOR process number.

Process Number
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Group/Parameter

Tab

Description

Metrics

Source

The total number of customer orders that the
Source category has sent to suppliers since the
start of the simulation.

Orders Sent

For details, see Configuring the Source Category.
Metrics

Source

The total number of change orders that the Source
category has sent to suppliers since the start of the
simulation.

Source

The total number of product shipments the
Source category has received from suppliers since
the start of the simulation.

Source

The average change in time from the Desired
Turnaround parameter of source products to the
actual time at which the Source category receives
product shipments. A positive number indicates
product shipments are early, and a negative
number indicates product shipments are late.

Change Orders Sent
Metrics
Product Shipments
Received
Metrics
Product Shipment
Lead Time

For a description of the Desired Turnaround
parameter, see Supplier Tab for a source product.
Outgoing

Financial

Buyer obligations for customer orders that the
Source category has placed with suppliers but has
not yet received since the start of the simulation.

Financial

The total amount of money that the Source
category has sent to suppliers for product
shipments received during the previous collection
period.

Financial

The total amount of money that the Source
category has sent to suppliers for product
shipments received since the start of the
simulation.

Cost

The total cost that the Source category has
incurred for receiving source products since the
start of the simulation.

Cost

The total cost that the Source category has
incurred for verifying product shipments since
the start of the simulation.

Financial Obligations
Outgoing
Financial Payments
within Financial
Period
Outgoing
Financial Payments
Total
Costs Incurred
Receiving Metric
Costs Incurred
Verification Metric
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Group/Parameter

Tab

Description

Costs Incurred

Cost

The total cost that the Source category has
incurred for transferring product shipments to
inventory since the start of the simulation.

Cost

The total cost that the Source category has
incurred for creating customer orders since the
start of the simulation.

Cost

The total cost that the Source category has
incurred for paying invoices for product
shipments received since the start of the
simulation.

Transfer Metric
Costs Incurred
Create Customer
Order Metric
Costs Incurred
Invoice Metric

Viewing Metrics for the Make Categories
The properties dialogs for the Make categories have these differences for metrics,
by tab:

• Manufacturer tab: The Mb and M3 categories include the Order Entry to
Manufacturing Timemetric.

• Cost tab: The Mb and M3 categories include the ECO Metric.
The Build Orders, Build Selection, Production Material, Manufacturing, Transfer,
and Engineering tabs have no metrics.
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The following figure shows the Manufacturer tab of a sample properties dialog
for the Mb: Make Product category of a Base Manufacturer role:

The number of build orders
the Make category has
started and completed
manufacturing since the
start of the simulation.
The average cycle time
from when the Make
category starts
manufacturing build
orders to when build
orders are complete.
The average time from
when the buyer places an
order to when the Make
category starts to
manufacture the build
order.
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The following figure shows the Cost tab of a sample properties dialog for the
Mb: Make Base Manufacturer category. The Cost tab for the M3: Engineer-toOrder is the same.

The costs incurred
for engineering
change orders
(ECO) for engineerto-order products
and for handling
raw materials.
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The following figure shows the Cost tab of a sample properties dialog for the
M1: Make-to-Stock category of a Manufacturer role:

The costs incurred for
handling the raw
materials.

Group/Parameter

Tab

Description

General

Manufacturer

The label of the associated role.

Role Label
General
Process Number
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See Configuring General Parameters for
Roles.
Manufacturer

The SCOR process number.
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Group/Parameter

Tab

Description

Metrics

Manufacturer

The total number of build orders the Make
category has started to manufacture since the
start of the simulation. The Make category
starts manufacturing a build order when it
receives a scheduled build order from the
P3: Plan Make category and it has
components.

Manufacturer

The total number of build orders the Make
category has completed manufacturing since
the start of the simulation. A build order is
complete when the Make category finishes its
manufacturing step but before it releases the
product.

Manufacturer

The average cycle time from when the Make
category starts to manufacture a build order
to when it releases finished products for
delivery.

Manufacturer

(Mb, M3) The total amount of time from when
the downstream Deliver category creates a
replenishment order to when the Make
category starts manufacturing the build order.
This metric is only relevant for ETO products.

Cost

(Mb, M3) The total cost that the Make
category has incurred for engineering change
orders since the start of the simulation.

Build Orders Started

Metrics
Build Orders
Completed

Metrics
Make Cycle Time

Metrics
Order Entry to
Manufacturing Time

Costs Incurred
ECO Metric

Note: This metric applies to ETO delivery
products only.
Costs Incurred
Production Material
Handling Metric

Cost

The total cost associated with handling the
components used to manufacture finished
products since the start of the simulation.
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Viewing Metrics for the ED: Enable Deliver Category
The following figure shows a sample properties dialog for the ED: Enable Deliver
category of a Base Manufacturer role:

The number of orders and
changed orders for delivery
products the ED category has
received from buyers, the
number of product shipments it
has sent, and the number of
contracts established since the
start of the simulation.

Performance metrics relating
to the supplier’s delivery
phase for all delivery products
associated with the role.

Note The metrics on the Enable Deliver tab include orders for all delivery products
associated with the role.

Group/Parameter

Tab

Description

General

Enable
Deliver

The label of the associated role.

Enable
Deliver

The SCOR process number.

Role Label
General
Process Number
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See Configuring General Parameters for Roles.
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Group/Parameter

Tab

Description

Metrics

Enable
Deliver

The total number of customer orders that the
ED category has received from buyers since
the start of the simulation.

Enable
Deliver

The total number of change orders that the ED
category has received from buyers since the
start of the simulation.

Enable
Deliver

The total number of product shipments that
the ED category has sent to buyers since the
start of the simulation.

Enable
Deliver

The total number of contracts for delivery
products that the ED category has established
with buyers since the start of the simulation.
When contracts have been established, one
contract is established for every downstream
buyer role.

Enable
Deliver

The percentage of product shipments that the
ED category has delivered on or before the
customer request date. The ED category
computes this date from the Desired
Turnaround parameter of the source product
of the downstream buyer role.

Enable
Deliver

The percentage of product shipments that the
ED category has delivered on or before the
customer request date and that are for the
requested quantities. The ED category
computes this date from the Desired
Turnaround parameter of the source product
of the downstream buyer role.

Orders Received
Metrics
Change Orders Received
Metrics
Product Shipments
Sent
Metrics
Contracts Established

Metrics
Delivery
Performance (%)

Metrics
Perfect Order
Fulfillment (%)
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Viewing Metrics for the Deliver Categories
The properties dialogs for the Deliver categories are the same except that the
D2 and D3 categories do not have the Fill Rates metric.
The Order, Order Selection, Fulfillment, and Transportation tabs have no metrics.
The following figure shows the Delivery tab of a sample properties dialog for the
D1: Deliver Stocked Product category of a Base Manufacturer role:

The number of orders
and change orders
the Deliver category
has received, and the
number of product
shipments it has sent
since the start of the
simulation.

Performance metrics
related to the
supplier’s delivery
phase for this
Deliver category.
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The following figure shows the Financial tab of a sample properties dialog for the
D1: Deliver Stocked Product category of a Base Manufacturer role:

The money that the
Deliver category has
received or will receive
from buyers for
products shipped.

289

The following figure shows the Cost tab of a sample properties dialog for the
D1: Deliver Stocked Product category of a Base Manufacturer role:

The costs that the
Deliver category has
incurred since the
start of the simulation.

Group/Parameter

Tab

Description

General

Delivery

The label of the associated role.

Role Label
General
Process Number
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See Configuring General Parameters for Roles.
Delivery

The SCOR process number.
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Group/Parameter

Tab

Description

Metrics

Delivery

The total number of valid customer orders the
Deliver category has received from buyers since
the start of the simulation.

Delivery

The total number of change orders the Deliver
category has received from buyers since the start
of the simulation.

Delivery

The total number of product shipments the
Deliver category has delivered to buyers since the
start of the simulation.

Delivery

(D1) The percentage of product shipments the
Deliver category has delivered within 24 hours of
receiving an order.

Delivery

The sum of the Pick Material Time and Pack
Material Time parameters of the Deliver category.

Orders Received
Metrics
Change Orders
Received
Metrics
Product Shipments
Sent
Metrics
Fill Rates (%)
Metrics
Ready to Ship Time
Metrics

For details, see Configuring the Deliver Category.
Delivery

The average time from when the Deliver category
enters a customer order to when the product
shipment is ready to deliver.

Financial

Supplier bookings for customer orders that buyers
have placed with the Deliver category but that the
Deliver category has not yet invoiced.

Financial

The amount of money outstanding for customer
orders that buyers have placed with the Deliver
category but for which the Deliver category has
not yet been paid.

Financial

The total amount of money for product shipments
the Deliver category has received from buyers
during the previous collection period.

Financial

The total amount of money for product shipments
the Deliver category has received from buyers
since the start of the simulation.

Order Entry to
Ship Time
Incoming
Financial Bookings
Incoming
Financial Outstanding

Incoming
Financial Collections
within Financial
Period
Incoming
Financial Collections
Total
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Group/Parameter

Tab

Description

Costs Incurred

Cost

The total cost that the Deliver category has
incurred for entering customer orders since the
start of the simulation.

Cost

The total cost that the Deliver category has
incurred for filling customer orders since the start
of the simulation.

Cost

The total cost that the Deliver category has
incurred for taking products out of inventory for
distributing to buyers since the start of the
simulation.

Cost

The total cost that the Deliver category has
incurred for packing product shipments for
buyers since the start of the simulation.

Cost

The total cost that the Deliver category has
incurred for transporting product shipments since
the start of the simulation.

Cost

The total cost that the Deliver category has
incurred for invoicing customers since the start of
the simulation.

Cost

The total cost that the Deliver category has
incurred for collecting payments from customers
since the start of the simulation.

Order Entry Metric
Costs Incurred
Order Fulfillment
Metric
Costs Incurred
Pick Metric

Costs Incurred
Packing Metric
Costs Incurred
Transportation Metric
Costs Incurred
Customer Invoicing
Metric
Costs Incurred
Customer Collections
Metric
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Viewing Metrics for Categories

Viewing Metrics for the Source Returns Categories
The properties dialogs for the Source Returns categories are the same except that
the cost metrics depend on the category, for example, Defective Product
Transportation Cost Metric, MRO Product Transportation Cost Metric, and
Excess Inventory Transportation Cost Metric.
The Transportation tab has no metrics.
The following figure shows the Source tab of a sample properties dialog for the
SR1: Source Defective Product category of a Consumer role:

No shipments have
been returned.
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The following figure shows the Cost tab of a sample properties dialog for the
SR1: Source Returns category of a Consumer role:

The costs that the
Source Returns category
has incurred since the
start of the simulation.

Group/Parameter

Tab

Description

General

Source

The label of the associated role.

Role Label
General

See Configuring General Parameters for Roles.
Source

The SCOR process number.

Source

The number of returned product shipments
received, based on defective products, MRO
products, and excess inventory.

Source

The number of replacement orders sent to
upstream suppliers.

Process Number
Metrics
Returned Product
Shipments Received
Metrics
Replacement Orders
Sent
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Viewing Metrics for Categories

Group/Parameter

Tab

Description

Costs Incurred

Cost

The total cost that the Source Returns category has
incurred for transporting defective products,
MRO products, or excess inventory since the start
of the simulation.

Cost

The total cost that the Source Returns category has
incurred for holding defective products, MRO
products, or excess inventory since the start of the
simulation.

SR1:
Defective Product
Transportation Metric
SR2:
MRO Product
Transportation Metric
SR3:
Excess Inventory
Transportation Metric
Costs Incurred
SR1:
Defective Product
Holding Metric
SR2:
MRO Product Holding
Metric
SR3:
Excess Inventory
Holding Metric
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Viewing Metrics for the Deliver Returns Categories
The properties dialogs for the Source Returns categories are the same except that
the cost metrics depend on the category, for example, Defective Product
Authorization Cost Metric, MRO Product Authorization Cost Metric, and Excess
Inventory Authorization Cost Metric.
The Transportation tab has no metrics.
The following figure shows the Cost tab of a sample properties dialog for the
DR1: Deliver Returns category of a Base Manufacturer role:

The costs that the Deliver
Returns category has
incurred since the start of
the simulation.

Group/Parameter

Tab

Description

General

Delivery

The label of the associated role.

Role Label
General
Process Number
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See Configuring General Parameters for Roles.
Delivery

The SCOR process number.

Viewing Metrics for Source and Delivery Products

Group/Parameter

Tab

Description

Costs Incurred

Cost

The total cost that the Deliver Returns category
has incurred for authorizing defective products,
MRO products, or excess inventory since the start
of the simulation.

Cost

The total cost that the Deliver Returns category
has incurred for disposing of defective products,
MRO products, or excess inventory since the start
of the simulation.

DR1:
Defective Product
Authorization Metric
DR2:
MRO Product
Authorization Metric
DR3:
Excess Inventory
Authorization Metric
Costs Incurred
DR1:
Defective Product
Disposition Metric
DR2:
MRO Product
Disposition Metric
DR3:
Excess Inventory
Disposition Metric

Viewing Metrics for Source and Delivery
Products
Each product composite computes a number of metrics, which you can view as
the simulation runs. Certain metrics are relevant for both source and delivery
products, whereas other metrics are relevant for source products or delivery
products only.
This section describes the metrics for the product composites defined for the
simplest e-SCOR model, which consists of a Base Manufacturer role and a
Consumer role. Each section provides sample dialogs for the product composites
that appear in the simplest model.
You can view metrics for:

• Delivery products.
• Source products.
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The metrics that you view for the source and delivery products of a Distributor
and Manufacturer role are similar. However, note that the metrics that appear on
the Metrics tab of a source and delivery product depend on the role.
A Base Manufacturer role has delivery products only, and a Consumer role has
source products only.

Viewing Metrics for Delivery Products
You can view metrics for delivery products on these tabs of the product
composite dialog:

• General tab
• Manufacturing tab
• Metrics tab

General Tab
The following figure shows the General tab of a sample properties dialog for the
delivery product of a Base Manufacturer role:

The number of delivery products
for which the supplier has
received orders, and the number
of products shipped since the
start of the simulation.
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Viewing Metrics for Source and Delivery Products

Group/Metric

Description

General

The label of the role on whose detail the product composite
exists.

Role Label
General
Product Name
Metrics
Quantity to Deliver
Metrics
Quantity Shipped

The name of the product specification in the product
hierarchy. You can think of the Product Name as the SKU
number for an item in inventory.
The total number of orders for delivery products that a
supplier has received since the start of the simulation.
The total number of delivery products that a supplier has
shipped since the start of the simulation. See also Shipped
Inventory Level on the Metrics tab.

Manufacturing Tab
The following figure shows the Manufacturing tab of a sample properties dialog
for the delivery product of a Base Manufacturer role:

The number of delivery products
the supplier has manufactured
and rejected, based on the Build
Yield parameter.
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Group/Metric

Description

Metrics

The total number of delivery products that the role makes
and accepts, then places in inventory for delivery.

Total Products
Accepted
Metrics
Total Products
Rejected

The total number of delivery products that the role rejects
when the Build Yield parameter is a value less than 1.0.

Metrics Tab
The following figure shows the Metrics tab of a sample properties dialog for the
delivery product of a Base Manufacturer role:
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Viewing Metrics for Source and Delivery Products

Group/Metric

Description

Metrics

For the delivery products of a Base Manufacturer,
Manufacturer, or Distributor role, the number of delivery
products that downstream buyers have ordered and the
supplier role has entered but which the supplier has not
yet delivered.

Awaiting Orders

Metrics
Products On Order

For the delivery products of a Manufacturer role, the
number of delivery products for which the make planning
process has created build orders but which the upstream
supplier has not yet received. For the delivery product of a
Base Manufacturer role, the number of delivery products
for which the make planning process has created build
orders but which it has not yet manufactured.
For the delivery products of a Distributor role that
assembles components into kits, the number of delivery
products for which the source planning process has
created replenishment orders but which the upstream
supplier has not yet received.

Metrics
Received Inventory Level

Metrics
Incoming Inventory Level

Metrics
Inventory Level

For the delivery products of a Base Manufacturer or
Manufacturer role, or a Distributor role that assembles
components into kits, the number of delivery products
that the supplier role has manufactured or assembled into
kits and has placed in inventory since the start of the
simulation.
For the delivery products of a Distributor role that
assembles components into kits, the number of delivery
products, or kits, that the role has assembled into kits but
not yet placed in inventory.
For the delivery products of a Base Manufacturer or
Manufacturer, or a Distributor role that delivers its source
products, the number of delivery products currently in
inventory.
Note: A Distributor role that assembles components into
kits does not calculate the Inventory Level of its finished
products.
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Group/Metric

Description

Metrics

For the delivery products of a Base Manufacturer or
Manufacturer role, the number of delivery products that
the role has taken from inventory and is waiting to deliver.

In Transit Inventory Level

For the delivery products of a Distributor role that
assembles is components into kits, the total number of
delivery products that the role has assembled into kits and
is waiting to deliver.
Metrics
Shipped Inventory Level

For the delivery products of a Base Manufacturer or
Manufacturer role, the number of delivery products that
the role has manufactured and shipped since the start of
the simulation.
For the delivery products of a Distributor role that
assembles is components into kits, the total number of
delivery products that the role has assembled into kits and
shipped since the start of the simulation.

Metrics
Pushed Inventory Level

Metrics
Manufacturing Batch Size

Metrics
Excess Inventory Level
Metrics
Defective Inventory Level
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For the delivery products of a Base Manufacturer or
Manufacturer role, or a Distributor role that assembles
components into kits, the number of delivery products
that the role has actually delivered to downstream buyers,
using a push planning strategy, since the start of the
simulation.
For the delivery products of a Base Manufacturer or
Manufacturer role, or a Distributor that assembles
components into kits, the size of the current batch of
finished products or kits.
For the delivery products of a Base Manufacturer,
Manufacturer, or Distributor role, the amount of excess
inventory.
For the delivery products of a Base Manufacturer,
Manufacturer, or Distributor role, the amount of defective
inventory.

Viewing Metrics for Source and Delivery Products

Group/Metric

Description

Metrics

For the delivery products of a Base Manufacturer,
Manufacturer, or Distributor role, the amount of
maintenance, repair, and overhaul (MRO) inventory.

MRO Inventory Level
Metrics
Order Fulfillment
Lead Time

For the delivery products of a Base Manufacturer,
Manufacturer, or Distributor role, the average amount of
time from when the role receives an order for delivery
products from downstream buyers to when the buyer
receives the product shipment.

Viewing Metrics for Source Products
You can view metrics for source products on these tabs of the product composite
dialog:

• General tab
• Sourcing tab
• Supplier tab
• Metrics tab
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General Tab
The following figure shows the General tab of a sample properties dialog for the
source product of a Consumer role:

The number of source
products the buyer has
ordered and received since
the start of the simulation.

Group/Metric

Description

General

The label of the role on whose detail the product composite
exists.

Role Label
General
Product Name
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The name of the product specification in the product
hierarchy. You can think of the Product Name as the SKU
number for an item in inventory.

Viewing Metrics for Source and Delivery Products

Group/Metric

Description

Metrics

The total number of source products that a buyer has
ordered from its suppliers since the start of the simulation.

Quantity Ordered
Metrics
Quantity Received

The total number of source products that a buyer has
received from its suppliers since the start of the simulation.
See also Received Inventory Level on the Metrics tab.

Sourcing Tab
The following figure shows the Sourcing tab of a sample properties dialog for the
source product of a Consumer role:

The weighted average of
the price the buyer pays
for its source products.
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Group/Metric

Description

Metrics

The weighted average of the price a buyer pays for its source
products, which is based on the Net Selling Price parameter
of the upstream supplier’s delivery product and the number
of units purchased.

Purchase Cost

Note: For a Base Manufacturer, Purchase Cost is a parameter
that you configure to determine the cost of raw materials for
the role.

Supplier Tab
The following figure shows the Supplier tab of a sample properties dialog for the
source product of a Consumer role:

The number of contracts
established since the start
of the simulation.

Viewing Metrics for Source and Delivery Products

Group/Metric

Description

Contract

The number of contracts that have been established since the
start of the simulation.

Contract Repetition
Counter

Metrics Tab
The following figure shows the Metrics tab of a sample properties dialog for the
source product of a Consumer role:
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Group/Metric

Description

Metrics

For the source products of a Manufacturer role, the
number of source products for which the role has created
build orders but which the upstream supplier has not yet
delivered.

Awaiting Orders

Metrics
Products On Order

Metrics
Received Inventory Level

Metrics
Incoming Inventory Level
Metrics
Work in Progress

Metrics
Inventory Level
Metrics
Excess Inventory Level
Metrics
Defective Inventory Level
Metrics
MRO Inventory Level
Metrics

For the source products of a Consumer, Manufacturer, or
Distributor role, the number of source products for which
the source planning process has created replenishment
orders but which the upstream supplier has not yet
delivered.
For the source products of a Consumer, Manufacturer, or
Distributor role, the number of source products that the
buyer role has received and placed in inventory since the
start of the simulation.
For the source products of a Consumer, Manufacturer, or
Distributor role, the number of source products that the
buyer role has received but not yet placed in inventory.
For the source products of a Manufacturer role, the
number of source products that the role has taken from
inventory and is waiting to manufacture into finished
products.
For the source products of a Consumer, Manufacturer, or
Distributor role, the number of source products currently
in inventory.
For the source products of a Consumer, Manufacturer, or
Distributor role, the amount of excess inventory.
For the source products of a Consumer, Manufacturer, or
Distributor role, the amount of defective inventory.
For the source products of a Consumer, Manufacturer, or
Distributor role, the amount of maintenance, repair, and
overhaul (MRO) inventory.

For the source products of a Consumer, Manufacturer, or
Distributor role, the average amount of time from when
Received Fulfillment Time
downstream buyers order source products to when the
buyer receives product shipments.
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Viewing Metrics for Resources

Viewing Metrics for Resources
Each resource computes a number of metrics, which you can view for individual
manufacturing resources as the model runs.
The following figure shows a sample properties dialog for a manufacturing
resource of a Base Manufacturer role:

Performance
metrics for
individual
manufacturing
resources.

Metric

Description

Current Utilization

Whether the resource is currently allocated. A value
of 0 means the resource is not currently allocated, and
a positive number indicates that the resource is
currently allocated.

Average Utilization

The amount of time the resource is allocated
compared to the amount of time it is available, which
is the Total Work Time divided by the Total Elapsed
Time of the resource. This metric provides a measure
of how intensively a role is using the resource to
manufacture finished products.

Total Work Time

The total amount of time that the resource has been
allocated since the start of the simulation.
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Metric

Description

Total Elapsed Time

The total amount of time that has elapsed since the
start of the simulation.

Total Idle Time

The total amount of simulation time that the resource
has not been allocated since the start of the
simulation.

9
What Happens When
the Simulation Runs
Describes the basic processes that occur while the simulation runs.
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Contracts Process 325
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Source Planning Process: Manufacturer and Distributor Roles 333

Introduction
When you run a simulation, e-SCOR initiates and runs various processes or
sequences of events. These processes interact to create the various objects the
model requires to source, make, and deliver products. They store various
transient objects, such as orders, in pools on the detail of each role. The processes
are also responsible for determining parameters and computing metrics.
Each process triggers when a particular event occurs, such as receiving an order.
Certain processes also trigger other processes and/or receive objects from other
processes, which can trigger a particular step in the process.
This chapter provides a general description and high-level diagram of each
process. The description lists the steps in the process as a numbered list. Each
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numbered step appears in the diagram next to the appropriate role. The diagrams
also show:

• Objects that flow through the process, with their associated step in
parentheses.

• Triggering events.
The diagrams use these conventions:
Convention/Example

Supplier

order (1)

build order
(Make Planning Process)

Description

Representation of a buyer a role in
the process.

The objects that flow through the
model during the process and the
associated step in parentheses.
The event that triggers the process.

An event that triggers another
process or an event that another
process triggers within the current
process.
invoice
(Financial process)

When you run the simulation, e-SCOR runs the following processes:

• Contracts process
• Order/Product process
• Build process
• Financial process
• Make Planning
• Source Planning process
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Contracts Process

See Also Showing Transient Objects in the e-SCOR User? Guide.

Contracts Process
The contracts process is responsible for establishing contracts between
downstream buyer roles and upstream supplier roles. By default, e-SCOR creates
a single contract between each buyer and potential supplier in the model. The
steps in the process are:
1

Send purchase requests to suppliers.

2

Send purchase responses to buyers in response to those purchase requests.

3

Receive and verify responses.

4

Send purchase awards to suppliers in response to purchase responses.

5

Save purchase awards in the Awards pool.

You can also configure a buyer role to use contracts when ordering identical
source products from multiple upstream supplier roles, in which case multiple
contracts can be established between buyers and suppliers.
You configure contract parameters for the source product of the buyer role to
determine the contract length and amount, as well as how the buyer chooses its
suppliers. When contracts are in effect, the buyer role determines the size of each
replenishment order for source products, based on the estimated contract
amount, rather than based on the source planning process.
The contracts process initiates on a regular planning cycle, based on parameters
that you configure in the P3: Plan Make and P2: Plan Source categories.
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This diagram shows a high-level representation of the steps in the contracts
process, the objects associated with each step, and the triggering event:
Planning Period
Initial Plan Delay
(P2 or P3)

purchase request (1)
purchase award (4)

2 send purchase
response

Supplier

Buyer

purchase response (2)

1 send purchase
request
3 receive and
verify responses
4 send purchase
award
5 save purchase
awards

The contracts process computes the Contracts Established metric for the
ES: Enable Source and ED: Enable Deliver categories.
For a Distributor role, the contracts process initiates each source planning cycle.
For a Manufacturer role, the contracts process initiates each make planning cycle.
The ES: Enable Source category of the downstream buyer role generates a
purchase request for its source products, based on contracts.
The ED: Enable Deliver category of the supplier role generates a purchase
response for its delivery products.
The ES: Enable Source category of the buyer role then chooses the desired
supplier based on Supplier Selection parameters that you configure for the source
product. It generates a purchase award and sends it to the chosen supplier.
The buyer role stores purchase awards in its Buyer Awards pool, and the supplier
role stores purchase awards in its Supplier Awards pool. Additionally, the buyer
role stores purchase responses in its Responses pool.
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Order/Product Process

Order/Product Process
The order/product process is responsible for generating orders, fulfilling orders,
and receiving shipments. The steps are:
1

Generate customer or replenishment orders for source products with
upstream suppliers.

2

Fulfill those orders, which includes entering the order, selecting the order,
fulfilling the order, picking materials, packing the container, and sending the
product shipment of delivery products to downstream buyers whenever they
are available.

3

Receive product shipments from suppliers.

The process initiates when the buyer receives a customer or change order from
the Input category on the Consumer role detail or when it receives a
replenishment order from the source planning process of a Distributor or
Manufacturer role.
The order fulfillment step (step 2) triggers when the buyer sends an order to the
supplier or when the supplier receives a chit from either the build process or the
source planning process. The build process generates a chit when finished goods
have been manufactured and are available for delivery. The source planning
process generates a chit when products have been received and are available for
delivery.
When the order/product process delivers a shipment, it triggers the financial
process, which sends an invoice to the downstream buyer role.
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This diagram shows a high-level representation of the steps in the order/product
process, the objects associated with each step, and the triggering events:
chit
(Build process)
or
receive chit
(Source Planning
process)

customer order
or
replenishment order
(Build process)

order (1)

1 generate order
2 fulfill order

Supplier

Buyer
3 receive shipment

product shipment (2)

invoice
(Financial process)

The order/product process computes performance and other metrics related to
order entry and order fulfillment, such as Supplier On-Time Performance (%),
Fill Rates (%), Delivery Performance (%), and Order Fulfillment Lead Time. It also
computes inventory metrics for source products.
The S1: Source Stocked Product category of the downstream buyer role generates
customer orders for its source products on a regular cycle, based on the Demand
Order Duration parameter of the source product or a Demand Input Report. The
size of each order is based on the Demand Order Size parameter of the source
product. It sends those orders to the Deliver category of the upstream buyer role.
The Source category of a Distributor and Manufacturer role behaves similarly,
except that these roles use source planning to determine order size and frequency.
Whenever it can, the Deliver category of the upstream supplier role delivers
shipments of delivery products to the Source category of the downstream buyer
role, based on customer orders.
The buyer role stores orders for delivery products in the Source Orders pool on
the role detail.
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Build Process: Base Manufacturer Role

Build Process: Base Manufacturer Role
The build process is responsible for manufacturing finished products from
components. The steps are:
1

Determine batches, based on the build order.

2

Select the build order to manufacture.

3

Manufacture finished products, based on build orders.

4

Stage finished products.

5

Generate and send payments for raw materials (Base Manufacturer role only).

6

Release finished products into inventory.

The process initiates when the manufacturer role receives a build order from the
make planning process, which is based on customer or replenishment orders for
its delivery products. For a Manufacturer role only, the process can also initiate
when the Make category receives source products from the order/product
process, indicating that additional components are available.
When the build process releases finished products into inventory, it generates a
chit, which triggers the order-fulfillment step of the order/product process.
This diagram shows a high-level representation of the steps in the build process
and the triggering events:
build order
(Make Planning process)

Manufacturer

1 determine batches
2 select build order
3 manufacture products
4 stage products
5 generate payments
6 release products

chit
(Order/Product process)

In general, the financial process is responsible for computing financial metrics for
a buyer role when it sources components. However, because a Base Manufacturer
role does not source components, the build process for a Base Manufacturer is
responsible for computing financial metrics for the role, as well.
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The build process computes performance and other metrics related to the buildorder processing and manufacturing process, such as Make Cycle Time. It also
computes inventory metrics for delivery products.
The Deliver category of the Base Manufacturer role receives orders for the
product family, which the P3: Plan Make category turns into build orders. Each
make planning cycle, based on the Planning Period, the Plan category sends the
build orders to the Make category for manufacturing. The Make category
determines how many batches it can make, then manufactures the finished
products.
A Base Manufacturer role makes batches as soon as it can, based on available
resources; it assumes its raw materials are always available. A Manufacturer role,
however, makes batches as soon as it can, based on available source products and
available resources.
When using a stock planning strategy, the default, the Make category makes just
enough delivery products to maintain desired inventory levels, given current
orders, based on replenishment planning.

Financial Process
The financial process is responsible for generating invoices and making
payments, based on orders for source products. The steps are:
1

Generate customer or replenishment orders for source products with
upstream suppliers.

2

Send product shipments of delivery products to the downstream buyer role.

3

Receive product shipments from the upstream supplier role.

4

Generate invoices based on shipments of delivery products.

5

Receive those invoices.

6

Generate payments based on invoices.

7

Receive those payments.

The process initiates when the buyer receives a customer order from the
Input: Send Orders or Change Orders source product of a Consumer role or a
replenishment order from the Source Planning process of a Distributor or
Manufacturer role.
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Financial Process

This diagram shows a high-level representation of the steps in the Financial
process, the objects associated with each step, and the triggering event:
customer order
or
replenishment order
(Build process)

order (1)
invoice (4)

2 send shipment
4 generate invoice
7 receive payment

Supplier

Buyer

1 generate order
3 receive shipment
5 receive invoice
6 send payment

product shipment (2)
payment (6)

The Financial process is also responsible for computing Financial Bookings,
Financial Outstanding, and Financial Collections within Financial Period and
Financial Collections Total for supplier roles and Deliver categories, and Financial
Obligations, Financial Payments within Financial Period, and Financial Payments
Total for buyer roles and Source categories. The Financial process computes these
metrics each Financial Period of the role.
In addition, each financial period, the financial process computes these asset
metrics for each role: Days of Supply metrics, Asset Turns, Cash-to-Cash Cycle
Time, Days Sales Outstanding, and Cash Flow Period. It also computes the Order
Management Costs metric for each role and the Costs Incurred metrics for each
Source and Deliver category, as appropriate.
The Source category of the downstream buyer role generates customer orders for
its source products on a regular cycle, based on the Demand Order Duration
parameter of the source product. The size of each order is based on the Demand
Order Size parameter of the source product. It sends those orders to the Deliver
category of the upstream buyer role.
The Source category of the Distributor and Manufacturer roles behaves similarly,
except that these roles use source planning to determine order size and frequency.
Whenever it can, the Deliver category of the upstream supplier role delivers
shipments of delivery products to the Source category of the downstream buyer
role, based on customer orders.
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At the same time, the Deliver category of the supplier role generates an invoice
for the cost of the order. The Net Selling Price parameter of the delivery product
of the supplier role determines the cost to the buyer.
The Source category of the buyer role receives the invoice. It waits the entire
Financial Payment Terms of the supplier role, then sends a payment to the
supplier. The Deliver category of the supplier role then receives the payment.

Make Planning Process: Base Manufacturer
Role
The make planning process determines when a Base Manufacturer or
Manufacturer role creates build orders for delivery products and, thus, when it
manufactures, and, implicitly, when it delivers those products. The steps are:
1

Determine the production requirements for finished products.

2

Determine the order type, which is stock, make-to-order, or engineer-to-order.

3

For stock orders, determine the planning mode, which is pull or push.

4

For pull planning, determine the inventory control strategy, which is
replenishment, forecast, Q, or R-Q.

The make planning process initiates on a regular planning cycle, based on
parameters that you configure in the P3: Plan Make category.
The make planning process generates a build order, which triggers the build
process.
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Source Planning Process: Manufacturer and Distributor Roles

This diagram shows a high-level representation of the steps in the make planning
process and the triggering events:
Planning Period (P3)
Initial Plan Delay (P3)

1 determine production requirements

Manufacturer

2 determine order type
3 determine planning mode
4 determine plan type

build order
(Build process)

The make planning process computes planning metrics for delivery products,
such as Awaiting Orders and Products On Order.
The P3: Plan Make category determines the frequency with which the role sends
build orders to the Make category for manufacturing its delivery products.
The P3: Plan Make category also implicitly determines when the role delivers
those products to downstream buyers; it delivers them when they are available
from the upstream Make category.

Source Planning Process: Manufacturer and
Distributor Roles
The source planning process determines when a Distributor or Manufacturer role
creates replenishment orders for source products. The source planning process
determines the order type and generates a plan differently, depending on the role:

• A Manufacturer role determines the order type and generates a plan for its
source products.

• A Distributor role determines the order type and generates a plan for its
delivery products first, then for its source products.

The source planning process initiates on a regular planning cycle, based on
parameters that you configure in the P2: Plan Source category.
The source planning process generates a replenishment order, which triggers the
order/product process and the financial process.

321

This diagram shows a high-level representation of the steps in the source
planning process and the triggering events:
Planning Period (P2)
Initial Plan Delay (P2)

1 determine role type

Manufacturer/
Distributor

2 get delivery products
3 determine order type
4 determine planning mode
5 determine plan type

replenishment order
(Order/Product process)

The source planning process computes planning metrics for source products,
such as Awaiting Orders and Products On Order.
The P2: Plan Source category of the Distributor and Manufacturer roles
determines the frequency with which these roles send replenishment orders for
source products to the Source category, which places orders with upstream
supplier roles.
For a Distributor role, the P2: Plan Source category also implicitly determines
when the role delivers those products to downstream buyers; it delivers them
when they are available from the upstream Source category.
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10
Using Reports
Describes how to view metrics and enter parameter values through various types
of reports.
Introduction 362
Creating Reports 363
Configuring the Time Unit 370
Updating Output Reports at Regular Time Intervals 372
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Introduction
You determine the performance of your supply-chain model by viewing metrics,
which are attributes that the model computes, based on parameters, which are
attributes that you configure. You can perform the following reporting tasks:

• Create reports, including output reports for viewing metrics and input reports
for configuring parameters.

• Update output reports at regular time intervals.
• Keep a history of data values.
• Chart report data.
• Configure report templates automatically.
• Filter the data to appear in a report.
• Configure the attributes to appear in a report.
• Create reports in Excel.
• Write to and read from CSV files.
• Write to and read from databases.
• Create specialized reports:
– Demand Reports
– Role Transaction Log Reports
Note When creating reports in Excel, be sure you have Excel installed on your
computer before you attempt to create a report.

For information on reports that you can create through the Navigator, see the
G2 Reporting Engine User’s Guide.

Viewing Simulation Metrics in a Toolbar
When you run a simulation, e-SCOR displays key metrics for roles and product
composites in the Metrics toolbars. The Metrics toolbars provides a quick way of
verifying model performance. The toolbar updates once every half second of
clock time.
The metrics toolbars include:

• Asset Metrics — Standard asset metrics for all roles in the model.
• Contract Metrics — Contract metrics for all product composites in the model.
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Viewing Simulation Metrics in a Toolbar

• Financial Metrics — Incoming and outgoing financial metrics for all roles in
the model.

• Inventory Metrics — Inventory metrics for all product composites in the
model.

• Order Metrics — Order metrics for all source and delivery products in the
model.

• Resource Metrics — Resource metrics for all manufacturing resources in the
model.

To hide and show the Metrics toolbar:
 Choose View > Asset Metrics, Contract Metrics, Financial Metrics, Inventory
Metrics, Order Metrics, or Resource Metrics.

The toolbars appear in separate tabs at the bottom of the window.
To view simulation metrics in a toolbar:
 Run the simulation and display the Metrics toolbars.
To sort data in the toolbar:
 Click the column header.
To configure the width of each column in the toolbar:
 Drag the border between each column left or right.
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This figure shows the Order Metrics toolbars for the simplest e-SCOR model,
which consists of two roles:

Following are examples of all the metrics toolbars.

Asset Metrics

Contract Metrics
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Financial Metrics

Inventory Metrics

Order Metrics

Resource Metrics

Creating Reports
To create a report, you:

• Create a report for the desired type of input or output report.
• Depending on the type of report:
– Generate output report data from the model.
– Apply input report data to the model.
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Summary of Input and Output Reports
This table summarizes the input and output reports you can create:
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Report

Description

Role Input Report

Role parameters, which determine the financial
payment period and terms, and the time period for
computing time-weighted statistics for each role in
the model.

Role Output Report

Role metrics, which display financial bookings,
outstanding, collections, and payments, asset metrics,
and total costs for each role in the model.

Category Input Report

Parameters for each Plan, Source, Make, and Deliver
category in the model.

Category Output
Report

Metrics for each Plan, Source, Make, Deliver, Enable
Source, and Enable Deliver category in the model.

Product Parameters
Report

Parameters for each product composite in the model.

Product Metrics Report

Metrics for each product composite in the model.

Creating Reports

Report

Description

Demand Report

Initial order demand parameters for the overall
supply chain, including Demand Order Size and
Demand Order Duration. You can also configure
change orders through a Demand Report. You
configure the source product of the Consumer role to
read order demand parameters from the report.

Product Specifications
Report

Parameters for each product specification in the
model.

Resource Input Report

Parameters for each resource in the model, including
resource capacity and efficiency.

Resource Output
Report

Metrics for each resource in the model, including
resource utilization metrics.

Role Transaction
Report

Transactions that occur between roles, including
orders, purchases, products, and financials.
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Creating a Report
The first step in creating a report is to determine where to place the report in your
model. By default, reports include data for all objects of the specified type on the
current workspace and all details. You can place reports in a number of locations
in the model, as follows:
To include data for...

Place the report object on...

All objects of the specified type in the
model

The model detail.

All objects of the specified type associated
with a particular workspace and any
details

The detail of an organizer and
choose the root workspace for the
report object.

You place report objects on an organizer when you have many reports and
placing them on the model detail would make the detail too cluttered. For
information on creating organizers, see Creating an Organizer.
Once you place the report object in the appropriate location in your model, you
can create the report. The report has a row for each object in the model that
corresponds to the type of report. For example, a Role Output Report has a row
for each role in the model, and a Product Composite Input Report has a row for
each product composite.
The report includes a column for each parameter or metric that the report defines,
depending on whether it is an input or output report. For example, the Role Input
Report contains columns for configuring the Financial Payment Period, Financial
Payment Terms, and other role parameters, and the Role Output Report contains
columns for viewing the Financial Bookings, Financial Outstanding, and other
role metrics.
The report identifies each object by its label; therefore, be sure to configure labels
for all objects in the model before you create the report.
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To create a report:
1

Display the Reports palette of the e-SCOR toolbox:

2

Create an input or output report object, based on the type of data you want to
enter or compute, and place it in the desired location in the model.
For information on the types of reports you can create, see Summary of Input
and Output Reports.
If you place the report object on the model detail or some other detail, you can
skip the following step. Otherwise, if you place the report object on the detail
of an organizer, you must choose the root workspace for the report object.

3

If necessary, choose Choose Root Workspace on the report object, then select
the workspace to which the report object should apply and choose Select.
The report object applies to all objects of the specified type on the selected root
workspace and all details.

4

To create the report, choose Show Report on the report object.
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This figure shows a model with a Role Input Report and a Role Output Report on
the same workspace as the model:

Here is the default report template for the Role Input Report:
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Here is the default report template for the Role Output Report:

Generating Output Report Data from the Model
To generate output report data, you simply run the simulation and update the
report. Each time the report updates, new data appears in the report.
By default, output reports are configured to update manually and output static
data.
You can configure the report to update automatically, as described in Updating
Output Reports at Regular Time Intervals.
You can also configure the report to output time-series data, as described in
Keeping a History of Data Values.
To generate output report data from the model:
1

Run the simulation.
For details, see Controlling the Simulation.

2

Update the report manually, using one of these techniques:
 Click the Update button at the top of the report.

or
 Choose Update Report on the report object.

333

Here is a Role Output Report, with several columns hidden, after running the
simulation for one financial period:

Applying Input Report Data to the Model
To apply input report data, you enter data in the input report and apply the
values to the model. Each time you apply new values, the parameters in the
model update.
Configuring parameters through input reports provides an alternative to
configuring the same parameters through properties dialogs and has these
advantages:

• Configuring parameters for the same types of items in a single spreadsheet,
for example, all source products or all delivery products.

• Running different configurations of the model, using different sets of input
parameters and comparing the results.

To apply input report data to the model:
1

Configure the report data for the specified parameters of the report objects.

2

Click the Apply button at the top of the report to apply the data to the model.

e-SCOR applies the values from the report to the appropriate parameters in the
model.
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Configuring the Time Unit

Here is a Role Input Report with values specified:

Configuring the Time Unit
By default, reports display all time-based values in hours, which means:

• All time-based metrics display in units of an hour in output reports.
• You must enter all time-based parameter values in units of an hour in input
reports.

For example, a value of 3 days displays in an output report as 72 hours, and you
must enter 72 hours in an input report as the value for 3 days.
Depending on your model, you might want to use a different time unit, such as
minutes, days, or weeks. Alternatively, you can configure the report to display all
time-based parameters and metrics as durations, for example, one week, one day,
one hour, one minute, and one second would be 001:001:001:001:001.
The report displays the current time unit at the top of the report.
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To configure the time unit:
 Display the properties dialog for the report and, on the General tab, configure
the Time Unit to be seconds, minutes, hours, days, or weeks, or configure the
Time Unit to be none to use a duration.

This figure shows the properties dialog for Role Input Report that is configured
for entering time-based parameter values in units of hours, the default:
Report displays timebased values in units of
hours, the default.
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Configuring the Time Unit

Here is the resulting report with the time unit specified as 1 hour and time-based
values entered in hours:
The time unit is hours,

You enter time-based values
in units of hours, so 720
hours equals 30 days.

This figure shows the dialog for a Role Input Report that is configured for
entering time-based parameter values in units of days:
Report displays time-based
values in units of days.
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Here is the resulting report with time-based values entered in units of days:
The time unit is days,

You enter time-based values
in units of days, so you can
enter 30 days directly.

This figure shows a Role Input Report that is configured for entering time-based
parameter values as a duration:
Time Unit is none, which means the report
displays time-based values as a duration.
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Updating Output Reports at Regular Time Intervals

Here is the resulting report with time-based values entered as a duration:
The time unit is none,

You enter time-based values
as a duration, where 4 weeks
and 2 days is equal to 30 days.

Updating Output Reports at Regular Time
Intervals
By default, you update output report data manually. You can configure reports to
update automatically at regular time intervals, based on:

• Simulation time.
• Clock time.
For example, you might want report data to update once a day, once a week, or
once per financial period, based on the amount of simulation time that has
passed. Alternatively, you might want the report data to update once every five
seconds of real time, based on the computer clock.
Note When updating reports that include financial metrics, you should configure the
report to update once per financial period. The report data updates at the end of
the financial period so values are always accurate for the current financial period.
To ensure that the report includes data for the last update period, you should run
the simulation for slightly longer than the last update interval. For example, to
include data from four weeks of simulation time, you should run the simulation
for 29 days, which is four weeks plus a day. For details, see Configuring the
Duration of the Simulation.
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By default, output reports refresh their values each time the report updates. To
improve performance, you can configure output reports to refresh at the end of
the simulation and when you manually request an update only.
You can also trigger updates by using an Update Trigger tool, which allows you
to trigger updates for multiple reports or based on model events. For details, see
the ReThink User’s Guide.

Configuring Output Reports to Update Regularly
The easiest way to trigger updates at regular time intervals is by configuring the
report object.
To configure an output report to update regularly:
1

Display the properties dialog for the output report whose data you want to
update regularly.

2

On the General tab, configure the Update Mode to be clock-time or simulationtime, depending on how you want to update the report.

3

Configure the Update Interval to be the time interval at which to update the
report, based on the Update Mode.

This figure shows how to configure a Role Output Report to update once per
financial period, based on simulation time, where the financial period is 30 days:

Report updates once every
4 weeks and 2 days
(30 days) of simulation time.
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Triggering Updates Manually
When using an Update Trigger tool, you can trigger the update of all associated
reports manually. You can also show all the items to update.
To trigger the update of all associated items manually:
 Choose the Update All Related Items menu choice on the Update Trigger.
To show items associated with the Update Trigger:
 Choose the Show Items to Update menu choice on the Update Trigger.

Configuring When Clients Refresh Their Data
By default, clients refresh their data each time the report updates. This means that
reports that appear within the client, reports that are generated in CSV files and
Excel, and reports that output their data to a database all refresh their data
automatically each time new data is collected in the server.
Depending on the number of reports in your model, the number of clients of the
server’s data, and the interval at which reports update, performance can be
degraded. To improve performance, you can disable the automatic refreshing of
client data. When automatic refreshing is disabled, e-SCOR refreshes client data
only when explicitly requested, using the Update menu choice or button, and
automatically at the end of the simulation.
To disable automatic refreshing of client data:
1

Display the properties dialog for the output report object for which you want
to disable client refreshing.

2

On the General tab, disable the Auto Refresh Clients option.

Keeping a History of Data Values
By default, output reports generate static data. To generate time-series data for
any type of output report, you configure the report to keep a history of data
values. Typically, you configure reports that keep a history to update at regular
time intervals. Each time the report updates, e-SCOR outputs new values to the
report for each metric so you can compare values over time. You can then output
the data to a CSV file, to Excel, or to a database to perform analysis on the timeseries data. For example, you might configure a Role Output Report to output
financial data once per financial period.
Each data value in the history has an associated timestamp that indicates when
the value was generated. You can format the timestamp as an absolute date and
time or as a relative duration. By using relative durations, you can use the timeseries data as input to the Demand Report, which provides initial order data to
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the overall supply chain through a report. To do this, you must create an output
report with the same visible attributes as the Demand Report. For more
information, see Configuring Demand and Change Orders through a Demand
Report.
When using the Scenario Manager to perform multiple simulations for the same
model, you can configure the report to keep a history across all simulations.
When keeping a history across multiple simulations, the output report has an
additional column named Simulation Counter, which indicates the number of the
simulation run. For details, see Using Batch Simulation.
To keep a history of data values:
1

Display the properties dialog for the output report object for which you want
to keep a history.

2

Configure the report to update at regular time intervals.
For details, see Updating Output Reports at Regular Time Intervals.

3

On the General tab, enable the Keep History option.
By default, the timestamp the report generates uses an absolute time and date,
based on simulation time. For example:
1/1/02 0:00
You can configure the timestamp to use a relative duration from the start of
the simulation. For example:
1 weeks, 2 days, 1 hour, 30 minutes, and 10 seconds
2 weeks, 1 day, 30 minutes, and 30 seconds
3 weeks and 1 hour
etc.
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4

Enable the Date/Time as Duration option to use relative timestamps,
if desired.

5

When running batch simulations on the same model, using the Batch
Simulation object, enable the Batch Simulation History option to keep a
history across multiple models, if desired.

Keeping a History of Data Values

This figure shows how to configure a Category Output Report to generate timeseries data once a days of simulation time, where the timestamps appear as
durations:

Report generates time-series
data each Update Interval,
based on the Update Mode.

Report displays timestamps
as relative durations.

When you run the simulation, e-SCOR generates data for each report metric each
time the report updates. This figure shows a Category Output Report that keeps a
history, uses durations as timestamps, and updates once a day of simulation time:

The Role Output Report
includes a history of values,
which are generated each
time the report updates.
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Charting Report Data
You can chart the data in a report in various types of charts. The chart updates
according to the update setting of the report.
To chart report data:
1

Create and configure an output report.
For details, see Creating a Report.

2

Configure the update interval for the report.
For details, see Configuring Output Reports to Update Regularly.

3

Ensure that the Enable Charting option on the General tab of the properties
dialog for the report is enabled, the default.

4

Enable the Update Charts option in the Scenario.
For details, see Configuring the Computation Behavior.

5

Choose Show Report on the report to create the report.

6

Choose Show Chart on the report to show a chart of the report data.

For example, here is a chart for a Category Output Report:
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Configuring Standard Report Templates
Most reports provide menu choices for automatically configuring standard report
templates. These menu choices configure the report title, the report filters, and the
attributes to appear in the report, depending on the type of report. The following
menu choices are available:
Report Type

Menu Choices

Role Input Report

Setup Report As Default Role Input

Role Output Report

Setup Report As Default Role Output
Setup Report As Role Asset Metrics
Setup Report As Role Financial Metrics

Category Input Report

Setup Report As Default Category Input
Setup Report As Deliver Parameters
Setup Report As Make Parameters
Setup Report As Plan Parameters
Setup Report As Source Parameters

Category Output
Report

Setup Report As Default Category Output Report
Setup Report As Deliver Metrics
Setup Report As Enable Deliver Metrics
Setup Report As Enable Source Metrics
Setup Report As Make Metrics
Setup Report As Plan Metrics
Setup Report As Source Metrics

Product Parameters
Report

Setup Report As Product Parameters

Product Metrics Report

Setup Report As Product Inventory Metrics
Setup Report As Product Metrics

To configure report templates automatically:
 Choose the appropriate menu choice on the report object.

The report title that appears next to the report updates to reflect the new report
template.
To verify the visible attributes and report filters for the template:
 Display the properties dialog for the report object and click the Attributes tab
and/or the Filters tab.
Note Only the Category Input and Output Reports have the Filters tab.
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For more information about these tabs, see Filtering Report Data and Configuring
the Attributes to Appear in a Report.
This figure shows the Filters tab for a Category Output Report that has been
configured to use the Make Metrics template:

This figure shows the Attributes tab for the Make Metrics report:
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Filtering Report Data

Filtering Report Data
The default category report templates include data for all types of categories:
Plan, Source, Make, Deliver, Enable Source, and Enable Deliver categories.
You can filter the data that appears in a report. For example, you can create
separate Category Input Reports for the Plan, Source, Make, and Deliver
categories. You can filter report data for a Category Input or Output Report; you
cannot filter data for a Role Input or Output Report or for a Product Composite
Input or Output Report.
You can filter report data automatically by using a pre-defined template for the
various types of reports. For details, see Configuring Standard Report Templates.
To filter category report data:
1

Create as many Category Input or Output Report objects as needed,
depending on the objects to which each report should apply.

2

Display the properties dialog of each report object and click the Filters tab.
By default, Select All is enabled, which includes data for all categories in the
report.

3

Disable the Select All option, then click the categories to which the report
should apply.

Configuring the Attributes to Appear in a
Report
Each type of report includes a default set of parameters and/or metrics,
depending on the type of report. You can configure the list of visible attributes
through the report object.
When configuring the list of visible attributes, you can include time-weighted
metrics that the model computes for categories and product composites, such as
average and moving average.
You can configure the attributes to appear in reports automatically by using a predefined template for the various types of reports. For details, see Configuring
Standard Report Templates.
To configure the list of visible attributes, you choose from a list of available
attributes, depending on the type of report. Some attributes, such as timing
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parameters, are defined within a group. For example, when the Category Input
report is configured as a Source Parameters Report, it contains these attributes
within these groups:

• Receiving Cycle Time Duration Subtable.min

Receiving Cycle Time Duration Subtable.mode
Receiving Cycle Time Duration Subtable.max

• Verification Cycle Time Duration Subtable.min

Verification Cycle Time Duration Subtable.mode
Verification Cycle Time Duration Subtable.max

• Transfer Cycle Time Duration Subtable.min

Transfer Cycle Time Duration Subtable.mode
Transfer Cycle Time Duration Subtable.max

Note In addition to the default set of attributes, all input report include the GFR-UUID
attribute, which uniquely identifies the object. This attribute must appear when
creating reports in .csv files; otherwise, you cannot apply values to the model.
When you create reports locally, this attribute is only required if the object labels
are not unique.
To configure the list of visible attributes in a report:
1

Display the properties dialog for the report object and click the Attributes tab.
The dialog shows the attribute in the left column and the column label in the
right column.
For example, here is the Attributes tab of the properties dialog for the default
Category Output Report:
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Configuring the Attributes to Appear in a Report

2

Add and remove attributes to and from the list, as needed:

• Click the Add Row button to add a row above the currently selected row.
• Click Delete Row to delete the selected row or rows.
Tip You can use the Shift key to select multiple rows.
3

To configure the attribute to appear in the report, double-click the attribute
name in the left column to display a dropdown list of available attributes and
their associated groups, where relevant, then choose an attribute.

Tip Double-click the border between the column headers to expand the column
width to just fit the longest attribute name.

By default, the attribute name and its associated group appear as the column
header when you display the report. You can also enter a label for the column
header.
4

Enter a Column Label for the attribute, if desired.

The report contains the attributes and column labels you configured.
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For example, this figure shows how to add several parameters associated with the
demand order size and cycle time to the Product Composite Input Report, along
with a column label:
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Here is the resulting report template with the new columns added and some
removed:

Creating Reports in Excel
You might want to create reports in Excel so you can perform further analysis on
the data and generate graphics. Creating a report in Excel is similar to creating a
report in the client, as follows:

• Create a report in Excel for the desired type of input or output report.
• Depending on the type of report, you:
– Generate output report data from the model to Excel.
– Apply input report data to the model from Excel.
When creating reports in Excel, you can:

• Filter report data in Excel.
• Control the simulation from Excel.
• Connect to and disconnect from the server from Excel.

Creating a Report in Excel
Before you can generate output report data or apply input report data, you must

create a report in Excel. To do this, first, you create a report object in the model,
then you create the report from the report object. You create the report in the
following default Excel spreadsheet:
\escor\data\e-SCOR-Summary-Reports.xls
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Each time you open the default Excel spreadsheet or a spreadsheet that is based
on this default, the Excel client automatically attempts to establish a connection
with the e-SCOR server. Excel can be running on the same computer as the server
or on a different computer. By default, you must configure the location of the
server each time you open the spreadsheet.
The e-SCOR server keeps track of which Excel spreadsheet corresponds to which
report object, based on a unique identifier, called a UUID. The Excel spreadsheet
need not be open to update an existing spreadsheet. The spreadsheet updates the
next time you open it, based on changes cached in the server.
When you create a report, Excel formats the tab page associated with the report
object to include the appropriate columns and rows for the particular report
object and model. For example, if you create a Role Output report, the
spreadsheet includes columns for all the financial, asset, and cost metrics
associated with a role, and rows for each role in the model.
Once you have created the report, you typically format the rows and columns
manually to suit your needs, then save the default spreadsheet to a new name.
When you are ready to generate output report data or apply input report data,
you simply open the spreadsheet you saved, which is automatically configured to
communicate with the correct report in the server.
The following figure illustrates the process of creating a report in Excel:
e-SCOR Server

The server keeps track
of which report data
goes with which report,
through its UUID.

Open the default Excel
spreadsheet to establish a
connection to the server.

UUID

Excel Client
e-SCOR Client
UUID

Choose Create Report on
the report object to create
a report template in Excel.
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Creating Reports in Excel

To create a report in Excel:
1

Create an input or output report, based on the type of data you want to enter
or compute, and place it in the desired location in the model.
For details, see Creating Reports.
If you place the report object on the model detail or some other detail, you can
skip the following step. Otherwise, if you place the report object on the detail
of an organizer, you must choose the root workspace for the report object, as
the next step describes.

2

If necessary, choose Select Root Workspace on the report object, then select the
workspace to which the report object should apply and choose Select.
The report object applies to all objects of the specified type on the selected root
workspace and all details.

3

Display the properties dialog for the report object and configure the Report
Title on the General tab to be a unique name.

4

In Excel, open e-SCOR-Summary-Reports.xls, located in the escor\data
directory of your installation directory.

Shortcut You can open the default report by choosing Start > Programs >
Gensym G2 2011 > Examples > G2 e-SCOR > e-SCOR Default Summary
Reports.

The report uses a default macro to format the cells. You must enable macros
each time you open the default spreadsheet.
Tip To configure Excel to enable macros automatically, choose Options from the
Excel Tools menu, click the General tab, and click the Macro Virus Protection
option off.
5

Click the Enable Macros button in the confirmation dialog that appears.
The Excel client attempts to establish a connection to the e-SCOR server. By
default, e-SCOR prompts you for the location of the server by displaying this
dialog:
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6

Enter the location of the computer on which the server is running, using the
following syntax:
<host>:<port>
You only need to edit the value if you are running the server on a computer
other than localhost:1111, such as my-host:1112.
The Excel client is now connected to the server.

7

In e-SCOR, choose Show Report on the report to create the report in the
default Excel spreadsheet.
Excel formats the tab page associated with the report for the particular model
by creating the appropriate rows and columns.

8

Reset the scenario.

9

In Excel, format the rows and columns of the report to suit your needs.
For example:

• Choose Format > Row > Hide and Format > Column > Hide to hide rows
and columns whose data you do not need to see.

• Choose Format > Column > Autofit Selection to adjust the column width
to match the column headers.

• Click a cell and choose Window > Freeze Panes to define column and row
borders that always remain visible, even when scrolling.

10 In Excel, save the report to a new file name, such as My-Model-SummaryReport.xls.
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Creating Reports in Excel

This figure shows a model with a Role Output Report:

Choose Show Report on the
report object to create a template
for the Role Output report in the
default Excel spreadsheet.

This figure shows the resulting spreadsheet template in the default Excel
spreadsheet:
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Generating Output Report Data from the Model to
Excel
Before you can generate output report data from the model, you must create a
report in Excel for the output report whose data you want to generate.
To generate output report data, you simply run the simulation and update the
report. Each time the report updates, new data appears in the report.
By default, output reports are configured to update manually and output static
data.
You can configure the report to update automatically, as described in Updating
Output Reports at Regular Time Intervals.
You can also configure the report to output time-series data, as described in
Keeping a History of Data Values.
By default, Excel does not format the data when the report updates. You can
create a macro in Excel to format report data. For details, see the Customizing
ReThink User’s Guide.
For information about reducing the amount of data that appears in the report, see
Filtering Report Data in Excel.
To generate output report data from the model to Excel:
1

Open an Excel report that is based on the e-SCOR-Summary-Reports.xls
spreadsheet.
For details, see Creating a Report in Excel.

2

Run the simulation.
For details, see Controlling the Simulation.

3

Update the report manually, using one of these techniques:
 In Excel, choose Report > Update from the e-SCOR floating toolbar:

or
 In Excel, enter Ctrl + U.

or
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Creating Reports in Excel

 In e-SCOR, choose Update Report on the report.

or
 In e-SCOR, select the report whose values you want to update and choose
Reports > Update.
4

When you have finished running the simulation, sort the report data, as
needed, by choosing Data > Sort in Excel.

Note Do not attempt to sort report data before the simulation has finished, because
updating the report reverts to the default sort order.

For example, here is part of a Role Output Report for a model with a Base
Manufacturer role and a Consumer role:

Applying Input Report Data to the Model from Excel
Before you can apply input report data to the model, you must create a report in
Excel for the input report whose data you want to apply.
To apply input report data, you simply enter data into the input report and apply
the values to the model. Each time you apply new values, the parameters in the
model update.
To apply input report data to the model from Excel:
1

Open an Excel report that is based on the Default-Summary-Reports.xls
spreadsheet.
For details, see Creating a Report in Excel.

2

Edit the spreadsheet cells for the specified parameters of the specified objects.
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3

Apply the report data to the model, using one of these techniques:
 In Excel, choose Report > Apply from the e-SCOR floating toolbar:

or
 In Excel, enter Ctrl + A.

or
 In e-SCOR, select the report whose values you want to apply and choose
Reports > Apply.

Excel applies the parameter values from the spreadsheet to the appropriate
parameters of the appropriate objects in the model.
For example, here is part of a Product Parameters Report for a model that
manufactures computers from electronics and components:

Filtering Report Data in Excel
If you have many objects in a model, you might want to filter report data to view
or configure a subset of the data. You can filter the report data, based on values in
any column of the report. For example, you might want to show the rows
associated with particular resources or the rows with the Total Cost greater than a
certain number.
Note Unlike filtering report data by object class, filtering data in Excel simply hides
certain data from view; the data still exists and can be displayed at any time.
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To filter report data in Excel:
 Click the dropdown list for a column header and choose the filter criterion,
based on available column data.

Here is the column header dropdown list for the Role Label column of a Role
Output Report:

To show all report data:
 Click the dropdown list for a column header and choose All.
To show only the top ten rows of data:
 Click the dropdown list for a column header and choose Top 10.
To filter report data based on custom criteria:
 Click the dropdown list for a column header, choose Custom, and configure
the custom filter criteria.

For example, here is how you would configure the report data to show only those
rows whose Cash-to-Cash Cycle Time is greater than 100:
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Here is a model with a Category Output Report:

By default, the Category Output Report looks like this, with all categories visible:

To show report data for individual categories, you would click the dropdown list
for the Block column header and choose the desired category, for example,
Deliver Stocked Product:
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The resulting report shows report data for Deliver Stocked Products categories
only:

To toggle the dropdown list buttons:
 Choose Report > Filter from the e-SCOR floating toolbar:

Controlling the Simulation from Excel
When creating Excel reports, you might want to control the simulation from
Excel, rather than switching back to e-SCOR. You can activate, deactivate, start,
reset, pause, or continue the simulation from Excel.
To control the simulation from Excel:
 In Excel, choose Simulation from the e-SCOR floating toolbar, then choose the
command to control the simulation:

Connecting to and Disconnecting from the Server
from Excel
When you first open the default report, e-SCOR automatically attempts to connect
to the server. Exiting Excel automatically disconnects from the server.
You can manually connect and disconnect to the server, as well, for example, if for
some reason you need to shut down e-SCOR while Excel is still open.

361

To connect to and disconnect from the server from Excel:
 In Excel, choose Server > Connect or Disconnect from the e-SCOR floating
toolbar:

or
 Enter Ctrl + Shift + C to connect to the server.

Writing to and Reading from CSV Files
For any output or input report in the model, you can:

• Write output report data to an CSV file.
• Import input report data from an CSV file.
You use CSV (comma separated values) files to import report data into a graphics
program or to perform further analysis on the data.
You also use CSV files when using the Batch Simulation object to run multiple
simulations from a script. For more information, see Using Batch Simulation.

Writing Output Report Data to CSV Files
You can create a CSV file for any output report.
Caution Do not attempt to edit the CSV file while the simulation is running; otherwise, the
model cannot write the data to the file.
To write output report data to an CSV file:
1

Display the properties dialog for the output report whose data you want to
write to a CSV file and click the Excel tab.

2

Enable the Excel Report Enabled option.

3

Configure the report to update at the desired intervals.
For details, see Updating Output Reports at Regular Time Intervals.

4

Configure the report to keep a history, if desired.
For details, see Keeping a History of Data Values.

5
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Configure the attributes to appear in the report.

Writing to and Reading from CSV Files

For details, see Configuring the Attributes to Appear in a Report.
6

Configure the time unit, as needed.
For details, see Configuring the Time Unit.

7

Generate the output report data.
For details, see Generating Output Report Data from the Model.

For details, see Generating Output Report Data from the Model to Excel.
When you run the simulation and the report updates, e-SCOR writes the report
data to a CSV file located in the Output directory of your installation directory
with this format:
model-label Vmodel-version - report-title Vscenario-version.csv
For example, for the model named Simplest Model, the default CSV file name for
a Role Output report is:
Simplest Model V0.0 - Role Output V0.0.csv
The model-version is the Model Version of the Model object, and the scenarioversion is the Scenario Version of the Scenario object.

Importing Input Report Data from CSV Files
You can import data into the model from a CSV file.
To import data into the model from an CSV file:
1

Display the properties dialog for the input report whose data you want to
import from a CSV file and click the Excel tab.

2

Enable the Excel Report Enabled option.

3

Configure the attributes to appear in the report.
For details, see Configuring the Attributes to Appear in a Report.

4

Configure the time unit, as needed.
For details, see Configuring the Time Unit.

5

Create the input report, which also creates the CSV file.
For details, see Creating a Report in Excel.

Tip To create a new CSV file, you must first delete the existing CSV file by
choosing Delete CSV Report File on the report.

e-SCOR creates a CSV file located in the Output directory with this format:
model-label Vmodel-version - report-title Vscenario-version.csv
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For example, for the model named Simplest Model, the default CSV file name
for a Role Input report is:
Simplest Model V0.0 - Role Input V0.0.csv
The report contains a header row that identifies each input parameter to
configure and rows for each object in the report. Each row contains default
values for each parameter in the report.
6

Open the CSV file, edit the input report data, and save the data in CSV file
format.

Note Be sure to save the file in CSV format; do not save the file in Excel format.
Also, do not edit the first row of the report or the object labels that identify
each row of the report.
7

Choose Import Data from File on the report.

Importing data from the CSV file automatically applies the data to the model.

Writing to and Importing from Databases
For any output or input report in the model, you can:

• Write output report data to a database.
• Import input report data from a database.
For details, see Using Reports to Access External Databases.

Creating Specialized Reports
You can create the following specialized reports:

• Demand Reports, which include order demand parameters for configuring
demand parameters for the source product of a Consumer role, such as
Demand Order Duration and Demand Order Size.

• Role Transaction Reports, which records transactions that occur between
roles, including orders, purchases, products, and financials.

Creating Demand Reports
By default, you determine initial order demand for the overall supply chain by
configuring parameters on the Demand Order tab for the source products of each
Consumer category.
You might have actual order demand data for your supply chain, which you
would like to use in your model. You might also want to simulate change orders
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for existing orders. To do this, you configure initial order demand and change
orders through a report by:

• Creating a Demand Report with the initial order demand and change order
data.

• Importing order demand and specifying the report to use.
When you run the simulation, the model creates orders and change orders for as
many products as you configured in the report, then stops.
For detailed information on creating a Demand Report, see Configuring Demand
and Change Orders through a Demand Report.

Logging Transactions that Occur Between Roles
You can use the Role Transaction Report to record and analyze transactions that
occur between roles. These transactions include:

• Customer orders that buyers send to suppliers.
• Product shipments that suppliers send to buyers.
• Invoices that suppliers send to buyers.
• Payments that buyers send to suppliers.
• Purchase requests that buyers send to suppliers.
• Purchase responses that suppliers send to buyers.
• Purchase awards that buyers send to suppliers.
Each transaction is on its own line in the report and includes:

• The time at which the transaction occurred, in seconds, measured from the
beginning of the simulation.

• The model version, simulation version, and simulation run.
• The object that the role sent.
• The parameter values for the object at the time of the transaction.
Logging is useful for analyzing the model, based on transactions that occur.
Whereas output reports generate data at particular times during the simulation,
logging generates data when a model transaction occurs. For example, a report
that updates once a week might show no change in the inventory level, whereas a
log file shows orders going out and product shipments coming in at particular
times during the simulation.
You configure logging to occur for individual roles. The report includes
transactions that occur between the role and its upstream and downstream roles.
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Each time you enable logging, e-SCOR appends the new log data to the existing
report.
To log transactions that occur between roles:
1

Create a Role Transaction Report from the Reports palette of the e-SCOR
toolbox and place it on the model detail.

2

Display the properties dialog for each role for which you want to log
transactions and click the Logging tab.

3

Enable the Transaction Logging Enabled option.

4

Configure the Transaction Logging Report to be the report you created.

5

Enable the desired Transaction Filtering options, as follows:

6
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Logging Specification

Description

Log Orders

Logs orders that buyers send to suppliers.

Log Purchases

Logs purchase requests that buyers send to
suppliers, purchase responses that suppliers
send to buyers, and purchase awards that
buyers send to suppliers.

Log Products

Logs product shipments that suppliers send to
buyers.

Log Financials

Logs invoices that suppliers send to buyers
and payments that buyers send to suppliers.

Run the simulation.

Creating Specialized Reports

This figure shows how to configure the role dialog for logging all transactions:

Each role that has logging enabled generates report data that looks similar to the
following. The left-hand column shows the type of object. The example also
shows the timestamp at which the transaction occurred and the order type. The
log file contains additional data for each parameter the object defines.
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Introduction
You can access external databases directly through e-SCOR to:

• Write report data to a database.
• Read report data from a database.
To access external databases, you must create a database and configure the ODBC
data source. You then create and configure a Database Interface object as the link
between the database and e-SCOR.
To configure a report for database access, you specify the database table and
enable database reporting. When you run the simulation, e-SCOR writes output
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report data to a database when the report updates. To read input report data from
a database, you must explicitly import the data.
Note To configure ReThink for database access, you must be in Developer mode.

Configuring e-SCOR for Database Access
To access an external database, you must first start the ODBC Bridge and
configure your computer to use the bridge. You can access any external database
that the ODBC Bridge supports, including, Microsoft Access, Oracle, and
SQL2000.
The ODBC Bridge allows e-SCOR to communicate with external databases via a
Database Interface object and a TCP/IP connection.
This figure shows how e-SCOR communicates with a Microsoft Access database
through the ODBC Bridge:
e-SCOR

Database
Interface
object

TCP/IP

ODBC
Bridge

Microsoft
Access

To configure e-SCOR for database access, you:

• Create the database.
• Configure the ODBC data source.
• Start the ODBC Bridge process.
• Create and configure a Database Interface object.
• Connect to the database.

Creating the Database
You create the database by using any database that the ODBC Bridge supports.
To write report data to a database or read report data from a database, you create
the database manually, then you can create the database table directly from the
report object.
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Configuring the ODBC Data Source
Once you have created your database, you must configure the ODBC data source
on your computer to name the data source and point to your database. The
following example shows how to configure the ODBC data source for a Microsoft
Access database named Role_Report.mdb.
To configure the ODBC data source:
1

Display the ODBC Data Source Administrator dialog by choosing
Start > Programs > Administrative Tools > Data Sources (ODBC).

2

Click the System DSN tab.

3

Click Add to add a new ODBC data source.

4

Choose the appropriate driver for the database you created, for example,
Microsoft Access Driver (*.mdb) and click Finish.

5

Configure the Data Source Name to be any name, for example,
Role_Report.

6

Click the Select button, navigate to your database, and click OK.

7

Click OK in the ODBC Microsoft Access Setup dialog to create the new data
source.

371

The ODBC Data Source dialog should have an entry for each data source. For
example, the following dialog shows the Role_Report data source:
Microsoft Access data source named Role_Report.

Starting the ODBC Bridge Process
Once you have configured the ODBC data source, you can start the ODBC Bridge
process. You must identify the host and port to which the bridge is connected for
configuring in the Database Interface object.
To start the ODBC Bridge process:
 Choose Start > Programs > Gensym G2 2011 > Bridges > G2 ODBC Bridge.

The ODBC Bridge process appears in the command window.
To determine the bridge port:
 Open the command window for the bridge process.

The last line indicates the TPC/IP host and port number, for example:
TCP_IP:NSALVO-1165:22041
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Creating and Configuring the Database Interface
Object
The Database Interface object specifies:

• A name, which the reports use to connect to the database.
• The ODBC source as a connect string.
• The host and port of the machine running the database bridge.
If the bridge process is running on the local machine, the host is localhost. The
port number is 22041, or 22042, or 22043, and so on, depending on the number
of clients that are currently connected on that port.
You create a Database Interface object for each database you want your model to
access. Typically, you write data to one database and read data from another
database, which means you must create two Database Interface objects.
Note To configure a Database Interface object, you must be in Developer mode.
To create and configure a database interface object:
1

Switch to Developer mode.
For details, see Switching User Modes.

2

Choose Project > System Settings > Interfaces > SQL > Manage and click the
New button to create a new Database Interface object.
Alternatively, you can choose View > Toolbox - G2, click the Network
Interfaces tab, and create a Database Interface object.

3

In the properties dialog for the Database Interface object, configure the
Interface Name attribute to be any symbol, for example, orders-databaseinterface.

Tip This is the Database Interface Name you specify when you configure the
report for database access.
4

Configure the Type of Database to be Access-ODBC.

5

Configure the Bridge Host and Bridge Port attributes to match the host and
port of the machine running the bridge, localhost and 22041, by default.

6

Configure the Connect String attribute to be the name of the ODBC data
source, for example: role_report.

7

Click Apply to apply these values.

8

Choose Tools > User Mode > Modeler to return to Modeler mode.
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Here is a Database Interface object named reports-database-interface and its
properties dialog:

Connecting to the Database
Once you have started the ODBC bridge and configured the Database Interface
object, you can connect to the database via the Database Interface object. You
must be connected to write records to or read records from the database.
To connect to the database:
1

Switch to Developer mode.
For details, see Switching User Modes.

2

Choose Connect on the Database Interface object or click the Manual Connect
and Log In button in the properties dialog.

The color of the Database Interface object turns to green and the Interface Status
in the properties dialog becomes 2 to indicate it is connected.
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Here is a Database Interface object that is currently connected to the database:
Icon turns green
indicating it is connected.

Using Reports to Access External Databases
For any output or input report in the model, you can:

• Configure the report object for database access.
• Write output report data to a database.
• Import input report data from a database.

Configuring Report Objects for Database Access
To configure a report object for database access, you must identify the Database
Interface object that connects to the database. You must also identify the database
table to access. You can create the database table from the report object if it does
not exist.
The resulting database provides columns for each attribute configured in the
report. The resulting database also provides these standard columns, which you
can use for querying data:

• Row_ID, which is a unique ID for the row.
• Model_Version, which is the value of the Model Version attribute of the
associated Model tool.

• Simulation_Version, which is the value of the Simulation Version attribute of
the associated Scenario tool.

Note To use reports to access external databases, you must be in System-Administrator
mode.
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To configure a report object for database access:
1

Display the e-SCOR toolbar and click the Reports tab:

2

Create and configure the report:
For details, see:

• Creating Reports.
• Configuring the Time Unit.
• Updating Output Reports at Regular Time Intervals.
• Keeping a History of Data Values.
• Filtering Report Data.
• “Configuring the Attributes to Appear in a Report” on page 372.
3

Click the Database tab of the properties dialog for the report object, then click
the Database Reporting Enabled option on.

4

Configure the Database Interface Name to be the name of an existing database
interface object.
For details, see Configuring e-SCOR for Database Access.
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5

Configure the Database Table Name to be the name of an existing table in the
database or a new name.
The table name must be a legal database table name, with no spaces or
hyphens and no more than 32 characters, for example, role_output_report.

6

Click Apply to apply the values configured above.

7

If you entered the name of a database table that does not exist, click the Create
Database Table button to create the table.

Note The report must already be configured for database reporting before you can
create a table.

If you are using Microsoft Access, ensure that the database is closed before
attempting to create the table.
The database table now exists in the database with database fields for each
attribute defined in the report object. You can click Drop Database Table to drop
the table, as needed.
Here is the Database tab for a Role Output Report that is configured to access the
ODBC data source defined by the reports-database-interface Database Interface
object. The report writes data to the table named role_output_report.

377

Here is the resulting Microsoft Access database table that is created for the default
attributes of a Role Output Report before creating or updating the report:

Here is the Database tab for a Role Input Report that is configured to access the
ODBC data source defined by the input-report-database-interface Database
Interface object. The report imports data from the table named role_input_report.

Here is the resulting Microsoft Access database table that is created for the default
attributes of the Role Input Report before entering any data:
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Writing Output Report Data to a Database
To write output report data to a database, you simply create the report and run
the simulation. e-SCOR writes the report data to the database each time the report
updates, either manually or based on clock time or simulation time, and at the
end of the simulation.
To write output report data to a database:
1

Configure e-SCOR for database access.
For details, see Configuring e-SCOR for Database Access.

2

Configure the report object for database access.
For details, see Configuring Report Objects for Database Access.

Note If you are using Microsoft Access, ensure that the database is closed before
you run the simulation.
3

Run the simulation.

Typically, when writing report data to a database, you run the simulation for a
fixed duration. For details, see Configuring the Duration of the Simulation.
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This figure shows a model that is configured to write Role Output Report data to
a database:

Here is the resulting Microsoft Access database table that is created for the two
roles after creating or updating the report:
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Importing Input Report Data from a Database
To import input report data from a database, you must populate the database
table with data that corresponds to the report you create, then you import the
data. Importing the data updates values in the model.
To import input report data from a database:
1

Configure e-SCOR for database access.
For details, see Configuring e-SCOR for Database Access.

2

Configure the report object for database access.
For details, see Configuring Report Objects for Database Access.

3

Choose Import Data from Database on the report object, or on the Database
tab of the Report object, click the Import Data from Table button.

This figure shows a model that is configured to import Role Input Report data
from a database:
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Here is the Microsoft Access database table from which the data is to be imported:
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Introduction
You use the Batch Simulation object to:

• Run multiple simulations from a script.
• Change the value of any parameter in the model while the simulation is
running.

For example, you can use the Batch Simulation object to optimize key parameters
and metrics by running multiple simulations, using different parameter values for
each simulation. You can then save the results to separate reports to analyze the
results. You can also use the Batch Simulation object to determine the impact on
the current model of changes in key parameters over time, such as those that
determine initial order demand.
To use the Batch Simulation object, you create a script that consists of a number of
keywords. The keywords identify the model to run and the various parameter
values to set. You can set parameter values for roles, categories, and product
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composites. You can save the results of a simulation to an Excel report, CSV file,
or database associated with an output report.
The keywords that set parameter values correspond to the parameter names in
the dialogs. For example, the SET-PRODUCT-ACQUISITION-COST keyword sets the
Product Acquisition cost parameter of a Source category.
Each keyword may take the following arguments, which identify the object and
value to set:

• The role label.
• The category label or product composite label, depending on the parameter.
• The new value.
• The simulation time at which to set the value, for example, 0, which sets the
value immediately after the Scenario has been reset, or 4 weeks, which sets
the value 4 weeks into the simulation.

The keywords that set timing parameters for categories take additional
arguments that set the Distribution Mode parameter and associated keyword
values. The keywords that set sort-order parameters, such as Sort Attribute 1 in
the Award Criteria group of the Source category, take an additional argument for
setting the parameter number.
The keywords and the arguments to keywords are not case-sensitive in the script.
The script ignores extra spaces and carriage returns in labels. When entering time
values, you may enter hour or hours, minute or minutes, and so on.
The script executes in the order in which the keywords appear.
This topic includes:

• Running simulations by using the Batch Simulation object.
• Example scripts.
• Simulation keywords.
• Report keywords.
• Scenario and model parameter keywords.
• Role parameter keywords.
• General category parameter keywords.
• Timing category parameter keywords.
• Sort-order category parameter keywords.
• Product composite parameter keywords.
• Resource parameter keywords.
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Using the Batch Simulation Object to Run
Simulations
You might want to run several simulations for the same model, each with
different values for the Safety Stock parameter. Alternatively, you might want to
run a single simulation in which the value of the Build Yield parameter increases
over time, which is common in many manufacturing processes.
You identify the simulation to run by referring to a unique scenario.
To use the Batch Simulation object to run simulations:
1

Display the properties dialog for the Scenario and configure the Label
parameter to be a unique name.

2

Choose Toolbox - ReThink to display the ReThink toolbox, then click the
Tools palette:

Batch Simulation Object

3

Select the Batch Simulation object and place it on the model detail or organizer
detail.

4

Display the properties dialog for the Batch Simulation object and configure
the script.
To do this, enter keywords and arguments in the Script field.
For information on the available keywords, see:

• Simulation Keywords.
• Report Keywords.
• Role Parameter Keywords.
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• Cost Category Parameter Keywords.
• Timing Category Parameter Keywords.
• Sort-Order Category Parameter Keywords.
• Product Composite Parameter Keywords.
5

Add comments to the script, as needed, using the following syntax:
/* this is a comment */

6

To verify that you have entered the keywords in the script correctly, click the
Check Script button:
e-SCOR displays error messages and warnings in red and yellow,
respectively, in the Log Book area.
For example, the Batch Simulation object generates an error if you have not
named the scenario, if an object does not exist, or if you have entered a
keyword that does not exist.

7

Click the Start button to start running the script:
e-SCOR displays messages in green in the Log Book each time a keyword
completes its execution, so you can follow the progress of the simulation.

8

To pause the simulation, click the Pause button:

9

To resume the simulation, click the Resume button:

10 To stop the simulation, click the Stop button:

e-SCOR completes the execution of the currently active keyword before pausing
or stopping the simulation. Normally, you let the script run by itself until it
finishes.
When the simulation finishes, it is as if you had run the simulation manually;
metrics compute normally and reports update at the specified time intervals. If
the script sets parameter values, the values update at the specified time and the
simulation continues.
Typically, if you are running multiple simulations, you save report data at the end
of one simulation, before starting the next one.
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For example, this script runs the simulation associated with Scenario-1 for 91
days, saves a report, then sets the Order Period parameters to different values,
runs the simulation again, then saves the report to a new file name. Notice that
the keyword that sets the Order Period parameter comes before the startsimulation keyword.
select-scenario(scenario-1)
set-order-period(consumer,product family,
triangular,5 days,6 days,7 days,0)
start-simulation(91 days)
wait-simulation
set-file-reporting(role output,true,Role Output Report 1.csv)
save-report(role output)
set-order-period(consumer,product family,
triangular,10 days,12 days,14 days,0)
start-simulation(91 days)
wait-simulation
set-file-reporting(role output,true,Role Output Report 2.csv)
save-report(role-output)

Here is the Batch Simulation object dialog:
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Example Scripts
This section provides example scripts that help you:

• Determine the impact of seasonal demand.
• Model changes in order demand over product life cycle.
• Determine optimal replenishment levels.

Determining the Impact of Seasonal Demand
Suppose you want to model seasonal demand by increasing initial order demand
during the course of the simulation, for example, during the holiday season.
You could create a Batch Simulation object that runs a single simulation for one
year, where the Order Size and Order Period parameters of product family
increase after 11 months (44 weeks) into the simulation, as this script shows:
select-scenario(scenario-1)
set-order-size(consumer,product family,
triangular,10,15,20,0)
set-order-period(consumer,product family,
triangular,6 days,7 days,8 days,0)
set-order-size(consumer,product family,
triangular,15,20,25,44 weeks)
set-order-period(consumer,product family,
triangular,4 days,5 days,6 days,44 weeks)
start-simulation(45 weeks)
wait-simulation
set-file-reporting(level 2 output,true,
Level 2 Output Report 1.csv)
save-report(role-output)
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Modeling Changes in Order Demand Over Product
Life Cycles
Suppose you want to model changes in order demand patterns over a product’s
life cycle. For example, in the first year, initial order demand might be relatively
high with a high degree of variation, which you model by using a triangular
distribution. After the first year, initial order demand might decrease around a
more stable mean, which you model by using an exponential distribution. An
exponential distribution generally has less variation, except very occasionally.
You could create a Batch Simulation object that changes the mathematical
distribution of the Order Size and Order Period parameters over time, as follows:
select-scenario(scenario-1)
set-order-size(consumer,product family,
triangular,10,15,20,0)
set-order-period(consumer,product family,
triangular,6 days,7 days,8 days,0)
set-order-size(consumer,product family,
exponential,10,52 weeks)
set-order-period(consumer,product family,
exponential,10 days,52 weeks)
start-simulation(104 weeks)
wait-simulation
set-file-reporting(level 2 output,true,
Level 2 Output Report 1.csv)
save-report(role-output)
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Determining Optimal Replenishment Levels
Suppose you want to determine the optimal value for the Safety Stock parameter
for the delivery product of a Distributor role. At the same time, you want to
ensure that the Supplier On-Time Performance metric of the downstream
Consumer role never falls below 100%.
You could create a Batch Simulation object that runs a number of simulations,
using different values for Safety Stock, as this script shows:
select-scenario(scenario-1)
set-safety-stock-level(site a,product,1800,0)
set-safety-stock-level(site b,product,4000,0)
set-safety-stock-level(site c,product,1200,0)
set-safety-stock-level(central distributor,
product,7000,0)
start-simulation(45 weeks)
wait-simulation
set-file-reporting(level 2 output,true,
Level 2 Output Report 1.csv)
save-report(level 2 output)
set-safety-stock-level(site a,product,2000,0)
set-safety-stock-level(site b,product,5000,0)
set-safety-stock-level(site c,product,1400,0)
set-safety-stock-level(central distributor,
product,8300,0)
start-simulation(45 weeks)
wait-simulation
set-file-reporting(level 2 output,true,
Level 2 Output Report 2.csv)
save-report(level 2 output)
set-safety-stock-level(site a,product,2250,0)
set-safety-stock-level(site b,product,6000,0)
set-safety-stock-level(site c,product,1500,0)
set-safety-stock-level(central distributor,
product,9750,0)
start-simulation(45 weeks)
wait-simulation
set-file-reporting(level 2 output,true,
Level 2 Output Report 3.csv)
save-report(level 2 output)
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Simulation Keywords
You use the Batch Simulation object to run a simulation for one or more scenarios
and for a specified duration for each. To run multiple simulations, you must wait
until the first simulation is finished running before starting another.
SELECT-SCENARIO(<scenario-label>)
Determines the scenario to use for all operations in the simulation, until a new
scenario is selected. You must configure the Label parameter of the scenario to
be a unique name.
Example:
SELECT-SCENARIO(Scenario 1)
START-SIMULATION(<duration>)
Starts the simulation and determines the duration of the simulation.
Note Always set parameter values before you start the simulation, even if you
schedule the parameter values to be set during the simulation.

Example:
START-SIMULATION(52 weeks)
WAIT-SIMULATION
Waits until the scenario is finished running. Use this keyword to run multiple
simulations for the same model, using different parameter values. This
keyword has no arguments.
CREATE-NEW-SEED(<truth-value>)
Whether to create a new value for the simulation.
SET-NEW-SEED(<seed>)
Sets a new seed value for the simulation.
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Report Keywords
The following keywords control various reporting functions that can occur
during the simulation. All keywords specify the <report-title> argument to
identify the report object. When you save a report, it writes the report data to an
Excel report, CSV file, or database, depending on how the report is configured.
SET-FILE-REPORTING(<report-title>,<excel-report-enabled>,
<excel-report-filename>)
Enables the creation of CSV files for reports and specifies the .csv file name to
create, as if you had clicked the Excel Report Enabled option and specified the
file name in the report dialog. This keyword sets the file name to save when
you use the SAVE-REPORT keyword. Typically, you save report data to
separate CSV files; otherwise, saving report data overwrites the file data.
Example:
SET-FILE-REPORTING(role output report,true,
role summary report.csv)
UPDATE-REPORT(<report-title>, <time>)
Updates a report at the specified simulation time interval, as if you had
manually updated the report while the simulation was running.
Example:
UPDATE-REPORT(role output report, 1 hour)
SAVE-REPORT(<report-title>)
Saves report data to the .csv file associated with the report that you set by
using the SET-FILE-REPORTING keyword. To save reports to different
filenames, use the SET-FILE-REPORTING keyword each time you use
SAVE-REPORT.
If an Excel client is currently connected or if a report view is currently visible
in the client, this keyword updates the report in Excel or the client.
If the report object is configured to output data to a database, this keyword
saves the report data to the specified database. The database table includes
columns for the Model_Version and Simulation_Version to uniquely identify
data for each simulation run of each model.
Example:
SAVE-REPORT(role output report)
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LOAD-REPORT(<report-title>)
Loads the .csv file associated with an input report, as if you had clicked the
Import Data from File button in the report dialog.
Example:
LOAD-REPORT(role input report)
LOAD-REPORT-FROM-DATABASE (<report-title>)
Loads the data from the database associated with an input report, as if you
had clicked the Import Data from Table button.
Example:
LOAD-REPORT-FROM-DATABASE(role input report)

Scenario and Model Parameter Keywords
These keywords set parameter values for Scenario and Model tools. The name of
the keyword corresponds to the resource parameter to set.
You specify <label>, the <new-value> for the parameter and the <time>.
For example, the following keyword sets the Scenario Version parameter to 2 for
the Scenario tool named my-scenario at the start of the simulation:
SET-SCENARIO-VERSION
(my-scenario,2,0)
SET-SCENARIO-VERSION(<scenario-label>,
<new-value>, <time>)
SET-MODEL-VERSION(<model-label>, <new-value>, <time>)

Role Parameter Keywords
These keywords set parameters for roles. The name of the keyword corresponds
with the role parameter to set.
You specify the <role-label>, a <new-value> for the parameter, and the <time>.
For example, the following keyword sets the Financial Period of the Computer
Manufacturer role to be 90 days at the start of the simulation:
SET-FINANCIAL-PERIOD(computer manufacturer,90 days,0)
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SET-STATISTICAL-METRICS-PERIOD(<role-label>,
<new-value>,<time>)
SET-FINANCIAL-PERIOD(<role-label>,
<new-value>,<time>)
SET-FINANCIAL-PAYMENT-TERMS(<role-label>,
<new-value>,<time>)
SET-SOURCE-PRODUCTS(<role-label>,
<comma-separated list of source products>,<time>)
SET-DELIVERY-PRODUCTS(<role-label>,
<comma-separated list of delivery products>,<time>)
SET-LOG-ORDERS(<role-label>,
<new-value>,<time>)
SET-LOG-PURCHASES(<role-label>,
<new-value>,<time>)
SET-LOG-PRODUCTS(<role-label>,
<new-value>,<time>)
SET-LOG-FINANCIALS(<role-label>,
<new-value>,<time>)
SET-ALLOW-TRANSACTION-LOGGING(<role-label>,
<new-value>,<time>)
SET-LOGGING-REPORT-NAME(<role-label>,
<new-value>,<time>)

Cost Category Parameter Keywords
These keywords set values for Level 2 category cost parameters for the Source,
Make, and Deliver categories. The name of the keyword corresponds to the Level
2 category parameter to set.
You specify the <role-label> of the role on whose detail the category exists, the
<level-2-label>, a <new-value> for the parameter, and the <time> at which the
parameter should be set.
For example, the following keyword sets the Product Acquisition cost parameter
of the S1: Source Stocked Products category on the Computer Manufacturer role
detail at the start of the simulation:
SET-RECEIVING-COST(computer manufacturer,
s1: source stocked product,10,0)
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The general category parameter keywords are organized as follows:

• Source category keywords
• Make category keywords
• Deliver category keywords
• Plan category keywords

Source Category Keywords
SET-RECEIVING-COST(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-VERIFICATION-COST(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-TRANSFER-COST(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-CREATE-CUSTOMER-ORDER-COST(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-CREATE-INVOICE-COST(<role-label>,
<level-2-label>,<new-value>,<time>)

Make Category Keywords
SET-PRODUCTION-MATERIAL-HANDLING-COST(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-ECO-COST(<role-label>,<level-2-label>,
<order-number>,<new-value>,<time>)

Deliver Category Keywords
SET-ORDER-ENTRY-COST(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-ORDER-FULFILLMENT-COST(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-PICK-COST(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-PACKING-COST(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-TRANSPORTATION-COST(<role-label>,
<level-2-label>,<new-value>,<time>)
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SET-CUSTOMER-INVOICING-COST(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-CUSTOMER-COLLECTIONS-COST(<role-label>,
<level-2-label>,<new-value>,<time>)

Plan Category Keywords
These keywords set values for Plan category parameters. The name of the
keyword corresponds to the Plan category parameter to set.
You specify the <role-label> of the role on whose detail the category exists, the
<level-2-label>, a <new-value> for the parameter, and the <time> at which the
parameter should be set.
SET-PLANNING-PERIOD(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-INITIAL-PLAN-DELAY(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-CONTINUOUS-PLANNING(<role-label>,
<level-2-label>,<new-value>,<time>)
SET-COMPENSATE-FOR-YIELD(<role-label>,
<level-2-label>,<new-value>,<time>)

Timing Category Parameter Keywords
These keywords set values for Level 2 category timing parameters. You specify
the <role-label> of the role on whose detail the category exists, the
<level-2-label>, the <mode-type>, <mode-type-args>, and the <time>.
The <mode-type> and <mode-type-args> is one of:
FIXED <mean>
EXPONENTIAL,<mean>
NORMAL,<mean>,<standard-deviation>
UNIFORM,<min>,<max>
TRIANGULAR,<min>,<mode>,<max>
BETA <min>,<max>,<alpha>,<beta>
ERLANG,<mean>
WEIBULL,<shape>,<scale>
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LOGNORMAL,<mean>,<standard-deviation>
GAMMA,<alpha>,<beta>
For example, the following keyword sets the Receiving Duration parameter of
the S1: Source Stocked Products category on the Computer Manufacturer role
detail to a Triangular distribution, with a Min, Max, and Mode value of 1 hour, 2
hours, and 3 hours, respectively, at the start of the simulation:
SET-RECEIVING-DURATION(computer manufacturer,
s1: source stocked product,TRIANGULAR,1 hour,2 hours,
3 hours,0)
The timing category parameter keywords are organized as follows:

• Source category keywords
• Make category keywords
• Deliver category keywords

Source Category Keywords
SET-RECEIVING-DURATION(<role-label>,
<level-2-label>,<mode-type>,<mode-type-args>,<time>)
SET-VERIFICATION-DURATION(<role-label>,
<level-2-label>,<mode-type>,<mode-type-args>,<time>)
SET-TRANSFER-DURATION(<role-label>,
<level-2-label>,<mode-type>,<mode-type-args>,<time>)

Make Category Keywords
SET-ORDER-RELEASE-TO-MANUFACTURING-DURATION(<role-label>,
<level-2-label>,<mode-type>,<mode-type-args>,<time>)
SET-PRODUCTION-MATERIAL-DURATION(<role-label>,
<level-2-label>,<mode-type>,<mode-type-args>,<time>)
SET-MANUFACTURING-DURATION(<role-label>,<level-2-label>,
<mode-type>,<mode-type-args>,<time>)
SET-MOVE-TO-DELIVERY-DURATION(<role-label>,
<level-2-label>,<mode-type>,<mode-type-args>,<time>)
SET-ENGINEERING-DURATION(<role-label>,
<level-2-label>,<mode-type>,<mode-type-args>,<time>)
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Deliver Category Keywords
SET-ORDER-ENTRY-DURATION(<role-label>,
<level-2-label>,<mode-type>,<mode-type-args>,<time>)
SET-PICK-DURATION(<role-label>,
<level-2-label>,<mode-type>,<mode-type-args>,<time>)
SET-PACKING-DURATION(<role-label>,
<level-2-label>,<mode-type>,<mode-type-args>,<time>)
SET-TRANSPORTATION-DURATION(<role-label>,
<level-2-label>,<mode-type>,<mode-type-args>,<time>)

Sort-Order Category Parameter Keywords
This keyword sets values for Make and Deliver category parameters that
determine sort order for selecting build orders and replenishment orders for
Manufacturing and Distributor roles, respectively.
You specify the <role-label> of the role, the <level-2-label>, the
<order-number> of the attribute to set, which is an integer between 1 and 4, the
<new-value> for the parameter, and the <time>.
For example, the following keyword sets the first Build Selection criteria
parameter of the M1: Make Stocked Product category of the Computer
Manufacturer role to Total Cost at the start of the simulation:
SET-SORT-ORDER-CRITERIA
(computer manufacturer,m1: make stocked product,1,
total-cost,0)

SET-SORT-ORDER-DIRECTION(<role-label>,
<level-2-label>,<order-number>,<new-value>,<time>)
SET-ORDER-SORT-CRITERIA(<role-label>,
<level-2-label>,<order-number>,<new-value>,<time>)
SET-ORDER-CUTOFF(<role-label>,
<level-2-label>,<order-number>,<new-value>,<time>)
SET-ORDER-CUTOFF-VALUE(<role-label>,
<level-2-label>,<order-number>,<new-value>,<time>)
SET-ORDER-CUTOFF-DURATION(<role-label>,
<level-2-label>,<order-number>,<new-value>,<time>)
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Product Composite Parameter Keywords
These keywords set parameter values for product composites. The name of the
keyword corresponds to the product composite parameter to set.
For many keywords, you specify the <role-label> of the role in whose Products
pool the product composite exists, the <product-name>, the <new-value> for the
parameter, and the <time>.
For example, the following keyword sets the Product Preference parameter of the
Computer delivery product for the Computer Manufacturer role to 1 at the start
of the simulation:
SET-PRODUCT-PREFERENCE
(computer manufacturer,computer,1,0)
The product composite category parameter keywords are organized as follows:

• General tab keywords
• Demand tab keywords
• Sourcing tab keywords
• Supplier tab keywords
• Supplier Selection tab keywords
• Multipliers tab keywords
• Delivery tab keywords
• Inventory tab keywords
• Manufacturing tab keywords

General Tab Keywords
SET-ORDER-TYPE(<role-label>,
<product-name>,<new-value>,<time>)
<new-order-type-value> is one of: stock, mto, or eto
SET-PRODUCT-PREFERENCE(<role-label>,
<product-name>,<new-value>,<time>)
SET-SUPPLIER-PREFERENCE(<role-label>,
<product-name>,<new-value>,<time>)
SET-CUSTOMER-PREFERENCE(<role-label>,
<product-name>,<new-value>,<time>)

399

Demand Tab Keywords
SET-DEMAND-START-TIME(<consumer-role-label>,
<product-name>,<new-value>,<time>)
SET-DEMAND-STOP-TIME(<consumer-role-label>,
<product-name>,<new-value>,<time>)
SET-ORDER-SIZE(<consumer-role-label>,<product-name>,
<mode-type>,<mode-type-args>,<time>)
SET-ORDER-PERIOD(<consumer-role-label>,<product-name>,
<mode-type>,<mode-type-args>,<time>)
SET-USE-DEMAND-INPUT-REPORT(<consumer-role-label>,
<product-name>,<new-value>,<time>)
SET-DEMAND-INPUT-REPORT-NAME(<consumer-role-label>,
<product-name>,<new-value>,<time>)

Sourcing Tab Keywords
SET-PURCHASE-COST(<base-mfg-role-label>,
<product-name>,<new-value>,<time>)

Supplier Tab Keywords
SET-DESIRED-TURNAROUND(<role-label>,
<product-name>,<new-value>,<time>)
SET-FULFILLMENT-PREFERENCE(<role-label>,
<product-name>,<new-value>,<time>)
SET-FULFILLMENT-USING-ALTERNATE-PRODUCTS(<role-label>,
<product-name>,<new-value>,<time>)
SET-PUSH-STOCK-PRODUCT(<role-label>
<product-name>,<new-value>,<time>)
SET-CONTRACT-START-TIME(<role-label>,
<product-name>,<new-value>,<time>)
SET-CONTRACT-LENGTH(<role-label>,
<product-name>,new-value>,<time>)
SET-CONTRACT-RESPONSE-TIME(<role-label>,
<product-name>,<new-value>,<time>)
SET-FORECAST-ESTIMATED-AMOUNT(<role-label>,
<product-name>,<new-value>,<time>)
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SET-CONTRACT-REPETITION-COUNT(<role-label>,
<product-name>,<new-value>,<time>)

Supplier Selection Tab Keywords
SET-MAXIMUM-NUMBER-OF-SUPPLIERS(<role-label>,
<product-name>,<new-value>,<time>)
SET-SPLIT-ORDER-BETWEEN-SUPPLIERS(<role-label>,
<product-name>,<new-value>,<time>)
SET-SUPPLIER-SELECTION-CRITERIA(<role-label>,
<product-name>,<criteria-number>,<new-value>,<time>)
This keyword sets values for product composite parameters that determine
sort order for selecting suppliers: Supplier Selection Criteria 1, Supplier
Selection Criteria 2, etc., where <criteria-number> is an integer between
1 and 4, corresponding to the criteria number, and <new-value> is the
attribute to use for the sort criteria.
SET-SELECTED-SUPPLIERS-PROPORTIONS(<role-label>,
<product-name>,<comma-separated-list of supplier proportions>,
<time>)
SET-POTENTIAL-SUPPLIERS(<role-label>,
<product-name>,<comma-separated-list of potential suppliers>
,<time>)

Multipliers Tab Keywords
SET-RECEIVING-DURATION-MULTIPLIER(<role-label>,
<product-name>,<new-value>,<time>)
SET-VERIFICATION-DURATION-MULTIPLIER(<role-label>,
<product-name>,<new-value>,<time>)
SET-TRANSFER-DURATION-MULTIPLIER(<role-label>,
<product-name>,<new-value>,<time>)
SET-ENGINEERING-DURATION-MULTIPLIER(<role-label>,
<product-name>,<new-value>,<time>)
SET-ORDER-RELEASE-TO-MANUFACTURING-DURATION-MULTIPLIER
(<role-label>,<product-name>,<new-value>,<time>)
SET-PRODUCTION-MATERIAL-DURATION-MULTIPLIER(<role-label>,
<product-name>,<new-value>,<time>)
SET-MANUFACTURING-DURATION-MULTIPLIER(<role-label>,
<product-name>,<new-value>,<time>)
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SET-MOVE-TO-DELIVERY-DURATION-MULTIPLIER(<role-label>,
<product-name>,<new-value>,<time>)
SET-ORDER-ENTRY-DURATION-MULTIPLIER(<role-label>,
<product-name>,<new-value>,<time>)
SET-PICK-DURATION-MULTIPLIER(<role-label>,
<product-name>,<new-value>,<time>)
SET-PACKING-DURATION-MULTIPLIER(<role-label>,
<product-name>,<new-value>,<time>)
SET-TRANSPORTATION-DURATION-MULTIPLIER(<role-label>,
<product-name>,<new-value>,<time>)

Delivery Tab Keywords
SET-PUBLISHED-DELIVERY-LEAD-TIME(<role-label>,
<product-name>,<new-value>,<time>)
SET-NET-SELLING-PRICE(<role-label>,
<product-name>,<new-value>,<time>)

Inventory Tab Keywords
SET-STARTING-INVENTORY-LEVEL(<role-label>,
<product-name>,<new-value>,<time>)
SET-MAXIMUM-INVENTORY-LEVEL(<role-label>,
<product-name>,<new-value>,<time>)
SET-INVENTORY-CONTROL-STRATEGY(<role-label>,
<product-name>,<new-value>,<time>)
SET-SAFETY-STOCK-LEVEL(<role-label>,
<product-name>,<new-value>,<time>)
SET-MINIMUM-REORDER-QUANTITY(<role-label>,
<product-name>,<new-value>,<time>)

Manufacturing Tab Keywords
SET-YIELD(<role-label>,
<product-name>,<new-value>,<time>)
SET-MINIMUM-BATCH-SIZE(<role-label>,
<product-name>,<new-value>,<time>)
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SET-MAXIMUM-BATCH-SIZE(<role-label>,
<product-name>,<new-value>,<time>)
SET-BUILD-TIME-DEPENDENT-ON-ORDER-SIZE(<role-label>,
<product-name>,<new-value>,<time>)

Resource Parameter Keywords
These keywords set parameter values for resources. The name of the keyword
corresponds to the resource parameter to set.
You specify the <role-label> of the role, the <plant-label>, the <new-value>
for the parameter, and the <time>.
For example, the following keyword sets the Resource Capacity parameter of the
Headquarters plant for the Computer Manufacturer role to 10 at the start of the
simulation:
SET-RESOURCE-CAPACITY
(headquarters,10,0)

SET-RESOURCE-CAPACITY(<<plant-label>, <new-value>, <time>)
SET-RESOURCE-EFFICIENCY(<role-label>, <plant-label>,
<new-value>, <time>)
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Part III
Building
e-SCOR Models
Chapter 13: Modeling a Distribution Process
Describes how to build a model that includes a Distributor role, which can deliver its source
products, assemble components into kits, and outsource finished products.
Chapter 14: Modeling a Manufacturing Process
Describes how to build a model that provides “value-added” to the process by including a
Manufacturer role, which manufactures finished products from components.
Chapter 15: Using Stock Planning Strategies
Describes the two planning strategies available for sourcing and delivering stock products:
replenishment, forecast, Q, and R-Q.
Chapter 16: Using Alternative Planning Strategies
Describes how to configure a role to source, make, and/or deliver stock, make-to-order, and/or
engineer-to-order products.
Chapter 17: Modeling a Process with Multiple Suppliers
Describes how to build a model that sources identical products from multiple suppliers, using
contracts.
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Chapter 18: Configuring Role Details for Multiple Products
Describes how to configure the detail of supplier and buyer roles to source, make, and/or
deliver multiple products.
Chapter 19: Using Pull and Push Planning Modes
Describes how to use pull and push planning modes to determine when to source, make, and
deliver products, and how much to source, make, and deliver.
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13
Modeling a
Distribution Process
Describes how to build a model that includes a Distributor role, which can deliver
its source products, assemble components into kits, and outsource finished
products.
Introduction 418
Configuring a Distributor to Deliver its Source Products 418
Configuring a Distributor to Assemble Components into Kits 421
Configuring a Distributor Role to Outsource Finished Products 424
Configuring Level 2 Parameters for a Distributor Role 426
Configuring Order Selection Parameters 428
What Happens When the Simulation Runs 436
Analyzing the Performance of a Distributor Role 437
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Introduction
You configure a Distributor role to deliver its source products, assemble
components into kits, or outsource finished products.
A Distributor role uses source planning to determine when the role orders its
source products and, implicitly, when it delivers its delivery products.
To model a distribution process, you:

• Configure the Distributor role to use one of these techniques:
– Deliver its source products, which are either components or finished
products.

– Assemble components into kits by sourcing components and delivering
finished products.

– Outsource finished products from a secondary supplier by sourcing and
delivering both components and finished products.

• Configure Level 2 parameters for a Distributor role.
• Configure order selection parameters for the Deliver category to choose which
orders to deliver first.

• Understand what happens when the simulation runs for a Distributor role.
• Analyze the performance of the distribution process by viewing metrics.

Configuring a Distributor to Deliver its Source
Products
Your supply chain might have a Distributor role that delivers the products it
receives from its upstream suppliers. These products can be components or
finished products.
To configure a Distributor role to deliver its source products, you assign the same
product specification as both the source product and the delivery product of the
role. e-SCOR creates a single product composite in the Products pool for the
product specification you assign, which is both a source product and a delivery
product.
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The following figure shows a model in which the Distributor role sources and
delivers components. When you assign the components to the Distributor role,
e-SCOR creates a single product composite, which is both a source product and a
delivery product.

Product specification

Products pool
Components:
Is Source Product = true
Is Delivery Product = true
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The next figure shows a model in which the Distributor role sources and delivers
finished products. The Distributor role sources computers from the Manufacturer
role, which manufactures them from components. When you assign the finished
product to the Distributor role, e-SCOR creates a product composite for the
finished product, which, again, is both a source product and a delivery product.

Product hierarchy

Products pool
Computer:
Is Source Product = true
Is Delivery Product = true

To configure a Distributor role to deliver its source products:
 Assign to a Distributor role components or finished products as both the
Source Product and Delivery Product of the role.

For details, see Configuring the Products a Role Sources and Delivers.
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Configuring a Distributor to Assemble
Components into Kits
Your supply chain might have a Distributor role that sources components,
assembles those components into kits, and delivers the kits to a downstream
buyer. To configure a Distributor role to assemble components into kits, you:

• Assign the components as the source product and the kits as the delivery
product of the role.

• Configure the delivery product to be a kit.
This configuration is similar to that of a Manufacturer role that sources
component, and makes and delivers finished products. However, the difference is
that assembling components into a kit simply adds to the simulation clock the
amount of time it takes to assemble the components, whereas manufacturing
finished products from components adds both time and value to the process.
The following figure shows a model in which the Distributor role assembles
components into kits. The Distributor role sources components from the Base
Manufacturer role and assembles those components into computer kits. You
assign the components and computer kit as the source and delivery products of
the role, respectively. e-SCOR creates a source product for the components and a
delivery product for the computer kit.
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Product hierarchy

Products pool

Components:
Is Source Product = true
Is Delivery Product = false
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Computer Kit:
Is Source Product = false
Is Delivery Product = true

Configuring a Distributor to Assemble Components into Kits

To configure a Distributor role to assemble components into kits:
1

Create a product hierarchy that contains a finished product with components.
For details, see Creating a Product Hierarchy with Components.

2

Assign to the Distributor role the components as the Source Product and the
finished product kits as the Delivery Product.
In the example above, the Product tab of the Distributor role’s dialog would
look like this:

For details, see Configuring the Products a Role Sources and Delivers.
3

On the General tab of the properties dialog for the delivery product that is a
kit, enable the Is Kitted option.

For information on configuring delivery products, see Configuring Parameters
for Delivery Products.
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Here is the properties dialog for the Computer Kit delivery product of the
Distributor role:

Indicates the delivery
product is assembled into
a kit from components.

Configuring a Distributor Role to Outsource
Finished Products
You might have a supply chain in which a Distributor role assembles components
into kits, while at the same time outsources those same kits as finished products
from a secondary supplier. You use this technique to address component
shortages when assembling components into kits. You can specify whether the
Distributor role prefers to deliver the kits that it assembles from components or
the complete finished products that it outsources from a secondary supplier.
The following figure shows a model in which the Distributor role both assembles
components into kits and outsources finished products. The Distributor role
sources components from the Component Manufacturer role and assembles those
components into computer kits. It also sources finished computers from the
Finished Computer Supplier role by outsourcing.
You assign both the components and the computer kits as the source products of
the role and the computer kit as the delivery product. e-SCOR creates two
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product composites, one for the components, which is both a source and delivery
product, and one for the computer kit, which is a delivery product.

Product hierarchy

Products pool

Components:
Is Source Product = true
Is Delivery Product = false

Computer Kit:
Is Source Product = true
Is Delivery Product = true

To configure a Distributor role to outsource finished products:
1

Create a product hierarchy that contains a finished product with components.
For details, see Creating a Product Hierarchy with Components.

2

Assign to the Distributor role the components as a Source Product, and the
finished products as both a Source Product and a Delivery Product.
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In the example above, the Product tab of the Distributor dialog would look
like this:

For details, see Configuring the Products a Role Sources and Delivers.
3

On the General tab of the properties dialog for the delivery product that is a
kit, enable the Is Kitted option.

Configuring Level 2 Parameters for a
Distributor Role
To configure the Level 2 parameters of a Distributor role, it is helpful to think
about the distribution process in terms of the upstream source and the
downstream delivery subprocesses. Each of these subprocesses has parameters
you can configure.
The following list of configurable parameters assumes a stock/replenishment
planning strategy, a single delivery product, a single supplier for each source
product, and a pull planning mode. See the referenced sections at the end of this
section for information about additional parameters you must configure for each
of these alternative modeling techniques.
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• Upstream source subprocess
Source category:

– Receiving Duration
– Verification Duration
– Transfer Duration
– Receiving, Verification, Transfer, Create Customer Order, and Invoice
costs

P2: Plan Source category:

– Planning Period
– Initial Plan Delay
– Continuous Planning
Source products:

– Order Type
– Customer Preference
– Starting Product Inventory Level
– Maximum Inventory Level
– Inventory Control Strategy
– Safety Stock
– Minimum Reorder Quantity
– Desired Turnaround
– Fulfillment Preference
– Fulfillment Using Alternate Products
– Receiving Duration Multiplier, Verification Duration Multiplier, and
Transfer Duration Multiplier

• Downstream delivery subprocess
Deliver categories:

– Order Entry Duration
– Order Selection parameters
– Pick Duration
– Packing Duration
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– Transportation Duration
– Order Entry, Order Fulfillment, Pick, Packing, Transportation, Customer
Invoicing, and Customer Collections costs

Delivery products:

– Order Type
– Product Preference
– Starting Product Inventory Level
– Maximum Inventory Level
– Inventory Control Strategy
– Safety Stock
– Minimum Reorder Quantity
– Published Delivery Lead Time
– Net Selling Price
– Order Entry Duration Multiplier, Pick Duration Multiplier, and Packing
Duration Multiplier

See Also Configuring the Deliver Category.

Configuring Parameters for Delivery Products.
Configuring Parameters for Source Products.
Using Stock Planning Strategies.
Using Alternative Planning Strategies.
Configuring Role Details for Multiple Products.
Modeling a Process with Multiple Suppliers.
Using Pull and Push Planning Modes.

Configuring Order Selection Parameters
By default, a Distributor role chooses orders for delivery at random. You can
control how a Distributor role sorts and selects orders for delivery, based on a set
of order selection criteria. You do this to describe how your current distribution
process works or to experiment with alternative techniques to enhance the
performance of the delivery phase of your distribution process.
For example, if two product shipments are waiting to be delivered, you can
configure the Deliver category to deliver the highest cost orders first, the oldest
orders first (FIFO), orders that are within a certain size of the maximum or
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minimum order first, or orders “just in time” to meet the buyer’s desired order
fulfillment lead time.
Note The Order Selection parameters are relevant for the D1: Deliver Stocked Product
and D2: Deliver Make-to-Order Product categories only.

e-SCOR uses an exclusion strategy to identify the orders to fill. The Deliver
category places all orders in the Orders pool into a list, then applies the first set of
sort criteria to the orders in the list. If an order does not meet the sort criteria, the
Deliver category removes the order from the list. If two orders have the same
value for the set of sort criteria, the Deliver category applies the second set of
criteria, and so on. You can configure the Deliver category to sort orders, based on
up to four sets of sort criteria.
Each set of sort criteria specifies the direction of the sort (smallest or biggest) and
the property of the order on which to sort. You can sort orders, based on numeric
and time-based property values of an order. For example, to sort orders on a
first-in, first-out (FIFO) basis, you would configure the sort direction to be
smallest and the sort attribute to be the time at which the order was placed.
You can also configure the Deliver category to use a cutoff value, which lets you
further restrict the orders that are candidates for delivery. For example, if you
choose to deliver the biggest orders first, based on order size, small orders will
accumulate in the Orders pool. To avoid this situation, you can configure a
maximum delta acceptable cutoff to ensure that small orders also get delivered,
but only after big orders.

419

The following figure shows the Order Selection tab of the properties dialog for a
D1: Deliver Stocked Product category that sorts orders on a first-in first-out
(FIFO) basis:

Chooses orders with the
smallest Internal Order
Number, which delivers
orders on a FIFO basis.
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To sort orders for delivery, configure the following order selection parameters for
the Deliver category:
Parameter

Description

First
Second
Third
Fourth
Sort Direction

Determines whether to sort orders, based on the
smallest or biggest value. You can also sort
orders, based on a random value, which chooses
an order at random, based on the specified Sort
Criteria. The default value is random.
For examples, see Sorting Orders with No Cutoff.

First
Second
Third
Fourth
Sort Criteria

Determines the value the Deliver category used to
sort orders. The options include numeric and
time-based properties of an order. The default
value is none.
The numeric options are: unit-price, total-cost,
order-size, payment-terms, customer-ordernumber, internal-order-number, customerpreference, and product-preference.
The time-based options are: order-placed-time,
order-received-time, order-selected-time, and
order-lead-time.
For examples, see Sorting Orders with No Cutoff.
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Parameter

Description

First
Second
Third
Fourth
Cutoff

Determines whether the Deliver category
includes all orders in its sort (none) or whether it
includes only those orders that meet an
acceptable cutoff.
If Sort Criteria is a numeric value, the options for
Cutoff are: minimum-acceptable, maximumacceptable, and maximum-delta-acceptable.
If Sort Criteria is a time-based value, the options
are: time-delta-acceptable and current-time-deltaacceptable.
If Cutoff is maximum-delta-acceptable or timedelta-acceptable, Sort Direction must be smallest
or biggest.
If Cutoff is current-time-delta-acceptable, Sort
Direction must be random and Sort Criteria must
be order-lead-time.
For examples, see Restricting the Orders to Sort
Based on a Numeric Cutoff and Restricting the
Orders to Sort Based on a Time Cutoff.

First
Second
Third
Fourth
Cutoff Value

When Cutoff is a value other than none and when
Sort Criteria is a numeric value, specifies a value
that determines whether an order is excluded
from the sort. If the specified value of an order
does not meet the cutoff criteria, the Deliver
category does not fill the order.
For examples, see Restricting the Orders to Sort
Based on a Numeric Cutoff.

First
Second
Third
Fourth
Cutoff Duration

When Cutoff is a value other than none and
Sort Criteria is a time-based value, specifies the
value that determines whether an order is
excluded from the sort. If the specified time of an
order does not meet the cutoff criteria, the Deliver
category does not fill the order.
For examples, see Restricting the Orders to Sort
Based on a Time Cutoff.
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To configure order selection criteria:
1

Display the properties dialog for the Deliver category and click the Order
Selection 1-2 tab to configure the first and second sort criteria.

2

Configure the parameters in the table above in the First group to configure the
basic parameters that the Deliver category uses to sort orders.

3

Configure the parameters in the Second group to configure a second set of
parameters, which the Deliver category applies after the first set of criteria.

4

Click the Order Selection 3-4 tab, and configure the parameters in the Third
and Fourth group, as needed, to configure up to four sets of criteria, which the
Deliver category applies after the first and second sets of criteria.

Sorting Orders with No Cutoff
The following table describes some of the most common strategies for sorting
orders for delivery. These strategies sort all orders that a Deliver category
receives; they do not use a cutoff.
To deliver...

Configure these parameters...

Orders based on when the model
creates them, which is equivalent to
using a FIFO delivery strategy

Sort Direction = smallest
Sort Criteria = internal-order-number

The largest orders first

Sort Direction = biggest
Sort Criteria = order-size

The most expensive orders first, where
total-cost is the order size times the net
selling price of the delivery product

Sort Direction = biggest
Sort Criteria = total-cost

The highest priority products first,
where the smaller the number the
higher the priority

Sort Direction = smallest
Sort Criteria = product-preference

Oldest orders first, based on when the
buyer placed the order

Sort Direction = smallest
Sort Criteria = order-placed-time

Orders based on the desired
turnaround of the buyer’s source
product

Sort Direction = smallest
Sort Criteria = order-lead-time
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Restricting the Orders to Sort Based on a Numeric
Cutoff
You can configure numeric cutoff values to restrict the orders that the Deliver
category considers for delivery.
When you configure the Cutoff to be the maximum-acceptable or minimumacceptable value, the Deliver category considers for delivery only those orders
that meet the maximum or minimum value. For example, you might restrict
orders to a minimum acceptable cost, so the supplier never delivers orders worth
less than that minimum.
When you configure the Cutoff to be the maximum-acceptable-delta value, the
Deliver category considers the Sort Direction, Sort Criteria, and Cutoff Value to
determine which orders can be delivered. You configure the Cutoff Value as a
fraction of the Sort Criteria property of the order. This fraction defines a range
either above the biggest or below the smallest Sort Criteria value. If the value of
the Sort Criteria property of an order falls within this range, the Deliver category
attempts to fill the order from current inventory.
For example, suppose you have configured the order selection parameters as
follows:

• Sort Direction = biggest
• Sort Criteria = order-size
• Cutoff = maximum-delta-acceptable
• Cutoff Value = 0.5
Now, suppose orders exist for 50, 30, and 10 units, and you have a current
inventory of 35 units. The Deliver category tries to deliver the order for 50 units
first, because it is the largest. However, because it cannot fill the order from
current inventory, it calculates a maximum delta acceptable value of 25 (0.5 x 50).
Because 30 lies in the range from 25 to 50 and the current inventory is sufficient to
fill the order for 30 units, it delivers the 30 units. The current inventory is now 5.
Now suppose the inventory goes up to 35. The Deliver category does not deliver
the order for 10 units because it is too small (10 < (0.5 x 35)).
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The following table describes two strategies for sorting orders, based on a
numeric sort criteria, using a cutoff:
To deliver...

Configure these parameters...

The most expensive orders first, with a
minimum acceptable cost of $100.

First tab:

If two orders have a value of more than $100,
then deliver the most expensive order first.
In this configuration, orders for less than $100
are never delivered.
The largest orders first, based on current
inventory. If the current inventory is not
sufficient to fill the chosen order, then deliver
orders that are at least 50% as big as the
current order.
In this configuration, all orders will be filled;
however, smaller orders will be filled after
larger orders.

Sort Direction = biggest
Sort Criteria = total-cost
Cutoff = minimum-acceptable
Cutoff Value = 100

First tab:
Sort Direction = biggest
Sort Criteria = order-size
Cutoff = maximum-delta-acceptable
Cutoff Value = .5

Restricting the Orders to Sort Based on a Time
Cutoff
You can configure time-based cutoff values to restrict the orders that the Deliver
category considers for delivery.
You can configure the cutoff to be a maximum acceptable time delta to determine
which orders the Deliver category can fill. If the current order meets the sort
criteria but cannot be filled from the current inventory, the Deliver category
considers all other orders that meet the sort criteria and fall within the delta time.
You can use this configuration to model a FIFO delivery strategy in which orders
are considered for delivery if they fall within a given delta time relative to the
order-placed time. The time-delta-acceptable cutoff behaves the same as the
maximum-delta-acceptable cutoff.
You can also configure the cutoff to implement a just-in-time (JIT) deliver
strategy. To do this, you configure the cutoff to be current-time-delta-acceptable,
and you configure the Cutoff Duration to be the amount of time it takes to pick,
pack, and ship an order. The Deliver category ships only those orders whose
Order Fulfillment Lead Time is less than the current time plus the Cutoff
Duration. The Order Fulfillment Lead Time contains a time in the future when the
buyer expects to receive the order.
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The following table describes two strategies for sorting orders, using a time-based
sort criteria and a cutoff:
To deliver...

Configure these parameters...

Oldest orders first, based on when the
buyer placed the order.

First tab:

The Deliver category considers equally all
orders that meet the sort criteria that were
placed within a day of the earliest orderplaced time.
Orders “just in time” to meet the buyer’s
desired turnaround, where the time it
takes to pick, pack, and ship an order is
2 days.
If two orders have the same order
fulfillment lead time, then deliver the
largest order first, based on current
inventory.
If the current inventory is not sufficient to
fill the chosen order, then deliver orders
that are within 25% of the largest order.

Sort Direction = smallest
Sort Criteria = order-placed-time
Cutoff = time-delta-acceptable
Cutoff Duration = 1 day
First tab:
Sort Direction = random
Sort Criteria = order-fulfillment-lead-time
Cutoff = current-time-delta-acceptable
Cutoff Duration = 2 days
Second tab:
Sort Direction = biggest
Sort Criteria = order-size
Cutoff = maximum-delta-acceptable
Cutoff Value = .25

What Happens When the Simulation Runs
Similar to a Consumer role, a Distributor role orders source products from its
upstream suppliers, and similar to a Base Manufacturer role, a Distributor role
delivers product shipments to its downstream buyers. The similarities and
differences are as follows. A Distributor role:

• Determines its available suppliers when the model initializes, just like a
Consumer role.

• Can source components or finished products, depending on how you have
configured the role, just like a Consumer role.

• Creates replenishment orders for its source products on a regular planning

cycle, based on source planning. Compare this process with a Base
Manufacturer role, which creates build orders for its delivery products, based
on make planning, and a Consumer role, which orders source products on a
regular cycle, based on parameters that you configure in the source products.
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• Can deliver components or finished products, depending on how you

configure the role, just like a Base Manufacturer role. However, a Distributor
role can also assemble components into kits and deliver those kits, which a
Base Manufacturer cannot do.

• Computes financial metrics on a regular cycle, just like a Base Manufacturer

and Consumer role. A Distributor role computes both incoming and outgoing
financial metrics, just like a Base Manufacturer role, whereas a Consumer role
computes outgoing financial metrics only.

Analyzing the Performance of a Distributor
Role
To analyze the performance of a Distributor role, you view:

• Level 1 metrics for the Distributor role.
• Level 2 metrics for the upstream source and downstream deliver
subprocesses.

Level 1 Metrics to Analyze
At the role level, you can analyze the:

• Financial metrics that the Distributor role computes, based on the Net Selling
Price parameter of the upstream supplier’s delivery product.

• Asset metrics that the role computes, based on inventory levels.
• Cost metrics that the role computes, based on costs associated with the
various source and delivery management tasks.

For details about these metrics, see Viewing Metrics for Roles.

Level 2 Metrics to Analyze
To analyze the performance of a distribution process at Level 2, it is helpful to
think about the process in terms of the upstream source and the downstream
delivery subprocesses. Each of these subprocesses has metrics you can analyze.
See Also Viewing Metrics for Categories.

Viewing Metrics for Source and Delivery Products.
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• Upstream source subprocess
ES: Enable Source category:

– Orders Sent and Change Orders Sent
– Product Shipments Received
– Contracts Established
– Supplier On-Time Performance (%)
Source category:

– Orders Sent and Change Orders Sent
– Product Shipments Received
– Product Shipment Lead Time
– Financial Obligations, Financial Payments within Financial Period, and
Financial Payments Total

– Receiving Metric, Verification Metric, Transfer Metric, Create Customer
Order Metric, and Invoice Metric costs

P2: Plan Source category:

– Number of Planning Periods
Source products:

– Quantity Ordered and Quantity Received
– Purchase Cost
– Products on Order, Received Inventory Level, Incoming Inventory Level,
and Inventory Level

– Received Fulfillment Time
• Downstream delivery subprocess
ED: Enable Deliver category:

– Orders Received and Change Orders Received
– Product Shipments Sent
– Contracts Established
– Delivery Performance (%)
– Perfect Order Fulfillment (%)
Deliver categories:

– Orders Received and Change Orders Received
– Product Shipments Sent
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– Fill Rates (%)
– Ready to Ship Time
– Order Entry to Ship Time
– Financial Bookings, Financial Outstanding, Financial Collections within
Financial Period, and Financial Collections Total

– Order Entry Metric, Order Fulfillment Metric, Pick Metric, Packing Metric,
Transportation Metric, Customer Invoicing Metric, and Customer
Collections Metric costs

Delivery products:

– Quantity to Deliver and Quantity Shipped
– Awaiting Orders, Products On Order, Received Inventory Level,

Incoming Inventory Level, Inventory Level, In Transit Inventory Level,
Shipped Inventory Level, and Manufacturing Batch Size

– Order Fulfillment Lead Time
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Introduction
You configure a Manufacturer role to make and deliver finished products from
components. Because a Manufacturer role sources components and converts them
into finished products, this role represents a value-added step in the supply
chain. Compare this process with a Distributor role, which simply delivers its
source products or assembles components into kits, which does not represent a
value-added step in the supply chain.
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A Manufacturer role uses two planning processes:

• Source planning, which determines when the role orders its components.
• Make planning, which determines when the role creates build orders for
manufacturing its finished products and implicitly determines when it
delivers its finished products.

To model a manufacturing process, you:

• Configure the Manufacturer role.
• Configure Level 2 parameters for a Manufacturer role.
• Configure build selection parameters for the Make category to choose which
build orders to manufacture first.

• Coordinate source and make planning for the Manufacturer role.
• Understand what happens when the model runs for a Manufacturer role.
• Analyze the performance of the manufacturing process by viewing metrics.

Configuring a Manufacturer Role
Your supply chain might include a manufacturing process, which sources
components from upstream suppliers, and makes and delivers finished products.
Unlike a Distributor role, which can source components or finished products, a
Manufacturer role must source components and it must make and deliver finished
products.
The following figure shows a model in which the Manufacturer role
manufactures components into finished products. The Manufacturer role sources
components from the Base Manufacturer role and manufactures finished
computers. You assign the components as the source products and the finished
product as the delivery product of the role.
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Configuring a Manufacturer Role

Product hierarchy

Products pool

Components:
Is Source Product = true
Is Delivery Product = false

Computer:
Is Source Product = false
Delivery Product = true

To configure a Manufacturer role:
1

Create a product hierarchy that contains a finished product with components.
For details, see Creating a Product Hierarchy with Components.

2

Assign to the Manufacturer role the components as the Source Product and
the finished products as the Delivery Product.

For details, see Configuring the Products a Role Sources and Delivers.
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In the example above, the Product tab of the Manufacturer role’s dialog would
look like this:

Configuring Level 2 Parameters for a
Manufacturer Role
To configure the Level 2 parameters of a Manufacturer role, it is helpful to think
about the manufacturing process in terms of the upstream source, the make, and
the downstream delivery subprocesses. Each of these subprocesses has
parameters you can configure.
The following list of configurable parameters assumes a stock/replenishment
planning strategy, a single delivery product, a single supplier for each source
product, and a pull planning mode. See the referenced sections at the end of this
section for information about additional parameters you must configure for each
of these alternative modeling techniques.

434

Configuring Level 2 Parameters for a Manufacturer Role

• Upstream source subprocess
Source category:

– Receiving Duration
– Verification Duration
– Transfer Duration
– Receiving, Verification, Transfer, Create Customer Order, and Invoice
costs

P2: Plan Source category:

– Planning Period
– Initial Plan Delay
– Continuous Planning
Source products:

– Order Type
– Customer Preference
– Starting Product Inventory Level
– Maximum Inventory Level
– Inventory Control Strategy
– Safety Stock
– Minimum Reorder Quantity
– Desired Turnaround
– Fulfillment Preference
– Fulfillment Using Alternate Products
– Receiving Duration Multiplier, Verification Duration Multiplier, and
Transfer Duration Multiplier

• Make subprocess
Make categories:

– Order Release to Manufacturing Duration
– Build Selection parameters
– Production Material Duration
– Manufacturing Duration
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– Move to Delivery Duration
– Production Material Handling cost
P3: Plan Make category:

– Planning Period
– Initial Plan Delay
– Continuous Planning
– Compensate for Yield
Source products:

– Order Release to Manufacturing Duration Multiplier and
Production Material Duration Multiplier

Delivery products:

– Build Time Dependent on Order Size
– Minimum Batch Size
– Maximum Batch Size
– Build Yield
– Manufacturing Duration Multiplier and Move to Delivery Duration
Multiplier

• Downstream delivery subprocess
Deliver categories:

– Order Entry Duration
– Order Selection parameters
– Pick Duration
– Packing Duration
– Transportation Duration
– Order Entry, Order Fulfillment, Pick, Packing, Transportation, Customer
Invoicing, and Customer Collections costs

Delivery products:

– Order Type
– Product Preference
– Starting Product Inventory Level
– Maximum Inventory Level
– Inventory Control Strategy
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– Safety Stock
– Minimum Reorder Quantity
– Published Delivery Lead Time
– Net Selling Price
– Order Entry Duration Multiplier, Pick Duration Multiplier, and Packing
Duration Multiplier

See Also Configuring the Make Category.

Configuring the Deliver Category.
Configuring Parameters for Delivery Products.
Configuring Parameters for Source Products.
Using Stock Planning Strategies.
Using Alternative Planning Strategies.
Configuring Role Details for Multiple Products.
Modeling a Process with Multiple Suppliers.
Using Pull and Push Planning Modes.

Configuring Build Selection Parameters
By default, a Manufacturer role selects build orders for manufacturing randomly.
You can control how a Manufacturer role sort and selects build orders, based on a
set of sort criteria. You do this to describe how your current manufacturing
process works or to experiment with alternative techniques to enhance the
performance of the manufacturing phase.
For example, if two build orders are waiting to be manufactured, you can
configure the Make category to manufacture the highest cost build orders first,
the oldest build orders first, or the largest build orders first with a minimum
batch size.
e-SCOR uses an exclusion strategy to identify the build orders to manufacture.
The Make category places all build orders in the Build Orders pool into a list, then
applies the first set of sort criteria to the build orders in the list. If a build order
does not meet the sort criteria, the Make category removes the build order from
the list. If two build orders have the same value for the set of sort criteria, the
Make category applies the second set of criteria, and so on. You can configure the
Make category to sort build orders, based on up to four sets of sort criteria.
Each set of sort criteria specifies the direction of the sort (smallest or biggest) and
cutoff parameters, which are relative to the selected property of a build order.

437

You sort build orders, based on numeric values of an order. For example, if the
property to sort by is the internal build order number and the sort direction is
smallest, the Make category sorts build orders, based on a first-in, first-out (FIFO)
basis.
You can also configure the Make category to use a cutoff value, which lets you
further restrict the build orders that are candidates for manufacturing. For
example, you can choose to manufacture only build orders of a certain size to
guarantee minimum batch sizes.
The following figure shows the Build Selection tab of the properties dialog for an
Mb: Make Product category that sorts build orders on a first-in first-out (FIFO)
basis:

Chooses build orders with the
smallest internal order number
first, which manufactures build
orders on a FIFO basis.
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To sort build orders for manufacture, you configure the following build selection
parameters for the Make category:
Parameter

Description

First
Second
Third
Fourth
Sort Direction

Determines whether to sort build orders, based on the
smallest or biggest value. You can also sort build
orders, based on a random value, which chooses a build
order at random, based on the specified criteria. The
default value is random.
For examples, see Sorting Build Orders with No Cutoff.

First
Second
Third
Fourth
Sort Criteria

Determines the value the Make category uses to sort
build orders. The options include numeric properties of
a build order. The default value is none.
The options are: unit-price, total-cost, order-size,
payment-terms, customer-order-number, internal-ordernumber, customer-preference, and product-preference.
For examples, see Sorting Build Orders with No Cutoff.

First
Second
Third
Fourth
Cutoff

Determines whether the Make category includes all
build orders in its sort (none) or whether it includes
only those build orders that meet an acceptable cutoff.
The options for Cutoff are: minimum-acceptable,
maximum-acceptable, and maximum-delta-acceptable.
For examples, see Restricting the Orders to Sort Based
on a Cutoff.

First
Second
Third
Fourth
Cutoff Value

When Cutoff is a value other than none, specifies the
value that determines whether a build order is excluded
from the sort. If the specified value of a build order does
not meet the cutoff criteria, the Make category does not
fill the order.
For examples, see Restricting the Orders to Sort Based
on a Cutoff.

First
Second
Third
Fourth
Cutoff Duration

When Cutoff is a duration, specifies the value that
determines whether a build order is excluded from the
sort. If the specified value of a build order does not
meet the cutoff criteria, the Make category does not fill
the order.
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To configure build selection criteria:
1

Display the properties dialog for the Make category and click the Build
Selection 1-2 tab to configure the first and second sort criteria.

2

Configure the parameters in the table above in the First group to configure the
basic parameters that the Make category uses to sort build orders.

3

Configure the parameters in the Second group to configure a second set of
parameters, which the Make category applies after the first set of criteria.

4

Click the Build Selection 3-4 tab, and configure the parameters in the Third
and Fourth group, as needed, to configure up to four sets of criteria, which the
Make category applies after the first and second sets of criteria.

Sorting Build Orders with No Cutoff
The following table describes some of the most common strategies for sorting
build orders. These strategies sort all build orders that a Make category receives;
they do not use a cutoff.
To manufacture...

Configure these parameters...

Build orders based on when the model
creates them, which is equivalent to
using a FIFO manufacturing strategy

Sort Direction = smallest
Sort Criteria = internal-order-number

The largest build orders first

Sort Direction = biggest
Sort Criteria = order-size

The most expensive build orders first,
based on the net selling price of the
delivery product

Sort Direction = biggest
Sort Criteria = total-cost

The highest priority products first,
where the smaller the number, the
higher the priority

Sort Direction = smallest
Sort Criteria = product-preference

Restricting the Orders to Sort Based on a Cutoff
You can configure numeric cutoff values to restrict the build orders the Make
category considers for manufacturing.
For example, you might want to configure the cutoff to be a minimum acceptable
value, based on the size of a batch. The Make category never manufactures
batches that are less than the minimum acceptable value. However, the Make
category combines batches so that it never makes more than one partial batch. By
configuring the build order criteria such that the Make category never makes a
batch that is smaller than a given size, you can guarantee minimum batch sizes.
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Coordinating Source and Make Planning

The following table describes a strategy for sorting build orders, using a cutoff:
To manufacture...

Configure these parameters...

The largest batches first with a minimum
acceptable batch size of 50 units.

First tab:

If two batches are both bigger than 50, then
manufacture the most expensive build order first.
In this configuration, the Make category always
combines build orders for less than 50 units to
make a larger batch; it never makes a batch that is
smaller than 50 units.

Sort Direction = biggest
Sort Criteria = order-size
Cutoff = minimum-acceptable
Cutoff Value = 50
Second tab:
Sort Direction = biggest
Sort Criteria = total-cost

Coordinating Source and Make Planning
A Manufacturer role uses source planning to determine when to place orders for
its source products and the size of those orders. The role uses make planning to
determine when to create build orders for its delivery products and the size of
those orders.
You should coordinate source and make planning within the Manufacturer role to
optimize performance as follows, depending on the planning mode:
If the
planning mode is...

Configure the Initial Plan Delay to be...

Pull

Smaller for the P3: Plan Make category than for the
P2: Plan Source category so that make planning
occurs before source planning.

Push

Smaller for the P2: Plan Source category than for the
P3: Plan Make category so that source planning
occurs before make planning.

In pull mode, you want the Manufacturer role to determine build order size
before it creates customer orders for its source products; whereas in push mode,
you want the role to determine customer order size before it creates build orders
for delivery products that it will push downstream.
Also, the Planning Period should either be the same for P2 and P3, or a multiple.
For example, if the Planning Period for P2 is 3 weeks, the Planning Period for P3
should be 3 weeks, 6 weeks, 12 weeks, and so on.
See Also Manufacturer Role in Push Mode.
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What Happens When the Simulation Runs
Similar to a Distributor role, a Manufacturer role orders source products from its
upstream suppliers and delivers finished products to its downstream buyers. The
similarities and differences are as follows. A Manufacturer role:

• Determines its available suppliers when the model initializes, just like a
Distributor role.

• Must source components, whereas a Distributor role can source components
or finished products.

• Must deliver finished products, whereas a Distributor role can deliver
components or finished products.

• Uses source planning to determine when to order source products, just like a
Distributor role.

• Uses make planning to determine when to make and implicitly delivery

finished products, whereas a Distributor role delivers its delivery products
whenever they are available.

• Computes incoming and outgoing financial metrics on a regular financial
cycle, just like a Distributor role.

Analyzing the Performance of a Manufacturer
Role
To analyze the performance of a Manufacturer role, you view:

• Level 1 metrics for the Manufacturer role.
• Level 2 metrics for the upstream source, the make, and the deliver
subprocesses.

Level 1 Metrics to Analyze
At the role level, you can analyze the:

• Financial metrics that the Manufacturer role computes, based on the Net
Selling Price parameter of the upstream supplier’s delivery product.

• Asset metrics that the role computes, based on inventory levels.
• Cost metrics that the role computes, based on costs associated with the
various source and delivery management tasks.

For details about these metrics, see Viewing Metrics for Roles.
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Level 2 Metrics to Analyze
To analyze the performance of a manufacturing process at Level 2, it is helpful to
think about the manufacturing process in terms of the upstream source
subprocess, the make subprocess, and the downstream delivery subprocess. Each
of these subprocesses has metrics you can analyze.
See Also Viewing Metrics for Categories.

Viewing Metrics for Source and Delivery Products.

• Upstream source subprocess
ES: Enable Source category:

– Orders Sent and Change Orders Sent
– Product Shipments Received
– Contracts Established
– Supplier On-Time Performance (%)
Source category:

– Orders Sent and Change Orders Sent
– Product Shipments Received
– Product Shipment Lead Time
– Financial Obligations, Financial Payments within Financial Period, and
Financial Payments Total

– Receiving Metric, Verification Metric, Transfer Metric, Create Customer
Order Metric, and Invoice Metric costs

P2: Plan Source category:

– Number of Planning Periods
Source products:

– Quantity Ordered and Quantity Received
– Purchase Cost
– Products on Order, Received Inventory Level, Incoming Inventory Level,
and Inventory Level

– Received Fulfillment Time
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• Make subprocess
Make categories:

– Build Orders Started and Build Orders Completed
– Make Cycle Time
– Production Material Handling Metric cost
P3: Plan Make category:

– Number of Planning Periods
Source products:

– Awaiting Orders
– Work in Progress
Delivery products:

– Total Products Accepted
– Total Products Rejected
– Manufacturing Batch Size
• Downstream delivery subprocess
ED: Enable Deliver category:

– Orders Received and Change Orders Received
– Product Shipments Sent
– Contracts Established
– Delivery Performance (%)
– Perfect Order Fulfillment (%)
Deliver categories:

– Orders Received and Change Orders Received
– Product Shipments Sent
– Fill Rates (%)
– Ready to Ship Time
– Order Entry to Ship Time
– Financial Bookings, Financial Outstanding, Financial Collections within
Financial Period, and Financial Collections Total

– Order Entry Metric, Order Fulfillment Metric, Pick Metric, Packing Metric,
Transportation Metric, Customer Invoicing Metric, and Customer
Collections Metric costs
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Delivery products:

– Quantity to Deliver and Quantity Shipped
– Awaiting Orders, Products On Order, Received Inventory Level,

Incoming Inventory Level, Inventory Level, In Transit Inventory Level,
and Shipped Inventory Level

– Order Fulfillment Lead Time
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Using Stock
Planning Strategies
Describes the two planning strategies available for sourcing and delivering stock
products: replenishment, forecast, Q, and R-Q.
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Using a Stock/Replenishment Planning Strategy 461
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Analyzing the Performance of a Model that Uses Stock Planning 468

Introduction
By default, each role uses a stock planning strategy to source, make, and deliver
its products. A stock planning strategy means the role:

• Places source and delivery products in inventory.
• Delivers products to any buyer that places an order.
Note that a Distributor role that assembles components into kits has an inventory
of its finished products, or kits, only when the kits are in transit to the buyer role.
By default, a role that uses a stock planning strategy uses a replenishment
inventory control strategy, which means it determines order size based on desired
inventory levels. You can also configure the inventory control strategy to use
forecast, Q, or R-Q planning.
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To configure the stock planning strategy, you:

• Configure the stock planning strategy for each role’s source and/or delivery
products.

• Configure the inventory control strategy of each role’s source and delivery
products to be:

– Stock/Replenishment — Creates customer and build orders for as many
source and delivery products, respectively, as are required to maintain
desired inventory levels, given current orders for source and delivery
products.

– Stock/Forecast Customer — Creates customer and build orders for as

many source and delivery products, respectively, as are required to meet
forecasts, based on buyer contracts.

– R-Q — Creates customer and build orders for a fixed quantity when the
inventory level falls below desired inventory levels.

– Q — Creates customer and build orders for a fixed quantity, plus an

average demand, when the inventory level falls below desired inventory
levels.

• Analyze the performance of the stock planning strategy by viewing metrics.
When using a stock planning strategy, you configure timing, cost, and other
parameters for the S1: Source Stocked Product, M1: Make-to-Stock, and
D1: Deliver Stocked Product categories, as appropriate for each role.

Configuring the Stock Planning Strategy
To determine the planning strategy for sourcing, making, and delivering stock
products, you configure the Inventory Control Strategy of the role’s source
and/or delivery products, which has different effects on planning, as this table
describes:

For this role...

Base
Manufacturer
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You configure the Inventory
Control Strategy of the...

Delivery products

Which determines...

The size of build orders for delivery
products, which determines how many
delivery products the role makes and
delivers. The role determines the size of
build orders, based on the size of customer
or replenishment orders for delivery
products from downstream buyers.

Configuring the Stock Planning Strategy

For this role...

You configure the Inventory
Control Strategy of the...

Distributor

Source products

Which determines...

The size of replenishment orders for
source products, which determines how
many delivery products the role delivers.
The role determines the size of
replenishment orders for source products,
based on the size of customer or
replenishment orders for delivery
products from downstream buyers.
Note: For a Distributor role that assembles
components into kits, you cannot
configure the Inventory Control Strategy
of the delivery products, or kits, because
the role does not keep an inventory of
those kits.

Manufacturer

Source products

The size of replenishment orders for
source products, which determines how
many delivery products the role has
available for making and delivering
finished products. Thus, source planning
is a separate planning cycle from make
planning for a Manufacturer role.

Delivery products

The size of build orders for delivery
products, which determines how many
delivery products the role makes and
delivers. The role determines the size of
build orders, based on the size of customer
or replenishment orders for delivery
products from downstream buyers.

Note By default, the Consumer role uses a stock planning strategy, which means it
places its source products in inventory. A Consumer role determines the size of
its replenishment orders and when to place those orders, based on demand
parameters that you configure for the source product. Therefore, you do not
configure the inventory control strategy of a Consumer role.

By default, when using a stock planning strategy, the role creates orders each
source or make planning cycle, depending on the role. It waits to create
replenishment orders for source products or build orders for delivery products
until the next planning cycle, even if orders from downstream buyers come in
during the planning cycle.
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You can configure a role to create orders on demand, which means it creates
replenishment orders for source products and build orders for delivery products
whenever the role receives an order from a downstream buyer for delivery
products. You can configure the role to create orders on demand in addition to
creating orders each planning cycle or instead of each planning cycle.
To configure the stock planning strategy for a role:
1

Show the detail for each role in the model for which you want to configure the
stock planning strategy.

2

Display the properties dialog for the source and/or delivery products for the
role, according to the table above, and on the General tab, configure the Order
Type to be stock, the default.

3

Click the Inventory tab and configure the Inventory Control Strategy
parameter to be replenishment, forecast customer, r-q, or q.
For details on which planning strategy to use, see:

• Using a Stock/Replenishment Planning Strategy.
• Using a Stock/Forecast Planning Strategy.
• Using a Stock/R-Q and Q Planning Strategy.
4

Show the properties dialog for the P2: Plan Source and/or P3: Plan Make
category of the role, according to the table above, and configure the Planning
Period and Initial Plan Delay parameters to determine the frequency with
which the role creates orders and when the first plan goes into effect.

5

To configure the role to create orders on demand, enable the Continuous
Planning option for the P2: Plan Source and/or P3: Plan Make category, as
appropriate for the role.

6

For Base Manufacturer and Manufacturer roles, to configure the role to
compensate for expected loss due to build yield, enable the Compensate for
Yield option for the P3: Plan Make category, the default.

Tip To configure the role to create replenishment orders on demand only, configure
the Planning Period to be a very large number, such as 10 years, so that cyclical
planning never takes place.
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Using a Stock/Replenishment Planning
Strategy
A role that uses a stock/replenishment planning strategy tries to keep extra
source and delivery products available in inventory to maintain inventory levels.
When using a stock/replenishment planning strategy, a role:

• Creates replenishment orders for the number of source products required to

maintain desired inventory levels, given current orders for delivery products.

• Creates build orders for the number of delivery products required to maintain
desired inventory levels, given current orders for delivery products.

• Fulfills customer and replenishment orders from buyers from its inventory for
delivery products.

• Whenever it can, delivers the exact number of delivery products required to
fill an order.

• If the role does not have enough inventory of delivery products to fulfill a

customer or replenishment order from a downstream buyer, and if the source
product of the downstream buyer allows partial shipments (Fulfillment
Preference = partial), the role delivers as many delivery products as it can.
Otherwise, it creates a back order for the unfilled order.

• Delivers products to any downstream buyer that places an order, according to
the Order Selection parameters of the role’s Deliver category.

To use a stock/replenishment planning strategy, you need to:

• Configure product composites to use replenishment planning.
• Understand how the role computes order size for replenishment planning.
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Configuring Product Composites for Replenishment
Planning
When the Inventory Control Strategy is replenishment, the default, a role
computes the size of each replenishment order for source products and each build
order for delivery products, based on these parameters, which you configure for
both source and delivery products:
Parameter

Description

Safety Stock

The minimum number of products the role needs to
maintain in inventory before reordering.

Minimum Reorder
Quantity

The minimum number of products for which the role
creates orders, when the inventory dips below the
Safety Stock. If necessary, the role can create orders
for more than this quantity.

If the Inventory Level metric of the source or delivery product falls below the
Safety Stock parameter, the role determines the size of the replenishment or build
order, respectively, based on the Minimum Reorder Quantity parameter and the
number of current orders.
A Consumer role determines order size and frequency, based on order demand
parameters that you configure in the source product; it does not use source
planning.
To configure a role to use a stock/replenishment planning strategy:
1

Show the detail of each Base Manufacturer, Distributor, and Manufacturer
role whose source or delivery product is configured to use a
stock/replenishment planning strategy.
For details, see Configuring the Stock Planning Strategy.

2

Display the properties dialog for each source and delivery product, click the
Inventory tab and configure the parameters described in the table above.

Understanding How the Role Computes Order Size
for Replenishment Planning
e-SCOR computes the size of a replenishment or build order by comparing these
values:

• The minimum number of products the role can reorder at one time (Minimum
Reorder Quantity).

• The desired inventory level (Safety Stock) and current inventory (Inventory
Level), given current orders (Products On Order and Awaiting Orders).
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The role orders the maximum of these two values, unless the current inventory
level can cover current orders, in which case, it orders nothing.

Formula for Computing Order Size for Replenishment Planning
The order size is based on the following formula:
if ( Inventory Level + Products On Order - Awaiting Orders) =<
Safety Stock
then order size = 0
else order size = Max [Minimum Reorder Quantity,
(Safety Stock Inventory Level Products On Order +
Awaiting Orders ) ]

Metrics and Parameters Used in the Formula
The formula is based on the following metrics and parameters for source and
delivery products:
Parameter/Metric

Description

Inventory Level

(Metric) The number of products that actually
exist in inventory.

Products On Order

(Metric) For source products, the number of
products that buyers have ordered but suppliers
have not yet delivered.
For delivery products, the number of products
that buyers have ordered but suppliers have not
yet entered or delivered.

Awaiting Orders

(Metric) The number of products that buyers have
ordered and suppliers have entered, but suppliers
have not yet delivered.

Safety Stock

(Parameter) The minimum number of products
that need to be maintained in inventory before
reordering.

Minimum Reorder
Quantity

(Parameter) The minimum number of products to
reorder, based on the Safety Stock.
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Example: Order Size is Zero
Here is an example where the order size is 0, because the current inventory can
cover the number of products on order:
Inventory Level 120
Safety Stock 100
Products On Order 10
Awaiting Orders 10
Minimum Reorder Quantity 30
120 - 100 + 10 = 30 (Inventory Level - Safety Stock +
Products On Order)
10 < 30 (Awaiting Orders < 30) therefore:
order size = 0

Example: Order Size is the Amount Needed to Maintain Current
Inventory
Here is an example where the order size is the amount that is needed to maintain
desired inventory levels, given current orders, because this amount is greater than
the minimum reorder quantity:
Inventory Level 120
Safety Stock 100
Products On Order 30
Awaiting Orders 90
Minimum Reorder Quantity 30
120 - 100 + 30 = 50 (Inventory Level - Safety Stock +
Products On Order)
50 < 90 (50 < Awaiting Orders)
100 - 120 - 30 + 90 = 40 (Safety Stock - Inventory Level Products On Order + Awaiting Orders)
max [30, 40] (max [Minimum Reorder Quantity, 40] therefore:
order size = 40
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Example: Order Size is the Minimum Reorder Quantity
Here is an example where the order size is the minimum reorder quantity,
because the amount needed to maintain desired inventory levels is less than the
minimum reorder quantity:
Inventory Level 120
Safety Stock 100
Products On Order 10
Awaiting Orders 50
Minimum Reorder Quantity 30
120 - 100 + 10 = 30 (Inventory Level - Safety Stock +
Products On Order)
30 < 50 (30 < Awaiting Orders)
100 - 120 - 10 + 50 = 20 (Safety Stock - Inventory Level Products On Order + Awaiting Orders)
max [30, 20] ( max [Minimum Reorder Quantity, 20] ) therefore:
order size = 30

Using a Stock/Forecast Planning Strategy
A role that uses a stock/forecast planning strategy tries to anticipate product
demand by using forecast estimates, based on contracts, which determine the
estimated amount of the order the role uses each planning period.
You use forecast planning to determine:

• The size of replenishment orders for the source products of a Distributor or
Manufacturer role.

• The size of build orders for the delivery products of a Base Manufacturer and
Manufacturer role.

When using a stock/forecast planning strategy, a role:

• Creates replenishment orders for the number of source products the role
forecasts it will need, based on buyer contracts.

• Creates build orders for the number of delivery products the role forecasts it
will need, based on buyer contracts.

• Adjusts replenishment order and build order size for the next planning cycle
by comparing actual orders with contract estimates.

• Fulfills customer and replenishment orders from buyers from its inventory for
delivery products.
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• Whenever it can, delivers the exact number of products required to fill an
order.

• If the role does not have enough inventory of delivery products to fulfill a

customer or replenishment order from a downstream buyer, and if the source
product of the downstream buyer allows partial shipments (Fulfillment
Preference = partial), the role delivers as many products as it can. Otherwise, it
creates a back order for the unfilled order.

• Delivers products to any buyer that places an order, according to the Order
Selection parameters of the role’s Deliver category.

To use a stock/forecast planning strategy, you need to:

• Configure buyer roles to use forecast planning by configuring contract
parameters in the source product of the buyer role.

• Understand how the role computes order size for forecast planning.
The model also uses contracts to choose among multiple suppliers for the same
source product and for push planning. For details, see Modeling a Process
with Multiple Suppliers and Using Pull and Push Planning Modes.

Configuring Buyer Roles to Use Forecast Planning
When the Inventory Control Strategy of a role’s source or delivery product is
forecast, the role uses forecast planning to compute the size of replenishment
orders for source products or the size of build orders for delivery products,
depending on the role.
To use forecast planning, you configure contract parameters for the downstream
buyer role’s source product, as follows:
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Parameter

Description

Contract Start Time

The time from the start of the simulation until the
buyer sends its first purchase request to upstream
suppliers for source products.

Contract Length

The length of time during which the contract is
valid.

Contract Response
Cycle Time

The length of time a supplier has to respond to a
purchase request with a purchase response.

Forecast Estimated
Amount

The estimated number of products the role plans
to order over the life of the contract.

Contract Repetition Count

The number of times to repeat the contract during
the lifetime of the simulation.

Using a Stock/Forecast Planning Strategy

Note Orders sent while no contract is in effect are deleted.
To configure the model to use a stock/forecast planning strategy:
1

Show the detail of each Distributor, Manufacturer, or Consumer role that is
downstream of the supplier role whose source or delivery product is
configured to use a stock/forecast planning strategy.
For details, see Configuring the Stock Planning Strategy.

2

Configure the contract parameters for the buyer role’s source product, as
described in the table above.

Understanding How the Role Computes Order Size
for Forecast Planning
When Inventory Control Strategy is forecast, the supplier role determines the size
of its replenishment or build orders by estimating how much delivery product the
role needs, based on awards for contracts from downstream buyers. The role
assumes a linear order/build cycle over the lifetime of the contract; it does not
look at inventory levels to determine order size.
For example, suppose a Manufacturer role has received a contract award for 100
units of its finished product. Suppose the length of the contract is 10 days and the
role performs its make planning once a day. The role plans to build 10 units per
day for the length of the contract. The role does not care whether it has actually
received orders for this amount of finished product; it makes this amount for the
life of the contract, regardless of orders. Assuming the downstream buyer always
orders the amount of the contract, the role always has enough stock in inventory
to fill orders, and it will never have too much stock.
Now, suppose the downstream buyer orders more than the amount of the
contract. When the current contract expires, the Manufacturer role automatically
makes just enough additional products to catch up with the orders during its next
make planning cycle.
Similarly, suppose the downstream buyer orders less than the amount of the
contract. Again, when the current contract expires, the Manufacturer role takes
into account the extra products it has already made and makes that many fewer
products during its next make planning cycle.
The Manufacturer role uses the same mechanism to determine the number of
source products to order during its source planning cycle.
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This table shows an example where the actual order amount varies with each new
contract, which results in different build order sizes each contract period:

Contract

Forecast
Estimated Amount

Amount Buyer
Actually Orders

Amount Manufacturer
Actually Makes

C1

100

100

100

C2

100

110

110

C3

100

90

100

C4

100

100

90

When using a forecast planning strategy, a supplier can maintain optimal
inventory levels, while still reacting to order fluctuations. Keep in mind, however,
that forecast planning assumes that the Forecast Estimated Amount that you
configure for the buyer role’s source product is relatively accurate. If not, the
downstream buyer receives product shipments late, which can adversely affect
turnaround time.

Using a Stock/R-Q and Q Planning Strategy
You can configure stock planning to use these additional inventory control
strategies:

• R-Q — If the Inventory Level is less than the Safety Stock, the buyer orders a
fixed quantity, which is the Minimum Reorder Quantity.

• Q — If the Safety Stock plus the average demand within the planning period

plus the average lead time is less than the Inventory Level, the buyer orders a
fixed quantity, which is the Minimum Reorder Quantity.

Note In the current version, the average demand within the planning period plus the
average lead time is equal to the Forecast Estimated Amount specified in the
Supplier tab of the product composite dialog. In future versions, it will rely on
average demand from forecasts.

Analyzing the Performance of a Model that
Uses Stock Planning
To analyze the performance of a model that uses a stock planning strategy, it is
helpful to think about the process in terms of the upstream source subprocess, the
make subprocess, and the downstream delivery subprocess. Each of these Level 2
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subprocesses has metrics you can analyze to determine the performance impact of
using a stock planning strategy.
See Also Viewing Metrics for Categories.

Viewing Metrics for Source and Delivery Products.

• Upstream source subprocess
ES: Enable Source category:

– Orders Sent and Change Orders Sent
– Product Shipments Received
– Contracts Established
– Supplier On-Time Performance (%)
Source category:

– Orders Sent and Change Orders Sent
– Product Shipments Received
– Product Shipment Lead Time
– Financial Obligations, Financial Payments within Financial Period, and
Financial Payments Total

– Receiving Metric, Verification Metric, Transfer Metric, Create Customer
Order Metric, and Invoice Metric costs

P2: Plan Source category:

– Number of Planning Periods
Source products:

– Quantity Ordered and Quantity Received
– Purchase Cost
– Products on Order, Received Inventory Level, Incoming Inventory Level,
and Inventory Level

– Received Fulfillment Time
• Make subprocess
Make categories:

– Build Orders Started and Build Orders Completed
– Make Cycle Time
– Production Material Handling cost
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P3: Plan Make category:

– Number of Planning Periods
Source products:

– Awaiting Orders
– Work in Progress
Delivery products:

– Total Products Accepted
– Total Products Rejected
• Downstream delivery subprocess
ED: Enable Deliver category:

– Orders Received and Change Orders Received
– Product Shipments Sent
– Contracts Established
– Delivery Performance (%)
– Perfect Order Fulfillment (%)
Deliver categories:

– Orders Received and Change Orders Received
– Product Shipments Sent
– Fill Rates (%)
– Ready to Ship Time
– Order Entry to Ship Time
– Financial Bookings, Financial Outstanding, Financial Collections within
Financial Period, and Financial Collections Total

– Order Entry Metric, Order Fulfillment Metric, Pick Metric, Packing Metric,
Transportation Metric, Customer Invoicing Metric, and Customer
Collections Metric costs

Delivery products:

– Quantity to Deliver and Quantity Shipped
– Awaiting Orders, Products On Order, Received Inventory Level,

Incoming Inventory Level, Inventory Level, In Transit Inventory Level,
Shipped Inventory Level, and Manufacturing Batch Size

– Order Fulfillment Lead Time
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Introduction
A role’s planning strategy determines:

• How much the role sources, makes, and/or delivers, depending on the role.
• To whom the role delivers its products.
By default, each role uses a stock/replenishment planning strategy. For details,
see Using Stock Planning Strategies.
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e-SCOR supports the following two alternative planning strategies for sourcing,
making, and/or delivering products:

• Engineer-to-order — Sources and makes exactly the number of source and

delivery products, respectively, required to fill an order; delivers exactly those
delivery products to the buyer that places the order; and maintains no
inventory.

• Make-to-order — Sources and makes exactly the number of source and

delivery products, respectively, required to fill an order; places both source
and delivery products in inventory; and delivers products to any buyer that
places an order.

The make-to-order planning strategy is based on the engineer-to-order; therefore,
it is explained first.
Engineer-to-order, make-to-order, and stock/replenishment are reactive planning
strategies, whereas stock/forecast is a proactive planning strategy.
A role can use the same planning strategy for its source and delivery products,
depending on the role, or it can combine different planning strategies within the
same role. The Order Type parameter of the role’s source and delivery product
determines which Level 2 category the role uses for each product.
To model alternative planning strategies, you need to:

• Determine which alternative planning strategy to use:
– Engineer-to-order
– Make-to-order
• Configure a role to use alternative planning strategies by configuring the
process categories of the appropriate type on the role detail.

• Understand the rules for configuring the planning strategy of a role.
• Analyze the performance of the alternative planning strategy by viewing
metrics.

Using an Engineer-to-Order Planning Strategy
When using an engineer-to-order (ETO) planning strategy, a role:

• Creates replenishment orders for the exact number of source products
required to fill an order for delivery products.

• Creates build orders for the exact number of delivery products required to fill
an order for delivery products.

• Fulfills customer and replenishment orders from buyers by placing delivery
products directly into the Staging Area pool.
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• Delivers the exact number of products required to fill an order.
• Delivers products to the exact customer that places the order.
While a role that uses an ETO planning strategy for sourcing products does
maintain an inventory of its source products, the entire inventory is always
allocated to making delivery products for specific buyers.
When using an ETO planning strategy, you configure these additional parameters
for the Mb: Make Product and M3: Engineer-to-Order categories:

• Engineering Duration parameter
• ECO (Engineering Change Orders) cost parameter
When using an ETO planning strategy, a role ignores the Inventory Control
Strategy parameter of its source and delivery products.

Using a Make-to-Order Planning Strategy
When using a make-to-order (MTO) planning strategy, a role:

• Creates replenishment orders for the exact number of source products
required to fill an order for delivery products.

• Creates build orders for the exact number of delivery products required to fill
an order for delivery products.

• Fulfills customer and replenishment orders from buyers from its inventory for
delivery products.

• Delivers the exact number of products required to fill an order.
• Delivers products to any buyer that places an order.
While a role that uses an MTO planning strategy for sourcing and delivering
products does maintain an inventory of both its source and delivery products, the
entire inventory is always allocated to specific buyers.
An MTO planning strategy for sourcing and delivering products is identical to a
stock/replenishment planning strategy, where the Safety Stock is 0 and the
Minimum Reorder Quantity is 1.
When using an MTO planning strategy, a role ignores the Inventory Control
Strategy parameter of its source and delivery products.
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Configuring the Role to Use Alternative
Planning Strategies
You configure a role to use alternative planning strategies by configuring the
Order Type parameter of the source and/or delivery products for the role. The
role sends orders, product shipments, invoices, and payments to the appropriate
source, make, and/or deliver categories on the role detail, based on the
Order Type.
By default, all product composites with the same Order Type use the same
planning strategy. You can also configure the role detail to use different
categories for product composites with the same Order Type by configuring the
Specific Product Name parameter for the category.
For details, see Configuring Role Details for Multiple Products.
To configure the role to use alternative planning strategies:
1

Configure the Order Type of the source and/or delivery product of a role to
be stock, mto, or eto to determine the planning strategy the role uses for
sourcing, making, and/or delivering products.
For details and examples of valid combinations or planning strategies, see
Rules for Configuring the Planning Strategy of a Role.

2

If the Order Type is eto, configure the additional Level 2 SCOR parameters for
the M3: Engineer-to-Order category.
For details, see Using an Engineer-to-Order Planning Strategy.
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The following figure shows a model in which the Manufacturer role uses an ETO
planning strategy for sourcing components and delivering finished products:

Manufacturer role’s Products pool

ETO Product:
ETO Part:
Is Source Product = false
Is Source Product = true
Is Delivery Product = true
Is Delivery Product = false
Order Type = ETO
Order Type = ETO

Note that the Order Type for the source and delivery product of the Manufacturer
role does not need to be the same. Similarly, the Order Type for the source and
delivery product of a Distributor role that assembles its components into kits does
not need to be the same. A Distributor role that delivers its source products,
however, uses the same Order Type for it source and delivery products.
Also, the Order Type for the delivery product of the Base Manufacturer role and
the source product of the Consumer role does not need to correspond to the Order
Type of the downstream and upstream roles, respectively.
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When you run the simulation, the S3: Source Engineer-to-Order Product category
creates orders and receives shipments of ETO components:
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The M3: Make Engineer-to-Order Product category creates build orders and
manufactures ETO finished products:

467

The D3: Deliver Engineer-to-Order Product category receives orders and sends
shipments of ETO finished products:
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Rules for Configuring the Planning Strategy of
a Role
You must follow these rules when combining planning strategies for the source
and delivery products of a role:
For this role...

Configure the planning strategy as follows...

Manufacturer role

The planning strategy for the source and delivery
products can be the same or different, as follows:

• If the same, the role uses the same planning

strategy for sourcing components, and making
and delivering finished products.

• If different, the role uses the planning strategy of

the source product for sourcing components, and
it uses the planning strategy of the delivery
product for making and delivering finished
products.

Distributor role that
delivers its source
products

The role uses the same planning strategy for sourcing
and delivering products.

Distributor role that
assembles components
into kits

The planning strategy for the source and delivery
products can be the same or different, as follows:

• If the same, the role uses the same planning

strategy for sourcing components and delivering
finished products as kits.

• If different, the role uses the planning strategy of

the source product for sourcing components, and
it uses the planning strategy of the delivery
product for delivering finished products as kits.
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Examples of Valid Planning Strategy Combinations
Here are some examples of valid combinations of planning strategies for a
Manufacturer role, a Distributor role that delivers its source products, and a
Distributor role that assembles components into kits.
Valid Planning Strategy Combinations for a Manufacturer Role
Default configuration, which sources,
makes, and delivers stock products.

Source product
Order Type = stock

Delivery product
Order Type = stock
Sources, makes, and delivers
make-to-order products.

Source product
Order Type = MTO

Delivery product
Order Type = MTO
Sources stock components, and makes and
delivers make-to-order finished products.

Source product
Order Type = stock

Delivery product
Order Type = MTO
Sources stock components, and makes and
delivers engineer-to-order finished products.

Source product
Order Type = stock

Delivery product
Order Type = ETO
Sources make-to-order components, and
makes and delivers stock finished products.

Source product
Order Type = MTO
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Delivery product
Order Type = stock

Rules for Configuring the Planning Strategy of a Role

Valid Planning Strategy Combinations for a Distributor Role
that Delivers its Source Products
Default configuration, which sources and
delivers stock products.

Source/ delivery product
Order Type = stock

Sources and delivers make-to-order products.

Source/ delivery product
Order Type = MTO

Sources and delivers engineer-to-order products.

Source/ delivery product
Order Type = ETO
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Valid Planning Strategy Combinations for a Distributor Role
that Assembles Components into Kits

Default configuration, which sources
and delivers stock products.

Source product
Order Type = stock

Delivery product
Order Type = stock

Sources and delivers make-to-order products.

Source product
Order Type = MTO

Delivery product
Order Type = MTO

Sources stock components and delivers
make-to-order finished products as kits.

Source product
Order Type = stock

Delivery product
Order Type = MTO

Sources make-to-order components and delivers
engineer-to-order finished products as kits.

Source product
Order Type = MTO

Delivery product
Order Type = ETO

Analyzing the Performance of a Model that Uses Alternative Planning Strategies

Analyzing the Performance of a Model that
Uses Alternative Planning Strategies
To analyze the performance of a model that uses alternative planning strategies, it
is helpful to think about the process in terms of the upstream source subprocess,
the make subprocess, and the downstream delivery subprocess. Each of these
Level 2 subprocesses has metrics you can analyze.

• Upstream source subprocess
ES: Enable Source category:

– Orders Sent and Change Orders Sent
– Product Shipments Received
– Contracts Established
– Supplier On-Time Performance (%)
Source category:

– Orders Sent and Change Orders Sent
– Product Shipments Received
– Product Shipment Lead Time
– Financial Obligations, Financial Payments within Financial Period, and
Financial Payments Total

– Receiving Metric, Verification Metric, Transfer Metric, Create Customer
Order Metric, and Invoice Metric costs

P2: Plan Source category:

– Number of Planning Periods
Source products:

– Quantity Ordered and Quantity Received
– Purchase Cost
– Products on Order, Received Inventory Level, Incoming Inventory Level,
and Inventory Level

– Received Fulfillment Time
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• Make subprocess
Make categories:

– Build Orders Started and Build Orders Completed
– Make Cycle Time
– Production Material Handling cost
– Order Entry to Manufacturing Time of the Mb: Make Product and
M3: Engineer-to-Order categories

– ECO Metric of the M3: Engineer-to-Order category
P3: Plan Make category:

– Number of Planning Periods
Source products:

– Awaiting Orders
– Work in Progress
Delivery products:

– Total Products Accepted
– Total Products Rejected
• Downstream delivery subprocess
ED: Enable Deliver category:

– Orders Received and Change Orders Received
– Product Shipments Sent
– Contracts Established
– Delivery Performance (%)
– Perfect Order Fulfillment (%)
Deliver categories:

– Orders Received and Change Orders Received
– Product Shipments Sent
– Fill Rates (%)
– Ready to Ship Time
– Order Entry to Ship Time
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– Financial Bookings, Financial Outstanding, Financial Collections within
Financial Period, and Financial Collections Total

– Order Entry Metric, Order Fulfillment Metric, Pick Metric, Packing Metric,
Transportation Metric, Customer Invoicing Metric, and Customer
Collections Metric costs

Delivery products:

– Quantity to Deliver and Quantity Shipped
– Awaiting Orders, Products On Order, Received Inventory Level,

Incoming Inventory Level, Inventory Level, In Transit Inventory Level,
Shipped Inventory Level, and Manufacturing Batch Size

– Order Fulfillment Lead Time
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Modeling a Process
with Multiple Suppliers
Describes how to build a model that sources identical products from multiple
suppliers, using contracts.
Introduction 489
Sourcing Identical Products from Multiple Suppliers 491
Configuring Contract Parameters in the Buyer 492
Configuring the Supplier Selection Criteria 494
Analyzing the Performance of a Model with Multiple Suppliers 501

Introduction
You can configure your model such that a buyer has multiple suppliers for the
same source product. By default, the buyer chooses a single supplier at random
from among its qualified suppliers.
When a buyer role has multiple suppliers for the same source product, you can
configure the buyer to choose its supplier(s), on a cyclic basis, based on contract
parameters that you configure in the buyer role’s source product. These
parameters include: the maximum number of suppliers, whether to split the order
among multiple suppliers, criteria for choosing the supplier, the length of the
contract, and the estimated amount of the contract. For example, you might
configure a buyer to choose the supplier with the highest priority, or you might
configure a buyer to split its orders among multiple qualified suppliers, based on
a specified proportion. Each time a contract expires, the buyer role chooses new
suppliers, based on the contract parameters.
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Contracts are relevant when a buyer role has multiple suppliers for the same
source product. Contracts are also used when using a stock/forecast planning
strategy and push planning. Otherwise, the model creates a single contract that is
in effect for the entire duration of the simulation.
When using contracts, the model performs two distinct functions, in this order,
each time a new contract is in effect:
1

The buyer issues purchase awards to qualified suppliers. The buyer
determines qualified suppliers, based on supplier selection criteria and the
specified number of suppliers.

2

The buyer determines the size of the order to send to each qualified supplier.
The buyer determines order size, based on whether it sends the order to a
single qualified supplier or splits the order, as follows:

• If the buyer specifies a single supplier, it chooses the supplier, based on
probabilities and sends the entire order to that supplier.

• If the buyer splits the order, it determines order size for each supplier,
based on proportions.

You can use contracts to analyze the performance impact on your supply chain of
adding multiple suppliers for the same source product. You can experiment with
choosing a single supplier or multiple suppliers, and you can experiment with
using different criteria for choosing and disqualifying suppliers.
When modeling a process with multiple suppliers, you:

• Configure the model to source identical products from multiple suppliers.
• Configure contract parameters in the buyer.
• Configure the criteria a buyer uses for choosing its suppliers.
• Analyze the performance of a model with multiple suppliers.
See Also Using a Stock/Forecast Planning Strategy.

478

Sourcing Identical Products from Multiple Suppliers

Sourcing Identical Products from Multiple
Suppliers
To configure a model to source identical products from multiple suppliers, create
multiple upstream suppliers that deliver the same product to a single
downstream buyer.
This figure shows a model in which a Distributor role assembles computer system
kits from monitor and CPU components. The role has three upstream suppliers,
one of which delivers monitors and the other two of which deliver CPU
components.

Multiple
suppliers
for the
same
source
product.
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Here is the Products pool of the Distributor role, which defines the CPU and
Monitor as source products, and the Computer System as a delivery product. You
configure contract parameters and supplier selection criteria in the CPU source
product, which has two potential suppliers.
Configure the contract parameters and supplier
selection criteria in the buyer role’s source product.

CPU:
Is Source Product = true
Is Delivery Product = false

Monitor:
Is Source Product = true
Is Delivery Product = false

Computer System:
Is Source Product = false
Is Delivery Product = true

Configuring Contract Parameters in the Buyer
To configure a buyer role to use contracts for choosing its suppliers, you
configure the following contract parameters on the Supplier tab of the buyer
role’s source product:
Parameter

Description

Contract Start Time

The time from the start of the simulation until the
buyer sends its first purchase request to upstream
suppliers for source products.

Contract Length

The length of time during which the contract is
valid.

Contract Response
Cycle Time

The number of days a supplier has to respond to a
purchase request with a purchase response.

Contract Repetition Count

The number of times to repeat the contract during
the lifetime of the simulation.

Note Orders sent while no contract is in effect are deleted.
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Configuring Contract Parameters in the Buyer

You must also configure the supplier selection criteria, as described in
Configuring Supplier Selection Criteria in the Source Product.
To configure contract parameters in the buyer:
1

Display the properties dialog for the source product of the buyer role that you
want to use contracts.

2

Click the Supplier tab and configure the parameters in the table above.

The following figure shows the Source tab of the properties dialog for a source
product of a Distributor role that uses contracts. The buyer waits one week before
sending a purchase request for source products to the supplier. The contract is
valid for 60 days. The supplier sends a purchase response within three days of
receiving the request.
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Configuring the Supplier Selection Criteria
When sourcing identical products from multiple upstream suppliers, you can
configure the criteria for choosing suppliers. You can configure:

• The source product of the buyer to choose suppliers, as follows:
– The maximum number of suppliers to which to issue awards.
– Whether the buyer splits the order among the specified number of
suppliers.

– The criteria the role uses for choosing its suppliers.
– When sending the order to a single supplier, the probability that the order
will go to each qualified supplier; when splitting the order, the proportion
of the order that goes to each qualified supplier.

• The supplier preference for the delivery product to rank suppliers, as needed.
For examples, see Examples of Configuring the Source Product for Choosing
Suppliers.

Configuring Supplier Selection Criteria in the
Source Product
To configure a buyer role to choose among multiple suppliers, you configure the
following supplier selection parameters in the buyer role’s source product:
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Parameter

Description

Maximum Number of
Suppliers

The number of suppliers to which to issue
awards.

Split Orders Between
Suppliers

Whether to split the order between the specified
number of suppliers.

Supplier Selection Criteria
1-4

The criteria for choosing among qualified
suppliers, where you can specify up to four
criteria.

Selected Suppliers
Proportions

How to split the order between qualified
suppliers, based on proportion or probability,
depending on whether the order is split between
multiple suppliers or not, respectively.

Configuring the Supplier Selection Criteria

To configure supplier selection criteria in the source product:
1

Display the properties dialog for the source product of the buyer role that
sources identical products from multiple upstream suppliers.

2

Click the Supplier Selection tab and configure the Potential Suppliers to be the
list of suppliers to which awards can be issued.
This parameter must be configured for all source products in the model.

3

Configure the parameters for choosing among the potential suppliers, as
described in the table above.

The following dialog shows the source product of a Distributor role that places
the entire order with one of two potential suppliers, based on probabilities. The
buyer chooses a single qualified supplier, first based on the product price, then
based on the supplier preference. It chooses the first supplier 80% of the time and
the second supplier 20% of the time.
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The following dialog shows the source product of a Distributor role that splits the
order between two potential suppliers, based on proportions. The buyer chooses
two suppliers, first based on the negotiated turnaround cycle time, then based on
the product price. It orders 75% of the source products from the first supplier and
25% from the second.
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Configuring the Supplier Selection Criteria

Configuring the Supplier Preference for the Delivery
Product
You can configure the Supplier Selection Criteria parameters of the buyer role’s
source product to choose suppliers, based on the Supplier Preference of the
supplier’s delivery product.
The following figure shows the properties dialog for a delivery product of the
Secondary CPU Manufacturer role, which ranks this supplier second when
choosing among potential suppliers:

To configure the supplier preference for the delivery product:
1

For each supplier, display the properties dialog for the delivery product.

2

On the General tab, configure the Supplier Preference parameter to rank the
supplier by preference, where the smaller the number, the more likely a
downstream buyer will choose this supplier when issuing purchase awards
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Examples of Configuring the Source Product for
Choosing Suppliers
To illustrate how the model can choose among multiple suppliers, suppose you
have three qualified suppliers for a given product, Supplier A, Supplier B, and
Supplier C. The Supplier Preference of the delivery product associated with each
supplier is 1, 2, and 3, respectively. Suppose you are issuing awards, based first
on Product Cost, then on Supplier Preference.
Suppose you want to issue awards to two suppliers, where the primary supplier
gets the order 75% of the time and the secondary supplier gets the order 25% of
the time. Assume Supplier A offers the lowest cost product, based on the Net
Selling Price of its delivery product. Assuming Split Orders Between Suppliers is
false, the default, the order goes to Supplier A 75% of the time, based on product
cost and to Supplier B 25% of the time, based on product cost.
Issuing Awards to Two Suppliers and
Placing an Order with a Single Supplier

Net Selling Price = 10
Supplier Preference = 1

The order goes to
Supplier A 75% of the
time, based on price.

Net Selling Price = 12
Supplier Preference = 2
The order goes to
Supplier B 25% of the
time, based on price.
Maximum Number of Suppliers = 2
Split Orders Between Suppliers = false
Supplier Selection Criteria 1 = Product Price
Supplier Selection Criteria 2 =Supplier Preference
Net Selling Price = 15
Supplier Preference = 3
Supplier C gets no
awards and no orders.
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Selected Suppliers Proportions = .75, .25
Potential Suppliers =
Supplier A, Supplier B, Supplier C

Configuring the Supplier Selection Criteria

This example shows a similar situation in which the buyer issues awards to three
potential suppliers, where two suppliers have the same Net Selling Price. In this
case, the buyer sorts suppliers, based on the secondary sort attribute, which is
Supplier Preference. The buyer places orders with a single supplier, based on
probabilities.
Issuing Awards to Three Suppliers and
Placing an Order with a Single Supplier

Net Selling Price = 10
Supplier Preference = 1

The order goes to Supplier
A 60% of the time, based
on preference.

Net Selling Price = 10
Supplier Preference = 2
The order goes to
Supplier B 20% of the
time, based on price.
Maximum Number of Suppliers = 3
Split Orders Between Suppliers = false
Supplier Selection Criteria 1 = Product Price
Supplier Selection Criteria 2 =Supplier Preference
Net Selling Price = 15
Supplier Preference = 3

Selected Suppliers Proportions = .6, .2, .2
Potential Suppliers =
Supplier A, Supplier B, Supplier C

The order goes to
Supplier C 20% of the
time, based on price.
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Suppose you decide to split the order among the three qualified suppliers, so you
configure Maximum Number of Suppliers as 3 and Split Orders Between
Suppliers as true. In this case, the Selected Suppliers Proportions parameter
determines the proportion of the order that each supplier receives. Suppose you
have specified the Selected Suppliers Proportions parameter such that 50% of the
order should go to the first supplier, 30% should go to second supplier, and 20%
should go to the third supplier. If Supplier A has the lowest product price and if
Suppliers B and C have the same product price, the buyer gives 50% of the order
to Supplier A, based on price, 30% of the order to Supplier B, based on preference,
and 20% of the order to Supplier C, based on preference.
Issuing Awards to Three Suppliers and
Splitting the Order Among All Suppliers

Net Selling Price = 10
Supplier Preference = 1

50% of the order goes to
Supplier A, based on price.

Net Selling Price = 12
Supplier Preference = 2
30% of the order goes to
Supplier B, based on
preference.
Maximum Number of Suppliers = 3
Split Orders Between Suppliers = true
Supplier Selection Criteria 1 = Product Price
Supplier Selection Criteria 2 =Supplier Preference
Net Selling Price = 12
Supplier Preference = 3
20% of the order goes
to Supplier C, based
on preference.
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Selected Suppliers Proportions = .5, .3, .2
Potential Suppliers =
Supplier A, Supplier B, Supplier C

Analyzing the Performance of a Model with Multiple Suppliers

Analyzing the Performance of a Model with
Multiple Suppliers
To view metrics specifically related to contracts, choose View > Contracts Metrics.
To analyze the performance of a model that uses multiple suppliers, it is helpful
to think about the process in terms of the upstream source subprocess, the make
subprocess, and the downstream delivery subprocess. Each of these Level 2
subprocesses has metrics you can analyze.

• Upstream source subprocess
ES: Enable Source category:

– Orders Sent and Change Orders Sent
– Product Shipments Received
– Contracts Established
– Supplier On-Time Performance (%)
Source category:

– Orders Sent and Change Orders Sent
– Product Shipments Received
– Product Shipment Lead Time
– Financial Obligations, Financial Payments within Financial Period, and
Financial Payments Total

– Receiving Metric, Verification Metric, Transfer Metric, Create Customer
Order Metric, and Invoice Metric costs

P2: Plan Source category:

– Number of Planning Periods
Source products:

– Quantity Ordered and Quantity Received
– Purchase Cost
– Products on Order, Received Inventory Level, Incoming Inventory Level,
and Inventory Level

– Received Fulfillment Time
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• Make subprocess
Make categories:

– Build Orders Started and Build Orders Completed
– Make Cycle Time
– Production Material Handling cost
P3: Plan Make category:

– Number of Planning Periods
Source products:

– Awaiting Orders
– Work in Progress
Delivery products:

– Total Products Accepted
– Total Products Rejected
• Downstream delivery subprocess
ED: Enable Deliver category:

– Orders Received and Change Orders Received
– Product Shipments Sent
– Contracts Established
– Delivery Performance (%)
– Perfect Order Fulfillment (%)
Deliver categories:

– Orders Received and Change Orders Received
– Product Shipments Sent
– Fill Rates (%)
– Ready to Ship Time
– Order Entry to Ship Time
– Financial Bookings, Financial Outstanding, Financial Collections within
Financial Period, and Financial Collections Total

– Order Entry Metric, Order Fulfillment Metric, Pick Metric, Packing Metric,
Transportation Metric, Customer Invoicing Metric, and Customer
Collections Metric costs
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Delivery products:

– Quantity to Deliver and Quantity Shipped
– Awaiting Orders, Products On Order, Received Inventory Level,

Incoming Inventory Level, Inventory Level, In Transit Inventory Level,
Shipped Inventory Level, and Manufacturing Batch Size

– Order Fulfillment Lead Time

491

492

18
Configuring Role
Details for Multiple Products
Describes how to configure the detail of supplier and buyer roles to source, make,
and/or deliver multiple products.
Introduction 505
Adding Multiple Categories to Role Details 506

Introduction
By default, each role detail contains a single Source, Make, and/or Deliver
category for each planning strategy—stock, make-to-order, and engineer-toorder. This means that if the role sources, makes, and/or delivers multiple
products that use the same planning strategy:

• Each source product uses the same Source category parameters.
• Each delivery product uses the same Make and/or Deliver category
parameters, depending on the role.

It also implies that each Source, Make, and/or Deliver category calculates
performance, financial, and cost parameters for all source and/or delivery
products together.
You might have a situation in which a source and/or delivery product uses the
same planning strategy but different modeling parameters, such as build
selection, order selection, or cost incurred parameters. You also might want to
track category metrics separately for each product that a role sources and/or
delivers, such as Inventory Level.
In these cases, you can add Source, Make, and/or Deliver categories to the role
detail for each source and/or delivery product that the role sources or makes
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and/or delivers. You then assign a specific product to each category on the role
detail.
Note When adding categories to the role detail, you must create one category for each
product composite that uses the same planning strategy; you cannot use the same
category for some product composites and separate categories for others.

If the source and/or delivery products use the same planning strategy but
different timing parameters only, you can configure multipliers for the timing
parameters of each product composite. In this case, there is no need to add
multiple categories to the role detail. For details, see Configuring Multipliers for
Timing Parameters.
If the source and/or delivery products use different planning strategies only, you
can use the existing categories on the role detail, as described in Using Alternative
Planning Strategies.
To configure the role detail for multiple products, you add multiple categories to
the role detail and connect multiple categories of the same type through the
category routers on the role detail.
Caution Whenever you add categories to the role detail, you should click the Upgrade
option for the role “off;” otherwise, when you install a new version of e-SCOR
and upgrade the model, the new version will overwrite your changes to the role
detail to use the default role template. For details, see Upgrading Models.

See Also Viewing Role Details.

Adding Multiple Categories to Role Details
If each delivery product associated with a Base Manufacturer, Distributor, or
Manufacturer role has different values for its Make and/or Deliver category
parameters, you can create multiple Make and/or Deliver categories on the role
detail for each delivery product.
Similarly, if each source product associated with a Distributor, Manufacturer, or
Consumer role has different values for its Source category parameters, you can
create multiple Source categories on the role detail for each source product.
To add multiple categories to role details:
1

Configure a buyer or supplier role to source, make, and/or deliver multiple
products, depending on the type of role.
For details, see Configuring the Products a Role Sources and Delivers.
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2

Display the e-SCOR toolbox and display the appropriate palette —
Source, Make, or Deliver:

3

Display the role detail.

4

For each source or delivery product, select from the palette a category that
uses the same planning strategy as the existing category and place it just
below the existing categories on the role detail.
For example:

• To configure a Base Manufacturer to make multiple delivery products,
select an Mb: Make Product category.

• To configure a Distributor to deliver multiple stock products, select a
D1: Deliver Stocked Product category.

• To configure a Consumer, Distributor, or Manufacturer role to source

multiple stock products, select an S1: Source Stock Products category.

• To configure a Manufacturer to make and deliver multiple stock products,
select an M1: Make-to-Stock category and a D1: Deliver Stocked Product
category.

5

Connect the new category through the category routers and paths on either
side of the existing categories.
A Base Manufacturer role has only a downstream category router on its detail,
and a Consumer role has only an upstream category router.

Note Ensure that the input and output paths on the upstream and downstream
sides of the category go in the same direction and connect to the same objects
as the existing categories. For an example, see Example of Adding Multiple
Categories to a Manufacturer Role.
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6

7

For each category, configure the Product Selection parameters, as follows:
a

Click the All Products option off.

b

Configure the Specific Product Name parameter to be a unique source or
delivery product by choosing a product from the dropdown list.

Configure the parameters of each category, as appropriate for the assigned
source or delivery products.

Note When adding multiple categories to the role detail, we recommend that you
configure duration parameters separately for each category rather than
configuring multipliers on the product composites.

Example of Adding Multiple Categories to a
Manufacturer Role
This figure shows a model and associated product structure in which the
Manufacturer role makes high-end and low-end computers from high-end and
low-end components:
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Adding Multiple Categories to Role Details

Here is the Product tab for the Manufacturer role, which sources high-end and
low-end components, and delivers high-end and low-end computers:
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This figure shows the detail of the Manufacturer role, which uses separate S1
categories for high-end and low-end components, and separate M1 and D1
categories for the high-end and low-end computers. Each S1, M1, and D1 category
configures the Specific Product Name and uses different values for various
parameters.
Specific Product Name = Low-End Computer
Build Selection
First Sort Direction = Smallest
First Sort Criteria = Internal Order Number
Specific Product Name = Low-End Components
Receiving Cost = 5
Verification Cost = 5
Transfer Cost = 5

Specific Product Name = Low-End Computer
Order Selection
First Sort Direction = Smallest
First Sort Criteria = Internal Order Number

Specific Product Name = High-End Components
Receiving Cost = 10
Verification Cost = 10
Transfer Cost = 10

Specific Product Name = High-End Computer
Order Selection
First Sort Direction = Biggest
First Sort Criteria = Total Cost

Specific Product Name = High-End Computer
Build Selection
First Sort Direction = Biggest
First Sort Criteria = Total Cost
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Using Pull and Push
Planning Modes
Describes how to use pull and push planning modes to determine when to source,
make, and deliver products, and how much to source, make, and deliver.
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Using Pull Mode Planning 514
What Happens When the Simulation Runs in Pull Mode 518
Using Push Mode Planning 525
What Happens When the Simulation Runs in Push Mode 530
Combining Pull and Push Mode within a Role 537
Analyzing the Performance of a Model that Uses Pull and Push Planning
Modes 544

Introduction
The planning mode determines:

• Which role and, therefore, which planning process takes precedence in

determining when to source products, and when to make and deliver
products.

• Which role and, therefore, which product composite takes precedence in

determining how many products to source, and how many delivery products
to make and deliver.
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The available planning modes are:

• Pull planning mode — A downstream buyer role’s source planning takes

precedence over an upstream supplier role’s “delivery planning” by placing
orders with upstream suppliers for its components.

• Push planning mode — An upstream supplier role’s “delivery planning”
takes precedence over a downstream buyer role’s source planning by
delivering finished products to its downstream buyers when they are
available.

By “delivery planning,” we mean the planning that determines when a role
delivers products to buyers, which differs depending on the role. For a
Distributor role, the role’s source planning determines its “delivery planning,”
whereas, for a Base Manufacturer or Manufacturer role, the role’s make planning
determines its “delivery planning.”
When you run the simulation, each role behaves differently in each planning
mode. For each role, you need to:

• Understand what happens when the model runs in pull mode.
• Understand what happens when the model runs in push mode.
You can combine pull and push planning modes within a role, for example, a
Manufacturer role might use pull mode to source components and push mode to
deliver finished products, or vice versa.
The only planning strategy available in push mode is stock. The number of
components a role sources in push mode depends on the forecast estimated
amount parameter, which you configure for both the role’s source product and
for the delivery product of the upstream supplier role. The amount of finished
product a role makes and delivers in push mode depends on the amount you
configure in the role’s delivery product.
Once you have configured the model to use pull or push planning, you can
analyze the performance of the model that uses pull and push planning.

Using Pull Mode Planning
To use pull mode planning, you configure:

• Initial order demand for customer orders that originate in the Consumer role.
• Order parameters for product composites.
• Planning parameters for product composites, depending on the planning
strategy: stock/replenishment, stock/forecast, stock/R-Q, stock/Q,
make-to-order, or engineer-to-order.
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Using Pull Mode Planning

• Planning parameters for the Plan categories, P2: Plan Source or P2: Plan Make
categories, depending on the role.

• Cost parameters related to orders for Source and Deliver categories.

Configuring Initial Order Demand
In pull mode, you configure initial order demand for the overall supply chain,
based on customer orders, which originate in each Consumer role in the model.
The model uses source and make planning to generate replenishment and build
orders throughout the supply chain, based on the initial order demand.
To configure initial order demand:
 Display the properties dialog of each source product of each Consumer role in
the model, click the Demand tab, and configure these parameters:

• Demand Start Time
• Demand Stop Time
• Demand Order Duration
• Demand Order Size
For a description of these parameters, see Configuring the Source Category.

Configuring Order Parameters for Product
Composites
In pull mode, you configure parameters related to orders for source and delivery
products.
To configure order parameters for product composites:
1

Display the properties dialog for each source and delivery product in the
model, click the General tab, configure this parameter to determine the
planning strategy the role uses for sourcing, making, and delivering products:
Order Type
For a description of the Order Type parameter for delivery products, see
General Tab, and for a description of Order Type for source products, see
General Tab.

2

Display the properties dialog for each source product in the model, click the
Supplier tab, and configure these parameters related to orders:

• Desired Turnaround
• Fulfillment Preference
• Push Stock Product = false
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For a description of these parameters, see Supplier Tab.

Configuring Planning Parameters for Product
Composites
In pull mode, when the model creates its initial customer orders, it uses source
and make planning to determine the size of each replenishment or build order.
If a role uses a stock/replenishment planning strategy, the default, you configure
planning parameters for source and delivery products related to inventory. If a
role uses a stock/forecast planning strategy, you configure planning parameters
for source products related to contracts.
If a role uses a make-to-order or engineer-to-order planning strategy for sourcing,
making, and/or delivering products, the role computes replenishment and/or
build order size, based on the order size of the downstream buyer role.
To configure planning parameters for product composites:
 Display the properties dialog for each source and delivery product in the
model and configure these parameters, depending on the planning strategy:

• If a role uses a stock/replenishment, stock/R-Q, or stock/Q planning

strategy, click the Inventory tab and configure these planning parameters
for source and delivery products:

– Starting Product Inventory Level
– Maximum Inventory Level
– Inventory Control Strategy
– Safety Stock
– Minimum Reorder Quantity
For a description of these parameters, see Inventory Tab.

• If a role uses a stock/forecast planning strategy, click the Supplier tab and
configure these planning parameters for source products:

– Contract Start Time
– Contract Length
– Contract Response Cycle Time
– Forecast Estimated Amount
– Contract Repetition Count
For a description of these parameters, see Supplier Tab.
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See Also Using an Engineer-to-Order Planning Strategy.

Using a Make-to-Order Planning Strategy.
Using a Stock/Replenishment Planning Strategy.
Using a Stock/Forecast Planning Strategy.

Configuring Planning Parameters for the Plan
Category
In pull mode, roles uses source or make planning, depending on the role, to
determine the size of replenishment and build orders for source and delivery
products, respectively.
If the role uses a stock planning strategy, you configure planning parameters for
the P2: Plan Source or P3: Plan Make categories, depending on the role, as
described in Configuring the Stock Planning Strategy.
For a Manufacturer role, which uses both source and make planning, you must
coordinate the timing of each type of planning, as described in Coordinating
Source and Make Planning.
To configure planning parameters for the Plan category:
1

Show the detail of each Base Manufacturer, Distributor, and Manufacturer
role in the model.

2

Display the properties dialog for the P2: Plan Source and/or P3: Plan Make
categories on the role detail, depending on the role, and configure these
parameters:

• Planning Period
• Initial Plan Delay
• Continuous Planning
• Compensate for Yield
For a description of these parameters, see Configuring the Plan Category.
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Configuring Cost Parameters Related to Orders
In pull mode, you can configure the cost parameters related to orders.
To configure cost parameters related to orders:
1

For each Base Manufacturer, Distributor, and Manufacturer role in the model,
show the detail of the role, display the properties dialog of the Deliver
category, click the Cost tab, and configure the cost parameters.

2

For each Distributor, Manufacturer, and Consumer role in the model, show
the detail of the role, display the properties dialog of the Source category, click
the Cost tab, and configure the cost parameters.

For a description of these parameters, see Configuring the Deliver Category and
Configuring the Source Category.

What Happens When the Simulation Runs in
Pull Mode
In pull mode, each role sources, makes, and delivers products differently, as
appropriate for the role to determine:

• When the role sources, makes, and/or delivers its products.
• How much product the role sources, makes, and delivers.
You need to understand what happens when the simulation runs in pull mode for
these roles:

• Distributor role
• Manufacturer role
• Base Manufacturer role
The Consumer role determines when it sources products, based on demand order
parameters that you configure in the source product.
The following sections provide a description of the behavior of each role in pull
mode. They also provide a diagram that maps each of these planning tasks to the
relevant process categories and to the source and delivery products of the role.
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Distributor Role in Pull Mode
In pull mode, a Distributor role determines when to source its components and
deliver its finished products, and how much to source and deliver, as follows:
Process Category

When

How Much

Source

Sources components, based
on source planning cycle
(P2: Plan Source).

The order size depends indirectly on
orders or forecasts for finished
products, which the Deliver category
sends upstream as replenishment
orders for components.

Deliver

Delivers finished products
when it can, based on
inventory levels for
components.

The amount to deliver depends on
customer or replenishment orders
for finished products.
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The following figure illustrates a Distributor role that uses pull mode:
Distributor Role in Pull Mode (Default)
The number of source products to order
depends indirectly on customer orders
for the role’s finished product.

Supplier

P2: Plan Source determines when the
Source category sends orders to
upstream suppliers for its components.
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The role delivers the number of finished
products it needs to fill an order.

Buyer

The role delivers its finished
products whenever it can, based on
inventory levels for components.

What Happens When the Simulation Runs in Pull Mode

Manufacturer Role in Pull Mode
In pull mode, a Manufacturer role determines when to source its components,
and make and deliver its finished products, and how much to source, make, and
deliver, as follows:
Process Category

When

How Much

Source

Sources components, based
on the source planning cycle
(P2: Plan Source).

The order size depends indirectly on
build orders for finished products,
which the Make category sends
upstream to the Source category as
replenishment orders for
components.

Make

Makes finished products,
based on the make planning
cycle (P3: Plan Make).

The amount to make depends
indirectly on customer or
replenishment orders for finished
products, which the Deliver category
sends upstream to the Make
category as build orders for finished
products.

Deliver

Delivers finished products
whenever it can, based on
inventory levels for finished
products.

The amount to deliver depends on
customer or replenishment orders
for finished products.
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The following figure illustrates a Manufacturer role that uses pull mode:
Manufacturer Role in Pull Mode (Default)
The number of source products to order
depends indirectly on build orders for
the role’s finished products.

The role delivers the number of finished
products it needs to fill an order.

Supplier

P2: Plan Source determines
when the Source category
sends replenishment orders
to upstream suppliers for its
components.
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Buyer

P3: Plan Make determines when the
Deliver category sends build orders to the
Make category for its finished products.
The number of finished products to build
depends indirectly on customer or
replenishment orders for the role’s
finished products.

The role delivers its finished
products whenever it can,
based on inventory levels for
finished products.
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Base Manufacturer Role in Pull Mode
In pull mode, a Base Manufacturer role determines when to make and deliver its
finished products, and how much to make and deliver, as follows:
Process Category

When

How Much

Make

Makes finished products,
based on the make planning
cycle (P3: Plan Make).

The amount to make depends
indirectly on customer or
replenishment orders for finished
products, which the Deliver category
sends upstream to the Make
category as build orders for finished
products.

Deliver

Delivers finished products
whenever it can, based on
inventory levels for finished
products.

The amount to deliver depends on
customer or replenishment orders
for finished products.
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The following figure illustrates a Base Manufacturer role that uses pull mode:
Base Manufacturer Role in Pull Mode (Default)
The role delivers the number of
components (delivery products)
it needs to fill an order.

Buyer

P3: Plan Make determines when the Deliver
category sends build orders to the Make category
for its finished products.
The number of finished products to build depends
indirectly on customer or replenishment orders for
the role’s finished products.
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The role delivers its finished
products whenever it can,
based on inventory levels
for finished products.

Using Push Mode Planning

Using Push Mode Planning
To use push mode planning, you configure:

• The number of delivery products to push to downstream buyers.
• Which delivery products to push first, given a supplier that pushes multiple
delivery products to downstream buyers.

• The amount to push when components are shared among multiple delivery
products.

The model computes how much is pushed for delivery products.
The only planning strategy available in push mode is stock, which behaves
differently depending on the finished products being pushed and the number of
downstream buyers.

Configuring the Amount to Push
You configure the number of delivery products a supplier role pushes to a buyer
role by configuring:

• Contract parameters in the downstream buyer role’s source product.
• Planning parameters in the upstream supplier role’s P2: Plan Source or P3:
Plan Make categories, depending on the role.

The supplier pushes the calculated amount each planning period.
The supplier computes the amount to push, based on the Forecast Estimated
Amount and Contract Length of the buyer role’s source product, and the
Planning Period of the supplier role’s Plan category, according to this formula:
(Planning Period / Contract Length) x Estimated Forecast Amount
For example, suppose the buyer specifies an 8 week contract and an estimated
amount of 800 products, and suppose the supplier has a 1 week planning period.
Assuming the contract coincides with the planning period, the supplier would
push 100 products each week for 8 weeks. If the contract does not coincide with
the planning period, the supplier pushes the balance of the calculated amount
during the next planning period.
You explicitly configure the source product of the buyer role to use push
planning.
When configuring a role to use push mode, the role’s source product must use
stock planning.
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To configure the amount to push:
 Display the properties dialog of the source product for the buyer role, click the
Supplier tab, and configure these parameters:

• Push Stock Product = true
• Contract Start Time
• Contract Length
• Contract Response Cycle Time
• Forecast Estimated Amount
• Contract Repetition Count
For a description of these parameters, see Supplier Tab.

Configuring Which Delivery Products to Push First
By default, if a supplier is pushing multiple delivery products to downstream
buyers, the supplier pushes products in a random order. You can configure the
Product Preference parameter of the supplier’s delivery product to determine
which product to deliver first. The Product Preference is a number that represents
the priority of the delivery product of the supplier role, where the lower the
number the higher the priority.
If a supplier is pushing multiple delivery products downstream and those
products are available at the same time, the supplier determines which finished
product to deliver first, based on the Product Preference parameter of each
delivery product. It pushes products with a higher Product Preference (smaller
number) before products with a lower Product Preference (larger number).
In the following figure, a Distributor role delivers office supplies and sports
equipment. If both finished products are available at the same time, the role
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delivers office supplies before sports equipment, because office supplies has a
higher Product Preference.

Product Preference = 1
Product Preference = 2

To configure the amount to push given multiple delivery products:
 Display the properties dialog of the delivery product of the supplier role that
is pushing products to downstream buyer roles, click the General tab, and
configure this parameter of each delivery product to determine the relative
priority of each product:

Product Preference
For a description of this parameter, see General Tab.

Configuring the Amount to Push When Components
are Shared
Suppose a buyer is delivering multiple products that share one or more
components, and upstream suppliers are pushing these components downstream
onto the buyer. By default, the buyer uses the shared components to deliver
finished products in a random order. You can configure the Product Preference
parameter of the buyer’s delivery product to determine which components the
buyer uses first.
The Product Preference is a number that represents the priority of the buyer’s
delivery product, where the lower the number the higher the priority
If the number of components that the upstream supplier pushes exceeds the
requirements of the downstream buyer, the buyer places the excess in inventory,
which the buyer might or might not use. If the upstream supplier does not push
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enough components onto the buyer, the buyer cannot deliver the desired number
of finished products.
To illustrate, suppose your model has a Distributor role that delivers two finished
products, X1 and X2, and sources three components, A, B, and C. The product
specification for X1 requires components A and C, and the product specification
for X2 requires components B and C; therefore, component C is shared.
Assume you configure the Product Preference for X1 to be 1 and the Product
Preference for X2 to be 2. This means the component requirements for X1
determine the number of C components the supplier pushes downstream.
Suppose the suppliers for products A, B, and C attempt to push their products
downstream, given a calculated amount to push of 50, 50, and 75, respectively.
This figure illustrates the product hierarchy, product preference, and amount to
push for this situation, where component C is shared:
Product Preference = 1

amount to push = 50

A

X1

X2

C

C

Product Preference = 2

B

amount to push = 50

amount to push = 75

Given this configuration, the questions are:

• How many C components does product X1 use compared with product X2?
• How many X1 and X2 products does the Distributor role deliver?
• How many B components does the Distributor role actually use?
The results are as follows:

• The Distributor role uses 50 C components to assemble product P1 and only
25 C components to assemble product P2, based on Product Preference.

• The Distributor role delivers 50 P1 products, but it delivers only 25 P2
products, because that is all it can assemble from the remaining C
components.

• Base Manufacturer B pushes 50 B components downstream; however, the

Distributor role only uses 25 B components to assemble P2 products. The rest
go into inventory.
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The following figure illustrates the number of components each Base
Manufacturer role pushes and the resulting number of finished products the
Distributor role delivers, given the shared component C:
Base Mfg. A pushes all 50 units of
component A downstream for use in
product P1, based on Product Preference.
A

50

Base
Mfg. A
push
Base Mfg. B pushes 50 units of
component B downstream; however,
the Distributor only uses 25 units.
B

Base
Mfg. B

50
(25 units
extra)

P1 takes priority over P2, based on Product
Preference; therefore, the Distributor role
uses 50 units of component C to go with the
50 available units of component A to make
50 units of product P1.

push

P1
C

P1

75

Base
Mfg. C

50

50

Distributor

Consumer

push
P2

25
P2

Base Mfg. C splits the
75 units of component C
between product P1
and P2, based on
Product Preference.

25

The Distributor role uses the remaining 25
units of component C and only 25 units of
component B to make 25 units of product P2.

To configure the amount to push given shared components:
1

Configure the downstream buyer role’s source products to be pushed by its
upstream supplier roles.
For details, see Configuring the Amount to Push.

2

Display the properties dialog of the downstream buyer role’s delivery
products, click the General tab, and configure this parameter to determine the
relative priority of each delivery product, which determines the amount of
each source product the buyer actually uses, given the calculated amount
to push:
Product Preference
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For a description of this parameter, see General Tab.

Determining How Much is Pushed
The model computes the Pushed Inventory Level metric for delivery products,
which is the number of products that an upstream supplier actually pushes onto a
downstream buyer.
To determine how much gets pushed:
 Display the properties dialog of the delivery product of the supplier role that
is pushing products to downstream buyers, click the Metrics tab, and view the
Pushed Inventory Level metric.

For a description of this parameter, see Metrics Tab.

What Happens When the Simulation Runs in
Push Mode
In push mode, each role sources, makes, and delivers products differently, as
appropriate for the role to determine:

• When the role sources, makes, and/or delivers its products.
• How much product the role sources, makes, and delivers.
You need to understand what happens when the simulation runs in push mode
for these roles:

• Distributor role
• Manufacturer role
• Base Manufacturer role
The Consumer role simply accepts the number of products that the supplier
pushes.
The following sections provide a description of the behavior of the role in push
mode. They also provide a diagram that maps each of these planning tasks to the
relevant categories and to the source and delivery products of the role.
The descriptions of the behavior of the role in push mode make the following
assumptions:

• The supplier is pushing its products to a single downstream buyer.
• The supplier is pushing a single product downstream.
• The buyer is delivering a single product to its downstream buyers.
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For information on what happens under different sets of assumptions, see:

• Configuring Which Delivery Products to Push First.
• Configuring the Amount to Push When Components are Shared.

Distributor Role in Push Mode
In push mode, a Distributor role determines how many components to source,
when to deliver finished products, and how much to deliver, as follows:
Process Category

When

How Much

Source

Source planning is ignored.
Instead, the role receives
components whenever the
upstream supplier pushes
them downstream.

Receives the calculated amount to
push of the upstream supplier’s
delivery product.

Deliver

Creates internal
replenishment orders for
finished products, based on
the source planning cycle
(P2: Plan Source).

Delivers the calculated amount to
push of the role’s delivery product,
given default assumptions.

Delivers finished products,
based on inventory levels for
components.
The following figure illustrates a Distributor role that uses push mode for
sourcing components and delivering finished products. The numbers represent

519

the sequence of events that occur when sourcing and delivering products in push
mode for a Distributor role.
Distributor Role in Push Mode
The role receives the calculated
amount to push of the upstream
supplier’s delivery product.

Supplier

1) P2: Plan Source is ignored for
source planning. The role
receives components whenever
the upstream supplier pushes
them downstream.
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The role delivers the
calculated amount to
push of finished products.

Buyer

2) The role creates internal replenishment
orders for its finished products, based on
the P2: Plan Source planning cycle.
3) The role delivers its finished products,
based on inventory levels for components.

What Happens When the Simulation Runs in Push Mode

Manufacturer Role in Push Mode
In push mode, a Manufacturer role determines how many components to source,
when to make and deliver finished products, and how many finished products to
make and deliver, as follows:
Process Category

When

How Much

Source

Source planning is ignored.
Instead, the role receives
components whenever the
upstream supplier pushes
them downstream.

Receives the calculated amount to
push of the upstream supplier’s
delivery product.

Make

Creates internal build orders
for finished products, based
on available components and
the make planning cycle
(P3: Plan Make).

Makes as many finished products as it
has build orders, which depends
indirectly on inventory levels for
components.

Deliver

As it creates internal build
orders, creates internal
replenishment orders for
finished products, based on
build-order size, which takes
place on the same make
planning cycle (P3: Plan
Make) as the build orders.

Delivers as much as it can, based on
build orders for finished products,
which depends indirectly on inventory
levels for components.

The number of components the role
receives indirectly determines how
many finished products the role makes
and delivers.

Delivers finished products
whenever it can, based on
inventory levels for finished
products.
The following figure illustrates a Manufacturer role that uses push mode for
sourcing components and delivering finished products. The numbers represent
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the sequence of events that occur when sourcing, making, and delivering
products in push mode for a Manufacturer role.
Manufacturer Role in Push Mode
The role accepts the calculated amount to
push of the upstream supplier’s delivery
product, which indirectly determines how
much the role makes and delivers.

Supplier

1) P2: Plan Source is
ignored. The role accepts
components whenever
the upstream supplier
delivers them.
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The role delivers as much as it
can, based on internal customer
orders for finished products.

Buyer

2) The role creates internal build
orders for finished products, based
on available components, which
takes place based on the P3: Plan
Make planning cycle.

3) The role creates internal replenishment
orders for its finished products, based on build
orders for its finished products, which takes
place based on the same P3: Plan Make
planning cycle as the build orders.

4) The role makes as many finished
products as it has build orders.

5) The role delivers as many finished products
as it can whenever it can.
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Base Manufacturer Role in Push Mode
In push mode, a Base Manufacturer role determines when to make and deliver
finished products, and how much to make and deliver, as follows:
Process Category

When

How Much

Make

Creates internal build orders
for finished products, based
on its internal replenishment
orders, which takes place
based on its make planning
cycle (P3: Plan Make).

Makes as much as it can, based on
build orders for its finished
products, which depends indirectly
on the calculated amount to push of
the delivery product.

Makes finished products,
based on the make planning
cycle (P3: Plan Make).
Deliver

Creates internal
replenishment orders for
finished products, based on
the Push Amount of the
role’s delivery product,
which takes place based on
its make planning cycle
(P3: Plan Make).

Delivers the calculated amount to
push of the role’s delivery product,
given the default set of assumptions.

Delivers finished products
whenever it can, based on
inventory levels for finished
products.
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The following figure illustrates a Base Manufacturer role that push mode. The
numbers represent the sequence of events that occur when making and delivering
products in push mode for a Base Manufacturer role.
Base Manufacturer Role in Push Mode
The role delivers the amount of finished product
specified by the calculated amount to push, which
indirectly determines how much the role makes.

Buyer

2) The role creates internal build orders for its finished
products, based on its internal replenishment orders,
which takes place based on the P3: Plan Make planning
cycle.

1) The role creates internal replenishment orders for its
finished products, based on the calculated amount to
push, which takes place based on the P3: Plan Make
planning cycle.

3) P3: Plan Make determines when the role makes its
finished products, based on its build orders.

5) The role delivers its finished products whenever it can,
based on inventory levels for finished products.

4) The role makes as much as it has build orders.
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Combining Pull and Push Mode within a Role
In addition to combining pull and push across roles, you can combine pull and
push planning modes within the same role. You can use these combinations of
pull and push for each role:

• Distributor role that uses pull-push.
• Distributor role that uses push-pull.
• Manufacturer role that uses pull-push.
• Manufacturer role that uses push-pull.

Distributor Role that Uses Pull-Push
The following table describes the behavior of a model in which a Distributor
role’s uses pull mode for sourcing components and push mode for delivering
finished products. The numbers represent the order in which the planning events
occur. In this case, push mode of the delivery phase takes precedence over pull
mode of the source phase in terms of when planning takes place.
Note The role must use a stock/replenishment planning strategy for its Deliver
category; stock/forecast, make-to-order, and engineer-to-order are not valid.
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Process Category

When

How Much

Deliver
(push)

1) Creates internal
replenishment orders for
finished products, based on
the source planning cycle
(P2: Plan Source).

Delivers the calculated amount to
push of the role’s delivery product,
given default assumptions.

Delivers finished products
whenever it can, based on
inventory levels for
components.
Source
(pull)

2) Creates internal
replenishment orders for
components, based on orders
for finished products, which
takes place based on the
same source planning cycle
(P2: Plan Source) as the
internal replenishment
orders for finished products.
Sources components, based
on source planning cycle
(P2: Plan Source).
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Sources components, based on
customer or replenishment orders
for finished products, combined with
the Safety Stock and current
inventory level of the source
product.

Combining Pull and Push Mode within a Role

Distributor Role that Uses Push-Pull
The following table describes the behavior of a model in which a Distributor role
uses push mode for sourcing components and pull mode for delivering finished
products. The numbers represent the order in which the planning events occur.
Push mode of the source phase takes precedence over pull mode of the delivery
phase in terms of when planning takes place.
Process Category

When

How Much

Source
(push)

1) Source planning is
ignored. Instead, the role
receives components
whenever the upstream
supplier pushes them
downstream.

Receives the calculated amount to
push of the upstream supplier’s
delivery product.

Deliver
(pull)

2) Delivers finished products
whenever it can, based on
inventory levels for
components.

The amount to deliver depends on
customer or replenishment orders
for finished products.
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Manufacturer Role that Uses Pull-Push
The following table describes the behavior of a model in which a Manufacturer
role uses pull mode for sourcing components and push mode for delivering
finished products. The numbers represent the order in which the planning events
occur. Push mode of the delivery phase takes precedence over pull mode of the
source phase in terms of when planning takes place.
Process Category

When

How Much

Make
(push)

1) Creates internal build
orders for finished products,
based on the calculated
amount to push, which takes
place based on its make
planning cycle (P3: Plan
Make).

Makes as many finished products as
it has build orders, which depends
indirectly on inventory levels for
components.

Deliver
(push)

2) Creates internal
replenishment orders for
finished products, based on
internal build orders, which
takes place based on the
same make planning cycle
(P3: Plan Make) as the
internal build orders for
finished products.

Delivers as many finished products
as it has replenishment orders,
which depends indirectly on
inventory levels for components.

3) Delivers finished products
whenever it can, based on
inventory levels for finished
products.
Source
(pull)
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4) Sources components,
based on the source planning
cycle (P2: Plan Source).

Sources components, based on build
orders for finished products.
Determines the amount to source,
based on customer orders for
finished products, the Safety Stock,
and the current inventory level of
the source product.

Combining Pull and Push Mode within a Role

Manufacturer Role that Uses Push-Pull
The following table describes the behavior of a model in which a Manufacturer
role that uses push mode for sourcing components and pull mode for delivering
finished products. The numbers represent the order in which the planning events
occur. Push mode of the source phase takes precedence over pull mode of the
delivery phase in terms of when planning takes place.
Process Category

When

How Much

Source
(push)

1) Source planning is
ignored. Instead, the role
receives components
whenever the upstream
supplier pushes them
downstream.

Receives the calculated amount to
push of the upstream supplier’s
delivery product.

Make
(pull)

2) Makes finished products,
based on make planning
cycle (P3: Plan Make).

The amount to make depends
indirectly on customer or
replenishment orders for finished
products, which the Deliver category
sends upstream to the Make
category as build orders for finished
products.

Deliver
(pull)

3) Delivers finished products
whenever it can, based on
inventory levels for finished
products.

The amount to deliver depends on
customer or replenishment orders
for finished products.

The number of components the role
receives indirectly determines how
many finished product the role
makes and delivers.
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Examples of Combining Pull and Push Mode
The following figures illustrate various combinations of pull and push modes for
various roles. The figures indicate which Plan category takes precedence for each
combination of pull and push.
Default Configuration of Source and Delivery Type (Pull)

Source product
of Manufacturer
uses pull mode.

Source product
of Distributor uses
pull mode.

P2: Plan Source of downstream
Distributor role determines when to
source components by placing
orders. The Base Manufacturer role
delivers finished products whenever
it can, based on orders.
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P2: Plan Source of downstream
Manufacturer role determines
when to source components by
placing orders. The Distributor role
delivers finished products
whenever it can, based on orders.

Source product
of Consumer uses
pull mode.

Source product of downstream
Consumer role determines when to
source components by placing orders.
The Manufacturer role delivers finished
products whenever it can, based on
orders.

Combining Pull and Push Mode within a Role

Distributor Role Pushing Its Finished Products Downstream

Source product
of Manufacturer
uses push mode.

Source product
of Distributor uses
pull mode.

P2: Plan Source of downstream
Distributor role determines when
to source components by placing
orders. The Base Manufacturer
delivers finished products
whenever it can, based on orders.

P2: Plan Source of the upstream
Distributor role determines when to
deliver finished products, then it
pushes them downstream
whenever it can, based on the
calculated amount to push.

Source product
of Consumer uses
pull mode.

Source product of downstream
Consumer role determines when to
source components by placing orders.
The Manufacturer role delivers
finished products whenever it can,
based on orders.
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Base Manufacturer and Manufacturer Roles
Pushing Finished Products

Source product
of Manufacturer
uses pull mode.

Source product
of Consumer uses
push mode.

Source product
of Distributor uses
push mode.

P3: Plan Make of upstream Base
Manufacturer role determines
when to make finished products,
then it pushes them downstream
whenever it can, based on the
calculated amount to push.

P2: Plan Source of downstream
Manufacturer role determines
when to source components by
placing orders. The Distributor
role delivers its finished products
whenever it can, based on orders.

P3: Plan Make of upstream
Manufacturer role determines when
to make finished products, then it
pushes them downstream whenever it
can, based on the calculated amount
to push.

Analyzing the Performance of a Model that
Uses Pull and Push Planning Modes
To analyze the performance of a model that uses pull or push planning modes, it
is helpful to think about the process in terms of the upstream source subprocess,
the make subprocess, and the downstream delivery subprocess. Each of these
Level 2 subprocesses has metrics you can analyze.
See Also Viewing Metrics for Categories.

Viewing Metrics for Source and Delivery Products.
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You analyze these metrics for pull and push modes:

• Upstream source subprocess
ES: Enable Source category:

– Orders Sent and Change Orders Sent
– Product Shipments Received
– Contracts Established
– Supplier On-Time Performance (%)
Source category:

– Orders Sent and Change Orders Sent
– Product Shipments Received
– Product Shipment Lead Time
– Financial Obligations, Financial Payments within Financial Period, and
Financial Payments Total

– Receiving Metric, Verification Metric, Transfer Metric, Create Customer
Order Metric, and Invoice Metric costs

P2: Plan Source category:

– Number of Planning Periods
Source products:

– Quantity Ordered and Quantity Received
– Purchase Cost
– Products on Order, Received Inventory Level, Incoming Inventory Level,
and Inventory Level

– Received Fulfillment Time
• Make subprocess
Make categories:

– Build Orders Started and Build Orders Completed
– Make Cycle Time
– Production Material Handling cost
P3: Plan Make category:

– Number of Planning Periods

533

Source products:

– Awaiting Orders
– Work in Progress
Delivery products:

– Total Products Accepted
– Total Products Rejected
• Downstream delivery subprocess
ED: Enable Deliver category:

– Orders Received and Change Orders Received
– Product Shipments Sent
– Contracts Established
– Delivery Performance (%)
– Perfect Order Fulfillment (%)
Deliver categories:

– Orders Received and Change Orders Received
– Product Shipments Sent
– Fill Rates (%)
– Ready to Ship Time
– Order Entry to Ship Time
– Financial Bookings, Financial Outstanding, Financial Collections within
Financial Period, and Financial Collections Total

– Order Entry Metric, Order Fulfillment Metric, Pick Metric, Packing Metric,
Transportation Metric, Customer Invoicing Metric, and Customer
Collections Metric costs

Delivery products:

– Quantity to Deliver and Quantity Shipped
– Awaiting Orders, Products On Order, Received Inventory Level,

Incoming Inventory Level, Inventory Level, In Transit Inventory Level,
Shipped Inventory Level, and Manufacturing Batch Size

– Pushed Inventory Level
– Order Fulfillment Lead Time
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Part IV
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and Index
Appendix A: Asset Metrics Formulas
Describes the formulasfor computing the standard asset metrics for roles and special
considerations when using these metrics.
Appendix B: SCOR Metrics
Provides the SCOR definition of each SCOR metric that is used in e-SCOR.

Glossary
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A
Asset Metrics Formulas
Describes the formulasfor computing the standard asset metrics for roles and
special considerations when using these metrics.
Introduction 549
Days of Supply 550
Asset Turns 553
Cash-to-Cash Cycle Time 554
Days Sales Outstanding 555

Introduction
This appendix describes the specific formulas e-SCOR uses to compute the
following asset metrics for roles:

• Days of Supply
– Raw Materials
– Work in Progress
– Finished Goods
– Inventory
• Asset Turns
• Cash-to-Cash Cycle Time
• Days Sales Outstanding
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Note Asset metric values can appear differently in dialogs and in Excel reports due to
differences in the way in which e-SCOR and Excel interpret binary numbers. For
example, a dialog might display a value of 1.9999 when a report displays the
same value as 2.0.

Days of Supply
The Days of Supply metrics are measured in days of supply of inventory for
source products, work in progress, delivery products, and total inventory. The
metrics include Days of Supply for all source products, delivery products, and
work in progress for the role.
The Days of Supply metrics are cost-weighted values, based on the Purchase Cost
metric for source products and the Net Selling Price parameter for delivery
products. The Days of Supply metrics assume the Purchase Cost and Net Selling
Price are both non-zero; otherwise, the Days of Supply metrics will be zero.
The Days of Supply metrics assume the Inventory Level metric for a source or
delivery product is non-zero; otherwise, the Days of Supply metrics will be zero.
The Days of Supply metrics assume the role consumes a certain amount of source
or delivery products during the current financial period. If the consumption is
zero for a given financial period, the Days of Supply metrics will equal infinity,
implying that the role has an infinite supply for the financial period.
A consumption of zero has different effects on the Inventory Days of Supply and
Cash-to-Cash Cycle Time metrics.
Caution A value of infinity appears in a dialog as the symbol +inf; however, a value of
infinite appears in a report as 65,536 or 216. Be sure to take into account infinite
numbers when interpreting results in Excel reports, for example, when averaging
values over time.

e-SCOR computes the Days of Supply metrics, based on a time-weighted average
of actual values over time. This means the e-SCOR Days of Supply metrics are
more accurate than standard computations for Days of Supply, which normally
use averages based on samples taken during the financial period.
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Days of Supply

Raw Materials
The sum of the cost-weighted values of each source product in inventory at the
end of the financial period, given current inventory and the consumption of
source products during the financial period.
Raw Materials Days of Supply is only relevant for a Manufacturer role and a
Distributor role that assembles components into kits. It is not relevant for a
Distributor role that delivers its source products or for a Base Manufacturer or
Consumer role.

 PurchaseCost  SourceAssets 

---------------------------------------------------------------------------------------------   PurchaseCost  Consumption    FinancialPeriod
Term

Description

PurchaseCost

The value of the Purchase Cost metric for each source
product.

SourceAssets

The sum of the Inventory Level metric and the Incoming
Inventory Level metric for each source product.

Consumption

The amount of each source product that the role has
consumed during the Financial Period.

FinancialPeriod

The value of the Financial Period parameter for the role.

Work in Progress
The sum of the cost-weighted values of the work in progress of each source
product at the end of the financial period, given current work in progress and the
consumption of source products during the financial period.
Work in Progress Days of Supply is only relevant for a Manufacturer role. It is not
relevant for a Base Manufacturer, Distributor, or Consumer role.

 PurchaseCost  WorkInProgress-

--------------------------------------------------------------------------------------------------- FinancialPeriod
   PurchaseCost  Consumption  
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Term

Description

PurchaseCost

The value of the Purchase Cost metric for each source
product.

WorkInProgress

The value of the Work in Progress metric for each source
product.

Consumption

The amount of each source product that the role has
consumed during the Financial Period.

FinancialPeriod

The value of the Financial Period parameter for the role.

Finished Goods
The sum of the cost-weighted values of each delivery product in inventory at the
end of the financial period, given current inventory and the amount of delivery
product picked for delivery during the financial period.
Finished Goods Days of Supply is relevant for a Base Manufacturer, Distributor,
and Manufacturer role. It is not relevant for a Consumer role.

 NetSellingPrice  DeliveryAssets-

------------------------------------------------------------------------------------------------------------- FinancialPeriod


  PurchaseCost  Consumption 
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Term

Description

NetSellingPrice

The value of the Net Selling Price parameter for each
delivery product.

DeliveryAssets

The sum of the Inventory Level metric and the In Transit
Inventory Level metric for each delivery product.

PurchaseCost

The value of the Purchase Cost metric for each source
product.

Consumption

The amount of each delivery product that the role has
picked for delivery during the Financial Period.

FinancialPeriod

The value of the Financial Period parameter for the role.

Asset Turns

Inventory
The sum of the Raw Materials, Work in Progress, and Finished Goods Days of
Supply metrics.
If any of these values is infinite due to a zero consumption, the Inventory Days of
Supply metric ignores the infinite term. If all three of the values are infinite, the
Inventory Days of Supply metric is also infinite.
Inventory Days of Supply is relevant for a Base Manufacturer, Distributor, and
Manufacturer role. It is not relevant for a Consumer role.

RawMaterials + FinishedGoods + WorkInProgress
Term

Description

RawMaterials

The value of the Raw Materials Days of Supply metric for
the role.

FinishedGoods

The value of the Finished Goods Days of Supply metric
for the role.

WorkInProgress

The value of the Work in Progress Days of Supply metric
for the role.

Asset Turns
The number of days the role takes to turn over its inventory for delivery products,
measured as a cost-weighted value.
Asset Turns is relevant for a Base Manufacturer, Distributor, and Manufacturer
role. It is not relevant for a Consumer role.

365
 FinancialCollectionsPeriod
--------------------------------------------------------------------------------------   -------------------------------------------------

  FinancialPeriod
AssetValue
AssetValue is defined as follows:
( (SourceProductInventory + WorkInProgress + IncomingAmount)
x PurchaseCost)
+ ( (DeliveryProductInventory + InTransitAmount)
x NetSellingPrice)
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Term

Description

FinancialCollectionsPeriod

The value of the Financial Collections within
Financial Period metric for the role.

FinancialPeriod

The value of the Financial Period parameter for
the role.

SourceProductInventory

The value of the Inventory Level metric for each
source product.

DeliveryProductInventory

The value of the Inventory Level metric for each
delivery product.

WorkInProgress

The value of the Work in Progress metric for each
source product.

IncomingAmount

The value of the Incoming Inventory Level metric
for each source product.

InTransitAmount

The value of the In Transit Inventory Level metric
for each delivery product.

PurchaseCost

The value of the Purchase Cost metric for each
source product.

NetSellingPrice

The value of the Net Selling Price parameter for
each delivery product.

Cash-to-Cash Cycle Time
The time it takes for money to flow from buyers to suppliers. A positive value
indicates the role spends more money than it takes in. A negative value indicates
the role takes in more money than it spends. This metric is weighted, based on the
Financial Payment Terms of each buyer role and is measured in days.
If any one of the values that make up the Cash-to-Cash Cycle Time is infinite, the
value of the metric is also infinite.
Caution A value of infinite appears in a dialog as the symbol +inf. However, a value of
infinite appears in a report as 65,536 or 216. Be sure to take into account infinite
numbers when interpreting results in Excel reports, for example, when averaging
values over time.

Cash-to-Cash Cycle Time is relevant for a Distributor and Manufacturer role. It is
not relevant for a Base Manufacturer or Consumer role.
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Days Sales Outstanding

nventoryDaysOfSupply + DaysSalesOuts tan ding – FinancialPaymentsPeriod
Term

Description

InventoryDaysOfSupply

The value of the Inventory Days of Supply metric
for the role.

DaysSalesOutstanding

The value of the Days Sales Outstanding metric
for the role.

FinancialPaymentsPeriod

The value of the Financial Payments within
Financial Period metric for the Source category.

Days Sales Outstanding
The value of delivery product sales, which includes Financial Collections within
Financial Period, Financial Bookings, and Financial Outstanding metrics for the
current financial period, measured in days.
Days Sales Outstanding is relevant for a Base Manufacturer, Distributor, and
Manufacturer role. It is not relevant for a Consumer role.

FinancialBookings
+ FinancialOuts tan ding
-------------------------------------------------------------------------------------------------------------------------------- FinancialCollectionsPeriod
--------------------------------------------------------------------------------------


FinancialPeriod
Term

Description

FinanicalBookings

The value of the Financial Bookings metric for the
role.

FinancialOutstanding

The value of the Financial Outstanding metric for
the role.

FinancialCollectionsPeriod

The value of the Financial Collections within
Financial Period metric for the role.

FinancialPeriod

The value of the Financial Period parameter for
the role.
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B
SCOR Metrics
Provides the SCOR definition of each SCOR metric that is used in e-SCOR.
Introduction 557
SCOR Definitions 558

Introduction
The following table alphabetically lists each of the SCOR metrics that e-SCOR
supports and provides the SCOR definition for the metric. If the e-SCOR
parameter or metric name is different from the SCOR metric name, the e-SCOR
name appears in parentheses below the SCOR metric name. If e-SCOR does not
fully support the SCOR definition, the part of the definition that is not supported
appears with a strike-through.
The table also lists the location in which the SCOR metric is defined in e-SCOR,
whether it is an e-SCOR metric or parameter, and where to go for the e-SCOR
definition.
These definitions are reprinted by permission by the Supply-Chain Council (SCC)
(www.supply-chain.org).
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SCOR Definitions
SCOR Metric
(Metric)

SCOR Definition

Location

Asset Turns

Total gross product revenue ÷
Total net assets.

Role,
Assets tab
(Metric)

Capacity Utilization

A measure of how intensively a
resource is being used to
produce a good or service. Some
factors that should be considered
are internal manufacturing
capacity, constraining processes,
direct labor availability, and key
components/materials
availability.

Resource
(Metric)

Cash-to-Cash
Cycle Time

Cash-to-cash cycle time =
inventory days of supply + days
sales outstanding – average
payment period for materials
(time it takes for a dollar to flow
back into a company after its
been spent for raw materials).

Role,
Assets tab
(Metric)

Create Customer
Order Costs

Includes costs for creating and
pricing configurations to order
and preparing order documents.

Source category,
Cost tab
(Metric)

Includes costs for invoicing,
processing customer payments,
and verifying customer
satisfaction.

Deliver
category,
Cost tab
(Metric)

5 point annual average of gross
accounts receivable ÷ (total gross
annual sales ÷ 365)

Role,
Assets tab
(Metric)

(Create Customer
Order Metric)
Customer Invoicing/
Accounting Costs
(Customer
Invoicing Metric
and Customer
Collections Metric)
Days Sales
Outstanding
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Definition

SCOR Definitions

SCOR Metric
(Metric)

SCOR Definition

Location

Delivery Performance
to Customer Request
Date

The percentage of orders that are
fulfilled on or before the
customer’s requested date.

ED: Enable
Delivery
category
(Metric)

Costs incurred from revisions to
a blueprint or design released by
engineering to modify or correct
a part. The request for the
change can be from a customer
or from production quality
control or another department.

Mb, M3
category,
Cost tab
(Metric)

The percentage of ship-fromstock orders shipped within 24
hours of order receipt.

D1 category,
Delivery tab
(Metric)

Finished goods inventory days
of supply are calculated as gross
finished goods inventory ÷
(value of transfers/365 days).

Role,
Assets tab
(Metric)

Total gross value of inventory at
standard cost before reserves for
excess and obsolescence. Only
includes inventory on company
books, future liabilities should
not be included. 5 point annual
average of the sum of all gross
inventories (raw materials &
WIP, plant FG, field FG, field
samples, other) ÷ (COGS ÷ 365).

Role,
Assets tab
(Metric)

(Delivery Performance
(%))
ECO Costs
(ECO Metric)

Fill Rates
(Fill Rates (%))
Finished Goods
Inventory Days of
Supply
(Finished Goods)
Inventory Days of
Supply
(Inventory)

Definition
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SCOR Metric
(Metric)

Make Cycle Time
(Make Cycle Time)

Number of End
Products/SKUs
(Number of End
Products)
Order Entry and
Maintenance Costs
(Order Entry Metric)

Order Entry Complete
to Start Manufacture
Time
(Order Entry
to Manufacturing
Time)
Order Entry Complete
to Order Ready for
Shipment Time
(Order Entry to Ship
Time)
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SCOR Definition

Location

The sum of the following
average times: Order release to
start actual build + Total build
cycle + End build to leaves plant
(i.e., moves to on/off-site
distribution or goes to customer).
For continuous and mixed
processes, manufacturing cycle
time is calculated as the average
number of units (doses, kilos,
pounds, gallons, etc.) in process
divided by the average daily
output in units.

Make category,
Manufacturer
tab
(Metric)

Total number of unique end item
product offerings. End items are
individually planned and
managed.

Role,
Role tab
(Metric)

Includes costs for maintaining
the customer data base, credit
check, accepting new orders and
adding them to the order system
as well as later order
modifications.

Deliver
category,
Cost tab
(Metric)

Time from completion of order
Mb, M3
entry to that of the release to
categories,
manufacturing, in calendar days. Manufacturer
tab
(Metric)

Including release to
manufacturing, order
configuration verification,
production scheduling, build,
pick/pack, and prepare for
shipment time, in calendar days.

Deliver
category,
Delivery tab
(Metric)

Definition

SCOR Definitions

SCOR Metric
(Metric)

SCOR Definition

Location

Includes costs for processing the
order, allocating inventory,
ordering from the internal or
external supplier, scheduling the
shipment, reporting order status
and initiating shipment.

Deliver
category,
Cost tab
(Metric)

Order Fulfillment
Lead Time

The average actual lead times
consistently achieved, from
Customer Signature/
Authorization to Order Receipt,
Order Receipt to Order Entry
Complete, Order Entry
Complete to Start-Build, Start
Build to Order Ready for
Shipment, Order Ready for
Shipment to Customer Receipt of
Order, and Customer Receipt of
Order to Installation Complete.

Product
composite,
Metrics tab
(Metric)

Order Management
Cost

The aggregation of the following
cost elements (contained in this
glossary):

Role,
Cost tab
(Metric)

Order Fulfillment
Costs
(Order Fulfillment
Metric)

Definition

• Create Customer Order
Costs

• Order Entry and

Maintenance Costs

• Contract/Program and

Channel Management Costs

• Installation Planning Costs
• Order Fulfillment Costs
• Pick Costs
• Packing Costs
• Transportation Costs
• Installation Costs
• Customer

Invoicing/Collections Costs
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SCOR Metric
(Metric)

Order Receipt to Order
Entry Complete Time
(Order Entry Duration)

Order Ready for
Shipment to Customer
Receipt of Order Time
(Transportation
Duration)
Pack Product Cycle
Time
(Packing Duration)

Perfect Order
Fulfillment
(Perfect Order
Fulfillment)

SCOR Definition

Location

Time required, in calendar days,
for order revalidation,
configuration check, credit
check, and scheduling of
received orders.

D1, D2
categories,
Order tab
(Parameter)

Including total transit time (all
components to consolidation
point), consolidation, queue
time, and additional transit time
to customer receipt of order, in
calendar days.

Deliver
category,
Transportation
tab
(Parameter)

Includes activities such as
sorting/combining the products,
packing/kitting the products,
pasting labels and barcodes, and
delivering the products to the
shipping area for loading.

Deliver
category,
Fulfillment tab
(Parameter)

A “perfect order” is defined as
an order that meets all of the
following standards:

ED: Enable
Delivery
category
(Metric)

Delivered complete; all items on
order are delivered in the
quantities requested
Delivered on time to customer’s
request date, using your
customer’s definition of on-time
delivery
Documentation supporting the
order including packing slips,
bills of lading, invoices, etc., is
complete and accurate
Perfect condition: Faultlessly
installed (as applicable), correct
configuration, customer-ready,
no damage
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Definition

SCOR Definitions

SCOR Metric
(Metric)

SCOR Definition

Location

Includes time for retrieving
orders to pick, determining
inventory availability, building
the pick wave, picking the
product, recording the pick and
delivering product to packing
area in response to an order.

Deliver
category,
Fulfillment tab
(Parameter)

Material acquisition costs
include costs incurred for
production materials: sum of
materials management and
planning, supplier quality
engineering, inbound freight and
duties, receiving and material
storage, incoming inspection,
material process engineering and
tooling costs.

Source category,
Cost tab
(Metric)

Includes costs for selecting
carrier and staging
products/systems.

Deliver
category,
Cost tab
(Metric)

Includes costs for warehouse
space and management, finished
goods receiving and stocking,
processing shipments, picking
and consolidating, selecting
carrier, and staging
products/systems.

Deliver
category,
Cost tab
(Metric)

Product Structure

Recipes / formulas / BOMs /
that define the composition of a
product

Product
Structure

Production Material
Cycle Time

Time required moving material
to point of use.

Make category,
Production
Material tab
(Parameter)

Pick Product Cycle
Time
(Pick Duration)

Product Acquisition
Costs
(Receiving Metric)

Product Packing Costs
(Packing Metric)

Product Picking Costs
(Pick Metric)

(Production
Material Duration)

Definition
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SCOR Metric
(Metric)

SCOR Definition

Location

Cost of handling/movement of
materials used to support
production.

Make category,
Cost tab
(Metric)

Published Delivery
Lead Time

The typical standard lead time
(after receipt of order) currently
published to customers by the
sales organization. For typical
orders only, not standing/resupply orders.

Product
composite,
Delivery tab
(Parameter)

Raw Material or
Product Days-ofSupply

Raw material inventory days of
supply are calculated as gross
raw material inventory ÷ (value
of transfers/365 days).

Role,
Assets tab
(Metric)

The total amount of time
required to move materials from
an inbound location to an
internal storage location.

Source
categories,
Receiving tab
(Parameter)

Stock Keeping Unit

Product
specification
(Parameter)

The percentage of orders that are
fulfilled on or before the original
customer requested date
(suppliers performance
measured by the customer).

ES: Enable
Source category,
(Metric)

Costs associated with paying
invoices, auditing physical
counts, performing inventory
accounting, and collecting
accounts receivable. (Does not
include customer collections
costs.)

Source category,
Cost tab
(Metric)

Production Material
Handling Cost
(Production Material
Handling Metric)

(Raw Materials)
Receiving and
Putaway Cycle Time
(Receiving Duration)
SKU
(Product Name)
Supplier On-Time
Delivery Performance
(Supplier On-Time
Performance (%))
Supply Chain Finance
Costs
(Invoice Metric)
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Definition

SCOR Definitions

SCOR Metric
(Metric)

Total Build Time
(Manufacturing
Duration)

Transportation Costs
(Transportation
Metric)
Total WIP Inventory
DOS
(Work in Progress)
Yield
(Build Yield)

SCOR Definition

Location

Total build time is the average
time for build-to-stock or
configure-to-order products
from when production begins on
the released work order until the
build is completed and unit
deemed shippable.

Make category,
Manufacturing
tab
(Parameter)

Includes all company paid
freight and duties from point of
manufacture to end-customer or
channel.

Deliver
category,
Cost tab
(Metric)

Total WIP inventory days of
supply are calculated as gross
WIP inventory ÷ (value of
transfers/365 days).

Role,
Assets tab
(Metric)

The ratio of usable output from a
process to its input.

Product
composite,
Manufacturing
tab
(Parameter)

Definition
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Glossary

B
Base Manufacturer role: A Level 1 role that makes and delivers raw materials for
the overall supply chain. A Base Manufacturer role uses make planning to
determine when to make raw materials and how much to make. A Base
Manufacturer role requires a resource.
boundary condition: A Level 2 process category that SCOR does not identify,
which exists at the beginning and at the end of the supply chain. The Mb: Make
Product category of a Base Manufacturer role, and the Input and End categories
of a Consumer role represent boundary conditions.
build order: Orders for delivery products of a Base Manufacturer or
Manufacturer role, which initiates the build process.
build process: A process that creates build orders and manufactures finished
products from components. The build process initiates, based on a cyclical make
planning process or by receiving source products, based on order/product
process, and triggers the order/product process when the finished product is
released.
buyer: Any Level 1 role that sources products from upstream suppliers.

C
category: A specific configuration of the Plan, Source, Make, and Deliver
management processes for each planning strategy. For example, the S1: Source
Stocked Product category sources products, using a stock planning strategy.
category router: An object that appears on the role detail between certain
categories, which send appropriate objects to appropriate categories when the
simulation runs.
change orders: Orders for existing demand orders for the finished products in the
overall supply chain that represent a change in the original order, which originate
in a Consumer role.
component: A product specification that a Manufacturer role requires to
manufacture finished products or that a Distributor role requires to assemble into
kits.
Consumer role: A Level 1 role that initiates the acquisition of finished products,
which determines initial order demand for the overall supply chain.
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contracts process: A process in which buyers issue awards to suppliers, based on
contracts and supplier selection criteria. The contracts process initiates when the
simulation begins, as well as based on the source planning process.
contract: A mechanism for determining how a buyer chooses its suppliers when
sourcing identical products from multiple suppliers. Contracts also determine the
estimated order size the role uses when using a stock/forecast planning strategy
and push planning.
customer order: An order for the source product of a Consumer role, which
initiates the order/product process for the overall supply chain.

D
Deliver category: A Level 2 category that distributes ordered products, manages
orders, and ships products.
delivery product: A product composite that a supplier delivers to a downstream
buyer.
demand orders: Customer orders for the finished products in the overall supply
chain, which originate in a Consumer role.
detail: A workspace associated with an object on which you place and view other
objects. Most objects have detail, such as a model, a role, and a category.
Distributor role: A Level 1 role that sources products from upstream suppliers
and delivers those products to downstream buyers. A Distributor role can also
assemble components into kits. A Distributor role uses source planning to
determine when to order source products and when to deliver product
shipments.
downstream: Toward the Consumer role end of the supply chain.

E
enable process: A Level 2 process category for each management process, which
manages the prerequisites for each process. The enable process categories are
ES: Enable Source and ED: Enable Deliver.
engineer-to-order (ETO) planning strategy: A planning strategy that fills orders
for engineer-to-order products by engineering and manufacturing custom
products for a particular customer; maintains no inventory; and delivers
shipments to the exact buyer that places an order.

F
financial process: A process in which a role performs accounting of financial
collections and payments, both ongoing and per financial period; updates asset
metrics, based on costs and inventory per financial period; and computes overall
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costs. The financial process initiates based on customer orders from the Consumer
role or replenishment orders from the source planning process.
finished product: A product specification in the product hierarchy that requires
components to manufacture.
forecast planning strategy: See stock/forecast planning strategy.

K
KB: A top-level application file that contains one or more models. A KB file has a
.kb file extension.
kit: A finished product that a Distributor role assembles from components. Unlike
a Manufacture role, however, a Distributor role that assembles components into
kits does not represent value-added in the supply chain.

L
Level 1 role: See role.
Level 2 SCOR: The configuration of the supply chain in terms of SCOR process
categories, which are specific configurations of each management process for each
planning strategy.
Level 3 SCOR: The operations strategy of each process category in terms of its
inputs and outputs, performance metrics, and best practices.

M
make-to-order (MTO) planning strategy: A planning strategy that fills orders for
make-to-order products from inventory; replenishes inventory only when a buyer
places an order; computes order size, based directly on orders; and ships products
to any buyer that places an order.
make planning process: A process in which a Base Manufacturer and
Manufacturer role plans when to make delivery products. The make planning
process initiates on a regular planning cycle and triggers the build process.
Make category: A Level 2 category that manufactures finished products and
places them into inventory.
Manufacturer role: A Level 1 role that sources components from upstream
suppliers, manufactures finished products, and delivers finished products to
downstream buyers. A Manufacturer role uses make planning to determine when
to make finished products and how much to make. A Manufacturer role requires
a resource.
metric: A value that e-SCOR computes during the simulation.e-SCOR provides a
number of SCOR metrics, as well as a number of e-SCOR metrics.
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model detail: The detail of a Model object on which you create a supply-chain
model.
model: A container in which you build a model. You build the model on the
model detail.

O
order/product process: A process in which a buyer sends orders to a supplier for
source products, and a supplier processes and fulfills those orders by sending
product shipments to buyers. The order/product process initiates based on
customer orders from the Consumer role or replenishment orders from the source
planning process. The order/product process triggers the financial process when
products are shipped to buyers. The build process can also initiate the process of
selecting orders for shipment when finished products become available from
manufacturing.

P
parameter: A value that you enter into the model as a variable. e-SCOR provides a
number of SCOR metrics as parameters, as well as a number of e-SCOR
parameters.
Plan category: A Level 2 category that plans supply and demand cycles in the
supply chain. The two Plan categories are P2: Plan Source, which is responsible
for creating replenishment orders for source products, and P3: Plan Make, which
is responsible for creating build orders for delivery products.
planning mode: Determines whether a role uses pull or push planning to source
and deliver its products. A buyer can source products by placing orders with
suppliers (pull) or simply receive products from suppliers when the role delivers
them (push). A supplier can deliver products, based on orders (pull) or simply
deliver a specified number of finished products (push).
planning strategy: Determines how a role computes order size and determines to
whom it delivers products. The available planning strategies are:
stock/replenishment, stock/forecast, stock/R-Q, stock/Q, make-to-order, and
engineer-to-order.
pool: An object on the role detail that stores permanent objects, such as product
composites, or transient objects, such as orders.
process category: See category.
product composite: A representation of each product a role sources and each
product a role delivers. There are two types of product composites in the Products
pool: source products and delivery products.
product hierarchy: A hierarchical representation of the products that a supply
chain sources, makes, and delivers. The product hierarchy consists of a high-level
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product specification, which is a finished product, and one or more lower-level
product specifications, which are components. Components, in turn, can consist
of other components.
product specification: A representation of each product in the product hierarchy.
You assign a product specification to each role in the model to determine the
products the role sources and/or delivers, which creates product composites in
the Products pool.
pull planning mode: A buyer sources products from suppliers by placing orders,
and a supplier delivers finished products to buyers, based on those orders.
push planning mode: A supplier pushes a fixed number of products onto buyers,
and a buyer simply receives those products from suppliers when the supplier
pushes them.

R
replenishment order: A customer order for the source product of a Distributor or
Manufacturer role, used to replenish the inventory of source products.
replenishment planning strategy: See stock/replenishment planning strategy.
resource: A representation of the capacity a role has for manufacturing finished
products. Base Manufacturer and Manufacturer roles require resources.
role: An abstraction of the management processes implicit in Level 2 SCOR,
which describes the scope and content of the overall supply chain. A role consists
of sets of Plan-Source-Make-Deliver processes. You create and connect roles to
form a supply-chain model. You assign product specifications to roles to create
source and delivery products. You assign resources to roles that manufacture
finished products. The Level 1 roles are: Base Manufacturer role, Distributor role,
Manufacturer role, and Consumer role.

S
scenario: The discrete event simulation engine for controlling the simulation.
SCOR: The Supply Chain Operations Reference model that the Supply Chain
Council has developed. SCOR identifies common terminology and measurements
that manufacturers and their vendors and distributors can use to evaluate the
performance of their supply chains and identify areas of improvement. e-SCOR
implements many of the features of SCOR.
source planning process: A process in which Distributor and Manufacturer roles
plan when to create replenishment orders for source products. The source
planning process initiates on a regular planning cycle and triggers the
order/product process.
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source product: A product composite that a buyer sources from an upstream
supplier.
Source category: A Level 2 category that places orders for source products from
suppliers and places those products in inventory.
stock planning strategy: A planning strategy that fills orders for stock products
from inventory and replenishes inventory, based on inventory levels or forecasts.
stock/forecast planning strategy: A planning strategy that sources and makes as
many source and delivery products, respectively, as the role forecasts it needs.
Forecasts are based on estimated amounts from downstream buyers for delivery
products.
stock/replenishment planning strategy: A planning strategy in which a role
sources and makes as many source and delivery products, respectively, required
to maintain the desired inventory level, given current orders.
supplier: Any Level 1 role that delivers products to downstream buyers.
supply chain management: The process of controlling the supply chain in the
most efficient and effective manner possible.
supply chain: A business process that describes the complete set of steps
involved in obtaining raw materials, producing and assembling products, and
delivering those products to consumers.

U
upstream: Toward the Base Manufacturer role in the supply chain.
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Symbols
+inf

Numerics
180 menu choice
controlling layout, using
Layout menu
90 Clockwise menu choice
controlling layout, using
Layout menu
90 Counterclockwise menu choice
controlling layout, using
Layout menu

A
About e-SCOR menu choice
About SCOR menu choice
Access Tables menu choice
Access, Microsoft
Acknowledge Messages Upon Selection
attribute
Activate menu choice
activating scenarios, using
Simulation menu
activating scenarios
Address field
adjusting
micro position of objects
order of objects
Administrator mode
configuring user preferences for
description of
Tools menu
Align or Distribute menu choice
controlling layout, using
distributing objects, using
Layout menu
All Products parameter
configuring
for Deliver categories

F
S

G
T

H
U

I
V

J K
W X

L
Y

M
Z

for Make categories
for Source categories
Alternate Product Priority parameter
alternate products, creating product
hierarchies with
analyzing performance of
alternative planning strategies
Distributor roles
Manufacturer roles
multiple suppliers
pull and push planning modes
stock planning strategies
Animation Color attribute
Animation Repeat Counter attribute
Animation Speed attribute
animation, configuring
applications
interacting with objects in
navigating
Apply menu choice
Excel toolbar
Reports menu
applying input report data
from databases
from Excel
arrows, indicator
configuring behavior of
setting and clearing
assembling components into kits
asset metrics
See Also metrics, list of
viewing for roles
Asset Metrics menu choice
View menu
Asset Metrics toolbar
Asset Turns metric
for roles
formula for
SCOR definition
assigning product specifications to roles
attributes, configuring for reports
Authorization Duration parameters
for Deliver Return categories
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Auto Refresh Clients attribute
Average Utilization metric, for resources
Awaiting Orders metric
computing for replenishment planning
for delivery products
for source products
awards
See purchase awards
Awards pool

B
Back menu choice
Go menu
Background Color attribute
background images, loading
Base Manufacturer roles
Build process for
configuring
guidelines for
resources for
to deliver multiple products
default product composites for
definition of
description of contents of
in pull mode
in push mode
Make Planning process for
Batch Simulation History attribute
Batch Simulation objects
creating
example scripts
keeping histories across multiple
simulations, using
keywords for
category timing parameters
cost category parameters
Plan category parameters
product composites
report parameters
role parameter
simulations
sort-order category parameters
using
batches, determining
Beep Enabled attribute
Best Practice URL, of models
Best Practices parameter
borders, adjusting workspace
boundary conditions
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breakpoints
setting and clearing
Bridge Host attribute
Bridge Port attribute
Bridge, ODBC
Bring to Front menu choice
controlling layout, using
Layout menu
build orders
definition of
restricting, based on a cutoff
selecting
sorting with no cutoff
Build Orders Completed metric
Build Orders pool
Build Orders Started metric
Build process
Build Selection parameters
configuring
for Make category
restricting build orders, based on a cutoff
sorting with no cutoff
Build Time Dependent on Order Size
parameter
Build Yield parameter
for delivery products
SCOR definition
Business Objects menu choice
Business Processes menu choice
Object Models menu
Business Rules menu choice
Project menu
Buyer Awards pool
buyers
See Also roles
configuring
contract parameters for
criteria for choosing suppliers
to source identical products from
multiple suppliers
to use forecast planning
definition of
by-products, creating product hierarchies with

C
Capacity Utilization metric
SCOR definition
Cash Flow Period metric
Cash-to-Cash Cycle Time metric

Index

for roles
formula for
SCOR definition
categories
See Also individual categories, by name
Batch Simulation object script keywords
for
cost parameters
Plan parameters
sort-order parameters
timing parameters
boundary conditions
configuring
mathematical distribution for timing
parameters for
Deliver
enable
Make
Plan
Return
Source
summary of process
viewing metrics for
Category Input Report
Category Output Report
category routers
change orders
configuring through a Demand Report
definition of
Change Orders Received metric
for Deliver categories
for ED category
charts
remote
creating from reports
Charts menu choice
Check Script button
Choose Root Workspace menu choice
Clear Breaks menu choice
clearing breakpoints, using
Simulation menu
Clear Indicators menu choice
clearing indicators, using
Simulation menu
using
client
connecting
directly to server
to a specific server
disconnecting
See e-SCOR, client

Clone menu choice
copying objects, using
Edit menu
Close menu choice
exiting client, using
File menu
collections, financial
See Financial Collections
colors
configuring
for workspaces
editing for objects
Colors menu choice
Edit menu
combining pull and push mode
examples of
within roles
comments, adding to scripts
Compensate for Yield parameter
components
assembling into kits
configuring push mode for shared
creating product hierarchies with
definition of
making finished products from
computation behavior of scenarios
Compute All Blocks attribute
computing
See Also metrics and updating
how much a role orders
for forecast planning
for replenishment planning
configuring
Batch Simulation object
build selection parameters
buyer roles
to source identical products from
multiple suppliers
to use forecast planning
contract parameters
criteria for choosing suppliers
database access
database interface objects
Deliver category
delivery products
Delivery tab
for choosing suppliers
for replenishment planning
General tab
Inventory tab
Manufacturing tab

563

Index

Multiplier tab
Return tab
Sourcing tab
Distributor roles
to assemble components into kits
to deliver its source products
to outsource finished products
engineer-to-order planning strategy
Level 1 roles
financial parameters of
general parameters of
product hierarchy for
resources for
SCOR definitions of
source and delivery products for
Level 2 SCOR
category parameters for
delivery product parameters for
general
product composite parameters for
product composite parameters,
introduction to
source product parameters for
Make category
make-to-order planning strategy
Manufacturer roles
to make finished products from
components
model environment
order selection parameters
Plan categories
push mode
for multiple finished products
for one buyer
for shared components
reports
attributes to appear in
filter criteria of
history for
time unit of
update interval for
Return category
Deliver
Source
role details
for multiple products
to use alternative planning strategies
scenarios
Source categories
general
source products
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criteria for choosing suppliers
criteria for choosing suppliers,
examples
Demand tab
for forecast planning
for replenishment planning
General tab
Inventory tab
MRO tab
Multipliers tab
Supplier Selection tab
Supplier tab
stock planning strategy
Connect menu choice
Database Interface object
Excel toolbar
Connect String attribute
connections
See Also paths
creating between roles
consumer demand
See demand, initial order
Consumer roles
configuring
guidelines for
to source multiple products
default product composites for
definition of
description of contents of
Continue menu choice
continuing the simulation, using
Simulation menu
Continuous Planning parameter
configuring
for pull planning
for stock planning
for Plan categories
Contract Length parameter
configuring
for choosing among multiple suppliers
for forecast planning
for pull mode
for push mode
for Source categories
Contract Metrics menu choice
View menu
Contract Metrics toolbar
Contract Repetition Count parameter
configuring
for choosing among multiple suppliers
for forecast planning
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for pull mode
for push mode
for Source categories
Contract Repetition Counter metric
Contract Response Cycle Time parameter
configuring
for choosing among multiple suppliers
for forecast planning
for pull mode
for push mode
for Source categories
Contract Start Time parameter
configuring
for choosing among multiple suppliers
for forecast planning
for pull mode
for push mode
for Source categories
contracts
configuring forecast planning, using
definition of
Contracts Established metric
for ED category
for ES category
Contracts Metrics toolbar
Contracts process
coordinating source and make planning
cost metrics
See Also Costs Incurred metrics
viewing
for Deliver categories
for Deliver Returns categories
for ES categories
for Make categories
for roles
for Source categories
for Source Returns categories
cost parameters
See Also Costs per Transaction parameters
configuring
for Deliver categories
for Make categories
for pull mode
for Return categories
for Source categories
for Source Return categories
Costs Incurred metrics
Create Customer Order Metric
Customer Collections Metric
Customer Invoicing Metric
Defective Product Authorization Metric

Defective Product Disposition Metric
Defective Product Holding Metric
Defective Product Transportation Metric
ECO
Excess Inventory Authorization Metric
Excess Inventory Transportation Metric
Invoice Metric
MRO Product Authorization Metric
MRO Product Disposition Metric
MRO Product Holding Metric
MRO Product Transportation Metric
Order Entry Metric
Order Fulfillment Metric
Packing Metric
Pick Metric
Production Material Handling Metric
Receiving Metric
Transfer Metric
Transportation Metric
Verification Metric
Costs per Transaction parameters
Create Customer Order
Customer Collections
Customer Invoicing
Defective Product Authorization
Defective Product Disposition Cost
Defective Product Holding Cost
Defective Product Transportation
ECO
Excess Inventory Authorization
Excess Inventory Disposition Cost
Excess Inventory Holding Cost
Excess Inventory Transportation
Invoice
MRO Product Authorization
MRO Product Disposition Cost
MRO Product Holding Cost
MRO Product Transportation
Order Entry
Order Fulfillment
Packing
Pick
Production Material Handling
Receiving
Transfer
Transportation
Verification
Create By-Product Connection menu choice
Create Connection menu choice
Create Customer Order Metric
for Source categories
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SCOR definition
Create Customer Order parameter
Create Detail menu choice
creating detail, using
Organizer tool
Create Product Connection menu choice
Create Surrogate menu choice
creating
Batch Simulation object
database interface objects
JMail interface objects
manufacturing resources
models
general
roles for
organizers
product composites
product hierarchies
with alternate products
with by-products
with components
with single product specification
projects
reports
general
in databases
scenarios
.csv files, Excel
Current Utilization metric
for resources
Customer Collections Metric
Customer Collections parameter
Customer Invoicing Metric
Customer Invoicing parameter
customer orders
See Also orders
definition of
Customer Preference parameter
customer support services
Cutoff Duration parameter
for build orders
for order selection
Cutoff parameter
for build selection
for order selection
Cutoff Value parameter
for build orders
for order selection
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D
D1, D2, and D3 categories
configuring parameters for
description of
introduction to
viewing metrics for
database access
configuring
connect string
database interface objects
e-SCOR for
host and port
ODBC data source
connecting to the database
creating the database
introduction to
starting ODBC Bridge
using reports
Database Interface Name attribute
configuring
for reports
database interface objects
Database Reporting Enabled parameter
Database tab
reports
Database Table Name attribute
Date-Time Time as Duration attribute
Days of Supply metrics
for roles
formulas for
Days Sales Outstanding metric
for roles
formula for
SCOR definition
deactivating scenarios
Default User Mode attribute
Default Web Location attribute
Defective Inventory Level metric
Defective Product Authorization Cost
parameter
Defective Product Authorization Duration
Defective Product Authorization Metric
for Deliver categories
Defective Product Disposition Cost parameter
Defective Product Disposition Metric
for Deliver categories
Defective Product Holding Cost parameter
Defective Product Holding Metric
for Deliver categories
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Defective Product Transportation Cost
parameter
Defective Product Transportation Duration
Defective Product Transportation Metric
for Deliver categories
Defective Return Authorization Yield
parameter
for delivery products
Definition parameter
Delete Background Image menu choice
deleting background images, using
Workspace menu
Delete CSV Report File menu choice
Delete menu choice
deleting objects, using
deleting workspaces, using
Edit menu
deleting
objects
workspaces
Deliver
See Also D1, D2, and D3 categories
category
SCOR management process
SCOR process category
delivering
See sending
Delivery
Delivery Performance metric
for ED category
SCOR definition
delivery products
See Also product composites
configuring
Delivery tab
for choosing supplier
General tab
Inventory tab
Manufacturing tab
Multiplier tab
parameters of
Return tab
Sourcing tab
default for each role
definition of
viewing metrics for
Delivery Products parameter
Demand Input Report Name parameter
configuring
for source product of Consumer role
Demand Order Duration parameters

configuring
initial order demand, using
for source product of Consumer role
Demand Order Size parameters
configuring
initial order demand, using
through a Demand Report
for source product of Consumer role
demand orders
Demand Report
creating
description of
example of
Demand Start Time parameter
configuring
for source product of Consumer role
Demand Stop Time parameter
configuring
for source product of Consumer role
demand, initial order
configuring
in pull mode
through a report
demo models, viewing
Desired Turnaround parameter
configuring
for pull mode
through a Demand Report
for source products
sorting orders, using
details
See Also roles, details
computing metrics for Task blocks with
creating
definition of
displaying for objects
showing
for container objects
for product structure organizers
for Products pool
superior object of
standard objects on role
Developer mode
configuring user preferences for
description of
dialogs
See properties dialogs
Disconnect menu choice
Excel toolbar
disconnecting
from the client
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using menu
distributing objects
Distribution Mode parameter
Authorization Duration
configuring mathematical distribution for
Defective Product Transportation
Duration
Demand Order Duration
Demand Order Size
Engineering Time
Excess Inventory Transportation Duration
Manufacturing Duration
Move to Delivery Duration
MRO Duration
MRO Product Transportation Duration
Order Entry Duration
Order Release to Manufacturing Duration
Packing Duration
Pick Duration
Production Material Duration
Receiving Duration
Transfer Duration
Transportation Duration
Verification Duration
Distributor roles
analyzing performance of
configuring
guidelines for
Level 2 parameters for
rules for combining planning
strategies
to assemble components into kits
to deliver its source products
to deliver multiple products
to outsource finished products
to source multiple products
default product composites for
definition of
description of contents of
Level 1 metrics to analyze
Level 2 metrics to analyze
modeling distribution process, using
pull mode
pull-push planning
push mode
push-pull planning
restricting orders to sort
based on a numeric cutoff
based on a time cutoff
source planning for
Source Planning process for
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what happens when the simulation runs
Documentation menu choice
Down menu choice
DR1 category
description of
DR1, DR2, and DR3 categories
configuring parameters for
introduction to
viewing metrics for
DR2 category
description of
DR3 category
description of
Duration attribute

E
ECO Metric
computing for ETO planning
for Mb and M3 categories
SCOR definition
ECO parameter
configuring for ETO planning
for Mb and M3 categories
ED category
configuring
description of
introduction to
viewing metrics for
Edit menu
See individual menu choice listings
Efficiency Factor parameter, for resources
email
configuring
address
format
to send
delivering messages by
starting JMail Bridge
startup parameters for sending
Enable Animation attribute
Enable Charting attribute
Enable Macros button
Enable Metrics Toolbar Update attribute
Enable MRO parameter
for source products
enable process
categories
definition of
Enable Status Bar Message Browser attribute
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Enable Tracking attribute
End category
boundary condition
description of
Engineering Duration Multiplier
Engineering Duration parameters
configuring
for ETO planning
for Make categories
multiplier
engineer-to-order (ETO) planning strategy
definition of
using
errors
initialization
viewing
when running the simulation
ES category
configuring
description of
introduction to
viewing metrics for
e-SCOR
benefits of
demo models
exiting
introduction to
running
running server
in secure G2 environment
toolbox
e-SCOR Help Topics menu choice
e-SCOR palette
Tools tab
Organizer
e-SCOR toolbar
Reports tab
e-SCOR toolbox
Tools
Scenario
e-SCOR-Summary-Reports.xls file
ETO
See engineer-to-order (ETO) planning
strategy
Event and Alarm Metrics menu choice
Events queue
Excel
connecting to the server from
manually
controlling simulation from
creating reports in

enabling macros in
Excel .csv files
Excel Report Enabled attribute
importing data, using
writing data, using
Excess Inventory Authorization Cost
parameter
Excess Inventory Authorization Duration
Excess Inventory Authorization Metric
for Deliver categories
Excess Inventory Disposition Cost parameter
Excess Inventory Disposition Metric
for Deliver categories
Excess Inventory Holding Cost parameter
Excess Inventory Holding Metric
for Deliver categories
Excess Inventory Level metric
Excess Inventory Return Authorization Yield
parameter
for delivery products
Excess Inventory Transportation Cost
parameter
Excess Inventory Transportation Metric
for Deliver categories
Excess Product Transportation Duration
Exit menu choice
exiting the server, using
Extended Menus attribute

F
F4 key
File menu
See individual menu choice listings
files
.csv
e-SCOR-Summary-Reports.xls
g2.ok
.kb

report log
StartServer.bat
twng.exe

Fill Rates metric
for Deliver categories
SCOR definition
Filter menu choice, Excel
filtering report data
general
in Excel
Financial Bookings metric
for Deliver categories
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for roles
Financial Collections Total metric
for Deliver categories
for roles
Financial Collections within Financial Period
metric
for Deliver categories
for roles
financial metrics
viewing
for Deliver categories
for ES categories
for roles
Financial Metrics menu choice
View menu
Financial Metrics toolbar
Financial Obligations metric
for roles
for Source categories
Financial Outstanding metric
for Deliver categories
for roles
financial parameters, configuring for roles
Financial Payment Terms parameter
Financial Payments Total metric
for roles
for Source categories
Financial Payments within Financial Period
metric
for roles
for Source categories
Financial Period parameter
for roles
Financial process
Finished Goods metric
for roles
formula for
SCOR definition
finished products
See Also delivery products
definition of
determining production requirements for
making and delivering multiple
making from components
manufacturing
outsourcing
releasing
staging
Flip Horizontally menu choice
controlling layout, using
Layout menu
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Flip Vertically menu choice
controlling layout, using
Layout menu
Forecast Estimated Amount parameter
configuring
for forecast planning
for pull mode
for push mode
for source products
forecast planning strategy
See stock/forecast planning strategy
Foreground Color attribute
formatting Excel reports
Forward menu choice
Go menu
Fulfillment Preference parameter
configuring
for pull mode
through a Demand Report
for source products
Fulfillment Using Alternate Products
parameter
for source products
using

G
G2 Help Topics menu choice
G2 JMail Bridge menu choice, Start menu
G2 toolbox
g2.ok file
generic products
Get menu choice
Workspace menu
GIF files, loading as background images
Go menu
See individual menu choice listings
Go To menu choice
manage dialog
project hierarchy
Search dialog
Go to Superior menu choice
showing Model objects, using
View menu

H
Help menu
Hide menu choice
View menu

Index

Highlight Color parameter, for roles
histories
keeping for reports
showing for metrics
Home menu choice
Go menu
Home Process Map attribute
HTTP menu choice

I
Import Data from Database menu choice
Import Data from File menu choice
In Transit Inventory Level metric
Incoming Inventory Level metric
for delivery products
for source products
Indicate Items attribute
configuring
Indicate Mode attribute
indicator arrows
See arrows
infinity, value for Days of Supply metrics
Initial Plan Delay parameter
configuring
for pull planning
for stock planning
coordinating source and make planning,
using
for Plan categories
initialization errors
Initialize Application menu choice
deleting messages, using
Project menu
Input category
boundary condition
description of
input paths
input reports
See Also reports
applying data to the model
from databases
from Excel
general
Interface Name attribute
Database Interface object
Interface Pools menu choice
Project menu
Interfaces menu choice
configuring network interfaces, using

Project menu
SMTP
SQL
Inventory Control Strategy parameter
configuring
for ETO planning
for MTO planning
for pull mode
for stock planning
delivery products
determining for planning
source products
Inventory Level metric
computing order size, using
for delivery products
for source products
Inventory metric
for roles
formula for
SCOR definition
Inventory Metrics menu choice
View menu
Inventory Metrics toolbar
Invoice Metric
for Source categories
SCOR definition
Invoice parameter
invoices, generating and receiving
Is Kitted parameter
assembling components into kits, using
for delivery products
outsourcing finished products, using

J
Java Mail (JMail)
configuring
in configuration file
in user preferences
JMS menu choice
JPEG files
loading as background images
saving workspaces to
Jump Mode menu choice
description of
running simulations, using
Simulation menu
just- in-time delivery
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K
.kb files

kits

description of
opening
saving
assembling from components
definition of

L
Label parameter
See Also Role Label and Resource Label
parameters
Deliver category
Make category
Plan category
Source category
layering
Layout menu
See individual menu choice listings
Layout toolbar
View menu
Left menu choice
Level 1 roles
See Also roles
definition of
features of
introduction to configuring
Level 1 SCOR, definition of
Level 2 SCOR
configuring
definition of
features of
Level 3 SCOR, definition of
Load Background Image menu choice
loading background images, using
Workspace menu
loading models
See opening models
loading projects
Log Financial Transactions parameter
Log Order Transactions parameter
Log Product Transactions parameter
Log Purchase Transactions parameter
Logging parameter, for roles

M
M1, M2, and M3 categories
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description of
introduction to
See Mb, M1, M2, and M3 categories
Make
See Also Mb, M1, M2, and M3 categories
category
SCOR management process
SCOR process category
Make Cycle Time metric
for Make categories
SCOR definition
make planning
See Also Make Planning process
configuring
coordinating with source planning
Make Planning process
make-to-order (MTO) planning strategy
definition of
using
Manage dialog
displaying object properties and details
using
Manage menu choice
management processes, SCOR
managing
objects
using Manage dialog
using Project menu
Manufacturer roles
analyzing performance of
configuring
build selection parameters for
build selection with cutoff
build selection with no cutoff
guidelines for
Level 2 parameters
resources for
source and make planning for
to deliver multiple products
to make finished products from
components
to source multiple products
default product composites for
definition of
description of contents of
introduction to modeling, using
Level 1 metrics to analyze
Level 2 metrics to analyze
modeling manufacturing processes, using
pull mode
pull-push planning

Index

push mode
push-pull planning
rules for configuring planning strategy for
source planning for
Source Planning process for
what happens when the simulation runs
Manufacturing Batch Size metric
Manufacturing Duration Multiplier
Manufacturing Duration parameters
for Make categories
multiplier
SCOR definition
manufacturing finished products
manufacturing resources
See resources
mathematical distribution, configuring for
timing parameters
Maximum Batch Size parameter
Maximum Capacity Used metric
Maximum Inventory Level parameter
configuring
for delivery products
for source products
Maximum Number of Suppliers parameter
configuring for choosing suppliers
for source products
Maximum Utilization parameter, for
manufacturing resources
Mb category
description of
introduction to
Mb, M1, M2, and M3 categories
configuring parameters for
viewing metrics for
menus
Edit
File
Go
Help
Layout
Model
Project
Simulation
Tools
Workspace
Message Board menu choice
View menu
viewing messages, using
Message Browser menu choice
View menu
message browsers

configuring
for modeler mode
for operator mode
showing by default in operator mode
Message Browsers menu choice
messages
delivering by email
viewing
when running the simulation
Messages queue
metrics
See Also metrics, list of
definition of
disabling updating of toolbar
introduction to viewing
SCOR
description of
SCOR definitions of
updating
in dialogs
in reports
verifying model by viewing
viewing
for categories
for D1, D2, D3 categories
for DR1, DR2, DR3 categories
for ED categories
for ES category
for Mb, M1, M2, M3 categories
for P2 and P3 categories
for resources
for roles
for S1, S2, S3 categories
for source and delivery products
for SR1, SR2, SR3 categories
general
viewing for product composites
General tab, delivery products
General tab, source products
Manufacturing tab
Metrics tab
Planning tab
Source tab
Supplier tab
viewing in the Metrics toolbar
viewing statistics and histories for
Metrics toolbar
viewing metrics in
Metrics toolbars
metrics, list of
Asset Turns
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Average Utilization
Awaiting Orders
delivery products
source products
Build Orders Completed
Build Orders Started
Cash Flow Period
Cash-to-Cash Cycle Time
Change Orders Received
Deliver categories
ED category
Contract Repetition Counter
Contracts Established
ED category
ES category
Create Customer Order Metric
Current Utilization
Customer Collections Metric
Customer Invoicing Metric
Days of Supply
Days Sales Outstanding
Defective Inventory Level
Defective Product Authorization Metric
Defective Product Disposition Metric
Defective Product Holding Metric
Defective Product Transportation Metric
Delivery Performance
ECO Metric
Excess Inventory Authorization Metric
Excess Inventory Disposition Metric
Excess Inventory Holding Metric
Excess Inventory Level
Excess Inventory Transportation Metric
Fill Rates
Financial Bookings
Deliver categories
roles
Financial Collections Total
Deliver categories
roles
Financial Collections within Financial
Period
Deliver categories
roles
Financial Obligations
roles
Source categories
Financial Payments Total
roles
Source categories
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Financial Payments within Financial
Period
roles
Source categories
Finished Goods
In Transit Inventory Level
Incoming Inventory Level
delivery products
source products
Inventory
Inventory Level
delivery products
source products
Invoice Metric
Make Cycle Time
Manufacturing Batch Size
Maximum Capacity Used
MRO Inventory Level
MRO Product Authorization Metric
MRO Product Transportation Metric
Number of End Products
Number of Financial Periods
Number of Planning Periods
Order Entry Metric
Order Entry to Manufacturing Time
Order Entry to Ship Time
Order Fulfillment Lead Time
Order Fulfillment Metric
Order Management Costs
Orders Received
Deliver categories
ED category
Orders Sent
ES category
Source category
Packing Metric
Perfect Order Fulfillment
Pick Metric
Product Name
delivery products
source products
Product Shipment Lead Time
Product Shipments Received
ES category
Source categories
Product Shipments Sent
Deliver categories
ED category
Production Material Handling Metric
Products On Order
delivery products

Index

source products
Purchase Cost
Pushed Inventory Level
Quantity Ordered
Quantity Received
Quantity Shipped
Quantity to Deliver
Raw Materials
Ready to Ship Time
Received Fulfillment Time
Received Inventory Level
Receiving Metric
Replacement Orders Sent
Returned Product Shipments Received
Shipped Inventory Level
Supplier On-Time Performance
Total Elapsed Time
Total Idle Time
Total Products Accepted
Total Products Rejected
Total Work Time
Transfer Metric
Transportation Metric
Verification Metric
Work in Progress
Mfg Resources pool
Microsoft
Access
Excel
Minimum Batch Size parameter
Minimum Reorder Quantity parameter
computing order size, using
configuring
for MTO planning
for pull mode
for replenishment planning
for delivery products
for source products
Mobile Email
address
Notification
Model button, Manage dialog
model environment, configuring
Model menu
Model tools
See models
Model Version column
Modeler Browser attribute
Modeler mode
configuring
user preferences for

description of
modeling
alternative planning strategies
determining level of detail
in product hierarchy
number of roles to use
to model
distribution process
manufacturing process
multiple products
delivery
introduction to
multiple suppliers
pull and push planning modes
stock planning strategies
forecast
introduction to
Q
replenishment
R-Q
models
See Also modeling, modules, and
simulations
Batch Simulation object script keywords
for
creating
general
roles for
summary of
definition of
demo
examples of supply-chain
organizing
introduction to
organizing, using Organizer tools
running
See running simulations
upgrading
verifying metrics for
working with
Move to Delivery Duration Multiplier
Move to Delivery Duration parameters
for Make categories
multiplier
MRO Duration parameters
for source product
MRO Inventory Level metric
MRO Product Authorization Cost parameter
MRO Product Authorization Duration
MRO Product Cost Metric
for Deliver categories
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MRO Product Disposition Cost parameter
MRO Product Holding Cost parameter
MRO Product Transportation Cost parameter
MRO Product Transportation Duration
MRO Product Transportation Metric
for Deliver categories
MRO Return Authorization Yield parameter
for delivery products
MRO Start Time parameter
for source products
MRO Stop Time parameter
for source products
MRO Verification Yield parameter
for source products
MTO
See make-to-order (MTO) planning
strategy
multiple
finished products
configuring push amount for
making and delivering
products, configuring role details for
suppliers
analyzing performance of
configuring buyers to source identical
products from
introduction to modeling, using
Level 2 metrics to analyze
modeling processes with
multipliers
configuring for timing parameters
Engineering Duration Multiplier
Manufacturing Duration Multiplier
Move to Delivery Duration Multiplier
Order Entry Duration Multiplier
Order Release to Manufacturing Duration
Multiplier
Packing Duration Multiplier
Pick Duration Multiplier
Production Material Duration Multiplier
Receiving Duration Multiplier
Transfer Duration Multiplier
Transportation Duration Multiplier
Verification Duration Multiplier
My User Preferences menu choice
configuring user preferences, using
Project menu
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N
naming
See labeling
navigating
applications
navigating to product composites
Navigator
menu choice
Navigator menu choice
View menu
Net Selling Price parameter
sorting build orders, using
sorting orders, using
New Instance menu choice, project hierarchy
New menu choice
creating
projects, using
top-level workspaces, using
File menu
Workspace menu
Normal menu choice
Nudge menu choice
controlling layout of objects, using
Layout menu
Number of End Products metric
for roles
SCOR definition
Number of Financial Periods metric
Number of Planning Periods metric

O
Object Models menu choice
object tracking
objects
adjusting the order of
aligning
copying
deleting
displaying properties for
distributing
editing colors
flipping
interacting with
in Modeler mode
managing
nudging
resizing
rotating

Index

See items on workspaces and transient
object
selecting
all
individual
transferring
ODBC Bridge
Start menu
using for database access
Online Mode menu choice
Simulation menu
Open menu choice
File menu
opening projects, using
Operator Browser attribute
Operator mode
configuring user preferences for
description of
user mode
Oracle
Order Entry Duration Multiplier
Order Entry Duration parameters
for Deliver categories
multiplier
SCOR definition
Order Entry Metric
for Deliver categories
SCOR definition
Order Entry parameter
Order Entry to Manufacturing Time metric
computing for ETO planning
for Mb and M3 categories
SCOR definition
Order Entry to Ship Time metric
for Deliver categories
SCOR definition
Order Fulfillment Lead Time metric
for delivery products
SCOR definition
Order Fulfillment Metric
for Deliver categories
SCOR definition
Order Fulfillment parameter
Order Management Costs metric
for roles
SCOR definition
Order menu choice
Layout menu
Order Metrics menu choice
View menu
Order Metrics toolbar

Order Ready for Shipment to Customer
Receipt of Order Time parameter, SCOR
definition
Order Release to Manufacturing Duration
Multiplier
Order Release to Manufacturing Duration
parameters
for Make categories
multiplier
order selection
configuring parameters for
restricting orders
based on a numeric cutoff
based on a time cutoff
sorting with no cutoff
Order Selection parameters
configuring
for Deliver category
Order Tag parameter
configuring through a Demand Report
Order Type parameter
configuring
for alternative planning strategies
for pull mode
determining for make planning
for delivery products
for source products
Order/Product process
orders
See Also build orders, customer orders,
and replenishment orders
concepts and terminology
configuring initial demand
in pull mode
through a report
fulfilling
generating
for delivery products
for source products
restricting
based on a time cutoff
based on numeric cutoff
sorting with no cutoff
Orders pool
Orders Received metric
for Deliver categories
for ED category
Orders Sent metric
for ES category
for Source category
organizers
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creating
definition of
output paths
Output Proportion parameter
output reports
See Also reports
generating report data
in databases
in Excel
in the client
outsourcing finished products

P
P2 and P3 categories
configuring parameters for
description of
viewing metrics for
P2, P3, and P5 categories
introduction to
Pack Product Cycle Time parameter, SCOR
definition
Packing Duration Multiplier
Packing Duration parameters
for Deliver categories
multiplier
SCOR definition
Packing Metric
for Deliver categories
SCOR definition
Packing parameter
parameters
configuring
for categories
for delivery products
for product composites
for product specifications
for resources
for roles
for source products
definition of
multipliers for timing
order demand, configuring through a
report
timing
configuring mathematical distribution
for
configuring multipliers for
parameters, list of
All Products
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Deliver categories
Make categories
Source categories
Authorization Duration
Best Practices
Build Selection
Build Time Dependent on Order Size
Build Yield
Compensate for Yield
Continuous Planning
Contract Length
Contract Repetition Count
Contract Response Cycle Time
Contract Start Time
Create Customer Order
Customer Collections
Customer Invoicing
Customer Preference
source products
Cutoff
build selection
order selection
Cutoff Duration
Deliver category

build orders

order selection
Cutoff Value
build selection
order selection
Defective Product Authorization
Defective Product Authorization Cost
Defective Product Disposition Cost
Defective Product Holding Cost
Defective Product Transportation Cost
Defective Product Transportation
Duration
Defective Return Authorization Yield
Definition
Demand Input Report Name
Demand Order Duration
Demand Order Size
Demand Start Time
Demand Stop Time
Desired Turnaround
ECO
Efficiency Factor
Enable MRO
Engineering Duration
Engineering Duration Multiplier
Excess Inventory Authorization
Excess Inventory Authorization Cost

Index

Excess Inventory Disposition Cost
Excess Inventory Holding Cost
Excess Inventory Return Authorization
Yield
Excess Inventory Transportation Cost
Excess Product Transportation Duration
Financial Payment Terms
Financial Period
Forecast Estimated Amount
Fulfillment Preference
Fulfillment Using Alternate Products
Highlight Color
Initial Plan Delay
Inventory Control Strategy
delivery products
source products
Invoice
Is Kitted
Label
Deliver categories
Make categories
Plan categories
Source categories
Log Financial Transactions
Log Order Transactions
Log Product Transactions
Log Purchase Transactions
Logging
Manufacturing Duration
Manufacturing Duration Multiplier
Maximum Batch Size
Maximum Inventory Level
Maximum Number of Suppliers
Maximum Utilization
manufacturng resource
Minimum Batch Size
Minimum Reorder Quantity
delivery products
source products
Move to Delivery Duration
Move to Delivery Duration Multiplier
MRO Duration
MRO Product Authorization
MRO Product Authorization Cost
MRO Product Disposition Cost
MRO Product Holding Cost
MRO Product Transportation Cost
MRO Product Transportation Duration
MRO Return Authorization Yield
MRO Start Time
MRO Stop Time

MRO Verification Yield
Net Selling Price
Order Entry
Order Entry Duration
Order Entry Duration Multiplier
Order Fulfillment
Order Release to Manufacturing Duration
Order Release to Manufacturing Duration
Multiplier
Order Selection
Order Type
delivery products
source products
Packing
Packing Duration
Packing Duration Multiplier
Pick
Pick Duration
Pick Duration Multiplier
Planning Period
Potential Service Provider Names
Potential Supplier Names
Process Number
Product Name
Product Preference
Product Selection
Deliver category
Make categories
Source category
Production Material Duration
Production Material Duration Multiplier
Production Material Handling
Published Delivery Lead Time
Purchase Cost
Push Stock Product
Receiving
Receiving Duration
Receiving Duration Multiplier
Resource Label
Resource Priority
Role Label
Safety Stock
delivery products
source products
Selected Suppliers Proportions
Site Latitude
Site Longitude
Sort Criteria
build selection
order selection
Sort Direction
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build selection
order selection
Specific Product Name
Deliver categories
Make categories
Source categories
Split Orders Between Suppliers
Starting Product Inventory Level
delivery products
source products
Statistical Metrics Period
Supplier Preference
Supplier Selection Criteria
Transfer
Transfer Duration
Transfer Duration Multiplier
Transportation
Transportation Duration
Transportation Duration Multiplier
Upgrade
categories
roles
Use Demand Input Report
Verification
Verification Duration
Verification Duration Multiplier
Verification Yield
paths, input and output
Pause menu choice
Batch Simulation object
pausing the simulation, using
Simulation menu
payments, generating
Build process
Financial process
Perfect Order Fulfillment metric
for ED category
SCOR definition
performance, analyzing for
alternative planning strategies
Distributor roles
Manufacturer roles
multiple suppliers
pull and push planning strategies
stock planning strategies
performance, enhancing
by configuring
animation
computation behavior
simulation speed
Pick Duration Multiplier
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Pick Duration parameters
for Deliver categories
multiplier
SCOR definition
Pick Metric
Deliver category
SCOR definition
Pick parameter
Pick Product Cycle Time parameter, SCOR
definition
Plan
See Also P2 and P3 categories
category
SCOR management process
planning
See Plan, planning mode, and planning
strategies
planning mode
See Also pull mode and push mode
introduction to pull and push
Level 2 metrics to analyze
pull and push
analyzing performance of
examples of combining
pull-push
Distributor role
Manufacturer role
push-pull
Distributor role
Manufacturer role
planning modes, pull or push
Planning Period parameter
configuring
for pull planning
for stock planning
for Plan categories
planning strategies
See Also stock/forecast,
stock/replenishment, stock/Q, stock/RQ, engineered-to-order planning
strategy, and made-to-order planning
strategy
alternative
analyzing performance of
configuring role detail to use
introduction to
metrics to analyze
modeling
configuring for stock
definition of
engineer-to-order
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examples of valid combinations of
make-to-order
pull mode planning
push mode planning
rules for configuring
stock
analyzing performance of
introduction to
Level 2 metrics to analyze
stock/forecast
stock/Q
stock/replenishment
stock/R-Q
pools
Build Orders
Buyer Awards
definition of
Orders
Responses
Source Orders
Staging Area
Supplier Awards
transient objects in
popup menus
interacting with objects, using
popup menus, displaying
Potential Service Provider Names parameters
for source product
Potential Supplier Names parameters
Print menu choice
File menu
printing workspaces, using
problems when running the simulations
process categories
See Also categories
definition of
Process Number metric
for Deliver categories
for Deliver Returns categories
for ED category
for ES category
for Make categories
for Plan categories
for Source category
for Source Returns categories
Process Number parameter
processes
See Also categories and roles
Build
Contracts
definition of

Financial
Make Planning
Order/Product
SCOR management
Source Planning
product composites
See Also source products and delivery
products
Batch Simulation object script keywords
for
concepts and terminology
configuring parameters for
in Products pool
introduction to
creating
default for each role
definition of
icon labels for
navigating to
viewing metrics for
general
General tab, delivery products
General tab, source products
Manufacturing tab
Metrics tab
Planning tab
Source tab
Supplier tab
product hierarchies
concepts and terminology
configuring
creating
with alternate products
with by-products
with components
with single product specification
definition of
determining level of detail in
examples of
viewing on Product tab for roles
Product Metrics Report
Product Name metric
for delivery products
for source products
Product Name parameter
for product specifications
SCOR definition
Product Packing Costs parameter, SCOR
definition
Product Parameters Report

581

Index

Product Picking Costs parameter, SCOR
definition
Product Preference parameter
configuring
for push mode
for shared components
for delivery products
sorting build orders, using
sorting orders, using
Product Selection parameters
configuring
for Deliver categories
for Make categories
for Source categories
Product Shipment Lead Time metric
Product Shipments Received metric
for ES category
for Source category
Product Shipments Sent metric
for Deliver categories
for ED category
product shipments, receiving
product specifications
See Also product hierarchies
assigning to roles
creating
creating product hierarchies
with alternate products
with by-products
with multiple
with single
definition of
examples of assigning to roles
Product Specifications Report
Product Structure metric, SCOR definition
product structure organizers
creating
definition of
showing details of
Product tab, roles
Production Material Duration Multiplier
Production Material Duration parameters
for Make categories
multiplier
SCOR definition
Production Material Handling Metric
for Make categories
SCOR definition
Production Material Handling parameter
products
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See Also product composites, product
hierarchies, product specifications,
delivery products, source products, and
shipments
concepts and terminology
Products menu choice
Products On Order metric
computing for replenishment planning
for delivery products
for source products
Products pool
configuring product composite parameters
by displaying detail of
placing product composites in
showing
details of
for roles
Products tab
for e-SCOR toolbar
Project
menu
managing objects, using
using
using submenus
Project menu
projects
creating
opening
saving
working with
properties dialogs
shortcuts for displaying
updating metrics in
properties dialogs, displaying
Properties menu choice
Edit menu
for items on workspaces
popup menu for objects
Published Delivery Lead Time parameter
for delivery products
SCOR definition
pull mode
Base Manufacturer role in
combining with push mode
coordinating source and make planning in
Distributor role in
Manufacturer role in
modeling, using
using
what happens when the simulation runs in
purchase awards
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Contracts process
Role Verification process
Purchase Cost
metric
parameter
purchase requests
Contracts process
Role Verification process
purchase responses
Contracts process
Role Verification process
push mode
Base Manufacturer role in
combining with pull mode
configuring push amount
multiple products
one buyer
shared components
coordinating source and make planning in
determining how much gets pushed
Distributor role in
Manufacturer role in
modeling, using
using
what happens when the simulation runs in
Push Stock Product parameter
configuring
for pull mode
for push mode
for source products
Pushed Inventory Level metric
determining how much gets pushed, using
for delivery products

Q
Quantity Ordered metric
Quantity Received metric
Quantity Shipped metric
Quantity to Deliver metric
Queues menu choice

R
raw materials
See Also delivery products
configuring cost of, for Base Manufacturer
roles
Raw Materials metric
for roles

formula for
SCOR definition
Ready to Ship Time metric
Received Fulfillment Time metric
Received Inventory Level metric
Receiving Duration Multiplier
Receiving Duration parameters
for Source categories
multiplier
SCOR definition
Receiving Metric
for Source categories
SCOR definition
Receiving parameter
Refresh menu choice
Go menu
remote charts
creating
from reports
Replacement Orders Sent metric
for Deliver categories
replenishment orders
See Also orders
definition of
Replenishment Planning parameter
configuring
for pull planning
for stock planning
replenishment planning strategy
See stock/replenishment planning
strategy
Report Time Series attribute, of reports
reports
accessing databases, using
Batch Simulation object script keywords
for
concepts and terminology
configuring
attributes to appear in
automatically
filter criteria of
for database access
history for
order demand through
time units of
update interval for
creating
in databases
in Excel
in the client
specialized
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templates
filtering
data
in Excel
generating output data
in .csv files
in databases
in Excel
in the client
importing input data
from .csv files
from databases
from the client
introduction to
keeping a history of data values in
refreshing data
summary of input and output
updating
Excel
introduction to
manually
regularly
triggering
Reports menu choice
Reports palette
ReThink toolbar
Reports tab, e-SCOR toolbar
repositories
Reset menu choice
resetting the simulation, using
Simulation menu
resizing objects
Resource Input Report
Resource Label parameter, for resources
Resource Metrics menu choice
View menu
Resource Metrics toolbar
Resource Output Report
Resource Priority parameter, for resources
resources
configuring
for Level 1 roles
parameters for
creating manufacturing
definition of
manufacturing
sharing between roles
showing representations of, for roles
viewing metrics for
Resources menu choice
Resources palette

584

ReThink toolbar
Resources pool
Responses pool
Restore Last Pane Settings attribute
Resume menu choice, Batch Simulation object
ReThink toolbox
Tools
Batch Simulation Object
Model
Return
category
Returned Product Shipments Received metric
for Deliver categories
Right menu choice
Role Input Report
Role Label metric
for Deliver categories
for Deliver Returns categories
for ED category
for ES category
for Make categories
for Plan categories
for product composites
for Source category
for Source Returns categories
Role Label parameter, for roles
Role Output Report
Role Transaction Report
roles
See Also Base Manufacturer, Consumer,
Distributor, and Manufacturer roles
assigning product specifications to
Base Manufacturer
Batch Simulation object script keywords
for
configuring
financial parameters of
general parameters of
SCOR definitions of
connecting
Consumer
default product composites for
details
configuring for multiple products
configuring to use alternative
planning strategies
default
example of making and delivering
multiple finished products
labeled diagram of items on
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making and delivering multiple
delivery products
standard objects on
determining number to use
Distributor
logging transactions between
Manufacturer
Product tab
rules for configuring planning strategies
for
showing
Products pool for
resource representations of
viewing metrics for
Rotate or Flip menu choice
controlling layout, using
Layout menu
Row ID column
running
simulations
using Batch Simulation object
using scenarios
running e-SCOR
running simulations
introduction to
problems when
summary of
verifying model
viewing metrics when

S
S1, S2, and S3 categories
configuring parameters for
description of
introduction to
viewing metrics for
Safety Stock parameter
computing order size, using
configuring
for MTO planning
for pull mode
for replenishment planning
for delivery products
for source products
Save A menu choice
saving projects, using
Save as JPEG menu choice
File menu
saving workspaces, using

Save As menu choice
File menu
Save menu choice
File menu
saving projects, using
scaling workspaces
SCC
See Supply-Chain Council (SCC)
scenarios
activating and deactivating
Batch Simulation object script keywords
Batch Simulation object script keywords
for
version
configuring
computation behavior
duration
indicator arrow behavior
mode
object tracking
simulation speed
start time
version
creating
definition of
introduction to
simulation time of
SCOR
configuring parameters for Level 2
management processes
metrics
description of
SCOR definitions of
modeling concepts
Script attribute, for Batch Simulation object
Search menu choice
searching for objects, using
Tools menu
Seconds per Tick attribute
secure G2, running in
Select All menu choice
Edit menu
selecting objects, using
Selected Suppliers Proportions parameters
configuring for choosing suppliers
for source products
Send to Back menu choice
controlling layout, using
Layout menu
server
connecting to
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default
from Excel, initially
from Excel, manually
specific
disconnecting from
from Excel
See e-SCOR, server
shutting down
using menus
starting
on specific port
Server Information menu choice
Set Break menu choice
Set Default User Mode attribute
Setup Report menu choices
Shipped Inventory Level metric, for delivery
products
Show Chart menu choice
output reports
Show Detail menu choice
Model tool
Organizer tool
summary of common tasks
View menu
workspaces
Show Flow History menu choice
Show Items to Update menu choice
Show Logbook attribute
Show Products menu choice
configuring product composite
parameters, using
navigating to product composites, using
Show Report menu choice
Show Resources menu choice
Show URL menu choice
models
Show Users menu choice
showing
details
for product structure organizers
for Products pool
Products pool for roles
resource representations for roles
transient objects
Shrink Wrap menu choice
Layout menu
shrink wrapping workspaces, using
Shut Down G2 menu choice
shutting down server
using menus
Simulation
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menu
toolbar
simulation clock
advancing
based on real time
continuously
for each discrete event
Simulation menu
activating and deactivating scenarios
clearing indicators
configuring simulation mode
See individual menu choice listings
starting and stopping simulations
Simulation Speed attribute
simulation time
scaling to real time
scenarios
Simulation toolbar
toggling
View menu
Simulation Version attribute
Simulation Version column
simulations
controlling
from Excel
introduction to
running
in jump mode
in step mode
in synch mode
using Batch Simulation object
starting and stopping
what happens when running
Site Latitude parameter, for roles
Site Longitude parameter, for roles
SKU numbers
SMTP menu choice
Sort Criteria parameter
for build selection
for order selection
Sort Direction parameter
for build selection
for order selection
sorting data in Metrics toolbar
Source
See Also S1, S2, and S3 categories
category
SCOR management process
SCOR process category
Source Orders pool
source planning
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See Also Source Planning process
configuring
coordinating with make planning
Source Planning process
source products
See Also components and product
composites
configuring
criteria for choosing suppliers
criteria for choosing suppliers,
examples
Demand tab
Distributor roles to deliver
General tab
initial order demand for
Inventory tab
MRO tab
Multipliers tab
parameters of
Supplier Selection tab
Supplier tab
default for each role
definition of
viewing metrics for
Source Products parameter
Specific Product Name parameter
configuring
Deliver categories
for Make categories
Source categories
Split Orders Between Suppliers parameter
configuring for choosing suppliers
for source products
SQL menu choice
creating database interface objects, using
SQL2000
SR1 category
description of
SR1, SR2, and SR3 categories
configuring parameters for
introduction to
viewing metrics for
SR2 category
description of
SR3 category
description of
Staging Area pool
Standard toolbar
View menu
Start All menu choice
Simulation menu

starting the simulation, using
Start menu choice
Batch Simulation object
Start Time tab
Starting Product Inventory Level parameter
configuring
for delivery products
for source products
starting simulations
using Batch Simulation Object
using Scenario
StartServer.bat file
startup, errors at
Statistical Metrics Period parameter, for roles
Status Bar menu choice
toggling status bar, using
View menu
Step Mode menu choice
description of
running simulations, using
Simulation menu
stock planning strategy
See Also stock/forecast,
stock/replenishment, stock/Q, and
stock/R-Q planning strategies
definition of
using
stock/forecast planning strategy
See Also planning strategies
computing how much a role orders, using
configuring buyers to use
definition of
using
stock/Q planning strategy
definition of
See also planning strategies
using
stock/replenishment planning strategy
See Also planning strategies
computing how much a role orders for
configuring source and delivery products
for
definition of
examples
order size is amount needed to
maintain current inventory
order size is reorder quantity
order size is zero
formula for computing order size
metrics and parameters used in formula
using for stock planning
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stock/R-Q planning strategy
definition of
See also planning strategies
using
Stop menu choice
Batch Simulation object
Go menu
stopping simulations
using Batch Simulation Object
using Scenario
stubs
See paths
Supplier Awards pool
Supplier On-Time Performance metric
for ES category
SCOR definition
Supplier Preference parameter
configuring for choosing suppliers
for delivery products
Supplier Selection Criteria parameters
configuring for choosing suppliers
for source products
suppliers
See Also roles
configuring
contract parameters for choosing
criteria for choosing
definition of
supply chain management
definition of
SCOR modeling concept
Supply Chain Operations Reference model
See SCOR
Supply Chain Processes menu choice
Project menu
supply chain, definition of
Supply-Chain Council (SCC)
supply-chain.org

surrogates, creating from resources
Synch Mode menu choice
description of
running simulations, using
Simulation menu
System Performance menu choice
System Settings menu
System-Administrator mode
configuring user preferences for
description of
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T
Tabbed Mdi Mode attribute
Telnet Command attribute
Templates menu choice
time periods, configuring for time-weighted
statistics
Time Unit attribute, of reports
Timeout attribute
time-weighted statistics, configuring time
period for
timing parameters
See Also individual parameter listings
Batch Simulation object script keywords
for category
configuring
mathematical distribution for
multipliers for
toolbars
See Also palettes
Layout
Metrics
Simulation
Standard
using
Web
Toolbars menu
toolbox
e-SCOR
G2
ReThink
Toolbox - e-SCOR menu choice
View menu
Toolbox - G2 menu choice
using
Toolbox - ReThink menu choice
View menu
Tools
menu
ReThink toolbox
Tools menu
See individual menu choice listings
Tools tab
e-SCOR palette
Organizer
e-SCOR toolbox
Scenario
Total Build Time parameter, SCOR definition
Total Elapsed Time metric, for resources
Total Idle Time metric, for resources
Total Products Accepted metric

Index

Total Products Rejected metric
Total Work Time metric, for resources
Transaction Logging Enabled parameter
Transaction Logging Report parameter
Transfer Duration Multiplier
Transfer Duration parameters
for Source categories
multiplier
Transfer menu choice
cutting and pasting objects, using
Edit menu
Transfer Metric
Transfer parameter
transient objects
in pools
showing
that flow through the model
Transportation Duration Multiplier
Transportation Duration parameters
for Deliver categories
for Source Returns categories
multiplier
SCOR definition
Transportation Metric
for Deliver categories
SCOR definition
Transportation parameter
twng.exe file
Type of Database attribute

U
Uninitialize Application menu choice
Project menu
Up menu choice
Update All Related Items menu choice
Update button
for dialogs
Update button, reports
Update Charts attribute
Update Interval attribute
Update menu choice
Excel toolbar
Reports menu
Update Mode attribute
Update Report menu choice
using when generating output
in e-SCOR
updating
metrics

reports
at regular time intervals
Excel
manually
Upgrade Block menu choice
Upgrade Model menu choice
Upgrade Models menu choice
Upgrade parameter
for categories
for roles
using
upgrading models
Usage Quantity parameter
Use Demand Input Report parameter
configuring initial order demand, using
for source product of Consumer role
User Interface Theme attribute
User Mode menu choice
switching user modes, using
Tools menu
user modes
configuring default
specifying user preferences for different
switching
User Name attribute
Modeler mode
user preferences
configuring
in Modeler mode
creating and configuring
specifying for different types of users
User Preferences menu choice
configuring user preferences, using
Project menu
Users menu choice
UUID attribute

V
Verification Duration Multiplier
Verification Duration parameters
for Source categories
multiplier
Verification Metric
Verification parameter
Verification Yield
verification, model
View menu
See individual menu choice listings
viewing
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metrics
for categories
for resources
for roles
for source and delivery products
viewing messages and errors
Volume parameter

W
Web toolbar
View menu
Weight parameter
what-if analysis
introduction to
Window menu
Work in Progress metric
for roles
for source products
formula for
SCOR definition
Workspace Margin attribute
Workspace menu
Delete Background Image
description of
Get
Load Background Image
New
workspaces
adjusting borders for
deleting
editing
colors of
margins of
name of
properties
hiding
interacting with
loading background images
printing
saving as JPEG
scaling
showing superior object of detail
shrink wrapping
www.supply-chain.org

X
XMB files, loading as background images
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Y
Yield parameter, SCOR definition

Z
Zoom In menu choice
scaling workspaces, using
View menu
Zoom menu choice
scaling workspaces, using
View menu
Zoom Out menu choice
scaling workspaces, using
View menu
Zoom to Fit menu choice
scaling workspaces, using
View menu

